Jump to content

Archived

This topic is now archived and is closed to further replies.

eronventer

Problema com acentuação

Recommended Posts

Boa tarde.

Preciso executar um script diariamente para renomear uma série de imagens, porém algumas delas possuem acentos e ç.

Estas acabam gerando erro no script e não funcionando o rename(). Tem uma forma de resolver?

Exemplo de nome: 176329_4 napa + camurça preto.jpg

Retorno o navegador: 176329_4 napa + camur�a preto.jpg

Share this post


Link to post
Share on other sites

Recomenda-se que os nomes de arquivos sejam únicos, sem caracteres especiais nem espaços.

Na hora de exibir dados na tela, deixe tudo na mesmo codificação, preferencialmente utf-8.

Veja este meu artigo sobre isso: http://rberaldo.com.br/problemas-com-codificacao-acentos-nao-interpretados/

Share this post


Link to post
Share on other sites

  • Similar Content

    • By clayton.lima2020
      Boa Tarde!
       
      Pessoal estou com um problema para resolver:
       
      Tenho um uma string que é um Nome:  SYLVIA
       
      Eu preciso fazer uma uma busca nessa string achar a letra Y e depois verificar se após a letra Y a próxima letra é Vogal ou Consoante.
       
      No caso do nome SYLVIA a próxima letra é L então retorna Consoante.
       
      Alguém sabe montar esse algoritmo ai?
    • By Nightmare SEP
      Bom dia,
      Estou com problema com acentos no PHPMailer (classe para envio de e-mails). Conforme anexo.
       
      Na configuração do e-mail de destinatário, o nome do destinatário tem acento, quando enviado o e-mail, ao invés de aparecer o nome, aparece aqueles caracteres ali (conforme anexo).
      Acontece o mesmo se eu coloco acentuação no assunto do e-mail.
       
      require("../phpmailer/class.phpmailer.php"); $mail = new PHPMailer(); $mail->IsHTML(true); $mail->CharSet = 'utf-8';  
      Será que pode ser algo no php.ini? Lá eu vi que está marcado o default_charset = 'utf-8'. Ou não tem nada a ver?
       
      EDITANDO:
      Funciona os acentos no corpo do e-mail. Só não funciona no ASSUNTO e no NOME DO DESTINATÁRIO.
       

    • By Hacker_Buiu
      Costuma dar erro quando você vai curtir um tópico?
    • By Hacker_Buiu
      Porque demora para aprovar meus tópicos?Porque quando tento curtir dá erro,e perco o direito de criar um novo tópico?
    • By LucasLV
      Olá.
      Tenho um site onde as imagens são geradas através de um arquivo PHP - utilizo esse método para retornar imagens webp ou jpg - e vi que o navegador não utiliza, ou não salva em cache, as imagens geradas dessa forma.
      Já as onde informo o caminho completo da imagem com a extensão, aparecem como utilizadas do cache.

      Esse comportamento é normal quando as imagens são geradas desse jeito ou é por não ter feito nenhuma configuração de cache no arquivo PHP que gera as imagens?
       
      Coloquei uma imagem do resultado exibido no navegador.

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.