Jump to content

Archived

This topic is now archived and is closed to further replies.

Rickson Jordan

Me ajudem nesse código de Reservamento de Cadeiras

Recommended Posts

Olá companheiros, preciso da ajuda de vocês para resolver a SAÍDA/entrada deste código de Reservamento de Cadeiras em uma Sala, onde terá que registrar o quando escolher ENTRADA (E) de entrada na opção de

-"se...entao" > cadeiras(assentos) disponíveis (Matriz 10x5) > logo em seguida>nome>matrícula a reservar somente UMA em seu "nome ou matrícula".



-Caso a pessoa declare no inicio entre as opções de ENTRADA (S) de saída deverá aparecer novamente a Matriz (10X5) de Assentos e a Fileira e Posição que deseja tirar a pessoa, logo em seguido caso digite certo, aparecerá o NOME da pessoa naquela POSIÇÃO (i,j=a,b) informado desde o inicio), e confirmar pedindo a matricula da pessoa para fazer verificação(isso impedira que qualquer um faça alteração do sistema, sem a matricula da pessoa) que SAIU no meio do evento e apagar da (Matriz 10x5) que aparece no início e disponibilizar na próxima reserva que o Usuário cadastrar denovo



Obs. No Final , quando o usuário não querer mais cadastrar ninguém, deverá aparecer uma Listagem das Pessoas(NOMES) que estavam Presente, com sua (MATRÍCULA.) e as Pessoas(NOMES) que desistiram , "saíram do evento"

Esta dando erro justo na Parte de Desistir da Lugar, no finalzinho.. Na hora que faz a equivalência logica:
"Se mat[a,b] = matricula[i,j] entao" <<<<<= Faz COMPARANDO uma matriz com a outra em termos de numero de linhas e colunas, mas eu não quero isso, quero que compare o VALOR que contém em cada VARIÁVEL COMPOSTA desta matriz, ex:

mat[1,1]="nome"
matricula[1,1]="nome"

Equivalência Lógica de valores:
(mat[1,1]="nome" = matricula[1,1]="nome")

CONDIÇÃO VERDADEIRA <<<quero atingir essa Condição , caso seja igual os valor de cada matriz, levando em consideração a sua posição [a,b]=[i,j]

Segue o código:

algoritmo "Controle de Evento Acadêmico"


var
   sala: vetor [1..10, 1..5] de Caractere
// 1,1  1,2  1,3  1,4  1,5
// 2,1  2,2  2,3  2,4  2,5
// 3,1  3,2  3,3  3,4  3,5
// 4,1  4,2  4,3  4,4  4,5
// 5,1  5,2  5,3  5,4  5,5
// 6,1  6,2  6,3  6,4  6,5
// 7,1  7,2  7,3  7,4  7,5
// 8,1  8,2  8,3  8,4  8,5
// 9,1  9,2  9,3  9,4  9,5
// 10,1 10,2 10,3 10,4 10,5
   i,j,f,p,totalpres: inteiro
   desistente: vetor[1..10,1..5] de caractere
   a,b:inteiro
   nome: vetor [1..10, 1..5] de caractere
   matricula: vetor [1..10, 1..5] de caractere
   r,pj, resp, resp2,confirma:  caractere
   
Procedimento cabecalho
inicio
      Escreval("*****************************************************************************")
      Escreval("---------------------------    SYSTEM CONTROL    ----------------------------")
      Escreval("*****************************************************************************")


Fimprocedimento


Procedimento end()
inicio
               Se resp2="s" entao
                   LimpaTela()
                   Se (sala[f,p]=nome[i,j]) entao
                        Escreval ("========================>Evento Encerrado!<======================= ")
                        Escreval ("-------------------  Lista de Alunos Presentes  -------------------")
                                totalpres <-0
                                
                               Escreval ("Nome: ",nome[i,j],"--- Matricula: ", matricula[i,j])
                               Escreval ("Assento: ", f,",",p)
                                totalpres <- totalpres + 1
                           Escreva("------------------------------------------------------------------")
                          
                               Escreval ("------------------ ",totalpres," aluno(s) presente(s) -------------------")
                   FimSe
               FimSe


                 Se resp2="c" entao
                               LimpaTela()
                 senao
                                 Escreval("Erro! Opção Inválida.")
                 Fimse
FimProcedimento


Procedimento MostraSala()
var
f,p:inteiro
inicio
EscrevaL("------------------------------------------------------------------------")
EscrevaL("=================RESERVAMENTO DE CADEIRA================================")
EscrevaL("------------------------------------------------------------------------")
   Para f <- 1 ate 10 passo 1 faca
        Para p <-1 ate 5 passo 1 faca
               Se (sala[f,p] = "") entao
                  Escreva ("[ ", f,",",p, " ]  ")
               senao
                  Escreva ("[ ------ ]")
               FimSe
        Fimpara
Escreval()
   FimPara
EscrevaL()
EscrevaL("------------------------------------------------------------------------")
FimProcedimento


inicio


      para i <- 1 ate 10 faca
            para j <- 1 ate 5 faca
                  Limpatela ()
                        cabecalho
                        Escreval
                           Escreva("Deseja registrar entrada ou saída(e{entrada}/s{saida}): ")
                           Leia (resp)
                  Limpatela ()
            Se resp="e" entao
                        cabecalho
                        Escreval
                           Escreval("                            REGISTRO DE ENTRADA")       
                                  Escreva("Nome do aluno: ")
                                        Leia (nome[i,j])
                                  Escreva("Matricula: ")
                                        Leia (matricula[i,j])




                                       LimpaTela
                                       MostraSala()
                                       Escreva("Reservar a cadeira: ")
                                       Leia(f,p)
                                       Se (sala[f,p]="") entao
                                          sala[f,p] <- nome[i,j]
                                          EscrevaL("Cadeira", f,",",p, " RESERVADA!")
                                       Senao
                                          EscrevaL("ERRO: Lugar Ocupado!")
                                       FimSe
                                       Escreva()
                                       LimpaTela()
                                       cabecalho
                                       Escreva ("Deseja encerrar o evento ou continuar (S/C): ")
                                       Leia (resp2)
                                           end()
             FimSe


             Se resp="s" entao
                          cabecalho
                   repita
                          Escreval
                             Escreval("                              REGISTRO DE SAÍDA") 
                             EscrevaL("Nome do desistente: ")
                             Leia (desistente[a,b])
                             Se nome[i,j]= desistente[a,b] entao
                                Escreval("Tem certeza que deseja excluir esta reserva? SIM=1 | NAO=0: ")
                                leia(confirma)
                                     Se confirma=1 entao
                                        sala[f,p]<-""
                                        nome[i,j]<-""
                                           escreval("Reserva Excluída com Sucesso!")
                                           senao
                                           escreval("Reserva Não Alterada!")
                                           fimse
                                           senao
                                           escreval("Este Lugar já está Desocupado!")
                                     Fimse
                                     EscrevaL("Deseja Continuar a Registar?")
                                     EscrevaL("(S)- Para Continuar/ (qualquer tecla)- para SAIR)")
                                     Leia(pj)
                 ate (pj="s")
             senao
                            Escreval
                            Escreval ("Erro! Só  sera aceito (e) para e entrada e (s) para saida.")
                            Limpatela()
             FimSe
                 
FimPara
       FimPara
                 
fimalgoritmo

Share this post


Link to post
Share on other sites

  • Similar Content

    • By fideles
      Fala pessoal, como anda as coisas?
       
      Meu conhecimento em JS e quase neutro, conheço algo, mais talvez não o suficiente para o que eu precise, por isso venho pedir ajuda a vocês,
       
      Tenho um pequeno programinha, simples mesmo que tem 4 areas (Administração, Compras, Financeiro, Almoxarifado).
       
      Quem fica na ADM solicita algo,  compras visualiza e da um "ok" e o financeiro tbm tem que dar um "ok" e no final, o almoxarifado dá um "Processo Concluido" (está parte está ok, funcionando, sem erro)
       
      Meu problema seria que quem está no almoxarifado consegue clicar no botão "Processo Concluido" mesmo o pessoal de compras e financeiro não dando um "ok" na solicitação ou ele tbm consegue dar "Processo Concluido" se um ou outro dar um "ok". Precisaria que ele so conseguisse dar "Processo Concluido" se os dois darem o "ok", se so um dar "ok" ele não pode dar "Processo Concluido".
       
      Alguém consegue pelo menos me dar um norte para que eu possa dar continuidade? Já tentei em PHP e nada.
       
    • By Pavolin9
      Bom dia, estou desenvolvendo um sistema bem simples de estoque onde os itens serao armazenados em uma matriz segue codigo:
          package main;          import java.io.Console;     import java.util.Arrays;     import java.util.Scanner;          public class IncluirItem{         public static void main(String[] args) {             String[][] itens = new String[2][5];             String[] campos = new String[7];             int opcao = 0;             int remover;             int verificar = 0;             int adcionar = 0;             int tamanho = 2;                          Scanner sc = new Scanner(System.in);                          campos [1] = "Nome";             campos [2] = "Codigo de barras";             campos [3] = "quantidade";             campos [4] = "validade";             campos [5] = "data de entrada";                          do {                 System.out.println("\n\n### Sistema de estoque - simplificado ###");                 System.out.println("=========================================");                 System.out.println("      |     1 - Adcionar itens   |");                 System.out.println("      |     2 - Excluir itens    |");                 System.out.println("      |     3 - Mostrar itens    |");                 System.out.println("      |     0 - Sair             |");                 System.out.println("=========================================\n");                                  System.out.println("Escolha uma opcao: ");                 opcao = sc.nextInt();                 System.out.print("\n");                                  switch (opcao) {                 case 1:                     System.out.println("Cadastro de itens: ");                     //Adciona itens                      for (int i = 0; i <2; i++) {                         System.out.println("Adcionar item? ");                         System.out.println("1 para sim \n2 para nao: ");                         adcionar = sc.nextInt();                         if (adcionar == 1) {                             System.out.printf("%d. item \n", (i+1));                             verificar = verificar + 1;                             for (int j=0; j < 5; j++) {                                     System.out.printf("%s ", campos[j+1]);                                 System.out.printf("= ", i,(j+1));                                 itens[i][j] = sc.next();                                                              }                             System.out.printf("\n");                         }                         else {                             break;                         }                     }                                              break;                 case 2:                     //Remove itens                     System.out.println("Exclusao de itens: ");                     if(verificar > 0) {                         for (int i = 0; i <2; i++) {                                 System.out.printf("%d. item \n", (i+1));                             System.out.printf("ID do produto= 00%d \n", (i+1));                             System.out.printf("\n");                         }                     }                     else {                         System.out.println("Nenhum item listado!");                     }                     System.out.println("\nEscolha o numero do item a ser removido: \n");                     remover = sc.nextInt();                     for (int i = 0; i <2; i++) {                         if(remover == 2) {                         itens[i] = itens[i-1];                         }                     }                     break;                 case 3:                     //Mostra itens                     if(verificar > 0) {                                                      for (int i = 0; i <2; i++) {                                     if (verificar == 2) {                                 System.out.printf("%d. item \n", (i+1));                                 System.out.printf("ID do produto= 00%d \n", (i+1));                                 for (int j=0; j < 5; j++) {                                         System.out.printf("%s ", campos[j+1]);                                     System.out.printf("= %s \n", itens [i][j]);                                 }                                 System.out.printf("\n");                             }                             else {                                         itens = Arrays.copyOf(itens, tamanho - 1);                                         verificar = 0;                                         System.out.printf("%d. item \n", (i+1));                                         System.out.printf("ID do produto= 00%d \n", (i+1));                                         for (int j=0; j < 5; j++) {                                                 System.out.printf("%s ", campos[j+1]);                                             System.out.printf("= %s \n", itens [i][j]);                                         }                                         System.out.printf("\n");                                         break;                                 }                         }                     }                     else {                         System.out.println("Nenhum item listado!");                     }                                          break;                 default:                     System.out.println("Opção Inválida!");                     break;                 }             } while(opcao != 0);         }     }  
      Minha duvida é a seguinte, eu quero excluir uma posicao da matriz, exemplo: registrei dois itens, na coluna um e coluna dois da matriz e gostaria de remover a coluna um da lista, como realizo essa função, e outra coisa, eu gostaria de quando eu inserisse pela segunda vez algum item a matriz começasse na proxima possicao vazia, atualmente se eu pedir para inserir um novo item a matriz começa da primeira posicao e assim apaga os elementos ja inseridos.
       
    • By renan mafra
      Olá pessoal,
      Estou aprendendo JS há alguns meses. Como todo processo de aprendizagem aparecem certas lacunas, dúvidas....
      A minha é a seguinte: Estou tendo dificuldade em atrelar elementos do tipo (arrays/listas/vetores) retornados pelos
      métodos do DOM e atrelá-los a eventos. Nesse código abaixo eu queria transformar cada dia de um calendário em
      um objeto clicável e estou tendo dificuldade em manipular os vetores retornados e atrelá-los A CADA DIA.,
      alguém pode dar essa luz ??
       
      segue o código:
       
      <script> window.onload = function(){ var msg = document.getElementById("msg"); var el = document.getElementById("mes"); var elemento = el.getElementsByClassName("dia"); /* elemento[0].onclick = function(){ elemento[0].style.backgroundColor = "#ccc"; } */ elemento[1].onclick = function(){ elemento[1].style.backgroundColor = "#ccc"; } elemento[2].onclick = function(){ elemento[2].style.backgroundColor = "#ccc"; } elemento[3].onclick = function(){ elemento[3].style.backgroundColor = "#ccc"; } } </script> </head> <body> <table id="mes"> <tr> <td class="dia">1</td><td class="dia">2</td><td class="dia">3</td><td class="dia">4</td><td class="dia">5</td><td class="dia">6</td><td class="dia">7</td> </tr> <tr> <td class="dia">8</td><td class="dia">9</td><td class="dia">10</td><td class="dia">11</td><td class="dia">12</td><td class="dia">13</td><td class="dia">14</td> </tr> <tr> <td class="dia">15</td><td class="dia">16</td><td class="dia">17</td><td class="dia">18</td><td class="dia">19</td><td class="dia">20</td><td class="dia">21</td> </tr> <tr> <td class="dia">22</td><td class="dia">23</td><td class="dia">24</td><td class="dia">25</td><td class="dia">26</td><td class="dia">27</td><td class="dia">28</td> </tr> <tr> <td class="dia">29</td><td class="dia">30</td><td class="dia">31</td> </tr> </table> </body> </html> Já usei função fora do onLoad, já usei loop for mas to quebrando a cabeça aqui.
       
      Eu gostaria que um único botão (o dia clicado) em uma função conseguisse fazer o trabalho, tipo assim:
            
             elemento[x].onclick =  function(){
                       elemento[x].style.backgroundColor = "#ccc";
              }
       
      qual a forma correta de fazer isso ????
       
      agradeço a ajuda.
       
    • By Josues
      Bom dia!
      Gostaria de uma auxilio sobre concatenação de números inteiros em uma matriz bidimensional,
      estou fazendo um trabalho da faculdade e me deparei com essa barreira.
      No programa deve conter duas matrizes de entrada e uma de matriz que vai receber os valores concatenados das duas.
      A matriz é 1 por 2
      L = 1 e C = 2
      no resultado que será mostrado é ex:
      matriz 1 [0][0]: 1
      matriz 1 [0][1]: 1
      Matriz 2 [0][0]: 1
      Matriz 2 [0][1]: 0
       
      Matriz Resultado:
      11            10
      11            10
       
      tem como fazer essa com catenação com inteiros? estou no segundo semestre da faculdade é e uma atividade avaliativa..
       
       
    • By P4870
      Sou estudante do 1º Ano do curso técnico em Informática do IFSP, e preciso de ajuda para fazer esse Algoritmo usando o visuAlg.
       
      01) Levando em consideração o início dos sistemas de informatização as informações eram armazenadas em arquivo do tipo texto. Analisando internamente estes arquivos pode-se notar que nada mais são do que matrizes, pois cada coluna representava um campo e cada linha uma tupla.
       
      Partindo desta informação construa uma matriz para armazenar o RA, CPF e um código para 40 alunos (no CPF digitar somente os números) e uma matriz que guardará 4 notas de 40 alunos e seus respectivos códigos, criando assim um tipo de relacionamento entre as duas matrizes. O primeiro CPF da matriz 1 representa o aluno que possui as 4 notas da primeira posição da segunda matriz. Após o preenchimento de todos os dados das 2 matrizes você deverá perguntar qual o tipo de consulta deverá ser realizada (1-RA, 2-CPF e 3-Código) se for escolhido a opção 1 deve ser solicitado o RA e pesquisar o mesmo na matriz e mostrar o RA, as 4 notas e a média das 4 notas do aluno, se a opção for 2 você deverá solicitar o CPF e também mostrar o CPF, as 4 notas e a média das 4 notas do aluno e se a opção for 3 você deverá solicitar o CÓDIGO e também mostrar o Código, as 4 notas e a média das 4 notas do aluno. Em ambas as consultas deve ser mostrado a situação do aluno (Aprovado quando a média for no mínimo 6; Recuperação quando a média for no mínimo 4 e não chegar a 6; e Reprovado se a média for inferior a 4).
       
      Ao mostrar cada resultado o sistema deve pedir se o usuário deseja fazer uma nova pesquisa.
       
      Caso deseje deve digitar S(SIM) para continuar ou N(NÃO) para finalizar.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.