Publicidade

Rapadura

[Resolvido] Problema no Menu do Site ( ul , li )

Patrocínio:

Olá pessoal do fórum Imasters

 

estou com uma duvida nesse código que quero fazer um menu  utilizando as tags li e ul segue os códigos

 

OBS: no ul o home, news, contact, about funcionam menos o formulário  ele fica invisivel;-;

como mostra nesta print

-->  http://prntscr.com/emda2d

 

OBS: peguei esse codigo do W3schools :)

 

Index.html

Citar

<!DOCTYPE html>
<html lang="pt-br">
<head>
    <title>Web Site</title>
    <meta charset="utf-8">
    <meta name="author" content="Rapadura"> 
    <meta http-equiv="refresh" content="15">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="stylesheet" type="text/css" href="css/styles.css">
</head>
<body>  
    <h1 >
        Web Site
    </h1>

<ul>
  <li><a href="menu/home.txt">Home</a></li>
  <li><a href="menu/news.txt">News</a></li>
  <li><a href="menu/contact.txt">Contact</a></li>
  <li><a href="menu/about.txt">About</a></li>
  <li><a href="menu/formulario.txt"Formulario></a></li>
</ul><br>

<img src="imagens/rapadura.jpg" alt="rapadura" usemap="#planetmap" style="width:200px;height:100%;">
<map name="planetmap">
  <area shape="rect" coords="0,0,82,126" alt="rapadura" href="imagens/rapadura.jpg">
  <area shape="circle" coords="90,58,3" alt="rapadura" href="imagens/rapadura.jpg">
  <area shape="circle" coords="124,58,8" alt="rapadura" href="imagens/rapadura.jpg">
</map>

</body>
</html>

 

Styles.css

Citar

body {
    background-color: powderblue;

}
h1 {
    color: blue;
}
p {
    color: red;
    border: 1px solid powderblue;
    padding: 100px;

}
ul {
    list-style-type: none;
    margin: 10;
    padding: 10;
    overflow: hidden;
    background-color: #333333;
}

li {
    float: left;
}

li a {
    display: block;
    color: white;
    text-align: center;
    padding: 16px;
    text-decoration: none;
}

li a:hover {
    background-color: #111111;
}

 

Deis de já agradeço

Rapadura.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

E qual sua dúvida, amigo? Você postou que tinha uma duvida, mas postou o código e um print-screen apenas.

 

Se sua dúvida é a respeito do item que não aparece, veja que seu código está errado.

 

Troque:

<li><a href="menu/formulario.txt"Formulario></a></li>

Por:

<li><a href="menu/formulario.txt">Formulario</a></li>

 

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

A tag  <a> foi fechada no lugar errado. Abaixo segue a linha corrigida.

 

<li><a href="menu/formulario.txt">Formulario</a></li>

 

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nossa kk obrigado pessoal por responderem resolveu kk Obrigado:sweat_smile: 

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora

  • Próximos Eventos

  • Conteúdo Similar

    • Por Elvis Alencar
      Pessoal, eu não sei onde estou errando.
      Tou tentando adicionar uma imagem em meu site e ela não aparece de jeito nenhum.
       
      Eu não sei o que fazer, não consigo encontrar o error, podem me ajudar ?
       
      <div class="banner-top hidden-xs"> </div> .banner-top { width:100%; height:300px; background-image:url(../imagens/banner.jpg) } Eu coloco isso e não aparece de jeito nenhum.
    • Por diegoDeferrari
      Como posso da forma mais simples mostrar uma figura por passar o mouse em um botão para tornar meu site mais atraente.  o efeito está ilustrado no anexo. obrigado
       
      site:
      http://hangarmma.com/downloads.php

    • Por lucas nc
      Ola, alguem pode me ajudar com um problema? atualmente estva tudo indo bem no meu site, quando de repente eu fui colocar um codigo de publicidade em uma area do meu tema atual, e depois disso as letras e as e os espaços para anuncios não estão se ajustando com a pagina, ta tudo um por cima do outro, na pagina inicial está tudo certo,  mas na pagina do post é que está o problema.
      um ex: eu acabo de fazer uma postagem de um novo video em meu site, ao lado do video tem 3 espaços para ADS abaixo se encontra a descrição do vídeo, só que nada se ajusta em seu determinado lugar, os espaços ads ficam na parte de baixo do video por trás da descrição do video ta uma zona. tonto é que eu até tirei os anuncios na lateral dos video.
       
       
    • Por adrianoalves
      Estou criando um documento para gerar certificado automático, após incluir os dados em um formulário, uma página chamado "dados.php" recebe os dados do formulário. Até aqui tudo certo. O problema que quero gerar um pdf da página "dados.php" e não estou conseguindo porque não consigo colocar esta pagina dentro de uma variável.
      Tentei o seguinte método:
           Teste 1 = Criei uma nova página  onde $html = include('dados.php');
           A unica coisa que aparece no pdf é o número 1.
       
          Teste 2 = Coloquei todo o código da página "dados.php" dentro da variável $html:
       
           $html ='
       <html lang="pt-br">
      <head>
          <meta charset="utf-8"/>
          <title>Untitled Document</title>
             <link rel="stylesheet" href="estilo-dados.css"/>
          <?php
              $nome = isset($_POST["tNome"])?$_POST["tNome"]:"   NOME DO ALUNO   ";
              $curso = isset($_POST["tCurso"])?$_POST["tCurso"]:"";
              switch ($curso) {
                          case "CURSO 1":
                              $instrutor = "<span class='inst'>Luciano da Silva Vaz</span>";
                              $h = 1;
                              break;
                          case "CURSO 2":
                              $instrutor2= "<span class='inst'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Lucas Bueno</span>";
                              $h= 2;
                              break;
                      }
              $inicio = isset($_POST["inicio"])?$_POST["inicio"]:"<span class='data'>00</span>";
              $fim = isset($_POST["fim"])?$_POST["fim"]:"<span class='data'>00</span>";
              $mes = isset($_POST["mes"])?$_POST["mes"]:"<span class='data'>Janeiro</span>";
              $ano = isset($_POST["ano"])?$_POST["ano"]:date('Y');
              $assinatura = isset($_POST["nCheck"])?$_POST["nCheck"]:"";
          ?>
      </head>
      <body>........bla bla bla
         ';
       
      Desta forma também não funcionou.......Alguém poderia me ajudar???