Jump to content
Patricia Carla

Algoritmo - Estrutura Enquanto

Recommended Posts

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

 
  •  
  •  

Share this post


Link to post
Share on other sites

SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.

Share this post


Link to post
Share on other sites

algoritmo "THIAGOSILVA.DVL"
// Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR
// Autor :
// Data : 4/6/2018
// Seção de Declarações
var
VALOR1, VALOR2, VALOR3: INTEIRO
inicio
// Seção de Comandos
ESCREVAL("ESCREVA O PRIMEIRO NUMERO")
LEIA(VALOR1)

ESCREVAL("ESCREVA O SEGUNDO NUMERO")
LEIA(VALOR2)

ESCREVAL("ESCREVA O TERCEIRO NUMERO")
LEIA(VALOR3)

SE VALOR1 > VALOR2 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SE VALOR1 > VALOR3 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SENAO SE  VALOR2 > VALOR1 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR2 > VALOR3 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR1 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR2 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

fimalgoritmo

 

SEGUE MAIS OU MENOS ESSA LÓGICA.  :tounge_wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By dannilson
      que leia um número
      inteiro e uma palavra de forma aleatório e exibir o resultado no final, ao mesmo tempo.
    • By cyyyyber
      oi galera, minha prof pediu um seminario sobre o heap sort. poderiam me passar materiais e alguns algoritmos fáceis para eu estudar? estou perdido. obg
    • By yasuo_mono_dedo
      VisualG
       
      Minha professora de lógica de programação passou alguns exercícios e preciso da ajuda de vocês
       
      O exercício que me acarretou dúvida extrema foi esse:
       
      Escreva um programa que leia um número qualquer e apresente-o somente
      se ele for menor que 100 ou entre 500 e 700
       
      O que me causou dúvida foi que eu ainda não aprendi a fazer isso :/
      Quem puder ajudar eu agradeceria <3
    • By Lauts
      programa
      {
          inclua biblioteca Matematica
          
          funcao inicio()
          {
              inteiro hom=0, mul=0, rsim=0, rnao=0, rhsim=0, rmsim=0, n, t=4
              real psim, pnao
              caracter sexo, resp
              (n == t)
          {
              leia ("Informe o Sexo: ", sexo)
              leia ("Gostou do produto (S/N): ", resp)
              se (sexo =='1')
              {
                  hom = hom + 1
                  se (resp == '1')
              {
                  rmnao = rmnao + 1
              }
              }
              senao
              {
                  se (sexo == '2')
              {
                  mul = mul + 1
                  se (resp == '2')
              {
                  rhsim = rhsim + 1    
              }    
              }
              }
                  se (resp == '1')
              {
                  rsim = rsim +1            
              }
                  senao
              {
                  se (resp == '2')
              {
                  rnao = rnao +1
              }
              }
          n = n  + 1
          }
              psim = 100 * (rmsim / t)
              pnao = 100 * (rhnao / t)
          }
              escreva ("Quantidade de pessoas que responderam sim: ", rsim)
              escreva ("Quantidade de pessoas que responderam não: ", rnao)
              escreva ("Porcentagem de mulheres que responderam sim: ", psim)
              escreva ("Porcentagem de homens que responderam não: ", pnao)
      }
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.