Ir para conteúdo
Patricia Carla

Algoritmo - Estrutura Enquanto

Recommended Posts

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

 
  •  
  •  

Compartilhar este post


Link para o post
Compartilhar em outros sites

SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.

Compartilhar este post


Link para o post
Compartilhar em outros sites

algoritmo "THIAGOSILVA.DVL"
// Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR
// Autor :
// Data : 4/6/2018
// Seção de Declarações
var
VALOR1, VALOR2, VALOR3: INTEIRO
inicio
// Seção de Comandos
ESCREVAL("ESCREVA O PRIMEIRO NUMERO")
LEIA(VALOR1)

ESCREVAL("ESCREVA O SEGUNDO NUMERO")
LEIA(VALOR2)

ESCREVAL("ESCREVA O TERCEIRO NUMERO")
LEIA(VALOR3)

SE VALOR1 > VALOR2 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SE VALOR1 > VALOR3 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SENAO SE  VALOR2 > VALOR1 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR2 > VALOR3 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR1 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR2 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

fimalgoritmo

 

SEGUE MAIS OU MENOS ESSA LÓGICA.  :tounge_wink:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por Dafny Stefany da Silva
      Oi gente, tô fazendo uma lista de programação c e algoritmo(portugol), esse é meu primeiro semestre fazendo programação, se pudessem me ajudar fazendo programas pra eu usar pra entender e conferir os meus eu agradeço desde já
       
      2. Suponha que a sequência S satisfaz a equação matemática e a condição inicial dadas abaixo. Elabore um programa que calcule um termo k qualquer de S, denominado Sk. No programa, faça o tratamento do valor da variável de entrada k. Sk = 5Sk-1 – 4Sk-2 + 2Sk-3 para todo inteiro k ≥ 3, sendo S0 = 1, S1 = -2 e S2 = 3
       
      3. Calcule o valor de P a partir da série infinita abaixo através de um programa em C. Informe o número de termos como dado de entrada. P = 1 1(3) + 2 3(5) + 3 5(7) +...+ n (2n −1)(2n +1)

       
      4. Economizar dinheiro se torna muito difícil em tempos de recessão; portanto, as empresas podem reduzir seus limites de crédito para evitar que suas contas a receber(dinheiro que lhes é devido) se tornem muito grande. Uma companhia reduziu o limite de crédito de seus clientes à metade. Desta forma, se um cliente tinha um limite de crédito de R$2000, agora seu limite passou a ser R$1000. Escreva um programa que analise a situação de crédito de 3 clientes dessa companhia. De cada cliente, você recebe: - o número da conta - seu limite de crédito antes da recessão - seu saldo atual (ou seja, a quantia que o cliente deve à companhia) Seu programa deve calcular e imprimir o novo limite de crédito de cada cliente e determinar (e imprimir) que clientes possuem saldos que excedem seus novos limites de crédito.
       
      5. Escreva um algoritmo/programa para receber um número complexo na forma POLAR e representá-lo na forma RETANGULAR. Ao final, escreva suas duas representações.
       
      6. Foi realizada uma pesquisa sobre algumas características físicas da população de uma certa região, a qual coletou os seguintes dados referentes a cada habitante para análise: - sexo (‘1’ para masculino ou ‘2’ para feminino) - cor dos olhos ( ‘1’ azuis, ‘2’ verdes, ‘3’ castanhos) - cor dos cabelos (‘1’ loiros, ‘2’ castanhos, ‘3’ pretos) - idade (O final do conjunto de habitantes é reconhecido pelo valor -1 entrando como idade) Faça um programa que determine e escreva: (a) A maior idade dos habitantes; (b) A porcentagem entre os indivíduos do sexo masculino cuja idade está entre 18 e 30 anos, inclusive; (c) A porcentagem do total de indivíduos do sexo feminino cuja idade está entre 18 e 30 anos, inclusive, e que tenham olhos verdes e cabelos loiros. Utilize o comando switch no programa.
       
      7. Escreva um programa que leia o número de habitantes de uma determinada cidade, o valor básico cobrado em R$ por KWh consumido, e para cada habitante, entre com os seguintes dados: (a) o consumo do mês em KWh; (b) o código do consumidor (1-Residencial, 2-Comercial, 3-Industrial). Teste se o código digitado é inválido. Sabe-se que o custo do KWh é 1,5 vezes maior para consumidores do tipo 2 e custa o dobro para consumidores do tipo 3. Caso o consumo seja maior do que 100kWh, inclua uma taxa de “bandeira vermelha” de R$ 100. Ao final, escreva: (i) o maior, o menor e a média do consumo em KWh dos habitantes, independente do tipo; (ii) o total resultante do consumo em R$ de cada categoria de consumidor
    • Por Leonardo Martinez
      Olá pessoal tudo bem.... Estava praticando algoritmo e me depareie com o exercício abaixo: Como fazer? Obg
       
      ''Dado um número inteiro positivo dizer qual o valor do dígito da unidade;''
    • Por Leonardo Martinez
      Olá pessoal tudo bem.... Estava praticando algoritmo e me depareie com o exercício abaixo: Como fazer? Obg
       
      ''Dado um número inteiro positivo dizer qual o valor do dígito da unidade;''
    • Por Mühlmann
      Bom dia
       
      Estou com um problema nesse algoritmo, a Variância Populacional apresenta resultado correto apenas para o Funcionário A, para os demais não fecha.
       
      Me ajudem por favor.
       
      Algoritmo "MAPA"
      // Disciplina  : Programação e Cálculo Numérico
      // Professor   : André Noel
      // Descrição   :1. Leia os valores de quantidades de peças produzidas por funcionários, por dia de semana, para 4 funcionários e 5 dias.
      //              2. Calcule a média aritmética simples de peças por funcionário.
      //              3. Calcule e exiba a variância populacional para cada funcionário.
      //              4. Calcule o desvio padrão para cada funcionário.
      //              5. Exiba a média aritmética +- desvio padrão, como no exemplo, para cada funcionário.
      // Autor(a)    : Rafael Muhlmann
      // Data atual  : 28/07/2018
      Var
         // Seção de Declarações das variáveis
         n1,n2,n3,n4,n5,n6,n7,n8,n9,n10,n11,n12,n13,n14,n15,n16,n17,n18,n19,n20 : inteiro
         media1, media2, media3, media4, vp1, vp2, vp3, vp4, dp1, dp2, dp3, dp4 : real
      Inicio
         // Seção de Comandos, procedimento, funções, operadores, etc...
         Escreval ("Digite a Produção do Funcionário A na Segunda")
         Leia (n1)
         Escreval ("Digite a Produção do Funcionário A na Terça")
         Leia (n2)
         Escreval ("Digite a Produção do Funcionário A na Quarta")
         Leia (n3)
         Escreval ("Digite a Produção do Funcionário A na Quinta")
         Leia (n4)
         Escreval ("Digite a Produção do Funcionário A na Sexta")
         Leia (n5)
         Escreval ("Digite a Produção do Funcionário B na Segunda")
         Leia (n6)
         Escreval ("Digite a Produção do Funcionário B na Terça")
         Leia (n7)
         Escreval ("Digite a Produção do Funcionário B na Quarta")
         Leia (n8)
         Escreval ("Digite a Produção do Funcionário B na Quinta")
         Leia (n9)
         Escreval ("Digite a Produção do Funcionário B na Sexta")
         Leia (n10)
         Escreval ("Digite a Produção do Funcionário C na Segunda")
         Leia (n11)
         Escreval ("Digite a Produção do Funcionário C na Terça")
         Leia (n12)
         Escreval ("Digite a Produção do Funcionário C na Quarta")
         Leia (n13)
         Escreval ("Digite a Produção do Funcionário C na Quinta")
         Leia (n14)
         Escreval ("Digite a Produção do Funcionário C na Sexta")
         Leia (n15)
         Escreval ("Digite a Produção do Funcionário D na Segunda")
         Leia (n16)
         Escreval ("Digite a Produção do Funcionário D na Terça")
         Leia (n17)
         Escreval ("Digite a Produção do Funcionário D na Quarta")
         Leia (n18)
         Escreval ("Digite a Produção do Funcionário D na Quinta")
         Leia (n19)
         Escreval ("Digite a Produção do Funcionário D na Sexta")
         Leia (n20)
         media1 <-(n1+n2+n3+n4+n5)/5
         Escreval ("Média da Produção Semanal para o Funcionário A é: ", media1 :1:2)
         media2 <-(n6+n7+n8+n9+n10)/5
         Escreval ("Média da Produção Semanal para o Funcionário B é: ", media2 :1:2)
         media3 <-(n11+n12+n13+n14+n15)/5
         Escreval ("Média da Produção Semanal para o Funcionário C é: ", media3 :1:2)
         media4 <-(n16+n17+n18+n19+n20)/5
         Escreval ("Média da Produção Semanal para o Funcionário D é: ", media4 :1:2)
         vp1 <-(((n1-media1)^2)+(n2-media1)^2)+(n3-media1)^2)+(n4-media1)^2)+(n5-media1)^2))/5)
         Escreval ("Variância Populacional para o Funcionário A é: ", vp1 :1:2)
         vp2 <-(((n6-media2)^2)+(n7-media2)^2)+(n8-media2)^2)+(n9-media2)^2)+(n10-media2)^2))/5)
         Escreval ("Variância Populacional para o Funcionário B é: ", vp2 :1:2)
         vp3 <-(((n11-media3)^2)+(n12-media3)^2)+(n13-media3)^2)+(n14-media3)^2)+(n15-media3)^2))/5)
         Escreval ("Variância Populacional para o Funcionário C é: ", vp3 :1:2)
         vp4 <-(((n16-media4)^2)+(n17-media4))^2)+(n18-media4)^2)+(n19-media4)^2)+(n20-media4)^2))/5)
         Escreval ("Variância Populacional para o Funcionário D é: ", vp4 :1:2)
         dp1 <- RaizQ(vp1)
         Escreval("O Desvio Padrão para o Fincionário A é: ", dp1 :1:2)
         dp2 <- RaizQ(vp2)
         Escreval("O Desvio Padrão para o Fincionário B é: ", dp2 :1:2)
         dp3 <- RaizQ(vp3)
         Escreval("O Desvio Padrão para o Fincionário C é: ", dp3 :1:2)
         dp4 <- RaizQ(vp4)
         Escreval("O Desvio Padrão para o Fincionário D é: ", dp4 :1:2)
         //Conforme solicitado no Enunciado:
         Escreval ("Funcionário A: ",vp1," +- ",dp1 :1:2, " peças por dia")
         Escreval ("Funcionário B: ",vp2," +- ",dp2 :1:2, " peças por dia")
         Escreval ("Funcionário C: ",vp3," +- ",dp3 :1:2, " peças por dia")
         Escreval ("Funcionário D: ",vp4," +- ",dp4 :1:2, " peças por dia")
      Fimalgoritmo
    • Por diegohamaz1
      Galera bom dia a todos,
       
      Gostaria de receber algumas sugestões para elaboração de um algoritmo que leia formulas customizadas , até pensei em fazer um serviço em nodeJs , mas minha aplicação está em Laravel PHP , seria fórmulas com variavéis e operações mais ou menos assim e até mesmo recursivas (encadeamentos dentro das operações)
       
      SE(P1*2 (P2+P3 / SE(R1-R2): SENAO (P4+P4) ))
       
      Alguém tem alguma fonte de pesquisa ? Li a respeito dessa biblioteca https://github.com/doctrine/lexer mas não sei se atenderia ao que eu preciso ( O algoritmo será para calculos finais de avaliações)
       
      Qualquer ajuda é bem vinda ..
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.