Jump to content
Patricia Carla

Algoritmo - Estrutura Enquanto

Recommended Posts

Estou tentando escrever um algoritmo que pede ao usuário inserir os números e no final exiba qual foi o número maior e o número menor.

Só que o número menor sempre é exibido 0.

algoritmo "SomadorNumerico"
// Função :
// Autor :
// Data : 12/04/2018
// Seção de Declarações
var
cont, N, S, maior, menor: Inteiro
inicio
cont <- 1
S <-0
Enquanto (cont <= 5) faca
   Escreva (" Digite o", cont, "o. valor: ")
   Leia (N)
   Se (N > maior) então
      maior <- N
   Senao
      Se (N < menor) então
         menor <- N
      FimSe
   FimSe
   S <- S + N
   cont <- cont + 1
FimEnquanto
EscrevaL ("----------------------------------------")
EscrevaL (" A soma de todos os valores é: ", S)
EscrevaL (" O maior valor digitado foi: ", maior)
EscrevaL (" O menor valor digitado foi: ", menor)
EscrevaL ("----------------------------------------")
fimalgoritmo

 

Alguém pode me ajudar?

 
  •  
  •  

Share this post


Link to post
Share on other sites

SEGUINTE. DEU PRA PERCEBER QUE VOCÊ ESTA ATRIBUINDO VALOR ZERO A SUA VARIALVEL S, ENTAO QUANDO você PEDE PRA IMPRIMIR ELE APARECE ZERO. TEM QUE ORGANIZAR MAIS O CÓDIGO E VER O QUE REALMENTE VOCÊ ESTA PRECISANDO, TEM VARIAVES QUE NAO ESTAÕA SENDO UTILIZADAS.

Share this post


Link to post
Share on other sites

algoritmo "THIAGOSILVA.DVL"
// Função : IMPRIMIR NUMEROS E MOSTRAR O MAIOR
// Autor :
// Data : 4/6/2018
// Seção de Declarações
var
VALOR1, VALOR2, VALOR3: INTEIRO
inicio
// Seção de Comandos
ESCREVAL("ESCREVA O PRIMEIRO NUMERO")
LEIA(VALOR1)

ESCREVAL("ESCREVA O SEGUNDO NUMERO")
LEIA(VALOR2)

ESCREVAL("ESCREVA O TERCEIRO NUMERO")
LEIA(VALOR3)

SE VALOR1 > VALOR2 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SE VALOR1 > VALOR3 ENTAO
   ESCREVAL(VALOR1, "MAIOR NUMERO")
FIMSE

SENAO SE  VALOR2 > VALOR1 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR2 > VALOR3 ENTAO
   ESCREVAL(VALOR2, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR1 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

SENAO  VALOR3 > VALOR2 ENTAO
   ESCREVAL(VALOR3, "MAIOR NUMERO")
FIMSE

fimalgoritmo

 

SEGUE MAIS OU MENOS ESSA LÓGICA.  :tounge_wink:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Andréia Bürck
      Gostaria de saber se há como fazer o seguinte, em JAVA ou qualquer outra linguagem: personalizar um áudio. Ou seja, tenho um áudio, e em lugares chaves desse áudio, depois dele pronto, um programa inserir nesses pontos-chave, por exemplo, nomes. Eu falo o nome, e o programa insere nos pontos pré-determinados.
    • By flipmartinz13
      Alguém pode me ajudar nessa questão de C++? não estou conseguindo construir o algorítmo corretamente.

      5.92)    Faça um algoritmo que leia a matrícula, nome, sexo e três notas dos alunos de uma escola e obtenha os seguintes resultados:
      a) A matrícula da aluna que obteve a maior média.
      b) A matrícula do aluno que obteve a menor média.
      c) O percentual de mulheres na turma.
      d) Quantos alunos foram aprovados, independente do sexo.
      e) O percentual de alunas aprovadas.
      Obs.: o flag é uma matrícula igual a 0 (zero).
    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
    • By Lucaahenr
      Boa tarde pessoal!

      Tenho que fazer um programa em C# que realize o calculo de uma equação de 2° Grau, porem é necessário realizar algumas verificações utilizando IF,  Else e estou tendo dificuldade em realizar estas verificações, gostaria de saber se está correto o que eu fiz ou se tem algum outro modo, segue questão em anexo.

      Muito Obrigado!

      using System; namespace equacaoSegundoGrau { class equacacao { static void Main(string[] args) { double a, b, c, delta; Console.WriteLine("Informe o coeficiente A"); a = double.Parse(Console.ReadLine()); Console.WriteLine("Informe o coeficiente B"); b = double.Parse(Console.ReadLine()); Console.WriteLine("Informe o coeficiente C"); c = double.Parse(Console.ReadLine()); // mesma coisa que a de baixo delta = (b * b) - 4 * a * c; delta = Math.Pow(b, c) - 4 * a * c; if ((a == 0) && (b == 0) && (c != 0)) { Console.WriteLine("Coeficientes informados incorretamente."); } else if ((a == 0) && (b != 0)) { Console.WriteLine("Essa é uma equação de primeiro grau e deverá ser informado o valor da raiz real da equação."); } else if (delta < 0) { Console.WriteLine("Esta equação não possui raízes reais"); } else if (delta == 0) { Console.WriteLine("Esta equação possui duas raízes reais iguais e informar o valor das raízes da equação." + delta); } else if (delta > 0) { Console.WriteLine("Esta equação possui duas raízes reais diferentes."); Console.WriteLine("O valor desta equação é " + delta); } } } }
       
    • By Motta
      Empresa disponibiliza algoritmo do Google em português gratuitamente
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.