Ir para conteúdo
julianopan

Ajuda com erro

Recommended Posts

Boa noite , não consigo achar o erro na validação das mensagens, alguém me da uma luz

 

#include<stdio.h>
#include<stdlib.h>
#include<locale.h>
#include<math.h>
int main(void)
{
    setlocale(LC_ALL,"Portuguese");
    float p1,p2,p3,media;
    printf("Digite três notas:\n");
    scanf("%f %f %f", &p1, &p2, &p3);
    media = (p1*2 + p2*3 + p3*5)/(2+3+5);
    if (media >=8,0 && media <=10)
        printf("A nota do aluno é: A \n");
    else if (media >=7,0 && media <7,5)
        printf("A nota do aluno é: B \n");
    else if (media >=6,0 && media <6,5)
        printf("A nota do aluno é: C \n");
    else if (media >=5,0 && media <5,5)
        printf("A nota do aluno é: D \n");
    else if (media >=0,0 && media <4,5)
        printf("A nota do aluno é: E \n");
    else
        printf("Verfique as notas! \n");
    return(0);
}

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@julianopan, esse teu código tem dois problemas: um sintático e um de lógica.

 

1º) Tu deve alterar a vírgula por ponto no número, para separar as casas decimais;

 

2º) Essa tua validação não compreende alguns casos. Por exemplo:  se o cara ficar com média 7.7, ele não vai cair em nenhum dos if's, vai ir pro else de "Verifique as notas!".

Faça o teste aí: entre com com as notas 5, 5 e 4. A média é ~4.7, que não é compreendido pela tua validação. Então essa nota, que em tese é uma nota válida, daria erro.

 

Abraço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Defina a localização da forma abaixo e continue usando o ponto para separar as casas decimais ao digitar um valor:

setlocale(LC_CTYPE, "Portuguese");

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por Marcela Loschi Salvador
      Microsoft VBScript runtime error '800a0009'
      Subscript out of range: '[number: 3]'
      /portal/estudantes/cadastro/verifica_cad_existe1.asp, line 191
    • Por Daniel Rabelo
      Meu código tá dando erro no fim algoritmo
       
      algoritmo "Calculador de Maioridade"
        var an : inteiro
        var anoa : inteiro
        var qfuac : caractere
        var facf : caractere
        var cpf : caractere
      inicio
         escreval ("Qual seu ano de nascimento ")
         leia (an)
      anoa <- (2018)
      an <- (anoa - an)
         se (an > 18) entao
         escreval ("Voce tem " , an)
         escreval ("Voce e maior de idade")
         escreval (" Voce quer fazer uma faculdade?")
         leia (qfuac)
         se (sim ou Sim ) entao
         escreval ("Qual faculdade voce quer fazer?")
         leia (facf)
         escreval ("Quer fazer seu cadastro para ", facf" ?")
            se (sim ou Sim) entao
               escreval ("Digite seu CPF")
               leia (cpf)
               escreval ("Digite seu RG")
               leia (rg)
               escreval ("Pronto Cadastro Feito. Boa sorte")
               fimse
         senao escreval ("Voce tem " , an)
         escreval ("Voce e menor de idade")
         fimse
      fimalgoritmo
       
      Da esse erro:
       
      Dados incorretos : [46:0] = fimalgoritmo
       
      Alguém me ajuda
       
    • Por nino22
      Alguém consegue me ajudar identificar onde esta o erro 
      esta hospedado aqui  http://www.ajudeomotorista.com.br/admin/
       
       
      conexao.php
      <?php $servidor = "localhost"; $usuario = "u967826836_five"; $senha = "bola8701"; $dbname = "u967826836_formu"; //Criar a conexao $conn = mysqli_connect($servidor, $usuario, $senha, $dbname);ÿÿÿÿ index.php
      <?php session_start(); ?> <!DOCTYPE html> <html lang="pt-br"> <head> <meta charset="utf-8"> <title>FIVE STAR DRIVERS Cadastrar</title> </head> <body> <h1>Cadastrar Usuário</h1> <?php if(isset($_SESSION['msg'])){ echo $_SESSION['msg']; unset($_SESSION['msg']); } ?> <form method="POST" action="processa.php"> <label>N° do Adesivo: </label> <input type="text" name="numero" placeholder="Digite o numero do adesivo"><br><br> <label>Nome: </label> <input type="text" name="nome" placeholder="Digite o nome completo"><br><br> <label>Placa: </label> <input type="text" name="placa" placeholder="Digite á placa do carro"><br><br> <label>Modelo: </label> <input type="text" name="modelo" placeholder="Digite o modelo do carro"><br><br> <label>Ano: </label> <input type="text" name="ano" placeholder="Digite o ano do carro"><br><br> <label>Cor: </label> <input type="text" name="cor" placeholder="Digite a cor do carro"><br><br> <label>Cep: </label> <input type="text" name="cep" placeholder="Digite Digite Cep Residencia"><br><br> <label>Numero da Casa: </label> <input type="text" name="casa" placeholder="Digite o numero Residencia"><br><br> <label>WhatsApp </label> <input type="text" name="Wpp" placeholder="Digite o WhatsApp vinculado ao grupo"><br><br> <label>Telefone Emergência</label> <input type="text" name="telefone" placeholder="Digite telefone de emergência"><br><br> <label>Telefone Emergência 2</label> <input type="text" name="telefone2" placeholder="Digite telefone de emergência"><br><br> <label>Cadastrado POR:</label> <input type="text" name="cadastrado" placeholder="Digite nome do Admin que estar cadastrando"><br><br> <label>E-mail: </label> <input type="email" name="email" placeholder="Digite o seu melhor e-mail"><br><br> <input type="submit" value="Cadastrar"> </form> </body> </html> processa.php
      <?php session_start(); include_once("http://www.ajudeomotorista.com.br/admin/processa.php"); $numero = filter_input(INPUT_POST, 'numero', FILTER_SANITIZE_STRING); $nome = filter_input(INPUT_POST, 'nome', FILTER_SANITIZE_STRING); $placa = filter_input(INPUT_POST, 'placa', FILTER_SANITIZE_STRING); $modelo = filter_input(INPUT_POST, 'modelo', FILTER_SANITIZE_STRING); $ano = filter_input(INPUT_POST, 'ano', FILTER_SANITIZE_STRING); $cor = filter_input(INPUT_POST, 'cor', FILTER_SANITIZE_STRING); $cep = filter_input(INPUT_POST, 'cep', FILTER_SANITIZE_STRING); $casa = filter_input(INPUT_POST, 'casa', FILTER_SANITIZE_STRING); $wpp = filter_input(INPUT_POST, 'wpp', FILTER_SANITIZE_STRING); $telefone = filter_input(INPUT_POST, 'telefone', FILTER_SANITIZE_STRING); $telefone2 = filter_input(INPUT_POST, 'telefone2', FILTER_SANITIZE_STRING); $cadastrado = filter_input(INPUT_POST, 'cadastrado', FILTER_SANITIZE_STRING); $email = filter_input(INPUT_POST, 'email', FILTER_SANITIZE_EMAIL); //echo "Numero: $numero <br>"; //echo "Nome: $nome <br>"; //echo "placa: $placa <br>"; //echo "Modelo: $modelo <br>"; //echo "Ano: $ano <br>"; //echo "cor: $cor <br>"; //echo "Cep: $cep <br>"; //echo "Casa: $casa <br>"; //echo "Wpp: $wpp <br>"; //echo "telefone: $telefone <br>"; //echo "telefone2: $telefone2 <br>"; //echo "cadastrado: $cadastrado <br>"; //echo "E-mail: $email <br>"; $result_usuario = "INSERT INTO usuarios (numero, nome, placa, modelo, ano, cor, cep, casa, wpp, telefone, telefone2, cadastrado, email, created) VALUES ('$numero', '$nome', '$placa', '$modelo', '$ano', '$cor', '$cep', '$casa', '$wpp', '$telefone', '$telefone2', '$email', NOW())"; $resultado_usuario = mysqli_query($conn, $result_usuario); if(mysqli_insert_id($conn)){ $_SESSION['msg'] = "<p style='color:green;'>Usuário cadastrado com sucesso</p>"; header("Location: admin/index.php"); }else{ $_SESSION['msg'] = "<p style='color:red;'>Usuário não foi cadastrado com sucesso</p>"; header("Location: admin/index.php"); }  

       
      ...
       
    • Por BrunoJavan
      Olá, estou tendo problemas para fazer um envio simples num formulário de e-mail.
      O formulário em questão tem somente 4 campos: nome, e-mail, assunto e mensagem.
      Estou utilizando o PHPMailer para realizar a autenticação e o envio, porém na hora de enviar, aparece o seguinte erro:
       
       
      Código do arquivo "enviar.php" que faz a autenticação e envio:
      $nome = ($_POST['nome']); $email = ($_POST['email']); $assunto = 'Contato Site - '.($_POST['assunto']); $mensagem = ($_POST['mensagem']); require_once('class/class.phpmailer.php'); $Email = new PHPMailer(); $Email->IsSMTP(); $Email->Host = 'mail.servidor.com.br'; $Email->SMTPAuth = true; $Email->Port = 587; $Email->Username = 'noreply@servidor.com.br'; $Email->Password = '12345678';  
      Agora o trecho do código que teoricamente está com erro:
      $encoded = preg_replace_callback('/([\000-\011\013\014\016-\037\075\077\137\177-\377])/',function($m) { return '='.sprintf('%02X', ord(stripslashes($m[1]))); }, $encoded);  
      Já testei com outro e-mail, com outra versão do PHPMailer e até verifiquei a versão do meu PHP pra ter certeza que não era isso (parece que só funciona em PHP5+). Enfim, já tentei várias coisas mas não consigo resolver. Sou leigo em PHP e geralmente pego coisas praticamente prontas e só vou alterando de acordo com a minha necessidade.

      Alguém poderia me ajudar?
    • Por matheusfenomeno
      algoritmo "semnome"
      var
      nome:caractere
      c,n:inteiro
      inicio
      escreva("Qual é o seu nome ? ")
      leia(nome)
      Escreval("Prazer ",nome,".")
      escreval("Escolha um numero")
      leia(n)
      c <- 0
      Enquanto (c<=n) faca
         c <- c + 1
      fimEnquanto
      fimalgoritmo
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.