Jump to content
PedroCaampos

Duvida com algoritmo portugol

Recommended Posts

Alguém sabe como resolver resolver esse exercício?  Sou novo nessa área da programação e estou quebrando a minha cabeça para fazer. Se vocês pelo menos me der um base irei agradecer.

 

Miguel é responsável pelas contas de uma grande empresa da área de mineração em Minas Gerais. Ele deseja pagar a seus funcionários um bom salário, mas se preocupa com as épocas de crise. Dessa forma, ele paga um salário fixo, condizente com a função do funcionário e paga a eles um valor adicional a título de participação de lucros. Ele deseja que você crie um programa que calcule quanto um funcionário específico receberá em um mês, tendo em vista a sua função e o quanto a empresa lucrou percentualmente em relação à expectativa. Os salários seguem a tabela:

Nível Salário

Ausente R$1600,00

Técnico R$2800,00

Analista R$3500,00

Especialista R$4000,00

 

ENUNCIADO

Ainda, o salário é acrescido do percentual que excedeu as expectativas de lucro da empresa. Lembrando que se o percentual for inferior a 100% o empregado não pode receber menos do que o salário. Enunciado Agora, que Miguel já consegue saber o quanto um funcionário recebe em um mês, ele deseja saber o quanto ele deverá pagar para todos os seus funcionários. Agora, para cada funcionário ele pagará uma bonificação (percentual) sobre seu salário relacionada a seu desempenho individual, além da participação dos lucros. Ele então deseja que você crie um programa que, recebendo as informações suficientes para o cálculo do pagamento de cada funcionário, informe o valor de pagamento total.

 

Questões

 

1. Identifique a entrada, saída e processamento para este problema.

2. Descreva textualmente os passos do algoritmo.

3. Identifique quais serão as variáveis e constantes utilizadas no algoritmo, com seus tipos respectivos.

4. Descreva as funções matemáticas que geram as saídas do algoritmo.

5. Para o algoritmo desenvolvido por você (não programado ainda!), identifique os laços e desvios de fluxo.

6. Escreva um código em Portugol que represente o algoritmo que resolve o problema de Miguel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By vfraanco
      Desenvolva um algoritmo em pseudocodigo que permita ler as notas que N alunos obtiveram numa disciplina e mostre a
      percentagem de notas positivas e a média das notas negativas. O número de alunos (N) deve ser
      introduzido pelo utilizador e validado.
    • By gbilibio
      Bom dia, preciso realizar uma atividade em portugol, aonde é feito a leitura de um número, identificando se o mesmo é primo, caso não seja primo, deve ser feita a decomposição em fatores primos, o algoritmo para de rodar quando for informado um número negativo. porém como posso realizar um laço ou condicional para fazer a fatoração ? Ainda não encontrei a forma adequada, se puderem ajudar por favor
       
      Segue o meu código:
       
      programa
      {
          
          funcao inicio()
          {
              inteiro n = 0, cont = 0
              inteiro d = 1
              inteiro fat
              inteiro div = 0
              inteiro comp = 0
              
              escreva("Informando se o número é composto ou primo e sua decomposição \n")

              enquanto(n >= 0){
              escreva("Informe um número natural: ")
              leia(n)
              se(n == 1){
                  escreva("O número não é primo nem composto! \n")
              }
              se(n % d == 0){
              
                  d = 2                
              }
              
              se(n == 0){
                  escreva("O número não é primo nem composto! \n")
              }
              senao
                  se(n % d == 0 e n % n == 0 e n != 2){
                      escreva("O número " ,n, " é composto! ")
                  
                      comp = n                            
                                                                                  
              }senao
                  se(n % n == 0 e n > 0 e n != 0 e n != 1){
                      
                  escreva("O número " ,n, " é primo! \n")
                  
                  }
              
                  
                  
              }                    
                                  
          }    
      }

       
       
    • By Lauts
      programa
      {
          inclua biblioteca Matematica
          
          funcao inicio()
          {
              inteiro hom=0, mul=0, rsim=0, rnao=0, rhsim=0, rmsim=0, n, t=4
              real psim, pnao
              caracter sexo, resp
              (n == t)
          {
              leia ("Informe o Sexo: ", sexo)
              leia ("Gostou do produto (S/N): ", resp)
              se (sexo =='1')
              {
                  hom = hom + 1
                  se (resp == '1')
              {
                  rmnao = rmnao + 1
              }
              }
              senao
              {
                  se (sexo == '2')
              {
                  mul = mul + 1
                  se (resp == '2')
              {
                  rhsim = rhsim + 1    
              }    
              }
              }
                  se (resp == '1')
              {
                  rsim = rsim +1            
              }
                  senao
              {
                  se (resp == '2')
              {
                  rnao = rnao +1
              }
              }
          n = n  + 1
          }
              psim = 100 * (rmsim / t)
              pnao = 100 * (rhnao / t)
          }
              escreva ("Quantidade de pessoas que responderam sim: ", rsim)
              escreva ("Quantidade de pessoas que responderam não: ", rnao)
              escreva ("Porcentagem de mulheres que responderam sim: ", psim)
              escreva ("Porcentagem de homens que responderam não: ", pnao)
      }
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
    • By Felipe_2k19
      Olá galera tudo beleza?
       Eu estou tentando resolver um problema no visualg, usando Portugol porém eu não sei aplicar algumas coisas que são pedidas no mesmo.
      Problema: Dado um número, informar se é par ou ímpar. Se for par somar 5 no número informado e se for  ímpar multiplicar por 3 o número informado.
      Eu fiz a parte em que ele fala se o número e par ou ímpar, mas não sei fazer a parte da soma e a multiplicação alguém pode me ajudar?
      ALGORITMO:
      Var n:inteiro inicio escreval("Insira um número inteiro") leia (n) se (n mod2=0) entao escreval ("O número é par") senao escreval("O número é impar") fimse Fimalgoritmo  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.