Jump to content
PedroCaampos

Duvida com algoritmo portugol

Recommended Posts

Alguém sabe como resolver resolver esse exercício?  Sou novo nessa área da programação e estou quebrando a minha cabeça para fazer. Se vocês pelo menos me der um base irei agradecer.

 

Miguel é responsável pelas contas de uma grande empresa da área de mineração em Minas Gerais. Ele deseja pagar a seus funcionários um bom salário, mas se preocupa com as épocas de crise. Dessa forma, ele paga um salário fixo, condizente com a função do funcionário e paga a eles um valor adicional a título de participação de lucros. Ele deseja que você crie um programa que calcule quanto um funcionário específico receberá em um mês, tendo em vista a sua função e o quanto a empresa lucrou percentualmente em relação à expectativa. Os salários seguem a tabela:

Nível Salário

Ausente R$1600,00

Técnico R$2800,00

Analista R$3500,00

Especialista R$4000,00

 

ENUNCIADO

Ainda, o salário é acrescido do percentual que excedeu as expectativas de lucro da empresa. Lembrando que se o percentual for inferior a 100% o empregado não pode receber menos do que o salário. Enunciado Agora, que Miguel já consegue saber o quanto um funcionário recebe em um mês, ele deseja saber o quanto ele deverá pagar para todos os seus funcionários. Agora, para cada funcionário ele pagará uma bonificação (percentual) sobre seu salário relacionada a seu desempenho individual, além da participação dos lucros. Ele então deseja que você crie um programa que, recebendo as informações suficientes para o cálculo do pagamento de cada funcionário, informe o valor de pagamento total.

 

Questões

 

1. Identifique a entrada, saída e processamento para este problema.

2. Descreva textualmente os passos do algoritmo.

3. Identifique quais serão as variáveis e constantes utilizadas no algoritmo, com seus tipos respectivos.

4. Descreva as funções matemáticas que geram as saídas do algoritmo.

5. Para o algoritmo desenvolvido por você (não programado ainda!), identifique os laços e desvios de fluxo.

6. Escreva um código em Portugol que represente o algoritmo que resolve o problema de Miguel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Felipe_2k19
      Olá galera tudo beleza?
       Eu estou tentando resolver um problema no visualg, usando Portugol porém eu não sei aplicar algumas coisas que são pedidas no mesmo.
      Problema: Dado um número, informar se é par ou ímpar. Se for par somar 5 no número informado e se for  ímpar multiplicar por 3 o número informado.
      Eu fiz a parte em que ele fala se o número e par ou ímpar, mas não sei fazer a parte da soma e a multiplicação alguém pode me ajudar?
      ALGORITMO:
      Var n:inteiro inicio escreval("Insira um número inteiro") leia (n) se (n mod2=0) entao escreval ("O número é par") senao escreval("O número é impar") fimse Fimalgoritmo  
    • By Felipe_2k19
      Fala galera tudo beleza?
      Então meu professor passou um "problema" e falou para criar um programa no Visualg usando Portugol, só que eu estou com alguns problemas principalmente na fórmula, alguém pode me ajudar?
      Pergunta: Dado o preço do ingresso e a idade o programa devera informar o preço do ingresso com os seguintes descontos de acordo com a idade:
      IDADE
      0-5-15%
      6-20-5%
      21-40- 2%
      acima de 40 - 30%
       
      Se puderem me ajudar agradeço.
    • By guiilhermej
      Galera, to com um impasse em umas questões passadas na faculdade, eu realmente gosto de resolver meus exercícios, pois só assim sei que irei aprender, mas acontece que to meio perdido nessas questões, alguem me da um help por favor.

       
      6. Escreva um algoritmo que peça um número n ao usuário, e que gere um novo n de acordo
      com a seguinte regra:
      • se n é par, n = n / 2
      • se n é impar, n = 3 * n + 1
      • imprime n
      • O programa deve parar quando x tiver o valor igual a 1. Por exemplo, para n = 13, a saída
      será:
      40 -> 20 -> 10 -> 5 -> 16 -> 8 -> 4 -> 2 -> 1

      7. Fazer um algoritmo que leia um número que servira para controlar os primeiros números
      ímpares. Deverá ser impressa a soma desses números. Suponha que o número informado será
      maior que zero, caso não seja, informar o erro.
      Informe um número: 5
      1 3 5 7 9
      A soma dos 5 valores impares é: 25

      8. Fazer um algoritmo que leia os limites inferior e superior de um intervalo e o número cujos
      múltiplos se deseja que sejam impressos no intervalo aberto. Suponha que os dados digitados
      são para um intervalo crescente. Exemplo:
      Valor inicial: 5
      Valor final: 15
      Divisor: 3
      6 9 12 15
       
      9. Fazer um algoritmo que leia a quantidade de números que se deseja digitar para que
      possa ser impresso o maior e o menor número digitado. Não suponha que todos os
      números lidos serão positivos. Exemplo:
      Quantos números deseja digitar?
      5
      Informe um numero:3
      Informe um numero:-2
      Informe um numero:5
      Informe um numero:6
      Informe um numero:19
      O maior numero informado foi: 19
      O menor numero informado foi: -2
    • By Felipe Cunha
      Boa tarde galera, sei que não é muito comum problemas com essa linguagem porem estou no começo e preciso muito da ajuda de vocês, preciso desenvolver um programa que estou desde ontem tentando desenvolver e não consigo achar uma solução,a linguagem é portugol estou começando no mundo de programação mais estou com muita dificuldade em solucionar esse algorítimo:
       
      Solicite para o usuário nome e sexo de pessoas, ao final da entrada desses dados pergunte para o usuário se o mesmo deseja digitar mais pessoas, se sim solicite novamente os dados, se não, encerre o programa e exiba a quantidade de pessoas que foram digitadas, o total de pessoas do sexo masculino, o total do sexo feminino, o total de sexo inválido e a porcentagem de cada um.
       
      Alguém poderia me ajudar por favor
    • By Maroto
      Olá, pessoas.
       
      Criei um programa com fins de estudo no visualg, cuja finalidade é preencher uma matriz com valores aleatórios e, em seguida, conferir e armazenar numa segunda atriz se o valores gerados são pares ou ímpares. Todavia o programa fica dando um erro ("Access violation at address xxxx in module" visualg30.exe). Não sei se eu que estou errando na lógica, se meu pc está quebrado ou se é um bug do visualg. 

      Abaixo deixo meu código para quem puder me ajudar. Obrigado :)
       
      Var // Seção de Declarações das variáveis matriz1: vetor [0..2, 0..2] de inteiro matriz2: vetor [0..2, 0..2] de caractere // Procedimento que gera valores inteiros aleatorios para preencher a matriz1. procedimento preencheMatriz var // Variaveis contadoras i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca aleatorio on leia (matriz1[i1,i2]) limpatela aleatorio off fimpara fimpara // Imprimindo a matriz na tela para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca escreva (matriz1[i1,i2]) fimpara escreval ("") fimpara fimprocedimento // Procedimento que verifica se os valores das posições da matriz1 são pares // ou ímpares. procedimento verificaParImpar var i1, i2: inteiro inicio para i1 de 0 ate 1 passo 1 faca para i2 de 0 ate 2 passo 1 faca se (matriz1[i1, i2] MOD 2=0) entao matriz2[i1,i2] <- "par" escreva(matriz2[i1,i2], " ") senao matriz2[i1,i2] <- "ímpar" escreva(matriz2[i1,i2], " ") fimse fimpara escreval(" ") fimpara fimprocedimento Inicio // Seção de Comandos, procedimento, funções, operadores, etc... preencheMatriz verificaParImpar Fimalgoritmo  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.