Ir para conteúdo
Marcosvn

[Resolvido] CPU de hospedagem com uso excedido

Recommended Posts

Falaii galera.

 

Hoje pela manha meu site começou apresentar erro 500 (erro de servidor interno) entrei em contato com o suporte da hostgator e eles ficaram quase uma hora pra dizer que não conseguiram encontrar o problema e q iriam abrir um chamado q pode levar 5 dias. Mas eu não posso esperar tanto assim e quero saber se alguem ai pode me ajudar a resolver isso antes.

 

O que ta ocorrendo é o seguinte:  20 processos estão em andamento para a url: /home/troca546/public_html/segredosdosonho.com.br/wp-login.php /usr/bin/php 

 

isso está sobrecarregando o uso de cpu e o site cai toda hora com o erro 500. Porém, é impossível finalizar os processos, eles recomeçam sem parar. E o suporte da hostgator tbm teve o mesmo problema.

 

Alguem pode me dar uma luz sobre essa situação ??

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Provavelmente você está sofrendo um ataque. Utilize um plugin para "limitar" às tentativas de login mal sucedidas, isso deve parar às requisições ;)

Movendo para área WordPress

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, Alaerte Gabriel disse:

Provavelmente você está sofrendo um ataque. Utilize um plugin para "limitar" às tentativas de login mal sucedidas, isso deve parar às requisições ;)

Movendo para área WordPress

 

Realmente era um ataque cara. Obrigado pela dica do plugin

 

abraço

Compartilhar este post


Link para o post
Compartilhar em outros sites

Existem mais medidas que você pode tomar para evitar este tipo de ataque. Além de limitar a quantidade de tentativa de login, você pode utilizar o CloudFare para trazer mais segurança ao seu servidor e requisições.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por leandrosv
      Boa tarde pessoal, uma dúvida somente,se conseguirem  me responder ficarei grato!.
      Programo em php há 6 meses. Até o momento foquei em aprender e fazer para  mim.
      Peguei meu primeiro projeto, para um amigo, porém design, css e javascript não é meu forte, falta criatividade e aprender bastante sobre o JS.
      A duvida é a seguinte: Comprei um tema no themeforest.net à escolha dele(amigo), e o tema veio com puglins woocommerce, a minha dúvida é se posso hospedar e utilizar normalmente no site esses plugins sem usar o sistema wordpress. Editei o código js e css do que não me interessa e está funcionando legal. A dúvida mesmo, unica dúvida é se posso e vou conseguir rodar meu site em uma hospedagem normal sem o sistema wordpress.
      Obrigado!
      **moderadores e administradores do fórum, caso seja aqui um tópico errado, perdão, procurei mas não achei nada a respeito do assunto.
    • Por M. Alberto
      Estou realizando a migração de meu site que utiliza um banco de dados em mySQL PHP porém estou obtendo erro.
       
      Criei o banco de dados e fiz upload dos arquivos, porém agora neste servidor não roda de maneira alguma. Alguém poderia me ajudar ?
    • Por Luisa Di Domenico
      Oi, pessoal
      Não tenho muito conhecimento em desenvolvimento, por isso estou aqui pra pedir ajuda.
      Contratei um desenvolvedor para adaptar um tema do wordpress as minhas necessidades, o trabalho foi entregue porém ficou faltando alguns detalhes, os quais a maioria eu já corrigi e um não consigo alterar de jeito nenhum. E a pessoa que contratei não me responde mais.
       
      Não consigo fazer com que abra uma nova janela quando a pessoa clica em "Candidatar-se à vaga". Atualmente ele abre um popup com o link da vaga.

                     <?php if ( candidates_can_apply() ) :
                      $external_apply = get_post_meta( $post->ID, '_apply_link', true ); 
                      if(!empty($external_apply)) {
                          echo '<a class="button" target="_blank" href="' . esc_url( $external_apply ) . '">' . esc_html__( 'Candidatar-se à Vaga', 'jobseek' ) . '</a>';
                      } else {
                          get_job_manager_template( 'job-application.php' ); 
                      }
                  endif; ?>
       
      Alguém pode me dar um luz, plis? 
      Obrigada!
       
    • Por fael97
      Olá a todos bom dia, tarde ,noite...
      bem estou com um problema meio chato, sempre que relogo a página no meu site a sessão que estava salva some.. eu preciso muito dela pois ela quem me mantem logado e navegando pelo site..
      a estrutura do meu site é assim. É uma rede social: www.onfamily.com.br.
      tenho a pagina de login que me leva para index, paginas de navegação que leva para pagina de cadastro de família caso não houver a sessão família. e caso não houver login nem senha  me leva pra pagina de login novamente.
      o problema é que quando eu logo, após ir para página de navegação mostra a sessão família la emcima, mas quando eu relogo a página a sessão some, e me leva para página de cadastro de família, sendo que a família ja foi cadastrada e validade na página de login do qual está na sessão. alguem poderia me ajudar com este bug? pra não precisar ficar fazendo várias consultas sempre quando relogo a página?
       
      meu codigo é assim:
       
      Página processa_login: 
       
      <?php 
          if((isset($_POST['email'])) and (isset($_POST['senha']))){
              //inclui arquivos de classes
              include('classes/classes.inc.php');
              //inclui arquivo de funcoes
              require_once('funcoes/conexao.func.php');
              $conn = Conn();
              if(!isset($_SESSION)) session_start();
              //recupera dados do form
              $email = $_POST['email'];
              $senha = utf8_encode($_POST['senha']);
              //instãncia novo objeto login da classe login
              $login = NEW Login("","","");
                          
              $retorno_log =  $login->autenticaUsuario("$email","$senha");                        
              if($retorno_log == 1){
                  //atribui os valores a sessão
                  $_SESSION['email'] = $email;
                  $_SESSION['senha'] = $senha;
                  $selecionar = $conn->prepare("
                      SELECT informacoes_usuario.familia FROM informacoes_usuario 
                      JOIN usuarios ON informacoes_usuario.usuario = usuarios.idusuario 
                      WHERE email = ?
                  ");
                  $selecionar->execute(array($email));
                  $registro = $selecionar->fetchAll(PDO::FETCH_ASSOC);
                  if($registro[0]['familia'] != null){
                      $_SESSION['familia'] = $registro[0]['familia'];
                      if(isset($_SESSION['url'])){
                          echo "<script>window.location.assign('$url');</script>";
                      }else{
                          echo "<script>window.location.assign('nav/index.php');</script>";
                      }                            
                  }else{
                      echo "<script>window.location.assign('cadastro/criar_familia.php');</script>";
                  }
              }else{
                  echo "usuário ou senha incorretos";
              }            
          }else{
              echo "Houve um erro interno. <a href=\"javascript:history.back()\">Voltar</a>";
          }
      ?>                
       
      trecho da página index: 
          //se não existe sessão, então inicia
          if(!isset($_SESSION)) session_start();
          
          //$_SESSION['url'] = $_SERVER['REQUEST_URI'];    
          //aqui imprime da primeira vez que faço o login, mas quando relogo a página a sessão some!, obs: a sessão email e senha continuam la
          echo $_SESSION['familia'];
          echo $_SESSION['email'];
          echo $_SESSION['senha'];
          if((!isset($_SESSION['email'])) and (!isset($_SESSION['senha'])) and (!isset($_SESSION['familia']))){
              header('location: ../index.php');
          }elseif((isset($_SESSION['email'])) and (isset($_SESSION['senha'])) and (!isset($_SESSION['familia']))){
              header('location: ../cadastro/criar_familia.php');
          }
       
      alguem da um help por favor, porque a sessão família está aparecendo somente uma vez e sumindo, e a sessão email e senha não está? 
      obs: no servidor local funciona perfeitamente, e antes estava funcionando normalmente após alterar alguns trechos que nem lembro mais oque é.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.