Ir para conteúdo
kim.y

Debugar website direto do Visual Studio no celular

Recommended Posts

Um mesmo site funciona normalmente no meu notebook porém quando acesso do celular ele apresenta um bug indesejável, eu gostaria de debugar pelo visual studio para não ter que ficar subindo o site toda hora para produção somente para testar.

 

O que eu consegui foi acessar o site da produção pelo celular e emular no meu notebook mas eu gostaria de debugar o site direto pelo Visual Studio para economizar tempo.

 

Preciso debugar um website no celular através do Visual Studio, é possível?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 16/07/2018 at 13:24, quintelab disse:

Já tentou utilizar a ferramenta de desenvolvedor do Chrome ? Tem um emulador de celular, talvez consiga reproduzir seu bug.

 

Sim, cheguei a utilizar mas estranhamente quando eu utilizo o inspecionar do Chrome o bug "desaparece", somente quando eu abro diretamente do meu celular que acontece.

 

O mais próximo que eu consegui, foi emular (não sei se esse é termo correto) a página do meu celular no meu notebook e assim consegui reproduzir o erro.

 

Porém meu problema é que para testar vou ter que ficar fazendo pull request pra ambiente dev para testar cada alteração (já é uma alternativa mas seria demorado).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vai depender muito de como esta sua rede....

Se você estiver usando IIS pra desenvolver e não IIS Express e seu celular estiver na mesma rede da sua máquina de desenvolvimento, você conseguirá acessar a versão da sua máquina.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por WAD - Soluções
      Olá, só pouco leigo, estou com dificuldade em deixa logo de um site padronizada poderia me ajudar com alguma orientação. A logo até na versão tablet exibida sem problemas porém quando chega na versão mobile tenho problema consideram que a logo e oval.

      Link do site: http://wadsolucoes.com.br/sys/editor/
      .logo_container { display: inline-block; padding-left: 76px; } .logo span { font-family: 'Open Sans', sans-serif; font-size: 30px; font-weight: 900; color: #3a3a3a; vertical-align: middle; text-transform: uppercase; margin-left: 3px; } <div class="logo_container"> <div class="logo"><a href="./"><img src="images/logo-2.png" alt="EDITOR FISCAL - UMA PARCERIA DE SUCESSO" width="210" height="204"/></a> </div> </div>
       
    • Por jgasper
      Boa tarde, preciso de ajuda, fiz o site para minha empresa de advocacia mas nao sei transformar em mobile, peguei template pronto e fiz modificações, nao sou bom em HTML, foi o que consegui fazer. Alguem pode me ajudar a transformar ele em responsivo? só fazendo o menu funcionar para celular?
       
      Os arquivos do site estao em: https://mega.nz/#!AEAUxa5Z!EwFVVhgaJeJg6DTFpzUfi0vnrULPzI8YI9I0-XJwaE8
       
      Agradeço desde ja.
    • Por lucasrodrigues
      Estou com esse problema ao tentar vincular uma tabela do MySql a um DataSet. Utilizo o MySqlConnector 8.0.13, MySql-For-VisualStudio 1.2.8.

    • Por Marcos PP
      A algum tempo atras um programador criou um sisteminha de leitura de porta serial para mim, este sistema lia uns valores vindo de uma balança este valor era processado e enviado para uma tabela em MYSQL.
      E infelizmente não consigo falar com ele mais, 

      O sistema esta pronto e rodando, porem hoje fui instalar ele em um PC para uma nova balança e a pontuação da balança vem diferente, e creio que por isso não esta gravando no banco
       
      Tenho o fonte do sistema que foi desenvolvido em Visual Studio 2010, porem o desenvolvedor me falou na época que era bem simples que pode ser editado ate em 2007, como não entendo muito, queria ver se alguém me da uma ajuda de colocar esta configuração de casas decimais no arquivo de configuração, onde eu altero Usuário e senha do banco e mais algumas funções, de rrrepente ate ja tem , mais não sei onde devo alterar
       
      O resumo e o seginte, 
      A balança manda o valor assim
      PB: 000,120 T: 000,000
      Este PB:  na frente significa que o peso esta parado, não existe mudança, então a tabela so atualiza quando vem **:

      Ate ai tudo ok. 
      O problema e que a nova balança me envia o valor assim
      PB: 120,0 T: 000,000


      Vou colocar o arquivo de configuração aqui, ai se alguém souber mais me fala se da para mudar só nele
       
      <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" > <section name="LogSerialPort.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" /> </sectionGroup> </configSections> <startup> <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7" /> </startup> <applicationSettings> <LogSerialPort.My.MySettings> <setting name="constr" serializeAs="String"> <value>Driver={MySQL ODBC 5.1 Driver};Server=localhost;charset=UTF8MB4;Database=balanca;User=root; Password=;Option=3;</value> </setting> <setting name="PortName" serializeAs="String"> <value>COM3</value> </setting> <setting name="BaudRate" serializeAs="String"> <value>9600</value> </setting> <setting name="Parity" serializeAs="String"> <value>None</value> </setting> <setting name="DataBits" serializeAs="String"> <value>8</value> </setting> <setting name="StopBits" serializeAs="String"> <value>One</value> </setting> <setting name="Handshake" serializeAs="String"> <value>None</value> </setting> <setting name="Debug" serializeAs="String"> <value>On</value> </setting> <setting name="Lista_Parity" serializeAs="String"> <value>None, Odd, Even, Mark, Space</value> </setting> <setting name="Lista_StopBits" serializeAs="String"> <value>None, One, Two, OnePointFive</value> </setting> <setting name="Lista_Handshake" serializeAs="String"> <value>None, XOnXOff, RequestToSend, RequestToSendXOnXOff</value> </setting> <setting name="ConnectionTimeout" serializeAs="String"> <value>10</value> </setting> <setting name="CommandTimeout" serializeAs="String"> <value>2</value> </setting> <setting name="SQLCommandText" serializeAs="String"> <value>UPDATE peso SET peso_atual = {0};</value> </setting> </LogSerialPort.My.MySettings> </applicationSettings> </configuration>

       
    • Por alexcorrea
      Olá pessoal, alguém poderia me ajudar?
      Como faço para redirecionar meu site responsivo direto para o WhatsApp, sem precisar abrir o site?
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.