Jump to content
paikoala

site funciona 100% no crhome mas buga css no firefox

Recommended Posts

bom dia galera, tenho um site que montei e hospedei ele no 000WEBHOST. enquanto estava montando ele em localhost funcionava tudo certo tanto no crhome quanto no firefox mas quando subi ele pra hospedagem no firefox ele começou a zuar. Pq o site abre normal no chrome e no firefox ele fica assim:

 

firefox.png

crhome.png

Share this post


Link to post
Share on other sites

Siga esses passos.

1 - Atualize o mozilla para última versão.

2 - Abra o mozilla pressione (crtl + shift + i)

3 - Vá na aba console depois procure pelo um ícone que parece uma pazinha

4 - Marque todas opções. depois feche o mozilla.

5 - Limpe todos dados de navegação.

6 - Abra o mozilla acesse o website e repita o processo do passo 2.

7 - Clique na aba console e veja todos erros e alertas que o mozilla apresenta. Pois são esses os erros que cometeu.

 

Nota: Pode ser difícil localizar os problemas se você utilizou diretamente no html div style="....

Nota 2: O mozilla muito menos exigente quanto aos acertos de regras (porém é muito exigente quando mal feitas)

Nota 3: O mozilla é de longe o melhor browser de desenvolvimento (na verdade é o único que presta para essa finalidade)

Nota 4: É possível configura-lo para não salvamento de dados

A - No canto superior direito clique no menu > opções

B - Clique em Privacidade e Segurança 

C - Localize histórico e selecione Nunca Memorizar.

D - Feche e abra novamente o mozilla.

Share this post


Link to post
Share on other sites

realmente tenho que concordar com você, o firefox é maravilhoso para desenvolvimento, usava o sublime para digitar codigos mas quase todo o css fiz pelo firefox, ele é fodastico. eu desenvolvi o site usando ele e em localhost ele fazia tudo certo. vou fazer esses passos e ver o que acontece.

Share this post


Link to post
Share on other sites

Funcionou 100%, ele mostrou um erro que nem sabia que tinha feito, tinha uma url .com comprada e por falta de dinheiro fiquei sem, na parte do css tinha a url .com e não lembrava disso. agora que atualizei para a url gratis do 000webhost ele ta funcionando normal, apesar de ainda não fazer sentido o pq ele ainda sim funcionava no chrome...

Juro que não conhecia essa função do developer do firefox, muito obrigado...

Share this post


Link to post
Share on other sites
Em 11/09/2018 at 16:58, Omar~ disse:

Siga esses passos.

1 - Atualize o mozilla para última versão.

2 - Abra o mozilla pressione (crtl + shift + i)

3 - Vá na aba console depois procure pelo um ícone que parece uma pazinha

4 - Marque todas opções. depois feche o mozilla.

5 - Limpe todos dados de navegação.

6 - Abra o mozilla acesse o website e repita o processo do passo 2.

7 - Clique na aba console e veja todos erros e alertas que o mozilla apresenta. Pois são esses os erros que cometeu.

 

Nota: Pode ser difícil localizar os problemas se você utilizou diretamente no html div style="....

Nota 2: O mozilla muito menos exigente quanto aos acertos de regras (porém é muito exigente quando mal feitas)

Nota 3: O mozilla é de longe o melhor browser de desenvolvimento (na verdade é o único que presta para essa finalidade)

Nota 4: É possível configura-lo para não salvamento de dados

A - No canto superior direito clique no menu > opções

B - Clique em Privacidade e Segurança 

C - Localize histórico e selecione Nunca Memorizar.

D - Feche e abra novamente o mozilla.

 

@Omar~ estou com a ultima versão do firefox 07/06/19... porém não encontrei essa "pazinha" que você descreve nos passos da solução.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By b2black
      Então, estou tentando criar um submenu com opções quando o usuário passa o link em cima da imagem, porém não estou conseguindo, qual é o jeito certo de fazer?
       
      Ao clicar no link (link-login) que é uma imagem colocada com css, abre um menu abaixo da imagem com 5 opções de link
       
      <div class="nav-container"> <nav> <ul class="desktop-nav"> <li> <a href="" class="link-logo"></a> </li> <li> <a href="">Charm Points</a> </li> <li> <a href="">Ranking</a> </li> <li> <a href="">Colaboradores</a> </li> <li> <a href="">Blog</a> </li> <li> <a href="">Eventos</a> </li> <li> <a href="">Suporte</a> </li> <li> <!--<a href="" class="link-search"></a>--> <form method="get" action="" class="search"> <input name="boxsearch" type="search-text" placeholder="" /> </form> </li> <li> <a href="" class="link-bag"></a> </li> <li> <a href="" class="link-login"></a> </li> </ul> </nav> </div>  
      .link-login { background: url('avatar.png'); background-repeat: no-repeat; display: block; background-position: center; background-size: 20px; height: 44px; width: 20px; } .link-login:hover { position: relative; display: inline-block; margin-top: 50px; min-width: 160px; box-shadow: 0px 8px 16px 0px rgba(0,0,0,0.2); padding: 12px 16px; z-index: 1; }  
    • By b2black
      Estava vendo para atualizar o Windows pro 11, e notei isso no site da Microsoft, alguém sabe qual repositorio, ou como pesquisar para desenvolver algo similar?
      Quando você rola a página, o menu fica transparente.
       
      Explore Windows 11 OS, Computers, Apps, & More | Microsoft
    • By ferreiradealmeida
      Prezados(as), boa tarde.
       
      Já trabalhei com webdesign e desenvolvimento frontend, mas faziam anos que não mexia com isso. Hoje sou advogado.
       
      Elaborei uma assinatura para e-mail em HTML, que quando aberta no navegador é exibida corretamente:
       

       
      Ocorre que quando a assinatura é inserida na mensagem (Microsoft Outlook 2016) a disposição dos elementos se mostra desconfigurada, assim permanecendo se a mensagem for enviada:
       

       
      Devem ter notado que a imagem que fica acima das informações é uma imagem de fundo. Já tentei também "background" na <table>, mas neste caso, apesar de aparecer no navegador a imagem sequer aparece na assinatura:
       
      <div style="max-width:716px; max-height:200px; position:relative;"> <img src="http://www.fafadv.com.br/images/assinatura.jpg" alt="imagem-assinatura" /> <div style="position:absolute; top:0px; bottom:0px; left:0px; right:0px;"> <table border="0" cellpadding="0" cellspacing="0" width="716" height="200" style="max-width:716px; max-height:200px;"> <tr> <td rowspan="3" style="width:242px;"></td> <td rowspan="3" style="width:340px; font-family:Gadugi; font-size:14px; padding:5px;"> <p><strong><span style="font-size:18px;">Daniel A. Ferreira de Almeida</span></strong><br> <span style="font-size:16px;">Advogado - OAB/SP 424.237</span></p> <p style="margin-top:-7px;">(16) 9 9373-2552<br> (16) 3421-7783</p> <p style="margin-top:-7px;"><a href="mailto:ferreiradealmeida@fafadv.com.br" style="font-family:Gadugi; font-size:14px; color:#000;"> ferreiradealmeida@fafadv.com.br</a><br> <a href="http://www.fafadv.com.br" style="font-family:Gadugi; font-size:14px; color:#000;">www.fafadv.com.br</a></p> <p style="margin-top:-7px;">Rua Marino Bruno Regini, nº 270, Sala 02<br> Nova Ribeirânia - Ribeirão Preto/SP, CEP 14096-710</p> </td> <td style="width:125px; height:67px; text-align:center;"> <a href="https://www.facebook.com/adv.faf/"> <img src="http://www.fafadv.com.br/images/logo-facebook.png" alt="logo-facebook" style="margin-top:10px;"> </a> </td> </tr> <tr> <td style="width:125px; height:66px; text-align:center;"> <a href="https://www.instagram.com/faf.adv/"> <img src="http://www.fafadv.com.br/images/logo-instagram.png" alt="logo-instagram" style="margin-top:10px;"> </a> </td> </tr> <tr> <td style="width:125px; height:67px; text-align:center;"> <a href="https://www.linkedin.com/company/faf-adv"> <img src="http://www.fafadv.com.br/images/logo-linkedin.png" alt="logo-linkedin" style="margin-bottom:5px;"> </a> </td> </tr> </table> </div> </div> Serei grato se alguém souber o que ocorre e puder colaborar.
       
      Obrigado.
    • By 4Unknow
      Boa tarde pessoal, como estão?
       
      Gostaria de uma ajudinha aqui. A forma mais prática e com um layout bacana, um pop-up toda vez(ou não) que o usuário abrir o site, um informativo que é importante.
      Tenho um site que vende algo muito específico e preciso deixar claro sobre meu produto como um informativo. Ou um banner/popup que abre quando o usuário entra no site para deixar claro.

      Ou um footer bonito que deixa claro essa informação.

      Se alguém tiver uma ideia ou puder ajudar, eu agradeceria.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.