Jump to content
  • 0
Felipe Cunha

Ajuda programa (Portugol) ou VisualG

Question

Boa tarde galera, sei que não é muito comum problemas com essa linguagem porem estou no começo e preciso muito da ajuda de vocês, preciso desenvolver um programa que estou desde ontem tentando desenvolver e não consigo achar uma solução,a linguagem é portugol estou começando no mundo de programação mais estou com muita dificuldade em solucionar esse algorítimo:

 

Solicite para o usuário nome e sexo de pessoas, ao final da entrada desses dados pergunte para o usuário se o mesmo deseja digitar mais pessoas, se sim solicite novamente os dados, se não, encerre o programa e exiba a quantidade de pessoas que foram digitadas, o total de pessoas do sexo masculino, o total do sexo feminino, o total de sexo inválido e a porcentagem de cada um.

 

Alguém poderia me ajudar por favor

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Olá, @Felipe Cunha! Desenvolvi este algoritmo. Espero que tenha ajudado!

Algoritmo "Contagem de pessoas"
Var
   nome, sexo, optEncerrar: caractere
   numPessoas, numFem, numMasc: inteiro
Inicio
   numPessoas <- 0
   numFem <- 0
   numMasc <- 0

   enquanto (optEncerrar <> "S") faca
      escreva("Digite o nome: ")
      leia(nome)
      escreva("Digite o sexo (M/F): ")
      leia(sexo)

      numPessoas <- numPessoas + 1

      se (sexo = "M") entao
         numMasc <- numMasc + 1
      senao
         numFem <- numFem + 1
      fimse

      escreva("Deseja encerrar o programa? (S/N): ")
      leia(optEncerrar)
   fimenquanto

   escreval("Número de pessoas: ", numPessoas)
   escreval("Número de homens: ", numMasc)
   escreva("Número de mulheres: ", numFem)

Fimalgoritmo

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By CadencePro
      Faça o código de uma aplicação Web em PHP, que realize o cálculo do consumo de energia de equipamentos eletrônicos e eletrodomésticos de uma residência. O usuário deve entrar com o nome do aparelho, juntamente com o seu consumo em Watts/hora e a quantidade de horas que ele fica ligado por dia. O resultado do cálculo deve ser dado em Kw/H.
      Regras:
      - Você deve permitir que seja adicionado quantos aparelhos forem possíveis.
      - Deve-se calcular o consumo total da casa, e o consumo mensal de cada aparelho deve ser obtido em Kw/h, mesmo com que a entrada esteja em Watts/hora.
      - A aplicação deve gravar em um arquivo o nome de cada equipamento, juntamente com o consumo mensal dele em Kw/H.
    • By Hacker_Buiu
      Tem alguma área no fórum dedicada ao Linux e um subfórum para programação no mesmo?
       
      Observação:Preciso de uma área dessas para divulgar meu trabalho e ser reconhecido por muitos,tenho vídeo aulas de Linux,programas feitos para Linux no formato .deb,.rpm e .txz(Slackware),e ainda dicas e artigos do mesmo assunto.
       
      Hacker_Buiu é só meu nick,lembrando que existe hacker do bem e hacker do mal,mas não me considero um hacker,apesar de ser apaixonado por Linux,programação e tecnologia.
       
      Preciso de uma área assim:
       
      Fórum:Linux
      Subfórum:Lazarus,Gambas e NetBeans,Explicação:Lazarus(Delphi 7 para Linux),Gambas(Visual Basic do Linux),NetBeans para programar em Java e as vezes com C/C++ via plugin.
      Subfórum:Vídeo aulas de Linux(Instalação de programas,de jogos e vídeo aulas de programação etc...).
       
      Moderadores e Administradores quero muito essas áreas para contribuir para o fórum,meu desejo de contribuição para o fórum é imenso.Desejo muito demonstrar meu trabalho e ser reconhecido e tenho a ideia criada por mim que um fórum é uma casa por exemplo:
       
      Moderadores e Administradores:Se a casa é bonita e organizada terá mais visitantes(Amigos ou vizinhos),no caso do fórum é uma casa também e se o fórum já é bonito só falta organizar mais essas áreas para ter mais visitantes(Amigos(Parceiros) ou usuários visitando o mesmo),o que acham da ideia que criei?
       
      Eu imploro aos administradores e moderadores,por favor criem essa área de Linux para que eu possa contribuir nessa área,assim como os outros,e também deixar o fórum mais organizado.
    • By leonardorafaeldev
      Boa noite pessoal estou com um problema que o icone do meu site não aparece no mobile segue uma foto do problema o meu codigo esta assim
       
      <!-- icones -->   <link href="icones/favicon.ico" rel="icon">   <link href="icones/favicon.ico" rel="shortcut icon">    <link rel="apple-touch-icon" sizes="57x57" href="icones/apple-icon-57x57.png">   <link rel="apple-touch-icon" sizes="60x60" href="icones/apple-icon-60x60.png">   <link rel="apple-touch-icon" sizes="72x72" href="icones/apple-icon-72x72.png">   <link rel="apple-touch-icon" sizes="76x76" href="icones/apple-icon-76x76.png">   <link rel="apple-touch-icon" sizes="114x114" href="icones/apple-icon-114x114.png">   <link rel="apple-touch-icon" sizes="120x120" href="icones/apple-icon-120x120.png">   <link rel="apple-touch-icon" sizes="144x144" href="icones/apple-icon-144x144.png">   <link rel="apple-touch-icon" sizes="152x152" href="icones/apple-icon-152x152.png">   <link rel="apple-touch-icon" sizes="180x180" href="icones/apple-icon-180x180.png">   <link rel="icon" type="image/png" sizes="192x192"  href="icones/android-icon-192x192.png" >   <link rel="icon" type="image/png" sizes="36x36" href="icones/android-icon-36x36.png">   <link rel="icon" type="image/png" sizes="48x48" href="icones/android-icon-48x48.png">   <link rel="icon" type="image/png" sizes="96x96" href="icones/android-icon-96x96.png">   <link rel="icon" type="image/png" sizes="144x144" href="icones/android-icon-144x144.png">   <link rel="icon" type="image/png" sizes="72x72" href="icones/android-icon-72x72.png">   <link rel="icon" type="image/png" sizes="32x32" href="icones/favicon-32x32.png">   <link rel="icon" type="image/png" sizes="96x96" href="icones/favicon-96x96.png">   <link rel="icon" type="image/png" sizes="16x16" href="icones/favicon-16x16.png">   <link rel="manifest" href="icones/manifest.json">   <meta name="msapplication-TileColor" content="#ffffff">   <meta name="msapplication-TileImage" content="icones/ms-icon-144x144.png">   <meta name="theme-color" content="#ffffff">   <meta charset="utf-8">   <meta content="width=device-width, initial-scale=1.0" name="viewport">
    • By cerejafalante
      Olá pessoal, estou com uma lista de exercício de funções para fazer no visualg mas não sei por onde começar, alguém pode me ajudar fazendo esse exercício? ai eu pego ele de exemplo e faço os outros, obrigada
       
      o exercício é 
      Escreva um programa que calcula área de figuras: quadrado, retângulo, triângulo e círculo. O usuário informa qual forma deseja calcular a área, informa os parâmetros necessários e a área da forma é calculada em uma função. 
    • By cerejafalante
      Pessoal tenho que fazer um algoritmo de função no visualg de uma calculadora. Eu fiz o algoritmo mas não sei como fazer função, alguém me ajudaaa
      o código está aqui, tem que por em função, obrigada
       
      Var
      n1,n2,r:real
      operacao:inteiro
      inicio
      repita
      escreval ("1. Multiplicação ")
      escreval ("2. Divisão ")
      escreval ("3. Subtração ")
      escreval ("4. Soma ")
      escreval ("5. Sair ")
      leia (operacao)
      se ( operacao = 5 ) entao
      fimalgoritmo
      fimse
      limpatela
      escreva ("Diga o primeiro numero: ")
      leia ( n1 )
      ate ( operacao >= 1 ) e ( operacao <= 5 )
      se ( operacao <= 4 ) e ( operacao >= 1 ) entao
      escreva ("Diga o segundo numero: ")
      leia (n2)
      fimse
      escolha operacao
      caso 1
      r <- n1*n2
      caso 2
      r <- n1/n2
      caso 3
      r <- n1-n2
      caso 4
      r <- n1+n2
      outrocaso
      escreva ("escolha incorreta")
      fimescolha
      escreval ("O resultado é: ", r)
      escreval ("")
      ate ( operacao = 5 )
      fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.