Jump to content
dfastm

Dúvidas sobre Tmediaplayercontrol e Tmediaplayer delphi comunity 10.2

Recommended Posts

Boa tarde a todos, não sei se inseri no lugar certo minha dúvida, caso não por favor onde devo colocar a seguinte pergunta

Estou usando a versão comunity do Delphi 10.2, e estou tendo dificuldades em criar um multi-device application, que reproduza vídeo .

O problema é que o vídeo não aparece centralizado no mediaplayercontrol. Ja tentei todos os align possiveis e nada. no meu programa tem apenas um trectangle sem alinhamento, com um mediaplayercontrol alinhado alclient e um botao para dar play no mediaplayer. Ao utilizar os programas de reprodução de vídeo que vêm com esta versão do delphi (mediaplayer HD.dproj), a imagem fica normal, centraliza normalmente e amplia quando eu maximizo a tela. no meu programa não acontece. ja tentei até criar em tempo real o form do programa de amostra(mediaplayer HD.dproj), no meu programa, mas ele passa a deslocar a imagem também para o lado e não amplia a imagem quando maximizo. Estou fazendo algo errado? agradeço antecipadamente.

image.png.90b0437bcfaea7a6b8c94619bb4c2d54.png

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By TeixeiraRamos
      Prezados,
      Desculpe caso não esteja no local correto para essa postagem.
      a) Gostaria que o vídeo "mp4" responsivo (PHP 7, Bootstrap 4), não focasse com a tela preta. É possível manter uma imagem antes de iniciar?
      b) Ao abrir a página index.php o vídeo inicia antes de clicar play isso é um erro. Como corrigir
      Código:
      <!--Início video médicos sem fronteiras--> <div class="col-md-6"> <div class="card flex-md-row mb-4 shadow-sm h-md-250"> <div class="card-body d-flex flex-column align-items-start"> <div class="embed-responsive embed-responsive-16by9"> <iframe class="embed-responsive-item" src="img/medicos-sem-fronteiras.mp4" allowfullscreen align-self-center> </iframe> </div> </div> </div> <div class="card-body d-flex flex-column align-items-start m-10 align-self-center"> <img src="img/logo-medicos-sem-fronteiras.png" alt="Médicos sem Fronteiras"> </div> </div> <!--Fim início video médicos sem fronteiras--> Obrigado
    • By Mano Reis
      Tenho tido alguns erros (travamento, pulos, etc) ao executar videos e não sei qual o formato mais seguro para evitar isso.
      Existe algum formato que cria com CRC?
      Obrigado.
    • By Gsn99
      Olá!
       
      Alguém conhece algum programa que faz cortes em vídeos com essa função?  -> Nós usuários que escolhemos quantas vezes o video deve ser cortado, adicionando apenas o número de vezes que deve o vídeo ser cortado, em várias tamanho uniformes que se ajustam de acordo com o número de vezes que foi inserido pelo usuário. Obrigado pela atenção.
       
       
      Hello!

      Someone know of some program that make cuts in videos with this funccion ? -> We users that will choice how many times  the video must be cut, adding just a number of times that it must be cut. Example: The user choice 3 times and then the program devide the video in three parts with length uniform. I Apologize you about my English.
      Thank you.
    • By cesarturmina
      Boa noite a todos ! 
      Estou com um problema um pouco complicado..
      Estou criando um LoadScreen em um game, e estou utilizando um video.mp4
      No Index.html e no Style.css a PRINCIPIO esta tudo correto.
      Quando vejo o video no navegador, ele reproduz normal, com audio e tudo, porém fica uma faixa branca em cima e quando o mouse fica passa por cima, ele pausa a musica. O index.jv ta com um comando de Hover play() e pause ()
       
      Se alguem puder me ajudar, o intuito é somente utilizar ele para dar o play no video e pronto ! até terminar o load do game.
       
      Segue linha de comando : 
      var figure = $(".video").hover( hoverVideo, hideVideo ); function hoverVideo(e) { $('video', this).get(0).play(); } function hideVideo(e) { $('video', this).get(0).pause(); }  
       
    • By Marxrj
      Galera, estou com um problema preciso ter mais de um vídeo na minha área do html. O Código fica assim:
      <video src="videos/video.mp4" controls="" style="max-width:100%; height:auto alt="" width="500"></video> Porém como chamo o vídeo do banco de dados fica assim:
      <video src="videos/[item_video]" controls="" style="max-width:100%; height:auto alt="" width="500"></video> Até aí tranquilo se tiver somente um vídeo, mas no caso eu no sistema posso inserir até quatro vídeos ficando assim:
      <video src="videos/[item_video]" controls="" style="max-width:100%; height:auto alt="" width="500"></video> <video src="videos/[item_video2]" controls="" style="max-width:100%; height:auto alt="" width="500"></video> <video src="videos/[item_video3]" controls="" style="max-width:100%; height:auto alt="" width="500"></video> <video src="videos/[item_video4]" controls="" style="max-width:100%; height:auto alt="" width="500"></video> O problema é que neste caso mesmo que eu não insira video algum, ele ficando dando um grande espaço para o restante dos menus abaixo. Alguém sabe como eu poderia introduzir os quatro vídeos em uma única tag ou dois ou três que eu tivesse disponível?  Se é que é possível.
      <video> </video>  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.