Jump to content
ronniecezar

Programação Matrizes C++

Recommended Posts

Preciso criar um programa, no qual informo uma matriz de ordem n, ou aleatória, e fazer a multiplicação de cada linhas impares e a soma de todas as linhas que forem par pares.

tendo na saída do programa o resultado de cada linha, exemplo:

Linha 1: 59

Linha 2: 28

Linha 3: 78

Linha 4: 35

.

.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Guss
      var carro = {
      cor = "azul",
      modelo = "fusca",
      marca = "Volwagen,
      kms = 10000,
      combustivel = "gasolina"
      }
       
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
    • By Eder cruz
      Quais linguagens de programação é usada na construção de sistemas de postagens automaticas em grupos do facebook?
    • By cyyyyber
      alguem poderia me ajudar com uma lista de atividades usando o for?? 
    • By C.SALLES
      Faça um programa leia dois números inteiros e utilize uma função SOMAR que receba esses dois números por parâmetro e retorne a soma dos números inteiros existentes entre eles.
      Sou iniciante em programação e tentei fazer o programa da tal forma:
       
      #include<stdlib.h>
      #include<math.h>
      #include<stdio.h>
      int SOMAR((((int soma;i;n1;n2))))
      {
          return; 
           for (i=n1+1; i<n2; i++) {  
          soma += i; 
          } 
      }
      int main() { 
      int n1, n2; 
      printf("Informe os números: "); 
      scanf("%d %d", &n1, &n2);  
      printf("\nSoma: %d\n", SOMAR(soma)); 
      return 0; 
      system ("pause");
      }
       
      Não roda por vários motivos e sinceramente sei nem como resolver
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.