Jump to content
leandrosv

woocomerce em sites fora do CMS wordpress.

Recommended Posts

Boa tarde pessoal, uma dúvida somente,se conseguirem  me responder ficarei grato!.

Programo em php há 6 meses. Até o momento foquei em aprender e fazer para  mim.

Peguei meu primeiro projeto, para um amigo, porém design, css e javascript não é meu forte, falta criatividade e aprender bastante sobre o JS.

A duvida é a seguinte: Comprei um tema no themeforest.net à escolha dele(amigo), e o tema veio com puglins woocommerce, a minha dúvida é se posso hospedar e utilizar normalmente no site esses plugins sem usar o sistema wordpress. Editei o código js e css do que não me interessa e está funcionando legal. A dúvida mesmo, unica dúvida é se posso e vou conseguir rodar meu site em uma hospedagem normal sem o sistema wordpress.
Obrigado!

**moderadores e administradores do fórum, caso seja aqui um tópico errado, perdão, procurei mas não achei nada a respeito do assunto.

Share this post


Link to post
Share on other sites

Se o plugin for PHP e a hospedagem estiver habilitada para tal linguagem deve funcionar, apenas tenha certeza que o código está realmente otimizado para rodar sem o WordPress, faça testes localmente , e depois o upload como teste antes de subir a versão final.

Share this post


Link to post
Share on other sites

Opa, obrigado pela dica Magno! Testei localmente e está tudo ok.  O plugin é JS, estou reaproveitando galeria de imagem, estou com dificuldade para achar puglins como zoom quando passa o mouse em cima das fotos, dificuldade para usar o slick slider, e etc...meus códigos não fecham. Então optei pelo modo facil. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By peterstefan
      Bom dia, estou fazendo uma cadastro via rest e estou utilizando o curl para cadastrar no webservice...
      Meu código está cadastrando tudo certinho, porem quando ele cadastra e mostra o retorno que foi cadastrado com sucesso ele fica o AGUARDE, CARREGANDO e não para.. não sei oque esta faltando pq já tentei varias coisas e não deu certo... 
       
       
       
      $Data = [ "nomeRazaoSocial" => $PostData['nomeRazaoSocial'], "identMF" => $PostData['identMF'], "email" => $PostData['email'], "telefone" => $PostData['telefone'], "senhaProvisoria" => $PostData['senhaProvisoria'] ]; $DataString = json_encode($Data); $curl = curl_init(WEBSERVICECADASTRO); curl_setopt($curl, CURLOPT_CUSTOMREQUEST, "POST"); curl_setopt($curl, CURLOPT_POSTFIELDS, $DataString); curl_setopt($curl, CURLOPT_RETURNTRANSFER, true); curl_setopt($curl, CURLOPT_HTTPHEADER, array( 'Content-Type: application/json', 'Content-Length: ' . strlen($DataString)) ); $result = curl_exec($curl); if ($result) { $jSON['success'] = "<i class='icon-checkmark'></i>Pronto, cadastro foi realizado com sucesso!"; }else{ $jSON['error'] = "<i class='icon-warning'></i>Oops! Erro ao cadastrar! Por favor, tente novamente!"; }  

       

    • By RSN
      Boa Noite,
      Preciso enviar uma consulta sql no corpo do e-mail, porém não estou conseguindo concatenar o laço while.
      <?php include_once('conexao.php'); require 'PHPMailer/PHPMailerAutoload.php'; $resultado = mysql_query("SELECT * FROM cupom WHERE FlagEstorno = 1;"); $linhas = mysql_num_rows($resultado); $mensagem = '<div class="x_content"> <table id="datatable-buttons" class="table table-striped table-bordered"> <thead> <tr> <th>Loja</th> <th>Nro Cupom</th> <th>Data</th> <th>Operador</th> </tr> </thead> <tbody> while($linhas = mysql_fetch_array( $resultado)){ echo " <tr>"; echo "<td>".$linhas['nroloja']."</td>"; echo "<td>".$linhas['NroCupom']."</td>"; echo "<td>".$linhas['DataProc']."</td>"; echo "<td>".$linhas['Operador']."</td>"; echo " </tr>"; }'; $mail = new PHPMailer(); $mail->isSMTP(); $mail->Host = 'smtp.gmail.com'; $mail->SMTPAuth = true; $mail->SMTPSecure = 'tls'; $mail->Username = ''; $mail->Password = ''; $mail->Port = 587; $mail->setFrom(''); $mail->addReplyTo(''); $mail->addAddress('', 'Nome'); $mail->isHTML(true); $mail->Subject = 'Assunto do email'; $mail->Body = $mensagem; $mail->AltBody = 'Para visualizar essa mensagem acesse http://site.com.br/mail'; //$mail->addAttachment('/tmp/image.jpg', 'nome.jpg'); if(!$mail->send()) { echo 'Não foi possível enviar a mensagem.<br>'; echo 'Erro: ' . $mail->ErrorInfo; } else { echo 'Mensagem enviada.'; } ?>  
    • By Augustomesquita
      Bom dia pessoal!
      Vocês também estão programando em primeira pessoa? Recentemente escrevi este artigo e gostaria de compartilhar a ideia com vocês.
      Pare de programar em primeira pessoa!
    • By Matheus Guto
      Eae pessoal, bom sou novo no ramo e quero uma ajudinha em um erro de um programa para médias
      Parse error: syntax error, unexpected 'endif' (T_ENDIF) in C:\xampp\htdocs\atividade2.php on line 32
      ah, e tá aqui o código
       
      <html>
          <head>
              <title>Médias</title>
          <meta charset="UTF-8">
          </head>
      <body>
          <div>
              <form method="get">
                  Primeira nota:<input type="text" name="nota1"/> <br>
                  Segunda nota:<input type="number" name="nota2"/> <br>
                  Terceira Nota:<input type="number" name="nota3"/>
                  <input type="submit" name="botao" value="clique"/>
              </form>
          <?php
              if (isset($_GET["botao"])) {
                  $nota1 = isset($_GET["nota1"])?$_GET["nota1"]:"";
                  $nota2 = isset($_GET["nota2"])?$_GET["nota2"]:"";
                  $nota3 = isset($_GET["nota3"])?$_GET["nota3"]:"";
              if ($nota1 == ""|| $nota3 =="" || $nota3 ==""){
                  echo "por favor digite todas as notas";
              } else {
                  $media = ($nota1+$nota2+$nota3)/3;
              echo "a média do aluno é" . $media . "<br>";
              }  if ($media >= 7)
              echo "aprovado";
                  elseif (($media < 7) && ($media >= 5))
                  echo "recuperação";
              else{
                  echo "reprovado";
              }
          endif
      endif
      ?>
          </div>
      </body>
      </html>
    • By s3c0
      Amigos,
       
      boa noite. Estou tentando fazer um script que informa o uso do Processador em um servidor Windows.
       
      Encontrei na internet um script que funciona em partes. Porém o uso do Processador sempre retorna vazio. 
       
      <?php define ( 'CPU_NAME', '.' ); $obj = new COM ( 'winmgmts:{impersonationLevel=impersonate}//' . CPU_NAME . '/root/cimv2' ); $pc = 0; foreach ( $obj->instancesof ( 'Win32_Processor' ) as $mp ) { echo "<pre>Processor (" . ++$pc . ")\r\n\r\n"; echo " Processor Id: " . $mp->ProcessorId . "\r\n"; echo " Name: " . trim ( $mp->Name ) . " @ " . $mp->CurrentClockSpeed . " MHz\r\n"; echo " CPU Load: " . $mp->LoadPercentage . "%\r\n"; echo " CPU Status: " . $mp->Status . "\r\n"; echo " CPU Stepping: " . $mp->Stepping . "\r\n"; echo " CPU Revision: " . $mp->Revision . "\r\n"; echo " System Name: " . $mp->SystemName . "\r\n</pre>"; } ?> Alguém tem alguma ideia de como trazer o uso do processador?
       
      Agradeço a atenção de todos.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.