Jump to content
  • 0
pedrof

Erro sobre parênteses no VisuAlg

Question

algoritmo "Bhaskara"
var
   a, b, c, delta, raiz_delta, x1, x, x_delta, x2: Real
inicio
      Escreva("Informe um numero inteiro diferente de 0: ")
      Leia(a)
      Escreva("Informe outro numero inteiro diferente de 0: ")
      Leia(b)
      Escreva("Novamente, informe outro numero inteiro diferente de 0: ")
      Leia(c)
      delta <- (b^2-4*a*c)
      Se (delta<0) entao
         delta <- Abs(delta)
         raiz_delta <- (RaizQ(delta))
         x <- (b-b*2)/(2*a)
         x_delta <- raiz_delta/(2*a)
         x1 <- (x, "+", x_delta, "i")
         x2 <- (x, "-", x_delta, "i")
         Escreval("Utilizando ", a, " como 'a', ", b, " como 'b', ", c, " como 'c' em Delta e aplicando a ")
         Escreval("Formula de Bhaskara, chegamos ao resultado:)
         Escreva("x1 = ", x1, " e x2 ", x2)
      FimSe
fimalgoritmo

visualg_9eC1E2ZSRO.png.d0b5ca095fa1bb9e9e6a64140016ec8d.png

Parece ser algo bem idiota, mas não estou conseguindo resolver... Ajuda?

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By viniciusfroner
      Boa noite, estou com um grande problema, formatei o meu notebook pela ferramenta de formatação do windows, quando estava tudo instalado reparei que alguns caracteres não eram mais reconhecidos, pesquisei pela internet sem sucesso, abri um ticket junto a microsoft e eles fizeram o reparo remoto, e mesmo assim não resolveu nada.
      O problema vai desde reconhecimento de caracteres em interface do windows ou programas, até na leitura de alguns textos como arquivos .srt e outros.
       
      Em anexo 2 imagens de exemplo do que acontece.
       
      Fico grato por qualquer ajuda.


    • By EstilloWeb
      Está ocorrendo um erro em meu comando MySQL na ordenação dos resultados. O código é o seguinte:
      $sql_imos4 = "Select DISTINCT imovel FROM propostas ORDER BY id DESC"; $exe_imos4 = mysqli_query($conexao, $sql_imos4); O objetivo é listar uma única vez um imóvel com proposta, mesmo que haja dois ou mais registros, sempre ordenado mais recente. O que está ocorrendo quando o imóvel tem mais de uma proposta cadastrada, a ordenação está sendo feita pelo ID da proposta mais antiga.
      Exemplo:
      imóvel ref. 4528 tem duas propostas, sendo que a mais recente tem o ID 235 porém aparece na listagem abaixo do imóvel ref. 4325, que tem uma só proposta e ID 230.
      O resultado deveria estar invertido neste caso.
      Onde pode estar o erro? Agradeço a ajuda.
    • By TeixeiraRamos
      Olá,
      Tenho uma página em PHP 7 com MySQL,  com um formulário, código (PDO). 
      Os registros são salvos no banco de dados sem problema, mas na parte superior do form indicar "Erro ao enviar a mensagem!".  O correto, já que não tem erro, seria indicar                                "Mensagem enviada com sucesso!", mensagem essa prevista no código.
      O Código é esse:
      <?php session_start(); include_once("../versao_03/bd/conexao.php") ?> <?php if (isset($_SESSION['msg'])){ echo $_SESSION['msg']; unset($_SESSION['msg']); } $nome = filter_input(INPUT_POST, 'nome', FILTER_SANITIZE_STRING); $mensagem = filter_input(INPUT_POST, 'mensagem', FILTER_SANITIZE_STRING); $sql = "INSERT INTO mensagens_terco_m_gozosos (nome, mensagem) VALUES ('$nome','$mensagem')"; $result = $PDO->query($sql); if(!$result) { //print_r($PDO->errorInfo()); //exit; $_SESSION['msg'] = "<div class='alert alert-success' role='alert'>Mensagem enviada com sucesso!</div>"; header("Location: http://localhost/minhaspaginas/versao_03/tercomisteriosgozosos.php"); }else{ $_SESSION['msg'] = "<div class='alert alert-danger' role='alert'>Erro ao enviar a mensagem!</div>"; header("Location: http://localhost/minhaspaginas/versao_03/tercomisteriosgozosos.php"); } ?> Obrigado
    • By quimera
      Estou com um problema, os registro entram no banco de dados dinamicamente, e neste caso algumas postagens pode enviar valores que já existem na tabela/coluna específica.
      Ex.: 
      UPDATE `tableoperator` SET `coluna`= '1' WHERE id = '1' o Registro no banco de dados está assim:
      id | coluna | data 1       1     2020-01-01 Simplesmente não atualiza se a coluna já tiver o valor.
      Alguém pode ajudar, nunca havia me deparado com isto
    • By dutopfave
      Boa Tarde, estou com problema do Erro 403 Forbidden,  isso ocorre quando eu vou enviar um e-mail para meus clientes, ai no  editor de texto utilizo tabela, html, imagem..... ai ele me da esse erro 403,
      minha pasta ta com permissão de 755 e arquivo 644, alguma solução pra isso ?
       
      Por que quando não utilizo html, tabela etc, somente texto, ele envia o e-mail normal.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.