Jump to content

Recommended Posts

Olá Gente me ajudam a resolver esses exercícios? Vamos lá   ( TODOS ESSES PROGRAMAS A ESTRUTURA DE REPETIÇÃO E ENQUANTO E SE TAMBÉM OBRIGADA)

 

1 - Imprima Os Números Primos Compreendidos entre 1 e 100 e faça um algoritmo para resolver esse problema.

 

Eu Montei o Algoritmo dessa forma, ele roda mais o resultado não tá exato no Visual G, se puder me ajudar com essa questão 

 

var p,n:inteiro

inicio

 

leia (n) 

p<- 1

enquanto p<=100 faca

se p mod = 0 entao

escreva (" Esse Numero é Primo",p)

senao

escreva (" Esse numero não é Primo")

fimse

fimenquanto

fimalgoritmo

 

2 - faça um algoritmo para que seja digitado a idade e diga se a pessoa e maior de idade ou não faça isso até que alguém digite 100 anos.

 

estrutura de repetição enquanto faca/se entao

 

3 -faça um algoritmo que imprima de 1 a 100 de forma decrescente 

 

estrutura de repetição enquanto

acrescentei o exemplo d<-d-1  mesmo assim não rodou

 

4- construa um algoritmo que diga os divisores de 100 compreendidos de 1 a 20 

 

bom, esse também eu fiz mais não conseguir roda 

 

 

5 - DIVISOES DO TRIANGULO E DIZER SE O MESMO E ISOCELE, ESCALENO OU EQUILATERIO 

 

LEIA (L1)

LEIA (L2)

LEIA (L3)

....

(SE)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By g.dmatos
      Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.
       
      porém quando vou executar da erro no código:
      var x, y: real inicio escreval("Digite o valor do coeficiente x") leia(x) Escreval ("O valor da conta é igual a:" + y) Leia (y) y=(3.x)+8 fimdoalgoritmo  
    • By TEC2587
      Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro:
       
      Esperava-se encontrar ENTAO na linha  "se((med=<8.9) e (med>=8))entao"
      Esperava-se encontrar ENTAO na linha  "escreval("Seu rendimento foi muito bom"
       
      Algoritmo "semnome"
       
       
      Var
         med: real
      Inicio
         escreval("-------------------")
         escreval(" RENDIMENTO ESCOLAR")
         escreval("--------------------")
         escreval("Qual é a sua média: ")
         leia(med)
         se ((med=10) ou (med>=9))entao
            escreval ("Seu rendimento foi excelente")
         senao
            se ((med=<8.9) e (med>=8))entao
               escreval("Seu rendimento foi muito bom")
            senao
               se ((med= 7.9) e (med>=7))entao
                  escreval("Seu rendimento foi bom")
               senao
                  se ((med=6.9) e (med>=6))entao
                     escreval("Seu rendimento foi regular")
                  senao
                     se ((med=5.9) e (med>=5))entao
                        escreval("Seu rendimento foi insuficiente")
                     senao
                        escreval("Seu rendimento foi ruim")
                     fimse
                  fimse
               fimse
            fimse
         fimse
      Fimalgoritmo
    • By lemao_code()
      Bom dia Galera, não sei se este é a div certa para a postagem (div sacou?)
      Mas vamos lá,
      A uns 2meses to estudando linguagens de programação, comecei pela Logica de Programação com o professor Guanabara,Agora estou em Python e HTML5 CSS e Java.
      Python estou no que o professor chama de Mundo 2, aprendendo if, elif, else, já sei operadores aritméticos etc.
      HTML5 está mais no inicio, to aprendendo a trabalha com o css para dar estilo na pagina.(Também sei Banco de Dados no MySQL)
      Mas vamos ao assunto, to procurando colegas que estejam na parecida situação como eu, para realmente estudarmos juntos.
      Certa vez o professor falou que isso ajudaria e muito, e concordo, alguém para ajudar, e alguem para você ajudar, é um crescimento e tanto, então convido-os quem tiver interesse
      duas cabeças pensam mais que 1. (ou não se a outra cabeça for de um gênio!Jobs,BIl,Einsten,Hawking esses cara kk)
      Geralmente, estudos das 4h manhã ate as 6hrs da manhã, depois a noite das 19 até a hora que os olhos sangrarem!
       
      Pode mandar msg aqui no meu perfil, estou online!
      Obrigado!
    • By eduardodsilvaq
      Tenho algumas duvidas para programadores focados em desenvolvimento web, e outras linguagens que estou começando a estudar.
       
      1- Navegador salvando cache. Bom atualmente uso Atom como ide para programar PHP, JavaScript, HTML e CSS. O problema e o navegador que nem sempre atualiza as mudanças do css. Tem alguma IDE especifica com navegador e debugger para solucionar esse tipo de problema? Alguma outra solução?
       
      2- Templates responsivos. Estou usando vários arquivos CSS para deixar meus templates responsáveis para vários dispositivos. (Exemplo no código abaixo.) Algumas coisas eu consegui fazer de maneira menos rustica através do estudo do Bootstrap, mas sera que não existe ainda um outro jeito?
      <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/largedeviceswidescreens1920.css" media="screen and (min-width: 2250px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/largedeviceswidescreens1680.css" media="screen and (min-width: 1680px) and (max-width:2249px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/largedeviceswidescreens1200.css" media="screen and (min-width: 1300px) and (max-width:1679px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/mediumdivicestablets&desktops990.css" media="screen and (min-width: 970px) and (max-width:1299px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/smalldevicestablets760.css" media="screen and (min-width:760px) and (max-width: 969px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/smalldevicestablets600.css" media="screen and (min-width:556px) and (max-width: 759px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/smalldevicessmartphones480.css" media="screen and (min-width: 350px) and (max-width:555px)" /> <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/engine/css/mobile320.css" media="screen and (min-width: 1px) and (max-width:349px)" />  
      3- Incompatibilidade entre navegadores. Para mim uma das principais dificuldade e desenvolver um template, pois não fica corretamente representado. (Atualmente estou priorizando o Chrome e o resto ...) Existe algumas IDE para fazer o suporte do desenvolvimento para múltiplos navegadores? Alguma outra solução?
       
      4- Métodos de desenvolvimento. Vejo em algumas vagas de emprego a procurar por conhecimentos em métodos ágeis. Isso se aplica na area desenvolvimento web em especifico? Qual método de desenvolvimento eu devo estudar? 
       
      5- Linguagens de programação para web. Quais linguagens de programaçao/frameworks eu devo estudar, mesmo que aos poucos para ampliar minha área de atuação. E interessante estudar Python, Java ou Ruby para atender essa área?
       
      6- Experiencia em outra linguagem. Quais linguagens vocês tem domínio fora do desenvolvimento web? Por exemplo C, C++, C# e Python. Sabemos que programadores não atuam sempre na sua zona de conforto. 
       
      7- SQL. Ate que ponto e interessante o estudo da linguagens e de seus SGBDs? Qual o nível de conhecimento ideal sobre a área de banco de dados em geral? O que se deve estudar? 
       
      8- GIT. Estou tentando implementar o uso do GIT, (Antes tarde que nunca.) quais tipos de projetos e códigos se deve publicar? Existe alguma IDE que faça update/commit automaticamente? Dicas?
       
      9- FTP. Tenho um site para trabalhar meus projetos online. nesse momento quero fazer um blog pessoal de desenvolvimento, e portfólio.  Existe algum jeito de sincronizar um diretório, ou automatizar o upload de arquivos do site para produção? (FTP, MYSQL)
       
      10- Empregos na área. Quais outras plataformas devo usar para enriquecer meu curriculum? (Por exemplo Perfil no Stack Overflow, GIT, Instagram, DropBox.) Como interessar empresas a contratar um programador sem experiencia no mercado? Como encontrar uma StartUp? Como proceder? 
       
      11- Comentar e Documentar código. Quando e importante comentar uma linha? (Ate que ponto não se torna poluição no codigo?) Programadores desenvolvem documentação sobre o programa? Se sim, como estudar essa área?
       
      12- JavaScript. Alguma dica em especial sobre o aprendizado dessa linguagem? Acho ela bem complicada de assimilar seu funcionamento. 
       
      13- Favor comentem dicas para boas praticas de programação web no geral. Experiencias no geral...
       
      o/ Obrigado
       
       
    • By P4870
      Sou estudante do 1º Ano do curso técnico em Informática do IFSP, e preciso de ajuda para fazer esse Algoritmo usando o visuAlg.
       
      01) Levando em consideração o início dos sistemas de informatização as informações eram armazenadas em arquivo do tipo texto. Analisando internamente estes arquivos pode-se notar que nada mais são do que matrizes, pois cada coluna representava um campo e cada linha uma tupla.
       
      Partindo desta informação construa uma matriz para armazenar o RA, CPF e um código para 40 alunos (no CPF digitar somente os números) e uma matriz que guardará 4 notas de 40 alunos e seus respectivos códigos, criando assim um tipo de relacionamento entre as duas matrizes. O primeiro CPF da matriz 1 representa o aluno que possui as 4 notas da primeira posição da segunda matriz. Após o preenchimento de todos os dados das 2 matrizes você deverá perguntar qual o tipo de consulta deverá ser realizada (1-RA, 2-CPF e 3-Código) se for escolhido a opção 1 deve ser solicitado o RA e pesquisar o mesmo na matriz e mostrar o RA, as 4 notas e a média das 4 notas do aluno, se a opção for 2 você deverá solicitar o CPF e também mostrar o CPF, as 4 notas e a média das 4 notas do aluno e se a opção for 3 você deverá solicitar o CÓDIGO e também mostrar o Código, as 4 notas e a média das 4 notas do aluno. Em ambas as consultas deve ser mostrado a situação do aluno (Aprovado quando a média for no mínimo 6; Recuperação quando a média for no mínimo 4 e não chegar a 6; e Reprovado se a média for inferior a 4).
       
      Ao mostrar cada resultado o sistema deve pedir se o usuário deseja fazer uma nova pesquisa.
       
      Caso deseje deve digitar S(SIM) para continuar ou N(NÃO) para finalizar.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.