Jump to content
  • 0
luc.oliveira1984

Alterar quantidade de anunciante por pagina

Question

Olá pessoal, sou novo por aqui e estou precisando da ajuda de vcs!

 

Tenho um modulo de marketplace (webkul) e preciso alterar a quantidade de exibição de anunciantes de 4 para 20 por página.

 

Alguem poderia me ajuda? :)

 

Minha página de anuncinates é: https://lenda360.com.br/marketplace/seller/sellerlist/

Meu arquivo sellerlist contem:

 

<?php
/**
* Webkul Software.
*
* @category Webkul
* @package Webkul_Marketplace
* @author Webkul
* @copyright Copyright (c) Webkul Software Private Limited (https://webkul.com)
* @license https://store.webkul.com/license.html
*/
$helper = $this->helper(\Webkul\Marketplace\Helper\Data::class);
$banner_display = $helper->getDisplayBanner();
$banner_image = $helper->getBannerImage();
$banner_content = $helper->getBannerContent();
$marketplacebutton = $helper->getMarketplacebutton();
$sellerlist_top_label = $helper->getSellerlisttopLabel();
$sellerlist_bottom_label = ($helper->getSellerlistbottomLabel());
$paramData = $this->getRequest()->getParams();
if (!isset($paramData['shop'])) {
$paramData['shop'] = '';
}
$sellerAccountUrl = $block->getUrl(
'marketplace/account/becomeseller',
["_secure" => $this->getRequest()->isSecure()]
);
if (!$helper->isCustomerLoggedIn()) {
$sellerAccountUrl = $block->getUrl(
'customer/account/create',
["_secure" => $this->getRequest()->isSecure()]
);
}
?>

<div class="wk-mp-design wk-mp-landingpage">
<?php
if ($banner_display) {?>
<div class="wk-mp-banner-container">
<div class="wk-mp-banner">
<div class="wk-mp-header">
<h1><?= $block->escapeHtml($marketplacebutton); ?></h1>
<h2>
<?= /* @noEscape */ $block->getCmsFilterContent($banner_content)?>
</h2>
<p>
<a href="<?= $block->escapeUrl($block->getUrl('marketplace/account/becomeseller/', ['_secure' => $this->getRequest()->isSecure()])); ?>">
<button class="button wk-mp-landing-button">
<span>
<span>
<strong><?= $block->escapeHtml($marketplacebutton); ?></strong>
</span>
</span>
</button>
</a>
</p>
</div>
</div>
</div>
<?php
} ?>
<h1 class="wk-marketplace-label"><?= $block->escapeHtml($sellerlist_top_label) ?></h1>
<style>

</style>
<div clas="wk-srach-wrapper">
<form method="get" action="<?= $block->escapeUrl($block->getUrl('marketplace/seller/sellerlist', ['_secure' => $this->getRequest()->isSecure()]))?>" id="search_mini_form" class="wk-search no-p" style="">
<div class="control">
<input id="sellersearch" type="search" name="shop" value="<?= $block->escapeHtml($paramData['shop'])?>" class="input-text required-entry" maxlength="128" placeholder="<?= $block->escapeHtml(__('Search sellers by shop name from here'))?>..." autocomplete="off" style="width:100%;border:1px solid #ccc;float:left;">
<button type="submit" title="Search" class="button"><span class="span"><span><?= $block->escapeHtml(__('Search')) ?></span></span></button>
</div>
</form>
</div>

<div class="wk-mp-sellerlist-container" style="display:inline-block;padding: 0;padding-top: 20px;width: 100%;">
<?php
if (count($block->getSellerCollection())==0) { ?>
<div class="wk-emptymsg">
<?= $block->escapeHtml(__('No Seller Available')) ?>
</div>
<?php
} else {?>
<ul>
<?php
foreach ($block->getSellerCollection() as $seller_coll) {
$seller_id = $seller_coll->getSellerId();
$seller_product_count = 0;
$profileurl = $seller_coll->getShopUrl();
$shoptitle = '';
$logo="noimage.png";
$seller_product_count = $helper->getSellerProCount($seller_id);
$shoptitle = $seller_coll->getShopTitle();
$logo=$seller_coll->getLogoPic()==''?"noimage.png":$seller_coll->getLogoPic();
if (!$shoptitle) {
$shoptitle = $profileurl;
}
$logo=$helper->getMediaUrl().'avatar/'.$logo;
?>
<li>
<div class="wk-mp-sellerlist-wrap">
<div class="wk-sellerlist-divide1">
<a href="<?= $block->escapeUrl($helper->getRewriteUrl('marketplace/seller/profile/shop/'.$profileurl));?>" title="<?= $block->escapeHtml(__("View Seller's Shop")) ?>"><img src="<?= $block->escapeUrl($logo) ?>"></a>
</div>
<div class="wk-sellerlist-divide2">
<div>
<a href="<?= $block->escapeUrl($helper->getRewriteUrl('marketplace/seller/profile/shop/'.$profileurl));?>" title="<?= $block->escapeHtml(__("View Seller's Shop")) ?>">
<strong><?= $block->escapeHtml($shoptitle) ?></strong>
</a>
</div>
<div><?= $block->escapeHtml(__('%1 Total Products', $seller_product_count)) ?></div>
<a href="<?= $block->escapeUrl($helper->getRewriteUrl('marketplace/seller/collection/shop/'.$profileurl));?>">
<button class="button" title="<?= $block->escapeHtml(__("View Seller's Collection")) ?>">
<span>
<span>
<?= $block->escapeHtml(__('View All')); ?>
</span>
</span>
</button>
</a>
</div>
</div>
</li>
<?php
}?>
</ul>
<?php
}?>
</div>
<?php if ($block->getPagerHtml()): ?>
<div class="order-products-toolbar toolbar bottom"><?= $block->getPagerHtml(); ?></div>
<?php endif ?>

<h1 class="wk-marketplace-label"><?= /* @noEscape */ $sellerlist_bottom_label ?></h1>

<a href="<?= $block->escapeUrl($sellerAccountUrl)?>">
<button class="button wk-mp-landing-button">
<span>
<span>
<strong><?= $block->escapeHtml($marketplacebutton); ?></strong>
</span>
</span>
</button>
</a>
</div>
<script>
require([
"jquery",
"mage/mage",
], function($){
$('.page-title-wrapper').hide();
$('.wk-mp-banner').css('background-image','url("<?= $block->escapeUrl($banner_image) ?>")');
});
</script>

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sapinn
      Estou usando o editor SummerNote em um projeto mas ele não está enviando os dados com o HTML apenas o texto. Eu estou colocando assim:

               
                                        <textarea id="summernote" class="textarea" required name="content">     <script> $('#summernote').summernote({         tabsize: 2,         height: 500,         toolbar: [           ['style', ['style']],           ['font', ['bold', 'underline', 'clear']],           ['color', ['color']],           ['para', ['ul', 'ol', 'paragraph']],           ['table', ['table']],           ['insert', ['link', 'picture', 'video']],           ['view', ['fullscreen', 'codeview', 'help']]         ]       });           </script>  
       
    • By Sapinn
      Galera estou usando o PHPStorm para alguns projetos e estou com meus arquivos marcados em vermelho não sei oq é alguem pode me ajuda?
       
       

    • By danielambrosio
      Estou trabalhando numa programação PHP é conectado na tabela (cl_configs) para reconhece coluna name que reconhece esses 5 campos.
      e também que adiciona esses 5 valores é adicionado nessa outra tabela (cl_ads_block_ips) nesses 8 coluna (id, ip, clicks, last_click, dads_refresh_qtd, dads_refresh_data, dads_refresh_ldata, clicks_rotativo_dia).
      E a conexão que eu usa era de outro site e não estou tendo problema e configurar em outro site que reconhece essa banco de dados abaixo.
       
      <?php $host = "localhost"; $user = "ads"; $pass = "_CMpFF4Hpa!G_gTh"; $dbname = "ads"; $port = 3306; try {     $conn = new PDO('mysql:host=' . $host . ';port=' . $port . ';dbname=' . $dbname, $user, $pass);     //echo "Conexão com banco de dados realizado com sucesso!"; } catch (PDOException $err) {     echo "Erro: Conexão com banco de dados não foi realizada com sucesso. Erro gerado " . $err->getMessage(); } ?>  
      Conecta com sucesso só não está reconhecendo a tabela (cl_configs) e nem adicionando na tabela (cl_ads_block_ips).
       
       
      Agora não sei porque não esta reconhecendo (cl_configs) e nem adicionando (cl_ads_block_ips).
       
       


    • By ment0r
      Boa tarde a todos.

      Estou iniciando um estudo com o banco MySQL (trabalho co PostgreSQL e Firebird) para futuros trabalhos. Bom, me deparei com um problema chato: caracteres especiais.
      Um exemplo: T�tulo.
      Não consigo exibir no meu site tais caracteres. O banco tem Charset/Collation: utf8/utf8_bin como configuração.
      Já usei o utf_encode e utf_decode - não resolveu.

      Alguém sabe o que mais posso fazer?
      Desde já, muito obrigado.
    • By asacap1000
      Galera salve salve!!
      Estou com um projeto em que são armazenados vídeos, porém seguindo os requisitos exigidos, para visualizar e baixar esses vídeos eles tem que aparecer com numero de cadastro do usuário que está acessando no centro do video como uma marca d'agua.
       
      Para simplesmente aparecer na tela eu consigo fazer uma camada superior com css e apresentar os dados do usuário mas para baixar o vídeo ele já faz sem a marca.
       
      Vocês conhecem algum recurso pra adicionar essa marca? ela não pode ficar no arquivo original pois outros usuário poderão baixar com sua identificação na tela.
       
      Se alguem puder me dar um norte ajudaria muito
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.