Jump to content
Sergio Cavalcante

Exercicios Resolvidos ......Vai quebrar seu galho...

Recommended Posts

 

 

 

 

 

 

 

38) Elaborar um algoritmo em pseudocodigo que efetue a leitura de um número inteiro e apresentar uma mensagem informando se o número é par ou ímpar.

algoritmo "Par ou Ímpar"

var

n: inteiro

inicio

escreval("Insira um número inteiro: ")

leia(n)

se(n mod 2 = 0) entao

escreval("O número: ",n," é par")

senao

escreval("O número: ",n," é impar")

fimse

fimalgoritmo

 

39) Elaborar um algoritmo em pseudocodigo que efetue a leitura de um valor que esteja entre a faixa de 1 a 9. Após a leitura do valor fornecido pelo usuário, o programa deverá indicar uma de duas mensagens: “O valor está na faixa permitida”, caso o usuário forneça o valor nesta faixa, ou a mensagem “O valor está fora da faixa permitida”, caso o usuário forneça valores menores que 1 ou maiores que 9.

algoritmo "Faixa Permitida"

var

n :real

inicio

escreval("Digite um valor: ")

leia(n)

se(n >= 1) e (n <= 9) entao

escreval("O valor está na faixa permitida")

senao

escreval("O valor não está na faixa permitida")

fimse

fimalgoritmo

 

40) Elaborar um algoritmo em pseudocodigo que efetue a leitura do nome e do sexo de uma pessoa, apresentando como saída uma das seguintes mensagens: “Ilmo Sr.”, para o sexo informado como masculino, ou a mensagem “Ilma Sra.”, para o sexo informado como feminino. Apresente na seqüência da mensagem impressa o nome da pessoa.

algoritmo "Sexo da pessoa"

var

nome, sexo :literal

inicio

escreval("Digite o seu nome: ")

leia(nome)

escreval("Digite o seu sexo: ")

leia(sexo)

se(sexo = "Masculino") entao

escreval("Ilmo Sr. ",nome)

senao

se(sexo = "Feminino") entao

escreval("Ilmo Sra. ",nome)

senao

escreval("Digite um sexo válido")

fimse

fimse

fimalgoritmo

 

41) Elaborar um algoritmo em pseudocodigo que leia um número. Se positivo armazene-o em uma variável chamada “A”, se for negativo, em uma variável chamada “B”. No final mostrar o resultado das duas variáveis.

algoritmo "Armazenamento"

var

n,a,b :real

inicio

escreval("Digite um número: ")

leia(n)

se(n >= 0) entao

a<- n

escreval("O número :",a," é variável de A")

senao

b <- n

escreval("O número :",b," é variável de B")

fimse

fimalgoritmo

 

42) Tendo como dados de entrada a altura e o sexo de uma pessoa, construa um algoritmo empseudocodigo que calcule peso ideal, utilizando as seguintes fórumulas:Para homens: (72.7*h) – 58 Para mulheres: (62.1*h) – 44.7 Onde h equivale a altura da pessoa

algoritmo "Peso Ideal"

var

a, p :real

s :literal

inicio

escreval("Digite o seu sexo F ou M: ")

leia(s)

escreval("Digite a sua altura: ")

leia(a)

se(s = "F") entao

p <- (62.1 * a) - 44.7

escreval("Seu peso ideal é: ",p)

senao

se(s = "M") entao

p <- (72.7 * a) - 58

escreval("Seu peso ideal é: ",p)

senao

escreval("Digite um sexo válido")

fimse

fimse

fimalgoritmo

 

43) Fazer um algoritmo em pseudocodigo para ler quatro valores referentes a quatro notas escolares de um aluno e imprimir uma mensagem dizendo que o aluno foi aprovado, se o valor da média escolar for maior ou igual a 5. Se o aluno não foi aprovado, indicar uma mensagem informando esta condição. Apresentar junto com uma das mensagens o valor da média do aluno para qualquer condição.

algoritmo "Situação com média"

var

n1, n2, n3, n4, media :real

inicio

escreval("Digite a 1ª nota :")

leia(n1)

escreval("Digite a 2ª nota :")

leia(n2)

escreval("Digite a 3ª nota :")

leia(n3)

escreval("Digite a 4ª nota :")

leia(n4)

media<- (n1 + n2 + n3 + n4) / 4

se(media >= 5) entao

escreval("O aluno foi aprovado com média: ",media)

senao

escreval("O aluno não foi aprovado com média: ",media)

fimse

fimalgoritmo

 

44) Fazer um algoritmo em pseudocodigo ler quatro valores referentes a quatro notas escolares de um aluno e imprimir uma mensagem dizendo que o aluno foi aprovado, se o valor da média escolar for maior ou igual a 7.0. Se o valor da média for menor que 7.0, solicitar a nota de exame, somar com o valor da média e obter nova média. Se a nova média for maior ou igual a 5, apresentar uma mensagem dizendo que o aluno foi aprovado em exame. Se o aluno não foi aprovado, indicar uma mensagem informando esta condição. Apresentar junto com as mensagenso valor da média do aluno, para qualquer condição.

algoritmo "Situação do Aluno"

var

n1, n2, n3, n4, media, nrecup, mrecup :real

inicio

escreval ("Digite a primeira nota: ")

leia (n1)

escreval ("Digite a segunda nota: ")

leia (n2)

escreval ("Digite a terceira nota: ")

leia (n3)

escreval ("Digite a quarta nota: ")

leia (n4)

media<-(n1+n2+n3+n4)/4

se(media >=7)entao

escreval ("O aluno está aprovado com média: ",media)

senao

escreval ("O aluno está de recuperação com média: ",media)

escreval ("Digite a nota de recuperação: ")

leia(nrecup)

mrecup<-(media + nrecup)/2

se(mrecup>=5)entao

escreval("O aluno foi aprovado na recuperação com media: ",mrecup)

senao

escreval("O aluno não foi aprovado na recuperação com média: ",mrecup)

fimse

fimse

fimalgoritmo

 

45) Fazer um algoritmo em pseudocodigo para ler o ano de nascimento de uma pessoa, calcular emostrar sua idade e, também, verificar e mostrar se ela já tem idade para votar (16 anos ou mais)e para conseguir a Carteira de Habilitação (18 anos ou mais).

algoritmo "Maior Idade"

var

ano, idade: inteiro

inicio

escreval("digite seu ano de nascimento: ")

leia(ano)

idade<- 2013 - ano

escreval("Sua idade é: ",idade)

se(idade >= 18) entao

escreval("Ja tem idade para votar")

escreval("Já tem idade para ter habilitação")

senao

se(idade >= 16 ) entao

escreval("Já tem idade npara votar")

senao

escreval("Não pode votar e nem ter habilitação")

fimse

fimse

fimalgoritmo

 

46) Fazer um algoritmo em pseudocodigo ler o código de um determinado produto e mostrar a suaclassificação. Utilize a seguinte tabela como referência:

algoritmo "pesquisa por codigo"

var

codigo, outro :inteiro

cla: literal

inicio

escreva("Digite o código da pesquisa: ")

leia(codigo)

escolhacodigo

caso 1

escreval("Alimento não perecível")

caso 2, 3, 4

escreval("Alimento perecível")

caso 5, 6

escreval("Vestuário")

caso 7

escreval("Higiene pessoal")

caso 8, 9, 10, 11, 12, 13, 14, 15

escreval("Limpeza e ultensíliosdomesticos")

outrocaso

leia(outro)

escreva ("Inválido")

fimescolha

fimalgoritmo

 

47) Escrever um algoritmo para ler três valores inteiros e escrever na tela o maior e o menordeles. Considere que todos os valores são diferentes.

algoritmo "Maior e Menor Valor"

var

v1, v2, v3: inteiro

inicio

escreval("Digite o primeiro valor: ")

leia(v1)

escreval("Digite o segundo valor: ")

leia(v2)

escreval("Digite o terceiro valor: ")

leia(v3)

 

se(v1 > v2) e (v1 > v3) e (v2 > v3) entao

escreval("O maior valor é: ",v1," e o menor é: ",v3)

senao

se(v1 > v2) e (v1 > v3) e (v3 > v2) entao

escreval("O maior valor é: ",v1," e o menor é: ",v2)

senao

se(v2 > v1) e (v2 > v3) e (v1 > v3) entao

escreval("O maior valor é: ",v2," e o menor é: ",v3)

senao

se(v2 > v1) e (v2 > v3) e (v3 > v1) entao

escreval("O maior valor é: ",v2," e o menor é: ",v1)

senao

se(v3 > v1) e (v3 > v2) e (v1 > v2) entao

escreval("O maior valor é: ",v3," e o menor é: ",v2)

senao

se(v3 > v1) e (v3 > v2) e (v2 > v1) entao

escreval("O maior valor é: ",v3," e o menor é: ",v1)

fimse

fimse

fimse

fimse

fimse

fimse

fimalgoritmo

 

48) Escrever um algoritmo para ler cinco valores inteiros, calcular a sua média, e escrever na telaos números que são superiores à média.

algoritmo "Média e comparação"

var

notas: vetor [1..5] de inteiro

i, maior_media, soma: inteiro

media: real

inicio

escreval("Digite as 5 notas: ")

para i de 1 ate 5 faca

leia(notas)

soma<- soma + notas

media<- soma / 5

fimpara

escreval("A Soma das notas é: ",soma)

escreval("A média das notas é: ",media)

escreval("Os valores maiores que a média são: ")

para i de 1 ate 5 faca

se(notas > media) entao

maior_media<- notas

escreval(maior_media)

fimse

fimpara

fimalgoritmo

 

49)Escrever um algoritmo para ler a quantidade de horas/aula de dois professores e o valor porhora recebido por cada um. Mostrar na tela qual dos professores tem salário total maior.

algoritmo "Média e comparação"

var

h_a, valor: vetor [1..2] de real

prof: vetor [1..2] de literal

i: inteiro

salario, maior: real

inicio

maior<- 0

salario<- 0

para i de 1 ate 2 faca

escreval("Digite o nome do professor ",i)

leia(prof)

escreval("Digite a quantidade de Hora/Aula do professor ",i)

leia(h_a)

escreval("Digite o valor da Hora/Aula do professor ",i)

leia(valor)

escreval("----------- x ------- x ------------- x ----------")

fimpara

para i de 1 ate 2 faca

salario<- h_a * valor

escreval("O salário do professor ",i," é: ",salario)

se( salario > maior) entao

maior<- salario

fimse

fimpara

escreval("O maior salário é o do professor que ganha: ",maior)

fimalgoritmo

 

50) Escreva um algoritmo que lê três valores para os lados de um triângulo. O algoritmo deveverificar se o triângulo é equilátero (todos lados iguais), isósceles (dois lados iguais) ou scaleno(todos lados diferentes).

algoritmo "Tipo de triangulo"

var

l1, l2, l3: real

inicio

escreval("Digite o lado 1 do triângulo: ")

leia(l1)

escreval("Digite o lado 1 do triângulo: ")

leia(l2)

escreval("Digite o lado 1 do triângulo: ")

leia(l3)

se(l1 = l2) e (l2 = l3) entao

escreval("O triângulo é equilátaro")

senao

se(l1 <> l2) e (l1 <> l3) e (l2 <> l3) entao

escreval("O triângulo é escaleno")

senao

se(l1 = l2) ou (l1 = l3) ou (l2 = l3) entao

escreval("O triângulo é isósceles")

fimse

fimse

fimse

fimalgoritmo

 

51) Escrever um algoritmo que leia valores inteiros em duas variáveis distintas.

• Se o resto da divisão da primeira pela segunda for 1 mostre a soma dessas variáveis mais oresto da divisão;

• Se for 2 escreva se o primeiro e o segundo valor são pares ou ímpares;

• Se for igual a 3 multiplique a soma dos valores lidos pelo primeiro;

• Se for igual a 4 divida a soma dos números lidos pelo segundo, se este for diferente de zero.

• Em qualquer outra situação mostre o quadrado dos números lidos.

algoritmo "Dois Valores"

var

v1, v2, soma, mult: inteiro

divisao, q1, q2: real

inicio

escreval("Digite o primeiro número: ")

leia(v1)

escreval("Digite o segundo número: ")

leia(v2)

se(v1 mod v2 = 1) entao

soma<- v1 + v2 + 1

escreval("A soma de v1 e v2 mais o resto é: ",soma)

senao

se(v1 mod v2 = 2) entao

se(v1 mod 2 = 0) e (v2 mod 2 = 0) entao

escreval("v1 e v2 são par")

senao

se(v1 mod 2 <> 0) e (v2 mod 2 <> 0) entao

escreval("v1 e v2 são impar")

fimse

fimse

senao

se(v1 mod v2 = 3) entao

mult<- (v1 + v2) * v1

escreval("A soma de v1 e v2 multiplicado por v1 é: ",mult)

senao

se(v2 = 0) entao

escreval("Não haver divisão por zero")

senao

se(v1 mod v2 = 4) entao

divisao<- (v1 + v2) / v2

escreval("A soma de v1 e v2 dividido por v2 é: ",divisao)

senao

q1<- v1^2

q2<- v2^2

escreval("O quadrado do número 1 é: ",q1)

escreval("O quadrado do número 2 é: ",q2)

fimse

fimse

fimse

fimse

fimse

fimalgoritmo

 

62) Escrever um algoritmo para ler dois valores e uma das seguintes operações a seremexecutadas (codificadas da seguinte forma: 1 – Adição, 2 – Subtração, 3 – Multiplicação e 4 –Divisão). Calcular e escrever o resultado dessa operação sobre os dois valores lidos.

algoritmo "Codificação"

var

v1, v2, cod, adicao, mult: inteiro

divisao, subtracao: real

inicio

escreval("Digite o primeiro valor: ")

leia(v1)

escreval("Digite o segundo valor: ")

leia(v2)

escreval("-------------- x ----------- x ------------- x ---------------------")

repita

escreval("Digite o código: ")

leia(cod)

escolhacod

caso 1

adicao<- v1 + v2

escreval("A soma é: ",adicao)

caso 2

subtracao<- v1 - v2

escreval("A subtração é: ",subtracao)

caso 3

mult<- v1 * v2

escreval("A multiplicação é: ",mult)

caso 4

divisao<- v1 / v2

escreval("A divisão é: ",divisao)

outrocaso

escreval("Digite um código válido")

fimescolha

ate (cod>= 1) e (cod<= 4)

fimalgoritmo

 

63) Escreva um algoritmo que leia um número inteiro. Se o número lido for positivo, escreva uma mensagem indicando se ele é par ou ímpar. Se o número for negativo, escreva a seguinte mensagem “Este número não é positivo”.

algoritmo "Positivo ou Negativo"

var

n: inteiro

inicio

escreval("Digite um número inteiro: ")

repita

leia(n)

se( n = 0 ) entao

escreval("Digite um número diferente de zero")

senao

se( n > 0 ) e ( n mod 2 = 0 ) entao

escreval("O número ",n," é positivo e par")

senao

se( n > 0 ) e ( n mod 2 <> 0 ) entao

escreval("O número ",n," é positivo e impar")

senao

escreval("O número não é positivo")

fimse

fimse

fimse

ate n > 0

fimalgoritmo

 

64) Zezinho comprou um microcomputador para controlar o rendimento diário de seu trabalhocomo pescador. Toda vez que ele traz um peso de peixes maior que o estabelecido peloregulamento de pesca do estado de Santa Catarina (50 quilos) deve pagar um multa de R$ 4,00por quilo excedente. Zezinho precisa que você faça um algoritmo que leia a o peso de peixes everifique se há excesso. Se houver, o excesso e o valor da multa que Zezinho deverá pagar. Casocontrário mostrar uma mensagem que ele não deve pagar nada.

algoritmo "Controle de peso"

var

multa, peso, pesopermitido, excesso : real

 

inicio

escreval("Digite o peso permtido: ")

leia(pesopermitido)

escreval("Digite o peso da pesca")

leia(peso)

se(pesopermitido< peso) entao

excesso<- peso - pesopermitido

multa<- excesso * 4

escreval("Houve excesso de: ",excesso," Kg, com multa de: ",multa)

senao

escreval("O pescador não vai pagar nada")

fimse

fimalgoritmo

 

65) Faça um algoritmo que receba o valor do salário de uma pessoa e o valor de umfinanciamento pretendido. Caso o financiamento seja menor ou igual a 5 vezes o salário dapessoa, o algoritmo deverá escrever “Financiamento Concedido"; senão, ele deverá escrever"Financiamento Negado". Independente de conceder ou não o financiamento, o algoritmoescreverá depois a frase "Obrigado por nos consultar."

algoritmo "Financiamento"

var

sala, financ: real

inicio

escreval("Digite o valor do salário: ")

leia(sala)

escreval("Digite o valor do financiamento pretendido: ")

leia(financ)

se(financ<= 5 * sala) entao

escreval("Financiamento concedido, obrigado por nos consultar")

senao

escreval("Financiamento negado, obrigadopor nos consultar")

fimse

fimalgoritmo

 

66) A Secretaria de Meio Ambiente que controla o índice de poluição mantém 3 grupos deindústrias que são altamente poluentes do meio ambiente. O índice de poluição aceitável varia de0 (zero) até 0,25. Se o índice sobe para 0,3 as indústrias do 1o grupo são intimadas asuspenderem suas atividades, se o índice crescer para 0,4 as industrias do 1o e 2o grupo sãointimadas a suspenderem suas atividades, se o índice atingir 0,5 todos os grupos devem sernotificados a paralisarem suas atividades. Faça um algoritmo que leia o índice de poluição medidoe emita a notificação adequada aos diferentes grupos de empresas.

algoritmo "Controle Ambiental"

var

indice: real

inicio

escreval("Digite o indice de poluição: ")

leia(indice)

 

se(indice>= 0.5) entao

escreval("Todos os grupos devem suspender suas atividades")

senao

se(indice>= 0.4) entao

escreval("1º e 2º grupos devem suspender suas atividades")

senao

se(indice>= 0.3) entao

escreval("Apenas o 1º grupo deve suspender suas atividades")

senao

escreval("Todas os grupos podem manter as atividades")

fimse

fimse

fimse

fimalgoritmo

 

67) Faça um programa que lê 4 valores X, A, B e C onde X é um número inteiro e positivo e A, B,e C são quaisquer valores reais. O programa deve escrever os valores lidos e:

• se X = 1, escrever os três valores A, B e C em ordem crescente;

• se X = 2, escrever os três valores A, B e C em ordem decrescente;

• se X = 3, escrever os três valores A, B, e C de forma que o maior valor fique entre os outrosdois;

• se X não for um dos três valores acima, dar uma mensagem indicando isso.

algoritmo "Manipulando valores"

var

x: inteiro

a, b, c, menor, meio, maior: real

inicio

escreval("Digite o valor de A: ")

leia(a)

escreval("Digite o valor de b: ")

leia(b)

escreval("Digite o valor de C: ")

leia©

se(a > b) e (b > c) entao

maior<- a

meio<- b

menor<- c

senao

se(a > c) e (c > b) entao

maior<- a

meio<- c

menor<- b

senao

se(b > a) e (a > c) entao

maior<- b

meio<- a

menor<- c

senao

se(b > c) e (c > a) entao

maior<- b

meio<- c

menor<- a

senao

se(c > a) e (a > b) entao

maior<- c

meio<- a

menor<- b

senao

se(c > b) e (b > a) entao

maior<- c

meio<- b

menor<- a

fimse

fimse

fimse

fimse

fimse

fimse

escreval("Digite o valor de X: ")

leia(x)

escolha x

caso 1

escreval(menor, meio, maior)

caso 2

escreval(maior, meio, menor)

caso 3

escreval(menor, maior, meio)

outrocaso

escreval("Não é nem 1, 2 ou 3")

fimescolha

fimalgoritmo

 

68) Elabore um algoritmo que informe se um dado ano é ou não bissexto. Obs: um ano é bissexto se ele for divisível por 400 ou se ele for divisível por 4 e não por 100.

algoritmo "Ano bissexto"

var

ano: inteiro

 

inicio

escreval("Digite um ano: ")

leia(ano)

se((ano mod 4 = 0) e (ano mod 100 <> 0)) ou (ano mod 400 = 0) entao

escreval("O ano: ",ano," é bissexto")

senao

escreval("O ano: ",ano," não é bissexto")

fimse

fimalgoritmo

 

69) Faça um algoritmo que determine o maior entre N números. A condição de parada é a entradade um valor 0, ou seja, o algoritmo deve processar o maior até que a entrada seja igual a 0(ZERO).

algoritmo "Maior número"

var

n, maior: real

inicio

maior<- 0

repita

escreval("Digite um número positivo maior que zero: ")

leia(n)

se(n > maior) entao

maior<- n

fimse

ate n = 0

escreval("O maior número é: ",maior)

fimalgoritmo

 

70) Faça um algoritmo que conte de 1 a 100 e a cada múltiplo de 10 emita uma mensagem:“Múltiplo de 10”.

 

algoritmo "Multiplos de 10"

var

n: vetor[1..100] de inteiro

i: inteiro

inicio

escreval("Os multiplos de 10 de 1 a 100 são:")

para i de 1 ate 100 faca

se(i mod 10 = 0) entao

escreval(i)

fimse

fimpara

fimalgoritmo

 

71) Elabore um algoritmo que gere e escreve os números ímpares entre números entre 100 e 200.

algoritmo "Numeros Impares de 100 a 200"

var

n: vetor[100..200] de inteiro

i, impar: inteiro

inicio

escreval("Os números impares de 100 a 200 são:")

para i de 100 ate 200 faca

se(i mod 2 <> 0) entao

escreval(i)

fimse

fimpara

fimalgoritmo

 

72) Construa um algoritmo que leia 50 valores inteiros e positivos e:

· Encontre o maior valor

· Encontre o menor valor

· Calcule a média dos números lidos

algoritmo "Maior menor e média"

var

valor: vetor[1..50] de inteiro

i, menor, maior, soma: inteiro

media: real

inicio

maior<- 0

menor<- 10000

escreval("Digite 50 números inteiros e positivos: ")

para i de 1 ate 50 faca

leia(i)

se(i > maior) entao

maior<- i

se(i < menor) entao

menor<- i

fimse

fimse

soma<- soma + i

media<- soma / 50

fimpara

escreval("O maior valor é: ",maior)

escreval("O menor valor é: ",menor)

escreval("A média dos valores é: ",media)

fimalgoritmo

 

73) Fazer um algoritmo que:

• Leia um número indeterminado de linhas contendo cada uma a idade de um indivíduo.

• Calcule e escreva a idade média deste grupo de indivíduos.

algoritmo "Idade média"

var

idade, soma, cont: inteiro

media: real

inicio

cont<- -1

escreval("Digite uma relação de idades: ")

repita

leia(idade)

soma<- soma + idade

cont<- cont + 1

ate idade = 0

media<- soma / cont

escreval("A soma das idades é: ",soma)

escreval("A quantidade é: ",cont)

escreval("A média das idades é de: ",media)

fimalgoritmo

 

74) Tem-se um conjunto de dados contendo a altura e o sexo (masculino, feminino) de 50pessoas. Fazer um algoritmo que calcule e escreva:

• A maior e a menor altura do grupo;

• A média de altura das mulheres;

• O número de homens.

algoritmo "Conjunto de dados"

var

cont, soma, nhomens, nmulher: inteiro

altura: real

alturaM, alturaH, media, maior, menor: real

sexo: literal

inicio

cont<- 0

nhomens<- 0

nmulher<- 0

escreval("Digite a altura e o sexo de 5 pessoas:")

repita

escreva("Altura: ")

leia(altura)

escreva("Sexo: ")

leia(sexo)

escreval("--------------- x xx --------------")

cont<- cont + 1

se(altura > maior ) entao

maior<- altura

se(altura < menor) entao

menor<- altura

fimse

fimse

se(sexo = "m") entao

nmulher<- nmulher + 1

atecont = 5

fimalgoritmo

 

75) A conversão de graus Farenheit para graus centígrados é obtida por: C ← (F-32)*5/9Fazer um algoritmo que calcule e escreva uma tabela em centígrados em função de grausFarenheit, que variam de 50 a 150 de 2 em 2.

algoritmo "De Farenheit para Centígrados"

var

graus: vetor[50..150] de inteiro

c: real

i: inteiro

inicio

para i de 50 ate 150 passo 2 faca

c <- (i - 32) * 5 / 9

escreval(i," F é igual a ",c," C")

fimpara

fimalgoritmo

 

76)Um comerciante deseja fazer o levantamento do lucro das mercadorias que ele omercializa.Para isto, mandou digitar cada mercadoria com o nome, preço de compra preço de venda dasmercadorias. Fazer um algoritmo que:

• Determine e escreva quantas mercadorias proporcionam:

• Lucro menor 10 %;

• Lucro entre 10% e 20%;

• Lucro maior que 20%.

• Determine e escreva o valor total de compra e de venda de todas as mercadorias, assim como olucro total.

algoritmo "Levantamento de lucro"

var

nome, x: literal

precompra, prevenda, lucro, menorl, mediol, maiorl, totalc, totalv, lucrog: real

 

inicio

repita

escreva("Produto: ")

leia(nome)

escreva("Preço de compra: ")

leia(precompra)

escreva("Preço de venda: ")

leia(prevenda)

escreva("Cadastrar outro produto,(s/n)?: ")

leia(x)

escreval("-------------------- x xx ---------------------")

totalc<- totalc + precompra

totalv<- totalv + prevenda

lucro<- prevenda - precompra

lucrog<- lucrog + lucro

se (lucro <precompra * 0.1) entao

menorl<- menorl + 1

senao

se(lucro >= precompra * 0.1) e (lucro <= precompra * 0.2) entao

mediol<- mediol + 1

senao

se(lucro >precompra * 0.2) entao

maiorl<- maiorl + 1

fimse

fimse

fimse

ate x = "n"

escreval("Nº de produtos com 10% de lucro: ",menorl)

escreval("Nº de produtos entre 10% e 20% de lucro: ",mediol)

escreval("Nº de produtos com mais de 20% de lucro: ",maiorl)

escreval("O valor total de compra é: ",totalc)

escreval("O valor total de venda é: ",totalv)

escreval("O Lucro geral é: ",lucrog)

fimalgoritmo

 

77) Supondo que a população de um país A seja da ordem de 90.000.000 habitantes com uma taxaanual de crescimento de 3% e que a população de um país B seja aproximadamente de 200.000.000habitantes com uma taxa anual de cresciemento de 1,5%. Fazer um algoritmo que calcule e escrevao número de anos necessários para que a população do país A ultrapasse ou iguale a população dopaís B, mantidas essas taxas de crescimento.

algoritmo "Crescimento anual"

var

a, b: real

ano: inteiro

inicio

a<- 90000000

b <- 200000000

ano<- 0

enquanto a <= b faca

a<- a * 0.03

b <- b * 0.015

ano<- ano + 1

fimenquanto

escreval("A quantida de anos para A chegar até B é: ",ano)

fimalgoritmo

 

78) Refaça o exercício 77, lendo as taxas e as populações.

algoritmo "Crescimento anual"

var

a, b, taxaa, taxab: real

ano: inteiro

inicio

ano<- 0

escreval("Digite a população do país A: ")

leia(a)

escreval("Digite a taxa do país A: ")

leia(taxaa)

escreval("-------------- x xx---------------")

escreval("Digite a população do país B: ")

leia(b)

escreval("Digite a taxa do país B: ")

leia(taxab)

enquanto a <= b faca

a<- a * taxaa / 100

b <- b * taxab / 100

ano<- ano + 1

fimenquanto

escreval("A quantida de anos para A chegar até B é: ",ano)

fimalgoritmo

 

79) Um determinado material radioativo perde metade de sua massa a cada 50 segundos. Dada amassa inicial, em gramas, fazer um programa que determine o tempo necessário para que essamassa se torne menor que 0,5 grama. Escreva a massa inicial, a massa final e o tempo calculado emhoras, minutos e segundos.

algoritmo "Material Radioativo"

var

massa, massai, massaf: real

contador, hora, minuto, segundo: inteiro

inicio

contador<- 0

massaf<- 0

escreval("Digite a massa inicial: ")

leia(massa)

massai<- massa

enquanto (massa >= 0.5) faca

massa<- massa / 2

contador<- contador + 50

fimenquanto

massaf<- massa

segundo<- contador mod 60

minuto<- contador div 60

hora<- minuto div 60

escreval("A massa inicial é: ",massai)

escreval("A massa final é: ",massaf)

escreval("O tempo gasto foi: ",hora," h ",minuto," m ",segundo," s")

fimalgoritmo

 

80) Deseja-se fazer um levantamento a respeito da ausência de alunos à primeira prova de Lógicade Programação para cada uma das 10 turmas existentes. Para cada turma é fornecido um conjuntode valores, sendo que os dois primeiros valores do conjunto correspondem à identificação da turma (A, B, C...) e ao número de alunos matriculados. Os demais valores deste conjunto contêm onúmero de matrícula do aluno e a letra A ou P para o caso de o aluno estar ausente ou presente,respectivamente. Fazer um programa que:

• Para cada turma, calcule a percentagem de ausência e escreva a identificação da turma e apercentagem calculada.

• Determine e escreva quantas turmas tiveram percentagem de ausência superior a 5%.

 

81) Um certa empresa fez uma pesquisa para saber se as pessoas gostaram ou não de um novoproduto lançado no mercado. Para isso, forneceu-se o sexo do entrevistado e a sua resposta (sim ounão). Sabendo-se que foram entrevistadas 2.000 pessoas, fazer um algoritmo que calcule e escreva:

• O número de pessoas que responderam sim;

• O número de pessoas que responderam não;

• A percentagem de pessoas do sexo feminino que responderam sim;

• A percentagem de pessoas do sexo masculino que responderam não;

algoritmo "Pesquisa"

var

sexo, res: literal

cont, conts, contn, nf, nm: inteiro

pf, pm: real

inicio

enquantocont< 2000 faca

escreva("Qual o seu sexo(m/f)?: ")

leia(sexo)

escreva("O produto está aprovado(s/n)?: ")

leia(res)

escreval("-------------- x xx --------------")

se(res = "s") e (sexo = "f") entao

nf<- nf + 1

senao

se(res = "n") e (sexo = "m") entao

nm<- nm + 1

fimse

fimse

se(res = "s") entao

conts<- conts + 1

senao

contn<- contn + 1

fimse

cont<- cont + 1

fimenquanto

pf<- nf / cont * 100

pm<- nm / cont * 100

escreval("O numero de reposta igual a sim é: ",conts)

escreval("O numero de reposta igual a não é: ",contn)

escreval("A percentagem de sim feminino é: ",pf)

escreval("A percentagem de não masculino é: ",pm)

fimalgoritmo

 

82) Foi feita uma pesquisa de audiência de canal de TV em várias casas de uma certa cidade, numdeterminado dia. Para cada casa visitada, é fornecido o número do canal (4, 5, 7, 12) e o número depessoas que o estavam assistindo naquela casa. Se a televisão estivesse desligada, nada era anotado,ou seja, esta casa não entrava na pesquisa. Fazer um algoritmo que:

• Leia número de casas pesquisadas;

• Calcule a percentagem de audiência para cada emissora;

• Escreva o número de cada canal e a sua respectiva percentagem.

algoritmo "Pesquisa 2"

var

ncasa, ncanal, p_a, cont, c4, c5, c7, c12: inteiro

tv_l: literal

pc4, pc5, pc7, pc12: real

inicio

tv_l<- "n"

escreval("Televisão desligada (s/n)?: ")

leia(tv_l)

enquantotv_l = "n" faca

cont<- cont + 1

escreva("Qual canal estão assistindo? ")

leia(ncanal)

escreva("Quantas pessoas estão assistindo? ")

leia(p_a)

escreval("------------- x xx ------------")

se(ncanal = 4) entao

c4<- c4 + 1

senao

se(ncanal = 5) entao

c5<- c5 + 1

senao

se(ncanal = 7) entao

c7<- c7 + 1

senao

se(ncanal = 12) entao

c12<- c12 + 1

fimse

fimse

fimse

fimse

pc4 <- c4 / cont * 100

pc5 <- c5 / cont * 100

pc7 <- c7 / cont * 100

pc12 <- c12 / cont * 100

escreva("Encerra pesquisa(s/n)? ")

leia(tv_l)

limpatela

fimenquanto

escreval("O número de casas pesquisadas é: ",cont)

escreval("A audiência da emissora do canal 4 é: ",c4)

escreval("A audiência da emissora do canal 5 é: ",c5)

escreval("A audiência da emissora do canal 7 é: ",c7)

escreval("A audiência da emissora do canal 12 é: ",c12)

escreval("A percentagem do canal 4 é: ",pc4," %")

escreval("A percentagem do canal 5 é: ",pc5," %")

escreval("A percentagem do canal 7 é: ",pc7," %")

escreval("A percentagem do canal 12 é: ",pc12," %")

fimalgoritmo

 

83) Uma Universidade deseja fazer um levantamento a respeito de seu concurso vestibular. Paracada curso é fornecido o seguinte conjunto de valores: Um código do curso;

• Número de vagas;

• Número de candidatos do sexo masculino;

• Número de candidatos do sexo feminino.

Fazer um programa que:

• Calcule e escreva, para cada curso, o número de candidatos por vaga e a percentagem decandidatos do sexo feminino (escreva também o código correspondente do curso);

• Determine o maior número de candidatos por vaga e escreva esse número juntamentecom o código do curso correspondente (supor que não haja empate);

• Calcule e escreva o total de candidatos.

algoritmo "semnome"

var

nvagas, cm, cf, tc: inteiro

pcf, cpv, mncv: real

cadastrar: literal

curso, cod_c: caracter

inicio

cadastrar<- "s"

mncv<- 0

tc<- 0

enquanto cadastrar = "s" faca

escreva("O código do curso: ")

leia(cod_c)

escreva("O nº de vagas do curso: ")

leia(nvagas)

escreva("O nº de candidatos masculino: ")

leia(cm)

escreva("O nº de candidatos feminino: ")

leia(cf)

tc<- tc + (cm + cf)

cpv<- (cm + cf) / nvagas

pcf<- cf / (cm + cf) * 100

se(mncv<cpv) entao

mncv<- cpv

curso<- cod_c

fimse

escreval("------------------- x xx---------------------")

escreval("O numero de cadidatos por vaga é: ",cpv)

escreval("O curso ",cod_c," teve ",pcf," % de candidatas mulheres")

escreva("Cadastrar outro curso(s/n)? ")

leia(cadastrar)

fimenquanto

escreval("---------------------------------- x xx ------------------------------------")

escreval("O curso ",curso," teve o maior numero de cadidatos por vaga que é: ",mncv)

escreval("O total de candidatos é: ",tc)

fimalgoritmo

 

 

84) O sistema de avaliação de uma determinada disciplina obedece aos seguintes critérios:

• Durante o semestre são dadas três notas;

• A nota final é obtida pela média aritmética das notas dadas durante o curso;

• É considerado aprovado o aluno que tiver a nota final superior ou igual a 6.0 e que tivercomparecido a um mínimo de 75% das aulas. Fazer um algoritmo que:

1. leia um conjunto de dados contendo o número de matrícula, as três notas e a frequência (númerode aulas frequentadas) para 100 alunos.

2. Calcule:

• A nota final de cada aluno;

• A maior e a menor nota da turma;

• A nota média da turma;

• O total de alunos reprovados;

• A percentagem de alunos reprovados por frequência insuficiente.

3. Escreva

• Para cada aluno, o número de matrícula, a frequência, a nota final e ocódigo (aprovado ou reprovado);

• Todos os valores que foram calculados no item 2;

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Alguém sabe como resolver esse?

 

Fazer um algoritmo para receber via teclado o Nome, o Número de Horas Trabalhadas no mês, o Cargo do empregado e o Local de Trabalho de seus 20 empregados. A empresa paga para cada hora trabalhada no mês de um empregado os seguintes valores:

CARGO

LOCAL DE TRABALHO

VALOR DA HORA TRABALHADA

GERENTE

ESCRITÓRIO

R$ 60,00

GERENTE

FÁBRICA

R$ 65,00

SUPERVISOR

ESCRITÓRIO

R$ 45,00

SUPERVISOR

FÁBRICA

R$ 40,00

OPERADOR

FÁBRICA

R$ 30,00

 

O algoritmo deverá calcular e imprimir o salário de cada empregado. Para isto, primeiramente o algoritmo deverá calcular o Valor da Hora Trabalhada de acordo com a tabela acima, e em seguida calcular o salário utilizando a seguinte fórmula:

SALARIO = VALOR HORA TRABALHADA * NÚMERO DE HORAS TRABALHADAS

Como resultados finais o algoritmo deverá imprimir:
a) O valor médio dos salários da empresa
b) A quantidade de Gerentes que tem na empresa
c) A quantidade de Supervisores que tem na empresa
d) A quantidade de Operadores que tem na empresa

obs.:

- neste exercício, utilize o comando enquanto...faca para controlar a repetição na entrada de dados e nos cálculos pedidos.

- para facilitar o teste do algoritmo, utilizar um número menor de empregados (8 por exemplo), e assim possibilitar com menor digitação visualizar a impressão dos resultados e conferir se estão corretos. Mas no teste, procure variar a digitação do cargo e o local de trabalho de cada empregado. Depois de testado o algoritmo e ter certificado que está correto, voltar o número de empregados para 20.

Share this post


Link to post
Share on other sites

O exercicio 50 no triangulo isosceles na apresenta a opcao de caso o lado C for igual a B 

no caso o correto seria em C#

 

 else if(A == C || A == B || C==A || C == B)
            {
                Console.WriteLine("O triângulo é isósceles.");

            }

Share this post


Link to post
Share on other sites

1  Foi feita uma pesquisa estatística com um grupo de 15 estudantes. Para cada estudante foram obtidos os seguintes dados: curso(1- Computação/2- Sistemas de Informação), idade, sexo(1-fem/2-mas) e período(1-8). Faça um algoritmo que leia os dados dos estudantes, calcule e imprima:

a. Média da idade dos estudantes de Computação

b. Quantidade de estudantes que estão cursando o sexto período

c. Quantidade de estudantes de Sistemas de Informação que tem menos de 22 anos

d. Percentual de mulheres no curso de Computação

Share this post


Link to post
Share on other sites
Em 13/09/2015 at 11:48, Evandro José da Cruz disse:

Alguém sabe como resolver esse?

 

Fazer um algoritmo para receber via teclado o Nome, o Número de Horas Trabalhadas no mês, o Cargo do empregado e o Local de Trabalho de seus 20 empregados. A empresa paga para cada hora trabalhada no mês de um empregado os seguintes valores:

 

CARGO

LOCAL DE TRABALHO

VALOR DA HORA TRABALHADA

GERENTE

ESCRITÓRIO

R$ 60,00

GERENTE

FÁBRICA

R$ 65,00

SUPERVISOR

ESCRITÓRIO

R$ 45,00

SUPERVISOR

FÁBRICA

R$ 40,00

OPERADOR

FÁBRICA

R$ 30,00

 

O algoritmo deverá calcular e imprimir o salário de cada empregado. Para isto, primeiramente o algoritmo deverá calcular o Valor da Hora Trabalhada de acordo com a tabela acima, e em seguida calcular o salário utilizando a seguinte fórmula:

SALARIO = VALOR HORA TRABALHADA * NÚMERO DE HORAS TRABALHADAS

Como resultados finais o algoritmo deverá imprimir:
a) O valor médio dos salários da empresa
b) A quantidade de Gerentes que tem na empresa
c) A quantidade de Supervisores que tem na empresa
d) A quantidade de Operadores que tem na empresa

obs.:

- neste exercício, utilize o comando enquanto...faca para controlar a repetição na entrada de dados e nos cálculos pedidos.

- para facilitar o teste do algoritmo, utilizar um número menor de empregados (8 por exemplo), e assim possibilitar com menor digitação visualizar a impressão dos resultados e conferir se estão corretos. Mas no teste, procure variar a digitação do cargo e o local de trabalho de cada empregado. Depois de testado o algoritmo e ter certificado que está correto, voltar o número de empregados para 20.

algoritmo "semnome"
var
   nome, cargo, local: caracter
   hotrab, contador, ger, sup, ope, salario, sal, media: real
inicio
   Enquanto contador < 20 faca
      Escreva("Nome do funcionário: ")
      Leia(nome)
      Escreva("Número de horas trabalhadas no mês: ")
      Leia(hotrab)
      Escreva("Cargo do funcionário: ")
      Leia(cargo)
      Escreva("Local de trabalho: ")
      Leia(local)
      Se (cargo = "gerente") e (local = "escritorio") entao
         salario <- hotrab * 60
         ger <- ger + 1
      Senao
         Se (cargo = "gerente") e (local = "fabrica") entao
            salario <- hotrab * 65
            ger <- ger + 1
         Senao
            Se (cargo = "supervisor") e (local = "escritorio") entao
               salario <- hotrab * 45
               sup <- sup + 1
            Senao
               Se (cargo = "supervisor") e (local = "fabrica") entao
                  salario <- hotrab * 40
                  sup <- sup + 1
               Senao
                     salario <- hotrab * 30
                     ope <- ope + 1
               FimSe
            FimSe
         FimSe
      FimSe
      sal <- salario + sal
      Escreval("O empregado ", nome, " ganhou ", salario, " reais nesse mês")
      Escreval("===================================================")
      contador <- contador + 1
   FimEnquanto
   media <- sal / 2
   Escreval("O valor médio de salários da empresa é de: R$", media)
   Escreval("A quantidade de gerentes que tem na empresa é de: ",  ger)
   Escreval("A quantidade de supervisores que tem na empresa é de: ",  sup)
   Escreval("A quantidade de operadores que tem na empresa é de: ",  ope)
fimalgoritmo

 

 

 

Share this post


Link to post
Share on other sites

Faz um código para desenvolva um algoritmo para testar se uma pilha P1 tem mais elementos que uma pilha P2. Considere que P1 e P2 já existem.

Para desenvolva um algoritmo para inverter a posição dos elementos de uma pilha P. Você pode criar pilhas auxiliares, se necessário. Mas o resultado precisa ser dado na pilha P.

E Desenvolver um algoritmo para testar se duas pilhas P1 e P2 são iguais. Duas pilhas são iguais se possuem os mesmos elementos, na mesma ordem. Você pode utilizar pilhas auxiliares também, se necessário

Share this post


Link to post
Share on other sites

Alguém sabe como resolver esse? 

 

Miguel é responsável pelas contas de uma grande empresa da área de mineração em Minas Gerais. Ele deseja pagar a seus funcionários um bom salário, mas se preocupa com as épocas de crise. Dessa forma, ele paga um salário fixo, condizente com a função do funcionário e paga a eles um valor adicional a título de participação de lucros. Ele deseja que você crie um programa que calcule quanto um funcionário específico receberá em um mês, tendo em vista a sua função e o quanto a empresa lucrou percentualmente em relação à expectativa. Os salários seguem a tabela:

Nível Salário

Ausente R$1600,00

Técnico R$2800,00

Analista R$3500,00

Especialista R$4000,00

 

ENUNCIADO

Ainda, o salário é acrescido do percentual que excedeu as expectativas de lucro da empresa. Lembrando que se o percentual for inferior a 100% o empregado não pode receber menos do que o salário. Enunciado Agora, que Miguel já consegue saber o quanto um funcionário recebe em um mês, ele deseja saber o quanto ele deverá pagar para todos os seus funcionários. Agora, para cada funcionário ele pagará uma bonificação (percentual) sobre seu salário relacionada a seu desempenho individual, além da participação dos lucros. Ele então deseja que você crie um programa que, recebendo as informações suficientes para o cálculo do pagamento de cada funcionário, informe o valor de pagamento total.

 

Questões

 

1. Identifique a entrada, saída e processamento para este problema.

2. Descreva textualmente os passos do algoritmo.

3. Identifique quais serão as variáveis e constantes utilizadas no algoritmo, com seus tipos respectivos.

4. Descreva as funções matemáticas que geram as saídas do algoritmo.

5. Para o algoritmo desenvolvido por você (não programado ainda!), identifique os laços e desvios de fluxo.

6. Escreva um código em Portugol que represente o algoritmo que resolve o problema de Miguel.

Share this post


Link to post
Share on other sites

Faça um algoritmo que tenha um menu com as seguintes opções:

1 - Inserir valor no vetor

2 - Ver todos os Valores do Vetor

3 - Sair do programa

O menu de opções deve ser feito em uma função que retorna a opção informada pelo usuário, inserir valor no vetor deve ser feito em um procedimento que insere valores informados pelo usuário no vetor, e ver todos deve ser feito também em um procedimento que mostra todos os valores do vetor;

Para facilitar tanto o vetor quanto a variável que conta quantos elementos tem no vetor poderão ser criadas Global, ou seja cria no var do programa principal que todos os outros sub programas conseguiram acessar eles.

Share this post


Link to post
Share on other sites

Faça um algoritmo que tenha um menu com as seguintes opções:

1 - Inserir valor no vetor

2 - Ver todos os Valores do Vetor

3 - Sair do programa

O menu de opções deve ser feito em uma função que retorna a opção informada pelo usuário, inserir valor no vetor deve ser feito em um procedimento que insere valores informados pelo usuário no vetor, e ver todos deve ser feito também em um procedimento que mostra todos os valores do vetor;

Para facilitar tanto o vetor quanto a variável que conta quantos elementos tem no vetor poderão ser criadas Global, ou seja cria no var do programa principal que todos os outros sub programas conseguiram acessar eles.

 

obs: preciso urgente!!!

visualg 

Share this post


Link to post
Share on other sites
  • Sabe-se que a Camiseteria Kanashiro está com uma promoção de camisetas nos seguintes tamanhos e valores:

    • Tamanho P - R$ 10

    • Tamanho M - R$ 15

    • Tamanho G - R$ 20

  • Construa um algoritmo que receba de entrada 3 valores do tipo inteiro, representando respectivamente as quantidades de camisetas Tamanho P, Tamanho M e Tamanho G de uma encomenda de um determinado cliente. Em seguida, calcule e imprima na saída qual o valor total que o cliente deverá pagar.

  • A mensagem na saída deverá seguir o seguinte padrão:

 

    Prezado(a) cliente, você deverá pagar {valor} reais!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.