Jump to content
Paulo Felipe de Araujo

Css não funciona

Recommended Posts

Começei um projeto simples, e assim que fui começar o css ele não apresenta nada.

<!DOCTYPE html>
<html lang="pt-br">
<head>
<meta charset="utf-8"/>
<title><?php echo $titulo; ?></title>
<link rel="stylesheet" href="css/estilo.css" type="text/css"/>
<script src="js/meu-contato.js"></script>
</head>

<body>
	<section id="conteudo">
		<nav>
			<ul>
				<li><a class="config" href="index.php">Home</a></li>
				<li><a class="config" href="?op=add">Adicionar Contato</a></li>
				<li><a class="config" href="?op=apagar">Apagar Contatos</a></li>
				<li><a class="config" href="?op=config">Configurações</a></li>
				<li><a class="config" href="?op=consultas">Consultas</a></li>
			</ul>
		</nav>
		<section id="principal">
			<?php include($conteudo); ?>
		</section>
	</section>
</body>
</html>

Css:

*{
	margin:0 auto;
	border:0;
}

@font-face{
	font-family: "Oswald";
	src: url("../fonts/Oswald-Light.ttf") format("light"),
	src: url("../fonts/Oswald-Regular.ttf") format("regular"),
	src: url("../fonts/Oswald-Bold.ttf") format("bold");
}

a{
	text-decoration:none;
	color:#FFFF00;
}

a:hover{
	color:#000000;
}

 

Share this post


Link to post
Share on other sites

Olá Paulo.

Deixa ver se entendi, nada aparece ou os estilos do seu arquivo css não são apresentados, caso seja isso você verificou se o css está carregando normalmente?

Boa sorte!

Share this post


Link to post
Share on other sites

Coloquei eles direto no index funcionou

<!DOCTYPE html>
<html lang="pt-br">
<head>
<meta charset="utf-8"/>
<title><?php echo $titulo; ?></title>
<style>
	*{
	margin:0 auto;
	border:0;
}

@font-face{
	font-family: "Oswald";
	src: url("../fonts/Oswald-Light.ttf") format("light"),
	src: url("../fonts/Oswald-Regular.ttf") format("regular"),
	src: url("../fonts/Oswald-Bold.ttf") format("bold");
}

a{
	text-decoration:none;
	color:#FF0000;
}

a:hover{
	color:#000000;
}
</style>
<script src="js/meu-contato.js"></script>
</head>

<body>
	<section id="conteudo">
		<nav>
			<ul>
				<li><a class="config" href="index.php">Home</a></li>
				<li><a class="config" href="?op=add">Adicionar Contato</a></li>
				<li><a class="config" href="?op=apagar">Apagar Contatos</a></li>
				<li><a class="config" href="?op=config">Configurações</a></li>
				<li><a class="config" href="?op=consultas">Consultas</a></li>
			</ul>
		</nav>
		<section id="principal">
			<?php include($conteudo); ?>
		</section>
	</section>
</body>
</html>

Mas quando coloco o link ele não funciona

Share this post


Link to post
Share on other sites

Abre o debug do navegador e observa se o arquivo está sendo carregado, se não estiver o problema está no caminho do arquivo estilo.css

Share this post


Link to post
Share on other sites

Ele não carrega essa parte do css

@font-face{
	font-family: "Oswald";
	src: url("../fonts/Oswald-Light.ttf") format("light"),
	src: url("../fonts/Oswald-Regular.ttf") format("regular"),
	src: url("../fonts/Oswald-Bold.ttf") format("bold");
}

a{
	text-decoration:none;
	color:#FF0000;
}

a:hover{
	color:#000000;
}

só a primeira parte

print.png

Share this post


Link to post
Share on other sites

@Paulo Felipe de Araujo, buenas.

 

Tu precisa informar onde as fontes serão usadas.

 

a{
	font-family: 'Oswald', sans-serif;
	text-decoration:none;
	color:#FF0000;
}

a:hover{
	color:#000000;
}

 

Share this post


Link to post
Share on other sites

Devs, eu consultei a documentação do Mozilla. Ao que parece o Firefox não aceita a instrução  type text/css, dentro de link rel,  nem tampouco o arquivo .css num diretório diferente do arquivo .html.   Isso acabou de acontecer comigo. To usando o Mozilla Firefox 84.0.2 (64-bits) para windows. Inicialmente, achei que fosse alguma incompatibilidade com VIM ou Git. Felizmente não era. Fiz a validação do HTML e do CSS e estavam ok. Ocorreu que o Firefox não carregava o Css - vi isso em inspecionar. Então, depois ler a documentação da Mozilla, segui lá o exemplo. Daí o CSS funcionou num arquivo na mesma página do HTML, sem type text/css, e também funcionou inserido diretamente no html. Nada bom isso!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Juan Carlos PT
      Olá, eu quero poder pegar um vídeo do meu canal na Nimo TV e deixar ele em sites parceiros para fortalecer a minha divulgação. Só que não consigo capturar o código <video></video> do html5 do site na Nimo TV. Eles não mostram o formato do vídeo:
       

      Se alguém souber me ajudar, terei enorme gratidão!
       
      OBS: Perdão se alguém postou algo parecido aqui no site, não vi!

    • By Roberto S. Santos
      Bom dia.
      Eu gostaria de postar uma foto do meu computador no facebok usando VB.NET com login automático.
      Teria como fazer em VB.net ou HTML ?
      Obrigado.
    • By Carlos Longo
      Srs Bom dia,
       
      fiz inumeras tentativas para mostrar a imagem com link em:
       <script type="text/javascript"> var imagens =  new Array( '1.jpg', '2.jpg', '3.jpg','4.jpg', '5.jpg', '6.jpg'); var num_img = 6; var img_atual =0; function ChangeImg() { if (img_atual < (num_img - 1) ) { img_atual = img_atual + 1; } else { img_atual = 0; } document["img_apoio"].src = "http://www.ficasimples.com.br/calcfal/prop/" + imagens[img_atual]; var x = setTimeout ("ChangeImg()", 2000); }   </script>  
      ela posteriormente é chamada assim:
      queria que ao clicar na figura fosse chamado o link da figura especifica conforme valor da variavel  imagens[img_atual]/////
      <img name="img_apoio" src="http://www.ficasimples.com.br/calcfal/prop/1.jpg" alt="" border="0"width="190px" height="210px" align="center">  
       
      poderiam me ajudar??
       
      grato
       
      Carlos
    • By RPM13
      Boa tarde, senhores(as)!
      Estou a procura de algum profissional para desenvolver um website para mim.
      Entro mais detalhes no privado.
      Interessados chamar por aqui.
      Obrigado!
    • By fideles
      Galera, 
       
      Alguém aqui já criou algum relatorio em php que seja gravado em abas ? Como ? Tenho um que é uma em unica pagina/ aba, e não faço a minima ideia de como fazer isso. 
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.