Jump to content
EliseuFirmino

Consulta

Recommended Posts

Bom dia! 

 

Tenho uma view que me trás todos os procedimentos realizados em um hospital.  

 

Existem pacientes que fazem o procedimento Consulta_Ambulatorial e depois realiza outros procedimentos de exame(ex: endoscopia).

Existem pacientes que não realizam Consulta_Ambulatorial mas realizam outros exames(ex: exame de sangue).

 

Eu preciso realizar uma consulta que verifique se: Paciente fez consulta ambulatorial ? imprime consulta e os outros exames realizados.

Não fez consulta ambulatorial ?  não imprime.

 

Tentei utilizar as instruções IF-THEN-ELSE mas não tive sucesso.

 

Alguém pode me dar uma luz?

Share this post


Link to post
Share on other sites

Publique a estrutura das tabelas e como se identifica um Consulta e/ou um Exame ?

 

Uma dica inicial pode ser um subselect com EXISTS , mas uma solução melhor pode existir dependendo da estrutura da tabela podem haver outras.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ludlima
      Boa noite,estou tentando executar um algoritmo no visualg que leia 100 números,descubra se existe números primos,se sim mostrar em que posição se encontra. Entretanto,o programa só está executando até onde mostra o vetor. Gostaria de ajuda de como terminar e realizar a verificação do número primo.
      Var
        num, cont, divisor: inteiro
        VET: vetor[0..99] de inteiro

      Inicio
         escreval ("Olá!Você quer saber se existe número primo? ")
         Para num <- 0 ate 99 faca
            Escreva("Digite o ", num, "o. valor: ")
            Leia(VET[num])
         FimPara
      LimpaTela
         escreva ("Vetor: ")
         para num <- 0 ate 99 faca
            escreva (VET[num])
         fimpara
         escreval ("")
         
      cont <- 0
      divisor <- 1
         Para num <- 0 ate 99 faca
      cont <- cont + 1
      divisor <- divisor + 1
         se (divisor <= num)e(num mod divisor = 0)e (cont = 2) entao
         EscrevaL("Valor", VET[num], " na posicao [",num, "] é Primo!")
      fimse
      fimpara

      Fimalgoritmo
    • By ludlima
      Boa noite,estou tentando fazer um algoritmo que leia 50 números e mostre em ordem crescente e decrescente ao usuário,preciso utilizar vetor. Até agora só conseguir fazer a parte crescente. Alguém tem alguma dica de como fazer a parte decrescente?
       
      Var
      CONTADORA, CONTADORB: inteiro
      NUM, AUX: inteiro
      VET: vetor[0..49] de inteiro
      Inicio
         para CONTADORA de 0 ate 49 faca
         escreval ("Digite um número")
         leia (NUM)
         VET[CONTADORA] <- NUM
      fimpara
      para CONTADORA de 0 ate 48 faca
         para CONTADORB de CONTADORA + 1 ate 49 faca
            se VET[CONTADORA] > VET[CONTADORB] entao
               AUX <-VET[CONTADORB]
               VET[CONTADORB] <- VET[CONTADORA]
               VET[CONTADORA] <- AUX
            fimse
         fimpara
      fimpara
      escreval("A ordem crescente dos números é: ")
      para CONTADORA de 0 ate 49 faca
         escreva(VET[CONTADORA])
      fimpara
      Fimalgoritmo
       
    • By RAFAEL C D EMELO
      ola pessoal mais uma vez aqui pedindo ajuda !!!!
       
      estou com uma tarefa aparentemente simples mas estou travado na conversao dos dados alguem poderia me ajudar
       
       
      DECLARE V_YEAR VARCHAR2(10); V_MONTH VARCHAR2(10); V_PREMIUM_START DATE; V_PREMIUM_END DATE; V_END_MONTH DATE; BEGIN FOR REG IN ( SELECT V.ATC_STARTDATE, V.ATC_ENDDATE, P.PREMIUMSTARTDATE,P.PREMIUMENDDATE,P.YEARPREMIUM,P.MONTHPREMIUM,P.AMOUNT,P.EXPOSURE,P.PAYMENTTYPE, P.FK_CLIENT, C.CLIENTKEY, V.FK_CLIENTKEY FROM GV_MANUAL_PREMIUM P, GV_MANUAL_CLIENT C, GV_MANUAL_VEHICLE V WHERE P.FK_CLIENT = C.CLIENTKEY AND C.CLIENTKEY = V.FK_CLIENTKEY AND P.FK_CLIENT = 'RO14VOH*SME*SME*WARREN FINANCIAL SOLUTIONS LIMITED' AND P.YEARPREMIUM IN (2014) ORDER BY P.YEARPREMIUM, P.MONTHPREMIUM ) LOOP DBMS_OUTPUT.PUT_LINE(REG.ATC_STARTDATE ||' '|| REG.ATC_ENDDATE ||' '|| REG.PREMIUMSTARTDATE ||' '|| REG.PREMIUMENDDATE ||' '|| REG.YEARPREMIUM ||' '|| REG.MONTHPREMIUM ||' '|| REG.AMOUNT ||' '|| REG.EXPOSURE ||' '|| REG.PAYMENTTYPE ||' '|| REG.FK_CLIENT); DBMS_OUTPUT.PUT_LINE('--------------------------------------------------------------------------'); DBMS_OUTPUT.PUT_LINE('--------------------------------------------------------------------------'); IF REG.ATC_STARTDATE > REG.PREMIUMSTARTDATE AND to_char(REG.ATC_STARTDATE, 'MM') = REG.MONTHPREMIUM AND to_char(REG.ATC_STARTDATE , 'YY') = REG.YEARPREMIUM THEN DBMS_OUTPUT.PUT_LINE('ENTER'); else DBMS_OUTPUT.PUT_LINE('not enter'); END IF; END LOOP; END;
       
       

      Eu tenho dois campos uma deles o ATC_STARTDATE  seria um campo data = 09-05-2015 e o campo PREMIUMMONTH e um campo varchar2 de 5 eu preciso fazer eles serem do mesmo tipo para comparalos no caso vou comparer o mesmo do campo ATC_STARTDATE usando somente o mes  para saber se e igual o mes do campo  PREMIUMMONTH
      DESDE JA AGRADECO QUALQUER AJUDA.
    • By C.SALLES
      Faça um programa leia dois números inteiros e utilize uma função SOMAR que receba esses dois números por parâmetro e retorne a soma dos números inteiros existentes entre eles.
      Sou iniciante em programação e tentei fazer o programa da tal forma:
       
      #include<stdlib.h>
      #include<math.h>
      #include<stdio.h>
      int SOMAR((((int soma;i;n1;n2))))
      {
          return; 
           for (i=n1+1; i<n2; i++) {  
          soma += i; 
          } 
      }
      int main() { 
      int n1, n2; 
      printf("Informe os números: "); 
      scanf("%d %d", &n1, &n2);  
      printf("\nSoma: %d\n", SOMAR(soma)); 
      return 0; 
      system ("pause");
      }
       
      Não roda por vários motivos e sinceramente sei nem como resolver
    • By gabriellbvbr
      Olá, estou em dúvida em qual Frameworks/Linguagens devo utilizar para desenvolver uma aplicação web flexível , seria um formulário que se adapta em tempo real conforme a opção selecionada, passando por verificação de campos e validação dos dados?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.