Ir para conteúdo

Recommended Posts

Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por giovannibatista
      Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs...
      O trabalho é este:
        
      Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo: 
      Tabela IRPF 
      Tabela INSS 
      Salário até R$1500,00 será 0% de imposto; 
      Salário até R$3000,00 será 15% de imposto; 
      Salário acima de R$3000,00 será 27,5% de imposto. 
      Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor) 
        
      Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido. 
      Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo: 
      Salário Bruto 
      Salário Líquido 
      R$ 5000,00 
      R$ 3225,00 
      R$ 3500,00 
      R$ 2152,50 
        
      Retorno de resultado 
      R$ 1800,00 
      R$ 1332,00 
      R$ 1400,00 
      R$ 1246,00
      Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor): 
        
      var
         salarioB, irpf, inss: real 
      inicio 
      //IRRF:
       //Até 1.500 | -
       //De 1.500 até 3.000 | 15,0
       //Acima de 3.000 | 27,5
        
      //INSS:
       //Fixo | 11,0 | Limite de desconto 400 
      escreva("Digite o salário:")
      leia (salarioB) 
      se (salarioB<1500.00)ou(salarioB=1500.00) entao
      inss<- salarioB*11/100
      escreval("Seu SalarioB Liquido é", salarioB - inss)
      senao
      se (salarioB>1500.01)e(salarioB<=3000.00) entao
      irpf<- salarioB*15/100
      inss<- salarioB*11/100
      escreval ("IRPF a ser descontado é", irpf)
      escreval ("INSS a ser descontado é", inss)
      escreval("O salário Líquido é", salarioB - irpf - inss)
      senao
      se (salarioB>3000.00)ou(salarioB= 3000.00) entao
      irpf<- salarioB*27.5/100
      inss<- salarioB*11/100
      escreval ("IRPJ a ser descontado é", irpf)
      escreval ("INSS a ser descontado é", inss)
      escreval("O salário Líquido é", salarioB - irpf - inss) 
      fimse
      fimse
      fimse
      fimalgoritmo 
        
    • Por lucas25
      estou precisando de ajuda nessa questão:
       
      A companhia de aviação balanca mas nao cai ltda deseja automatizar o calculo de desconto durante o procedimento de vendas de passagens areas para os seus 2500 voos. Dessa forma, confeccionar um algoritimo que:
      a. leia cada venda:
      o dia da semana do voo (2-3-4-5-6-7-0)
      o turno do voo (diurno ou noturno)
      a quantidade de passagens 
      o valor da passagem.
       
      estou precisando de ajuda não estou conseguindo faze.
    • Por Daniel Rabelo
      Meu código tá dando erro no fim algoritmo
       
      algoritmo "Calculador de Maioridade"
        var an : inteiro
        var anoa : inteiro
        var qfuac : caractere
        var facf : caractere
        var cpf : caractere
      inicio
         escreval ("Qual seu ano de nascimento ")
         leia (an)
      anoa <- (2018)
      an <- (anoa - an)
         se (an > 18) entao
         escreval ("Voce tem " , an)
         escreval ("Voce e maior de idade")
         escreval (" Voce quer fazer uma faculdade?")
         leia (qfuac)
         se (sim ou Sim ) entao
         escreval ("Qual faculdade voce quer fazer?")
         leia (facf)
         escreval ("Quer fazer seu cadastro para ", facf" ?")
            se (sim ou Sim) entao
               escreval ("Digite seu CPF")
               leia (cpf)
               escreval ("Digite seu RG")
               leia (rg)
               escreval ("Pronto Cadastro Feito. Boa sorte")
               fimse
         senao escreval ("Voce tem " , an)
         escreval ("Voce e menor de idade")
         fimse
      fimalgoritmo
       
      Da esse erro:
       
      Dados incorretos : [46:0] = fimalgoritmo
       
      Alguém me ajuda
       
    • Por matheusfenomeno
      algoritmo "semnome"
      var
      nome:caractere
      c,n:inteiro
      inicio
      escreva("Qual é o seu nome ? ")
      leia(nome)
      Escreval("Prazer ",nome,".")
      escreval("Escolha um numero")
      leia(n)
      c <- 0
      Enquanto (c<=n) faca
         c <- c + 1
      fimEnquanto
      fimalgoritmo
    • Por Leonardo Thompson
      Olá pessoal podem me ajudar com esses exercicios? anexei a foto das questoes no post, Obrigado a todos pela atenção!
       
       
       
      1) Considerando a=5, b=2, e c=8, escreva qual será o valor impresso pelo algoritmo quando valor a ser lido(valor de entrada):
      a) Valor de entrada, num = -2
      b) Valor de entrada, num = 2
       
      2) Escreva um algoritmo que leia dados de entrada  3 números, verificando se eles podem ou não ser lados de um triangulo. Caso sejam lados de um triangulo, calcular a area do mesmo e imprimir o resultado, caso nao sejam  imprimir "não sao lados de um triangulo"
      para que o triangulo exista , um de seus lados  deve ser maior que o valor absoluto (modulo) da diferença dos outros dois lados e menor que a soma dos outros dois lados:
      a > l b-c l, b > l a-c l, c > l a-b l
      ao calcular a area de um triangulo utilize a formulaçao sendo que a, b e c sao os lados do triangulo
      A=v(p x(p-a) x (p-b) x (p-c))
      P= (a+b+c)/2


×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.