Ir para conteúdo

Recommended Posts

Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora


  • Conteúdo Similar

    • Por Lucas Carlos
      "Escreva um algoritmo que leia o nome, idade e sexo de 10000 pessoas
      finalizando a digitação quando o nome for igual a espaço. Mostrar o total de
      pessoas digitadas, o percentual de homens e de mulheres, a média de idade
      e o nome e idade da pessoa mais velha e da pessoa mais nova."
       
      Estou resolvendo esse exercício mas não consegui fazer a média dentro do para.
       
      Algoritmo "numero2" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Lucas // Data atual : 21/04/2018 Var // Seção de Declarações das variáveis idade, x, pessoas, homens, mulheres : inteiro velha, nova:inteiro media, num : real nome, sexo, nomevelho,nomenovo : caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... velha <- 0 nova <- 200 pessoas <- 0 homens <- 0 mulheres <- 0 num <- 0 para x de 1 ate 2 faca escreva ("Insira o seu nome: ") leia (nome) se nome=" " entao interrompa fimse escreva ("Insira seu sexo(F/M): ") leia (sexo) escreva ("Insira sua idade: ") leia (idade) limpatela media <- idade pessoas <- pessoas+ 1 se sexo="M" entao homens <- homens +1 fimse se sexo= "F" entao mulheres <- mulheres+1 fimse se idade > velha entao velha <- idade nomevelho <- nome fimse se idade < nova entao nova <- idade nomenovo <- nome fimse fimpara homens <- homens * 50 mulheres <- mulheres * 50 escreval ("A pessoa mais nova é: ",nomenovo,", sua idade é: ",nova) escreval ("A pessoa mais velha é: ",nomevelho,", sua idade é: ",velha) escreval ("O número total de pessoas é: ",pessoas) // escreval ("A media da idade é: ",media) escreval ("O percentual de homens é: ",homens, "%") escreval ("O percentual de mulheres é: ",mulheres,"%") Fimalgoritmo Gente deu tudo certo, só não consegui fazer a media das idades, se alguém puder ajudar agradeço muito.
      Obs: em vez de colocar 100000 eu coloquei só 2 para ficar mais fácil testar.
    • Por Rodrigo Yuzo Matsubara
      Boa tarde pessoal,
       
      Sou novato em VisualG, não sei como fazer estes execícios abaixo, alguém poderia ajudar?
       
      Obrigado.
       
      4) Solicitando 15 valores inteiros entre 10 e 200, apresente a quantidade de números pares informados.
      5) Solicite 10 números inteiros entre -100 e 100, e apresente a quantidade de números ímpares, e a média aritmética dos números pares.
      6) Construa um algoritmo que solicite 10 números e apresente a média aritmética dos mesmos.
      7) Considerando que a nota bimestral de um aluno seja calculada através da média ponderada de 4 avaliações, solicite os dados (notas e respectivos pesos) e apresente a média.
      8) Solicite 10 valores inteiros ao usuário e apresente a média harmônica deste conjunto.
      9) Construa um programa que gere N números randômicos entre 64 e 1239 e os apresente ao usuário. O valor de N deverá ser indagado ao usuário. Dica: Utilize o comando RANDI.
      10) Solicite dois valores inteiros (A,B) onde B deve ser obrigatoriamente maior que o valor de A. Posteriormente, apresente o produto entre as duas variáveis, sem no entanto utilizar o operador de multiplicação (*).
      11) Solicite um número inteiro e positivo, e posteriormente apresente se o mesmo é ou não um número PRIMO.
      12) Solicite um valor inteiro maior ou igual a zero, e posteriormente apresente o seu FATORIAL.
      13) A sequência de Fibonacci é uma sequência de números inteiros, começando por 0 e 1, na qual cada termo subsequente corresponde a soma dos dois anteriores. Os números de Fibonacci, são, portanto, os números que compõem a seguinte sequência:
      0, 1, 1, 2, 3, 4, 8, 13, 21, 34, 55, 89, 144, 233, ...
      Desta forma, desenvolva um algoritmo que apresente os N-primeiros termos da sequência de Fibonacci. O usuário deverá fornecer o valor de N.
      14) Construa um algoritmo que solicite o divisor e o dividendo de uma expressão e posteriormente apresente o quociente inteiro desta operação sem no entanto utilizar o operador de divisão (/). O divisor obrigatoriamente deverá ser MENOR que o dividendo.
      15) Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo.
       
      17) Uma universidade deseja saber algumas informações estatísticas referente a uma sala de aula com 40 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas:
      - Nome do aluno
      - Data de nascimento (DD/MM/AAAA)
      - Sexo (F/M/O)
      - Signo
      - Altura
      - Peso
      Desta forma, deseja-se apresentar no final as seguintes informações:
      a) Percentual de alunos do sexo Feminino
      b) média de idade dos alunos
      c) nome e peso da pessoa mais pesada do sexo masculino
      d) quantidade de pessoas do signo de GEMEOS abaixo de 1,75m de altura
      e) nome e altura da pessoa mais baixa
      f) média aritmética de peso de todos os alunos entrevistados
      g) percentual de pessoas que nasceram em ano BISSEXTO
      h) quantidade de pessoas que nasceram em dias PRIMO
      J) quantidade de alunos por signo
    • Por Rafael Trigueiro
      Problema:
      Numa fábrica de peças, o salário base de um operário da linha de fabricação é R$ 240,00.
      Além do salário base, o operário tem um adicional de produtividade baseado na quantidade de peças que ele fabrica por mês que é pago segundo os requsitos a seguir:
      Se o número de peças é inferior, ou igual a 500: receberá apenas o salário base. Se o número de peças é superior a 500 e inferior, ou igual a 750: Será adicionado R$ 0,50 por peça fabricada acima das 500. Ex. se fabricou 501 receberá R$ 240,50. Se o número de peças for superior a 750: Receberá R$ 350,00 (fixo) mais R$ 0,75 por peça fabricada acima das 750. Ex. se fabricou 751 receberá R$ 350,75 Desenvolva um algoritmo que permita entrar com o número de peças fabricadas por um operário e imprima seu salário.
    • Por Rodrigo Yuzo Matsubara
      Boa noite Galera,
      Sou novo no grupo, tenho duvidas referente ao exercício abaixo:
       
      Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
    • Por Rodrigo Yuzo Matsubara
      Boa noite Galera,
      Sou novo no grupo, tenho duvidas referente ao exercício abaixo:
       
       Faça um Algoritmo que receba dois números e ao final mostre a soma, subtração, multiplicação e a divisão dos números lidos, entre o primeiro e o segundo.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.