Ir para conteúdo
Luis Felipe Reis

Alguém Pode Me dizer no que estou errando?

Recommended Posts

Então pessoal, sou novo na área de algorítimos e estou usando a ferramenta VisualG. Estou desenvolvendo uma agenda telefônica, porém está dando um na estrutura de condição (se, senao).

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 19/10/2018
// Seção de Declarações 
var
opcao,codigo, numero_logradouro,cep,data:Real
nome, logradouro, bairro, cidade, estado,contato: Caracter
inicio
// Seção de Comandos 
Escreval ("------------------------------")
Escreval ("Agenda Telefônica")
Escreval ("------------------------------")
Escreval ("Digite a opção que desejar:")
Escreval ("1-Para Incluir Novo Contato")
Escreval ("2-Para Pesquisar um contato")
Escreval ("3-Para Excluir Um Contato")
Escreval ("Esc- Encerrar o Prorama")
         Leia(opcao)
                    se opcao=1 entao
Escreval ("-----Incluir um novo contato-------")
Escreval ("Digite um código localizador:")
         Leia(codigo)
Escreval ("Digite o nome do contato:")
         Leia(nome)
Escreval ("Escreva o Logradouro:")
         Leia(logradouro)
Escreval ("Digite o número do Logradouro")
         Leia(numero_logradouro)
Escreval ("Digite o Bairro:")
         Leia(bairro)
Escreval ("Digite a Cidade:")
         Leia(cidade)
Escreval ("Digite O Estado:")
         Leia(Estado)
Escreval ("Digite O Cep")
         Leia(cep)
Escreval ("Digite a Data do Cadastro")
         Leia (data)
Escreval ("Cadastro Efetuado com Sucesso!")
         senao
              se opcao=2 entao
              Escreval("-------PESQUISA DE CONTATO---------")
Escreval("Digite o nome do contato ou código a ser Pesquisado:")
        Leia(contato)
Escreval("Digite 1 para editar Contato")
         Leia (opcao)
Escreval("Digite o que deseja Editar:")
Escreval("1-Código")
Escreval ("2-Nome")
Escreval("3-Logradouro")
Escreval("4-Numero do Logradouro")
Escreval("5-Bairro")
Escreval("6-Cidade")
Escreval("7-Estado")
Escreval("8-Cep")
Escreval("9-Editar Tudo")
Leia (opcao)
                se opcao=1 entao
Escreval("Digite o novo código")
                 Leia(codigo)
Escreval("Código Alterado para", codigo)
                 senao
                   se opcao=2 entao
Escreval("Digite o novo nome:")
                 leia(nome)
Escreval("Nome alterado para", nome)
               senao
                    se opcao=3 entao
Escreval("Digite o novo Logradouro:")
                 Leia (logradouro)
Escreval("Logradouro alterado para",logradouro)
                     senao
                          se opcao=4 entao
Escreval("Digite o novo Número do logradouro")
                 Leia (numero_logradouro)
Escreval("Número do Logradouro alterado para", numero_logradouro)
                     senao
                          se opcao=5 entao
Escreval("Digite o Novo Bairro")
                 Leia(bairro)
Escreval("Bairro alterado para", bairro)
                 senao
                      se opcao=6 entao
Escreval("Digite a nova Cidade")
                 Leia (cidade)
Escreval ("Cidade alterada para", cidade)
                  senao
                       se opcao=7 entao
Escreval("Digite o novo Estado")
                 Leia (estado)
Escreval("Estado alterado Para", estado)
                 senao
                      se opcao=8 entao
Escreval("Digite o novo CEP")
                 Leia(cep)
Escreval ("Cep Alterado Para", cep)
                        senao
                             se opcao=9 entao
Escreval("Digite o Novo Codigo:")
                 Leia(codigo)
Escreval("Digite o Novo Nome: ")
                 Leia (nome)
Escreval ("Digite o Novo Logradouro")
         Leia (logradouro)
Escreval("Digite o Novo Número De Logradouro:")
                 Leia(numero_logradouro)
Escreval("Digite o novo Bairro")
                 Leia(bairro)
Escreval("Digite a nova cidade")
                 Leia (cidade)
Escreval("Digite o novo Estado")
                 Leia (estado)
Escreval("Digite o novo Cep:")
                 Leia (cep)
Escreval("Contato Alterado com Sucesso!")
                  
                  se opcao=3 entao
Escreval("------------------------------------------------------------")
Escreval("EXCLUIR CONTATO")
Escreval("------------------------------------------------------------")
Escreval("Digite o nome do contato a ser excluído:")
                 Leia (contato)
Escreval ("Deseja realmete apagar esse contato? 1-Sim  2-Cancelar")
         se opcao=1 entao
Escreval("Contato excluído com sucesso!")
                     senao
                     se opcao=2 entao
Escreval("Operação cancelada com sucesso!")
                            FimSe
                                 FimSe
                                      FimSe
                                           FimSe
                                                FimSe
                                                     FimSe
                                                          FimSe
                                                               FimSe
                                                                    FimSe
                                                                         FimSe
                                                                              FimSe
                                                                                   FimSe
                                                                                        FimSe


fimalgoritmo

 

 

Então, o meu problema está sendo o seguinte, quando digito a opção 3 ele simplesmente escreve o numero digitado, mas encerra o programa. Alguém pode me ajudar por favor? Segue abaixo ERRO.PNG.21ed2869d062695a3c17749a463e764f.PNG

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.