Jump to content
jtc-carr

Dúvida sobre vetores

Recommended Posts

Não estou a conseguir avançar alguem me ajuda? obrigada joana

/******************************************************************************
Considere o seguinte código que gera todos os números de 0000 a 'a'
Refaça o programa utilizando vetores com o valor máximo 20000
Remova os duplicados e mostre quantos números foram apresentados
O resultado deverá ser 0000 .(...). 1111
                       Foram mostrados .(...)
*******************************************************************************/

#include <stdio.h>

int main()
{
    //Listar numeros de 00000 até a
int i, j, k, w, h, a = 1;

for (i = 0; i <= a; i++)
  for (j = 0; j <= a; j++)
    for (k = 0; k <= a; k++)
      for (w = 0; w <= a; w++)
        for (h = 0; h <= a; h++)
          printf ("%d%d%d%d\t", i, j, k, w, h);
}

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jadson16
      Estou com um erro no site , esse site era de um jogo antigo que estava gravado no dvd ai tentei abrir ele só pra olhar mesmo e relembrar os velhos tempos mais não consigo arrumar, estou muito precisando de ajuda quem poder me ajudar por favor ficarei grato, vou postar a imagens dos seguinte erros:
       

      Esse é o primeiro erro que mostra e quando vou olhar na linha 460 está assim


       
    • By christin cley
      Construir um algoritmo em C++ que preencha um matriz quadrada de tamanho 4 pelo usuário. Após o preenchimento pelo usuário, verifique na diagonal principal qual foi o maior valor digitado e exiba na tela o valor. Por fim,  exiba na tela toda matriz em forma de matriz na tela.
    • By Guss
      var carro = {
      cor = "azul",
      modelo = "fusca",
      marca = "Volwagen,
      kms = 10000,
      combustivel = "gasolina"
      }
       
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.