Jump to content

Recommended Posts

Preciso fazer uma calculadora e ela deve fazer produto e divisão mas no código nao poderei usar operadores de produto (*) e nem de divisao (/)

Algoritmo "semnome"
//
//
// Descrição   : Aqui você descreve o que o programa faz! (função)
// Autor(a)    : Nome do(a) aluno(a)
// Data atual  : 22/04/2019
Var
   // Seção de Declarações das variáveis
   x,y,r:inteiro
   final:real

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   repita
      final<-0
      escreval("Digite 1 para divisão")
      escreval("Digite 2 para subtração")
      escreval("Digite 3 para soma")
      escreval("Digite 4 para produto")
      escreval("Digite 5 para finalizar")
      escreval("Escolha uma operação:")
      leia(r)
      se r=5 entao
         interrompa
      fimse
      escreva("digite aqui um valor:")
      leia(x)
      escreva ("digite aqui um valor:")
      leia(y)
      limpatela

      se (r=1) entao
         final<-
         escreval("o resultado é:",final)
         fimse

         se (r=2) entao
            final<-x-y
            escreval("o resultado é:",final)
         fimse

         se (r=3) entao
            final<-x+y
            escreval("o resultado é:",final)
         fimse

         se (r=4) entao
            final<-
            escreval("o resultado é:",final)
         fimse
      ate (r=5 )


Fimalgoritmo

 

nada me vem a cabeça de como sair dessa.... to mt perdido

alguem tem alguma sugestao ou dica ????

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.