Jump to content
  • 0

Question

Diversos processos matemáticos se utilizam de repetição para a obtenção dos resultados. Observe o código abaixo.

Algoritmo "fatorial"
Var
   c, i: inteiro

Inicio
   escreval("Digite um número:")
   leia(c)
   i <- 1
   enquanto (c > 1) faca
     i <- i * c
   fimenquanto
   escreval(i)
fimalgoritmo


Considerando o código acima, assinale a alternativa correta.
Alternativas
Alternativa 1:

A execução do programa acima irá ocasionar um looping infinito.

 
Alternativa 2:

O código acima para cálculo do fatorial deveria ser feito com a estrutura "para" para funcionar.

 
Alternativa 3:

Apesar do nome "fatorial", o código acima representa a soma dos números de 1 até o número digitado.

 
Alternativa 4:

A linha de saída após a estrutura enquanto deveria exibir o conteúdo da variável c ao invés da variável i.

 
Alternativa 5:

Se o usuário digitar o número 5, o programa irá calcular o fatorial de 5 (5!) e retornar na tela o número 120.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By antonio david
      oi, boa tarde, preciso muito de ajuda, estou iniciando o curso de T.I e gostaria de ajuda com duas perguntas se alguém puder me ajudar agradeço muito.
      1: Escreva uma função que leia
      um vetor com 10 posições de
      números inteiros e verifique se um
      determinado valor, digitado pelo
      usuário, está no vetor. em visualg.
       
      2: Escreva um procedimento que leia um
      vetor de 80 elementos inteiros.
      Encontre e mostre o menor elemento e
      a sua posição. visualg
      alguém ajuda pfv desde já muito obrigado
    • By fainformatica
      Olá pessoal, estou com um pequeno probleminha..
      Eu quero fazer o seguinte:
      fazer duas conexões com servidores, um local o outro em uma hospedagem.
      quero que o php conecta primeiro com o servidor na web, se ele não estiver online ou o cliente tiver sem internet ele conecta com o servidor local!
       
      o problema é que não faço a minima idéia de como fazer. eu sei fazer duas conexões, o problema é que nao sei como fazer esse "if"...
      quem puder me ajudar, ficaria muito grato!
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.