Jump to content

Question


Notice: Undefined index: user in C:\xampp\htdocs\Seila.php on line 4

Notice: Undefined index: pass in C:\xampp\htdocs\Seila.php on line 5

Notice: Undefined index: hdi in C:\xampp\htdocs\Seila.php on line 6

Notice: Undefined offset: 1 in C:\xampp\htdocs\Seila.php on line 14

Notice: Undefined offset: 2 in C:\xampp\htdocs\Seila.php on line 15

Notice: Undefined offset: 3 in C:\xampp\htdocs\Seila.php on line 16

Notice: Undefined offset: 4 in C:\xampp\htdocs\Seila.php on line 17
Nao Cadastrado


Codigo abaixo



 

$infoHDI  = htmlspecialchars($_GET["hdi"]);
$users = '';
$libera = false;
while(!feof($fh)) {

    $user = explode(',',fgets($fh));

    $username = trim($user[0]);
    $password = trim($user[1]);
    $data     = trim($user[2]);
    $HDI      = trim($user[3]);
    $status   = trim($user[4]);
    if (!empty($username) AND !empty($password)) {
        if ($username == $infouser AND $password == $infopass    ) {
           
           if (empty($data) AND empty($HDI) AND empty($status)){
            $libera = true;
            $data   = date('d-m-Y');
            $data   = date('d-m-Y', strtotime("+1 month", strtotime($data))); 
            $HDI    = $infoHDI;
            $status = "OK";
            $data_inicial =  date('Y-m-d');
            $data_final = $data;
            $time_inicial = strtotime($data_inicial);
            $time_final = strtotime($data_final);
            $diferenca = $time_final - $time_inicial; 
            $dias = (int)floor( $diferenca / (60 * 60 * 24)); 
            echo $status . "|" . $HDI . "|" . $dias; 
           }else{
            $libera = true;
            $data_inicial =  date('Y-m-d');
            $data_final = $data;
            $time_inicial = strtotime($data_inicial);
            $time_final = strtotime($data_final);
            $diferenca = $time_final - $time_inicial; 
            $dias = (int)floor( $diferenca / (60 * 60 * 24)); 
            if ($dias < 0) {
              //Acabou
              $status = "Acabou";
              echo $status . "|" . $HDI . "|" . $dias;     
            }else{
            echo $status . "|" . $HDI . "|" . $dias;   
             
            }
            
        }
        }

        $users .= $username . ',' . $password .','. $data . ',' . $HDI . ',' . $status ;
        $users .= "\r\n";
     }
}

file_put_contents($file, $users);

fclose($fh); 

if ( $libera == false ){
echo "Nao Cadastrado";

}
?>

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MateusOFCZ
      Olá, estou desenvolvendo um projeto de registro de clientes em java no netbeans e usando o MySQL Workbench e Xampp, gostaria de saber se é possível fazer com que o programa fique verificando se está conectado com o banco de dados, e caso não esteja ele mostra uma mensagem pedindo para o usuário se conectar em uma rede, caso ele se conecte o programa irá esconder essa mensagem e funcionará normalmente.

      Eu consegui fazer com que ele mostre se está conectado ou não, porém se eu desligar o servidor ele não atualiza mostrando que está offline, ele continua como online...
    • By Roberto Pereira Lima Ribei
      Estou tentando instalar o xampp pela enésima vez e não inicia de forma alguma o Apache ou o MySQL.
      Apresenta erro de porta 80 e 443. Mesmo tendo alterado no httpd.conf e httpd-ssl.conf as portas para 8080, 82, 85 / 446, 447, 448 o mesmo erro apresentado.
       
      [Apache]     Problem detected!
      [Apache]     Port 80 in use by "Unable to open process" with PID 4!
      [Apache]     Apache WILL NOT start without the configured ports free!
      [Apache]     You need to uninstall/disable/reconfigure the blocking application
      [Apache]     or reconfigure Apache and the Control Panel to listen on a different port
      -------------------------
      [mysql]     MySQL Service detected with wrong path
      [mysql]     Change XAMPP MySQL and Control Panel settings or
      [mysql]     Uninstall/disable the other service manually first
      [mysql]     Found Path: C:\MySQL\bin\mysqld.exe --defaults-file=C:\MySQL\my.ini MySQL
      [mysql]     Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
       
      ------------------------
       
      Alguém sabe como resolver por favor?
    • By Acrianinho
      Turma eu fiz o download de um sistema opensource para testes, conseguido neste link https://github.com/hiltonbruce/Igreja.
      Instalei o Xamp 7.3.2 e Colei a pasta baixada dentro da pasta htdocs, do campo. Ao iniciar os serviços do xampp não tive problemas. Acessei PhpMyadmin e criei o banco de dados pedido na descrição do sistema. 
      Quando tentei acessar o localhost/projeto abriu uma série de erros de php no navegar. Resolvi todos, um a um, mas quando acabaram os erros não aparece nada no navegador.
      Quando eu abro localhost vejo a pagina do xampp funcionando, mas nada é exibido no localhost/projeto.
      Pensei que fosse erro de porta e troquei a porta para 8080 e continua exibindo somente uma página em branco. Alguém tem uma ideia de onde eu estou errando?
    • By caioandreis
      Olá, pessoal. Tudo bem?
      Gostaria de pedir um direcionamento com a seguinte situação:
       
      Tenho um amigo que tem um site feito em php, com painel gerenciador de conteúdo. Como estou estudando mais a fundo php agora, gostaria de pegar um site que funciona e estudar em cima dele: (alterar tanto layout quanto incluir/retirar novas funcionalidades).
       
      Meu amigo liberou o acesso ao ftp e banco de dados dele, para eu fazer uma cópia e colocar em um localhost (xampp) para estudar em cima dele. Assim, não corro risco de danificar o site dele que está no ar.
       
      Já estou com a pasta do site dentro do htdocs, e o banco de dados importado no phpmyadmin, porém ao tentar acessar o site, o browser acusa erro no servidor. 500
       
      Busquei tutoriais sobre isso, mas encontrei apenas passo-a-passo para sites em wordpress. Com isso, vem a pergunta:
       
      Alguém tem algum tutorial ou poderia me dizer como faço para "plugar" o site com o banco de dados no localhost? 
       
      Peço desculpas se a pergunta é muito leiga mas, como não encontrei nada específico sobre o assunto, achei que valia a tentativa.
       
      Desde já, agradeço pela atenção.
       
      Caio
       
       
       
       
    • By gilbertjuniors
      Pessoal, boa noite.
       
      Instalei o Xampp na minha máquina e estou tentando configurar o Mercury para enviar emails para minha conta no GMail
       
      Segui os seguintes vídeos tutoriais
      https://www.youtube.com/watch?v=iwjNIUuM_iI
      https://www.youtube.com/watch?v=rcWS1uuf304
      https://www.youtube.com/watch?v=2-WYsG_yIX8
       
      As explicações sobre as configurações são similares nestes 3 vídeos, porém, não está funcionando.
      O envio usando o Send Mensage Message do próprio Mercury também não deu certo
       
      Desativei o anti-vírus e o firewall mas também não resolveu.
       
      Alguém pode me dar uma luz? 
      Preciso criar um ambiente para testar o envio de email através de formulário de site que estou criando.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.