Jump to content
  • 0
ludlima

Dúvida algoritmo ordenação.

Question

Boa noite,estou tentando fazer um algoritmo que leia 50 números e mostre em ordem crescente e decrescente ao usuário,preciso utilizar vetor. Até agora só conseguir fazer a parte crescente. Alguém tem alguma dica de como fazer a parte decrescente?

 

Var
CONTADORA, CONTADORB: inteiro
NUM, AUX: inteiro
VET: vetor[0..49] de inteiro

Inicio
   para CONTADORA de 0 ate 49 faca
   escreval ("Digite um número")
   leia (NUM)
   VET[CONTADORA] <- NUM
fimpara

para CONTADORA de 0 ate 48 faca
   para CONTADORB de CONTADORA + 1 ate 49 faca
      se VET[CONTADORA] > VET[CONTADORB] entao
         AUX <-VET[CONTADORB]
         VET[CONTADORB] <- VET[CONTADORA]
         VET[CONTADORA] <- AUX
      fimse
   fimpara
fimpara

escreval("A ordem crescente dos números é: ")
para CONTADORA de 0 ate 49 faca
   escreva(VET[CONTADORA])
fimpara

Fimalgoritmo

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Supondo seu algoritmo certo

 

VET[CONTADORA] < VET [CON TADORB]

 

Só trocar o sinal ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By luizrufino
      Boa tarde pessoal, estou com dificuldade para 
      desenvolver as linhas de códigos de um problema.
       
      Escreva um algoritmo em potrugol que leia o NOME do responsável e o número de filhos matriculados em uma escolinha de futebol. com mensalidade de $120,00, imprimir o valor que o responsável vai pagar, baseando-se na seguinte tabele de descontos
       
      filhos matriculados        Desconto
       1                                             10%
       2 a 3                                       15%
      acima de  3                             20
       
      Se alguém puder me ajudar, pode ser somente a estrutura básica.
    • By andre2654
      Boa tarde, eu preciso de ajuda de vocês, estou com um problema que é o seguinte, eu preciso que quando a pessoa clicar na lixeira, exclua essa linha do banco de dados, mas como posso fazer? perdoem a minha inexperiência, mas já busquei bastante a respeito e nada.
    • By xPeedroo
      Tenho uma tabela assim 
      Usuario(id,login,senha,email,adm)
       
      E fiz um if em php assim 
      $adm = $_GET['adm'];
      If ($adm == 1){ 
      <input type="submit"> botão </input>

       
       
      No caso eu queria pegar um valor direto da tabela, qual função ou comando eu uso?
       
       
      Gostaria de saber qual é o erro que está ocorrendo, e como eu poderia resolver. Postem o código pf. Obrigado 
    • By Ewfc2005
      Eu gostaria de saber como faço para criar uma area de serviço igual ao dessa página https://ciesalon.com/services
      deixando ela responsiva
       
    • By pedrof
      algoritmo "Bhaskara" var a, b, c, delta, raiz_delta, x1, x, x_delta, x2: Real inicio Escreva("Informe um numero inteiro diferente de 0: ") Leia(a) Escreva("Informe outro numero inteiro diferente de 0: ") Leia(b) Escreva("Novamente, informe outro numero inteiro diferente de 0: ") Leia(c) delta <- (b^2-4*a*c) Se (delta<0) entao delta <- Abs(delta) raiz_delta <- (RaizQ(delta)) x <- (b-b*2)/(2*a) x_delta <- raiz_delta/(2*a) x1 <- (x, "+", x_delta, "i") x2 <- (x, "-", x_delta, "i") Escreval("Utilizando ", a, " como 'a', ", b, " como 'b', ", c, " como 'c' em Delta e aplicando a ") Escreval("Formula de Bhaskara, chegamos ao resultado:) Escreva("x1 = ", x1, " e x2 ", x2) FimSe fimalgoritmo

      Parece ser algo bem idiota, mas não estou conseguindo resolver... Ajuda?
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.