Jump to content
Henrique83vrdrhu47h

Problema com mod_deflate - compactando o arquivo executável

Recommended Posts

Ao tentar baixar o arquivo com a extensão .EXE no site, os arquivos estão vindo como .GZ

Ambiente
Centos 7 64
Apache 2.4.6

Mudando o arquivo em /etc/httpd/conf/httpd.conf Eu já tentei usar cada um destes métodos abaixo, no entanto, sem sucesso (eu reiniciei o apache e deletei o cache do navegador em cada tentativa):

1: SetEnvIfNoCase Request_URI .exe $ no-gzip não varia

2: SetEnv não-gzip 1

3: SetEnv mod_deflate off

4: SetEnv no-gzip off

5: No arquivo /etc/httpd/conf.modules.d/00-base.conf eu comentei: LoadModule deflate_module modules / mod_deflate.so

6: Eu tentei apagar o arquivo, mas não funcionou. /usr/lib64/httpd/modules/mod_deflate.so

Toda ajuda é bem vinda.
Eu pesquisei muito, confiei em vários testes com soluções semelhantes, mas sem sucesso.
Eu não sei mais o que tentar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By unset
      Olá, eu formatei minha máquina e agora não consigo fazer rodar meu sistema.
       
      Instalei o Wampserver e agora o Xamp e eles não leem minhas url amigáveis, existe alguma configuração extra a se fazer?
       
      O modulo do arquivo httpd.conf esta ativado 
       
      LoadModule rewrite_module modules/mod_rewrite.so  
      meu htaccess
      <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{SCRIPT_FILENAME} !-f RewriteCond %{SCRIPT_FILENAME} !-d RewriteRule ^(.*)$ index.php?url=$1 </IfModule> Os sites carrega normal mais ao clicar nos links por exemplo http://localhost/site/eventos da erro 404
       
      Error 404 localhost Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.4.2  
       
       
    • By JoãoRicardo.Lima
      Olá pessoal.
      Pessoal como eu faço o roteamento dos meus arquivos no meu projeto, pois sempre que inicio o meu servidor embutido do php em um diretório especifico, ele obviamente não "enxerga" as outras pastas, por exemplo. Eu tenho minha pasta com as views, mas qualquer link que eu coloco em uma view para ser redirecionado para ou view, o servidor não consegue achar o caminho, pois ele não conhece as outras pasta. Como eu faria este roteamento?.
    • By Nightmare SEP
      Bom dia,
      Eu tenho configurado em um servidor no meu trabalho, um sistema da intranet (PHP e MySQL), onde já está tudo configurado.
      Esses tempos tivemos um problema no servidor, eu precisei reinstalar o XAMPP e para ficar tudo configurado eu copiei toda a pasta do XAMPP que eu tinha backup e colei por cima. Tudo funcionou corretamente mas agora eu preciso migrar para um novo servidor, e gostaria de fazer algumas alterações.
       
      1 - Como eu configuro um nome (host) para acessar a intranet. Por exemplo, estou acessando de um computador dentro da minha rede, e quero ir no navegador e digitar: http://intranet. Sem ter a necessidade de digitar o IP do servidor.
      2 - Qual arquivo devo editar para criar/alterar o usuário e senha de conexão com o banco de dados?
      3 - Quando eu fiz essa cópia das pastas, o serviço do apache no windows veio como padrão a mesma unidade de disco que estava antes (no caso a unidade E:), mas eu gostaria de mudar também esse caminho. Tem um arquivo que eu consiga editar esse caminho do serviço?
       
      Valeu!
    • By wekend
      Sempre que tento iniciar o httpd no CentOS 7 no meu Google VPS, a seguinte mensagem sempre aparece. pode me ajudar?
      ● httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
      Active: failed (Result: exit-code) since Sun 2019-09-08 13:12:27 UTC; 1min 21s ago
      Docs: man:httpd(8)
      man:apachectl(8)
      Process: 2019 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
      Process: 2018 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
      Main PID: 2018 (code=exited, status=1/FAILURE)
      Sep 08 13:12:27 centos-web systemd[1]: Starting The Apache HTTP Server…
      Sep 08 13:12:27 centos-web httpd[2018]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
      Sep 08 13:12:27 centos-web systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
      Sep 08 13:12:27 centos-web kill[2019]: kill: cannot find process ""
      Sep 08 13:12:27 centos-web systemd[1]: httpd.service: control process exited, code=exited status=1
      Sep 08 13:12:27 centos-web systemd[1]: Failed to start The Apache HTTP Server.
      Sep 08 13:12:27 centos-web systemd[1]: Unit httpd.service entered failed state.
      Sep 08 13:12:27 centos-web systemd[1]: httpd.service failed.
    • By Carcleo
      Fiz o download do Apache Haus 64 bits nesse link: https://www.apachehaus.com/cgi-bin/download.plx#APACHE24VC15
       
      No httpd.conf alterei o diretório do htdocs para o disco C:
      Habilitei a diretiva LoadModule vhost_alias_module modules/mod_vhost_alias.so para usar Virtuais Hosts
      Habilitei a diretiva Include conf/extra/httpd-vhosts.conf também para usar Virtuais Hosts
      No extras/httpd-ahssl.conf, configurei os VirtuaisHosts no final do arquivo da seguinte forma:
      <VirtualHost _default_:443>   SSLEngine on   ServerName localhost:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/server.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/server.key"   DocumentRoot "D:/Trabalhos/host/htdocs/fielcard.net.br" # DocumentRoot "${SRVROOT}/htdocs" # DocumentRoot access handled globally in httpd.conf     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost> <VirtualHost *:443>   SSLEngine on   ServerName serverone.tld:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/serverone.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/serverone.key"   DocumentRoot "D:/Trabalhos/host/htdocs/fielcard.net.br"     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost> <VirtualHost *:443>   SSLEngine on   ServerName servertwo.tld:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/servertwo.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/fielcard.net.br/ssl/servertwo.key"   DocumentRoot "D:/Trabalhos/host/htdocs/fielcard.net.br"     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost>  <VirtualHost _default_:443>   SSLEngine on   ServerName localhost:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/server.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/server.key"   DocumentRoot "D:/Trabalhos/host/htdocs/mvc_crud_pdo"     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost> <VirtualHost *:443>   SSLEngine on   ServerName serverone.tld:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/serverone.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/serverone.key"   DocumentRoot "D:/Trabalhos/host/htdocs/mvc_crud_pdo"     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost> <VirtualHost *:444>   SSLEngine on   ServerName servertwo.tld:443   SSLCertificateFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/servertwo.crt"   SSLCertificateKeyFile "D:/Trabalhos/host/htdocs/mvc_crud_pdo/ssl/servertwo.key"   DocumentRoot "D:/Trabalhos/host/htdocs/mvc_crud_pdo"     CustomLog "${SRVROOT}/logs/ssl_request.log" \           "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"     <Directory "${SRVROOT}/htdocs">         Options Indexes Includes FollowSymLinks         AllowOverride AuthConfig Limit FileInfo     Require all granted     </Directory> </virtualhost>   
      Os Problemas:
      A ) http://localhost/site parou de funcionar, ou seja, quando o link começa com localhost
      B ) Apenas o primeiro site cadastrado (fielcard.net.br) no http-ahssl.conf está abrindo, o outro (mvc_crud_pdo) está abrindo o fielcard.net.br
       
      Onde estou errando?
       
      O objetivo é configurar Hosts Virtuais
       
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.