Jump to content
  • 0
tato6919

Encerrar entrada de dados e mostrar menor valor

Question

   Boa tarde pessoal.

   Estou iniciando meus estudos em logaritmo no Visualg e preciso de uma ajuda. Já testei várias hipóteses encontradas aqui e em outros forums mas nada funcionou ainda.

   Tenho um alg criado para este exercicio: Foi feita uma pesquisa entre os habitantes de uma região. Foram coletados os dados de idade, sexo (M/F) e salário. Faça um algoritmo que informe:
a) a média de salário do grupo;
b) a maior e a menor idade do grupo;
c) a quantidade de mulheres com salário até R$100,00.
Encerre a entrada de dados quando for digitada uma idade negativa

 

   Abaixo esta o código que criei... para finalizar digito 0 em idade (que é a primeira pergunta) mas o programa não interrompe e continua me pedindo outros dados e, por não conseguir encerrar a entrada de dados completamente, ele adiciona mais um laço na média. E em minha tentativa de mostrar o menor valor o mesmo só aparece 0. O estranho é o maior valor aparece, mas mesmo eu cancelando as linhas com // e deixando somente o menor valor... ele não acha. Como podem perceber, escrevi e excluí algumas tentativas com //.

   Deve ser coisa simples para vocês, hehe, mas já quebrei a cabeça aqui sozinho e não acho solução.

   Agradeceria muito se pudessem me auxiliar, pois com essa resposta conseguirei refazer outros exercícios.

   Desde já agradeço a todos. Grd abraço.

   

var
   idade, salario, maior, menor, medsal, saltt, mulher, cont, f100: Real
   sexo, resp: caractere
inicio
      idade <- 1
             Enquanto (idade<>0) faca
             //se (idade = 0) entao
             //interrompa
             //fimse
      Escreval("Escreva: Idade, Sexo [m/f], salário")
      leia(idade)
      leia(sexo)
      leia(salario)
      
      //se (idade <> 0) entao
      cont <- cont+1
      //fimse
      
      //se (idade <> 0) entao
      saltt <- saltt+salario
      //fimse
            se (idade>maior) entao
            maior <- idade
            senao
                 se (idade<menor) entao
                 menor <- idade
                 fimse
            fimse
                 Se (sexo="f") e (salario<=100) entao
                 f100 <- f100 + 1
                 fimse

      Fimenquanto
      escreval("Media salaria do grupo: ", saltt/cont)
      escreval("Maior idade: ", maior,". Menor idade: ", menor)
      escreval("Mulheres com salario até 100: ", f100)
      
fimalgoritmo

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.