Jump to content

Recommended Posts

Preciso desenvolver um algoritmo no Visualg, da função y=3x+8, onde, a partir da informação de um valor para a variável independente x, o sistema automaticamente informe o valor da variável dependente y.

 

porém quando vou executar da erro no código:

var
x, y: real

inicio
escreval("Digite o valor do coeficiente x")
leia(x)
Escreval ("O valor da conta é igual a:" + y)
Leia (y)
y=(3.x)+8

fimdoalgoritmo

 

Share this post


Link to post
Share on other sites

Informe o erro.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Motta
      O algoritmo que procura padrões ocultos na maior base de dados de sonhos do mundo
    • By slaoxx
      Não conseguir obter êxito, minha sintaxe foi a seguinte:
       
      CREATE FUNCTION precomed ()
      RETURNS decimal
      SELECT AVG(preco_cd);
       
      SELECT precomed ();
       
    • By Andréia Bürck
      Gostaria de saber se há como fazer o seguinte, em JAVA ou qualquer outra linguagem: personalizar um áudio. Ou seja, tenho um áudio, e em lugares chaves desse áudio, depois dele pronto, um programa inserir nesses pontos-chave, por exemplo, nomes. Eu falo o nome, e o programa insere nos pontos pré-determinados.
    • By flipmartinz13
      Alguém pode me ajudar nessa questão de C++? não estou conseguindo construir o algorítmo corretamente.

      5.92)    Faça um algoritmo que leia a matrícula, nome, sexo e três notas dos alunos de uma escola e obtenha os seguintes resultados:
      a) A matrícula da aluna que obteve a maior média.
      b) A matrícula do aluno que obteve a menor média.
      c) O percentual de mulheres na turma.
      d) Quantos alunos foram aprovados, independente do sexo.
      e) O percentual de alunas aprovadas.
      Obs.: o flag é uma matrícula igual a 0 (zero).
    • By TEC2587
      Quando eu excuto o algoritmo, a primeira condição comporta-se bem, mas apartir da segunda aparece o erro:
       
      Esperava-se encontrar ENTAO na linha  "se((med=<8.9) e (med>=8))entao"
      Esperava-se encontrar ENTAO na linha  "escreval("Seu rendimento foi muito bom"
       
      Algoritmo "semnome"
       
       
      Var
         med: real
      Inicio
         escreval("-------------------")
         escreval(" RENDIMENTO ESCOLAR")
         escreval("--------------------")
         escreval("Qual é a sua média: ")
         leia(med)
         se ((med=10) ou (med>=9))entao
            escreval ("Seu rendimento foi excelente")
         senao
            se ((med=<8.9) e (med>=8))entao
               escreval("Seu rendimento foi muito bom")
            senao
               se ((med= 7.9) e (med>=7))entao
                  escreval("Seu rendimento foi bom")
               senao
                  se ((med=6.9) e (med>=6))entao
                     escreval("Seu rendimento foi regular")
                  senao
                     se ((med=5.9) e (med>=5))entao
                        escreval("Seu rendimento foi insuficiente")
                     senao
                        escreval("Seu rendimento foi ruim")
                     fimse
                  fimse
               fimse
            fimse
         fimse
      Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.