Jump to content

Search the Community

Showing results for tags 'agendar'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 2 results

  1. Luis Fernando R. Valle

    agendar horario

    Boa tarde. Estou tentando fazer uma consulta no mysql. Já tentei de todas as formas e não estou conseguindo obter a resposta correta. Os campos são: dia, horario_inicio, horario_fim A consulta que estou fazendo é: SELECT * FROM (`auditorio`) WHERE `horario_inicio` >= '07:00' AND `horario_fim` > '07:00' AND `horario_fim` <= '11:00' AND `dia` = '2018-07-05' Sendo as: 07:00 horario_inicio 11:00 horario_fim Desde já agradeço pelo auxilio, pois ja tentei de varias formas, tanto com ou sem OR.
  2. Olá mundo, tudo certo? Espero que alguém possa me ajudar, vamos lá. Estou com um problema para resolver a respeito de um trabalho na faculdade. Preciso desenvolver um código em PORTUGOL que execute um MENU para agendar consultas com diversos médicos, mostrando data, hora, especialização do médico, enfim. Precisa ser completo. Programa solicita nome do paciente Programa solicita especialidade médica desejada Programa solicita que o paciente escolha o médico Programa mostra datas e horas disponíveis para agendar a consulta com aquele médico (OBS.: O horário não pode bater com o horário de outra consulta) (OBS.: Cada consulta tem um intervalo de 45 minutos ou 1 hora se facilitar) (OBS.: A clínica funciona de 8h as 18h de segunda a sexta) Paciente seleciona a data e hora Programa mostra confirmação contendo nome do paciente, nome e especialização do médico, data e hora da consulta. Programa retorna para o menu inicial. Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias? E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito. Se alguém puder me dar uma luz, será muito bem-vindo. Segue parte do código que fiz. Está muito incompleto ainda, porém não sei mais como prosseguir a partir do "caso 1" no código abaixo.. algoritmo "Menu Clínico" // Função : Efetuar o agendamento de consultas com o médico específico // Autor : GRUPO 6! // Data : 11/14/2016 // Seção de Declarações var opcao1, cardio, opcao_cardio, neuro, opcao_neuro, nutri, opcao_nutri, geri, opcao_geri: inteiro paciente: caractere inicio // Seção de Comandos escreval ("==========================================================") escreval ("|| OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR ||") escreval ("==========================================================") escreval ("Por favor, informe seu nome: ") leia (paciente) procedimento menu_inicial inicio escreval ("==========================================================") escreval ("|| ESPECIALIZAÇÕES MÉDICAS! ||") escreval ("==========================================================") escreval ("||1. Cardiologista ||") escreval ("||2. Neurologista ||") escreval ("||3. Nutricionista ||") escreval ("||4. Geriatra ||") escreval ("||5. SAIR ||") escreval ("==========================================================") fimprocedimento procedimento menu_cardio inicio escreval ("==========================================================") escreval ("|| CARDIOLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dra. Cristiane Guedes Pita ||") escreval ("||2. Dr. George Paulo Cobe Fonseca ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_neuro inicio escreval ("==========================================================") escreval ("|| NEUROLOGISTAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Trigueiro de Souza ||") escreval ("||2. Dr. Antônio Tomás Turbano ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_nutri inicio escreval ("==========================================================") escreval ("|| NUTRICIONISTAS ||") escreval ("||======================================================||") escreval ("||1. Mônica Cristina Salgado Galvão ||") escreval ("||2. Fernanda Tarcélia de Oliveira Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento procedimento menu_geri inicio escreval ("==========================================================") escreval ("|| GERIATRAS ||") escreval ("||======================================================||") escreval ("||1. Dr. Carlos Antonio Batista de Medeiros ||") escreval ("||2. Dr. Anceio Botelho Pinto ||") escreval ("||3. Voltar ||") escreval ("==========================================================") fimprocedimento repita menu_inicial escreval ("Olá ", paciente,", por favor, escolha uma opção:") leia (opcao1) limpatela se opcao1>=6 então escreval ("**********************************************************") escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************") escreval ("**********************************************************") fimse ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5) escolha (opcao1) caso 1 repita menu_cardio escreval ("Digite o número referente ao seu médico de preferência: ") leia (opcao_cardio) limpatela ate opcao_cardio=3 caso 2 menu_neuro caso 3 menu_nutri caso 4 menu_geri caso 5 escreval ("==========================================================") escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||") escreval ("==========================================================") fimescolha fimalgoritmo Gratidao e boas vibrações! <3
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.