Jump to content

Search the Community

Showing results for tags 'encoding.utf8'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 1 result

  1. miqueiasrafael

    Encoding.UTF8 para GetAsync não funciona

    Olá a todos, estou desenvolvendo um novo sistema e estou com o seguinte problema na hora de recuperar os dados de uma API via GetAsync segue abaixo o código para melhor exclarecimento. A variável (content) está recebendo o seguinte Json: { "code": 200, "status": "success", "paging": { "total_count": 1, "total": 1, "offset": 0, "limit": 0, "limit_max": 250 }, "data": [ { "id_cliente": 1137929, "tipo_pessoa": "PJ", "tipo_cadastro": "Cliente", "cnpj_cliente": "11.111.111/1111-11", "passaporte_cliente": "", "razao_cliente": "Cli LTDA", "fantasia_cliente": "Cli teste", "endereco_cliente": "Endereço Teste", "numero_cliente": "", "bairro_cliente": "", "complemento_cliente": "", "cep_cliente": "", "cidade_cliente": "", "cidade_cliente_cod": 0, "uf_cliente": "", "contato_cliente": "", "fone_cliente": "(41) 9893-3274", "fone_contato_cliente": "", "situacao_cliente": "Ativo", "data_nasc_cliente": "0000-00-00", "data_cad_cliente": "2017-10-18 11:37:45", "data_mod_cliente": "2017-10-18 11:54:54", "lixeira": "Nao" } ] } A parte da conversão hoje está assim: var content = await response.Content.ReadAsStringAsync(); ///////// TRATAR O UTF-8 ///////////// var respContent = new StringContent(content, Encoding.UTF8, "application/json"); var httpResponse = await _restClient.GetAsync(respContent.ReadAsStringAsync().Result); var result = JsonConvert.DeserializeObject<List<ClientesModel>>(httpResponse.ToString(), GetConverter()); lvDados.ItemsSource = result; a última linha no caso a que contem result não tem o Json corrigido, daí está minha dúvida, o que já não corrigi corretamente já que passo o UTF-8? Conto com ajuda de vocês, desde já obrigado.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.