Jump to content

Search the Community

Showing results for tags 't_variable'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 2 results

  1. rogirn2

    Syntax Error, Unexpected T_variable

    Olá pessoal, estou com um problema chato que aparentemente é simples, mas não tô conseguindo achar o erro de jeito nenhum... Vi que já haviam aberto um tópico sobre esse mesmo erro, mas era muito antigo (de 2008) e o cara só resolveu postando o código dele aqui, por isso resolvi postar o meu para que mais olhos possam procurar, pq os meus cansaram de tanto procurar e não achar nada. ps.: no tópico em questão este erro tinha sido causado devido a falta de um ";" ou do excesso de aspas no código, mas o meu não tem nada disso (ao menos não aos meus olhos, espero estar errado). <?php if(!isset($_GET['token']) || $_GET['token'] != "meuToken") { echo "Token não confere!"; exit(); } require_once('scripts/banco.php'); require_once('PHPMailer/class.phpmailer.php'); require_once('PHPMailer/class.smtp.php'); if($clientes = $banco->query("SELECT * FROM clientes WHERE token != ''")){ while($cliente = $clientes->fetch_assoc()){ $corpo = ' <html> <head> <title>Titulo</title> <meta http-equiv="content-type" content="text/html; charset=utf-8"> </head> <body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0"> <!-- Save for Web Slices (1.png) --> <center> <table id="Tabela_01" width="650" height="1455" border="0" cellpadding="0" cellspacing="0"> <tr> <td colspan="3"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/be84f1f0-743e-44bc-87b1-1389292c88ec.jpg" width="650" height="702" alt="" style="display:block;"> </td> </tr> <tr> <td colspan="3"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/78060dda-bbd8-424e-bb60-bba99909bf45.jpg" width="650" height="212" alt="" style="display:block;"> </td> </tr> <tr> <td rowspan="2"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/daf32221-1e04-4d9a-8c54-50f431a8bfea.jpg" width="45" height="541" alt="" style="display:block;"> </td> <td> <a href="http://www.superfacilatacado.com.br/finalizar_cadastro.php?token='.$cliente['token'].'"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/10544e6c-c550-4f83-883e-196a9cb031d0.png" width="156" height="26" border="0" alt="" style="display:block;"> </a> </td> <td rowspan="2"> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/8936e151-0c50-4ec7-a285-0f467f96cfd7.jpg" width="449" height="541" alt="" style="display:block;"> </td> </tr> <tr> <td> <img src="https://gallery.mailchimp.com/eaea0012d51d0c982ab77172b/images/9d39104c-1e50-447e-a614-13172eaec86a.jpg" width="156" height="515" alt="" style="display:block;"> </td> </tr> </table> </center> <!-- End Save for Web Slices --> </body> </html>'; $mailer = new PHPMailer(); $mailer->SMTPDebug = 1; $mailer->Port = 587; //Indica a porta de conexão para a saída de e-mails. Utilize obrigatoriamente a porta 587. $mailer->Host = 'smtp.servidorsmtp.com.br'; //Onde em 'servidor_de_saida' deve ser alterado por um dos hosts abaixo: //Para cPanel: 'mail.dominio.com.br'; //Para Plesk 11 / 11.5: 'smtp.dominio.com.br'; //Descomente a linha abaixo caso revenda seja 'Plesk 11.5 Linux' //$mailer->SMTPSecure = 'ssl'; $mailer->SMTPAuth = true; //Define se haverá ou não autenticação no SMTP $mailer->CharSet = "UTF-8"; $mailer->Username = 'meuemail@meuemail.com.br'; //Informe o e-mai o completo $mailer->Password = 'minhasenha'; //Senha da caixa postal $mailer->FromName = 'Igor Brito'; //Nome que será exibido para o destinatário $mailer->From = 'meuemail@meuemail.com.br'; //Obrigatório ser a mesma caixa postal indicada em "username" $mailer->AddAddress($cliente['email']); //Destinatários $mailer->Subject = "Assunto do Email"; $mailer->Body = $corpo; $mailer->IsHTML(true); if($mailer->Send()){ echo "E-mail enviado com sucesso para: ".$cliente['email']."<br>"; }else{ echo "Falha ao enviar e-mail para: ".$cliente['email']."<br>"; } } }else{ echo $banco->error; }
  2. Olá Estou tentando capturar a imagem de um banco de dados mysql, já tentei fazer a leitura de um campo tipo blob não deu certo, então pensei em simplesmente criar um campo no bd e referenciar onde está a imagem mas me deparo com o seguinte erro: Parse error: syntax error, unexpected '$produto' (T_VARIABLE), expecting ',' or ';' in C:\Program Files\NetMake\v9\wwwroot\boletosite\cursos.php on line 148 <table data-minrequestedwidth="934" data-computedwidth="934" style="width: 934px;"> <tbody> <?php $Servidor = '127.0.0.1:3306'; $Usuario = 'root'; $Senha = 'senha'; $Banco = 'bd_boleto'; $Conexao = mysqli_connect($Servidor, $Usuario, $Senha); if (mysqli_connect_errno()) { printf("Connect failed: %s\n", mysqli_connect_error()); exit(); } mysqli_SELECT_DB($Conexao, $Banco); $cmd = "SELECT * FROM curso"; $produtos = mysqli_query($Conexao, $cmd); While($produto = mysqli_fetch_array($produtos)) { $seq1 = $produto['seq']; ?> <tr> <td colspan="3" rowspan="1" <style="text-align: center; width: 926px; height: 21px; margin-top: 0px; margin-left: 0px;" class="imVc"> <?php echo $produto['titulo'];?> </td> </tr> <tr> <td style="text-align: center; height: 21px; width: 304px;" class="imVc"> <?php echo $produto['descricao'];?> </td> <td colspan="2" rowspan="1" style="text-align: justify; width: 615px; height: 21px; margin-top: 0px; margin-left: 0px;" class="imVt"> <?php echo "<img src="$produto['endfoto']">";?> </td> </tr> <?php } ?> </tbody> </table> A linha 148 seria essa: <?php echo "<img src="$produto['endfoto']">";?> Procurei por aqui e tentei de várias maneiras mas não obtive sucesso. Onde estou errando? Abraços
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.