Jump to content

Archived

This topic is now archived and is closed to further replies.

alexandremenezes

JDBC 2.0 e BLOB

Recommended Posts

Ola. Tenho um problema. Estou tentando recuperar uma Imagem de um Banco (SQL SERVER 2000) utilizando o tipo de dados Blob. Ao compilar minha classe, não é apresentado erro nenhum, mas ao executar o programa aparece um erro:("Exception in thread "main" java.lang.UnsupportedOperationException at sun.jdbc.odbc.JdbcOdbcResultSet.getBlob(JdbcOdbcResultSet.java:4390) ") Ao fazer algumas pesquisa percebi que o método que estou tentando utilizar (getBlob) só pode ser utilizada apartir do JBDC 2.0. Então vem minha dúvida. Como posso saber qual é minha versão de JBDC e se a minha versão for abaixo da versão 2.0 como fazer para atualizar meu JBDC ???Att,Alexandre Menezes---------------------------------Analista de SistemasFaculdade Ruy Barbosa

Share this post


Link to post
Share on other sites

Olá!Como você disse, o problema deve ser causado pq seu driver JDBC não implementa a versão 2.0. Desse modo, você deve pegar um driver que implemente esse versão ou posterior para o seu banco de dados.Até

Share this post


Link to post
Share on other sites

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.