Jump to content
JonatasFn

Configurar EasyPHP na rede local

Recommended Posts

Bom dia,

preciso de uma ajuda...

 

tenho o EasyPHP rodando no meu servidor e consigo acessá-lo com o endereço localhost normalmente.

Mas eu gostaria de acessar minhas páginas por outras eataçoes da minha rede local.

 

Já procurei e todos mandam digitar o endereço do servidor no browser da estação, mas não funciona.

 

Andei pesquisando e descobri q é necessário configurar o EasyPHP para acesso via rede local ao servidor.

Mas até agora não encontrei como faço tal configuração.

 

Alguém pode me ajudar ???????

 

Grato

Share this post


Link to post
Share on other sites

Seria possível uma resposta mais concreta ????

 

Já pesquisei no site, e no forum a maioria dos posts é em francês!!!!!

Share this post


Link to post
Share on other sites

Cara o easyphp está instalado em um computador da rede correto? você já tentou colocar o endereço do computador na barra de endereços do seu Browser? visto que quando você digita no computador que tem o easyphp você chama pelo ip local (localhost ou 127.0.0.1) eu acho que você precisará acessar o ip da máquina que tem o easyphp instalado. tenta isso

Share this post


Link to post
Share on other sites

Isso eu já tentei...

Não funciona, pensei até que fosse o compartilhamento das pastas, mas não era.

 

 

 

Li que é necessário configurar o Apache para rodar na rede... e é isso que quero descobrir como fazer???

Share this post


Link to post
Share on other sites

to precisando muito fazer a mesma coisa... mas ate agora não consegui... tipo nas configurações do apache troquei o ip do servidor pelo do meu servidor, 192.168.0.1

ai as outras maquinas acessam, mas só q ai o easyphp não funciona direito, não tenhu acesso ao mysql, nem ao phpmyadmin

Share this post


Link to post
Share on other sites

Já liberou a porta 80 no firewall do windows???

 

]

Seria possível uma resposta mais concreta ????

 

Já pesquisei no site, e no forum a maioria dos posts é em francês!!!!!

Share this post


Link to post
Share on other sites

Boa tarde... se alguem ainda estiver com dúvida sobre isso...ai vai a solução

 

Entre nas configurações do Apache e altere essa linhas:

 

#Listen 12.34.56.78:80

Listen 127.0.0.1:80 (padrao)

Listen 172.....:80

 

Adicione mais uma linha com o IP da rede do Seu micro, ou o ip válido do seu servidor.

 

Aqui funcionou blzinha.

 

falow

Share this post


Link to post
Share on other sites

Leonardo Calheiros é melhor criar um topico para o seu problema pois este é do ano passado e é provavel que os participantes da epoca nao lhe ajudem

 

Crie um topico para o seu caso

Share this post


Link to post
Share on other sites

CARA, SIMPLES!!!!!!!

 

Abra os arquivos de Configuração do PHP e do Apache (php.ini e httpd.conf) com um editor avançado de texto (dreamweaver ou notepad++)

 

Configure um IPV4 fixo (tipo 192.168.0.101 ou 10.0.0.101)

 

Nos arquivos php.ini e httpd.conf faça um localizar e substituir e substitua o seguinte valor pelo seu ip configurado

 

Localizar: 127.0.0.1 (se for windows 7 ou XP, procure por localhost, alguns casos acontecem este problema)

Substituir Por: 192.168.0.101 (presumindo que seja este seu ip escolhido)

OBS: São 2 alterações no php.ini e 21 no httpd.conf

 

Salve e reinicie o EasyPHP

 

Tcharam! agora pode ser acessado de qualquer computador por 192.168.0.101:80 (ou 8080 caso use o Skype).

 

Lembrando que agora o acesso no computador do EasyPHP terá que ser acessar pelo próprio IP não mais pelo 127.0.0.1 ou localhost.

 

Espero ter ajudado e coloque seus resultados aqui! O meu funcionou tão bem que até no iphone e android pude acessar!

Share this post


Link to post
Share on other sites

Felipesouza12,

 

Perfeito!!! Rodou como manteiga... Agora consigo acessar tudo direto no IP configurado...

 

Porém somente o PHPMyAdmin e as telas de configuracao do EasyPHP não abrem...

 

Alguém teria alguma sugestão de configuração para arrumar esse problema??

Share this post


Link to post
Share on other sites

Resolvido!!!

 

Pra quem chegou depois de anos nesse tópico assim como eu hehehe... segue a solução para as IMAGENS e o PHPMyAdmin:

Nas configurações do Apache:

<Directory "${path}/binaries/home/images_easyphp">
Options Indexes MultiViews
AllowOverride None
Order deny,allow
#Allow from 127.0.0.1 //Comente este linha com o uso do #
#Deny from all //Comente este linha com o uso do #
Allow from all //Insira esta nova linha
Require all granted
</Directory>
<Directory "${path}/binaries/home">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
#Allow from 127.0.0.1 //Comente este linha com o uso do #
#Deny from all //Comente este linha com o uso do #
Allow from all //Insira esta nova linha
Require all granted
</Directory>
<Directory "${path}/modules">
Options FollowSymLinks Indexes
AllowOverride All
Order deny,allow
#Allow from 127.0.0.1 //Comente este linha com o uso do #
# Deny from all //Comente este linha com o uso do #
Allow from all //Insira esta nova linha
Require all granted
</Directory>

Share this post


Link to post
Share on other sites

Então, feito tudo isso, quando eu digito o meu endereço no browser de outra máquina da minha rede local, aparece aquela lista de sistemas do easyphp como deveria. 

Mas quando eu clico nos sistemas, alguns abrem e outros não. 

Aconteceu o mesmo com alguém?

 

Obs: Espero que eu ainda possa responder, já fazem 10 anos desde que a pergunta foi feita.

 

Opa, já foi resolvido, obrigada.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.