Ir para conteúdo
Wesley Balestrini

Configurar localhost para ser acessado em outro local

Recommended Posts

Olá pessoal!

 

Tenho xamp instalado no meu pc, e gostaria de disponibilizar meu localhost, para meu amigo entrar nos meus sites. Eu informaria o meu atual ip, e ele poderia entrar. Sei que á configurações nos arquivos do apache, mas não consigo fazer pegar, já vi um monte de tutoriais na net, mas nada deu certo! Quem poder me ajudar ai... vlw!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dentro da pasta xampp acesse:

a pasta apache dentro de apache acesse conf

Dentro da pasta config acesse httpd.conf

fica assim

xampp\apache\conf\httpd.conf

 

 

Nesse arquivo altere procure por ServerName

 

Provavelmente o valor é localhost:80

 

Altere esse cara para ServerName

 

Salve e reinicie o XAMPP

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dentro da pasta xampp acesse:

a pasta apache dentro de apache acesse conf

Dentro da pasta config acesse httpd.conf

fica assim

xampp\apache\conf\httpd.conf

 

 

Nesse arquivo altere procure por ServerName

 

Provavelmente o valor é localhost:80

 

Altere esse cara para ServerName

 

Salve e reinicie o XAMPP

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vamos lá, o que exatamente você está tentando fazer? você está tentando passar acessar a maquina fora da rede local?

 

 

Tenta liberar por outra porta

 

Altera:

 

LISTEN :80

 

Para

 

LISTEN :8080

 

Ai quando for acessar tu vai precisar usar assim

 

http://seuip:8080/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Infelizmente, ainda não deu.

 

Obs.: No arquivo httpd, não tem a "LISTEN :80" em maiusculo, apenas em minusculo "Listen 80", e depois do listen, não há dois pontos, como esta indicado ai em cima na dica do senartes. Não sei se isso faz diferença, mas...

 

Outra coisa, agora, realmente se eu não colocar " :8080 "depois do ip ou do localhost ele não entra, porem, outro computador, fora da minha rede não consegue entrar. mesmo assim.

 

Alguem tem ideia, do porque não consigo fazer essa "mágica"?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Para funcionar corretamente pela porta 80 você deve fazer o redirecionamento no roteador ou modem que tu usa, apontando para a tua maquina, e torcer para que o provedor de internet que você contratou naõ tenha bloqueado a porta 80, o que é muito comum.

 

Troca o 80 para 8080 e ver se funciona o acesso pela porta 8080

Compartilhar este post


Link para o post
Compartilhar em outros sites

Para funcionar corretamente pela porta 80 você deve fazer o redirecionamento no roteador ou modem que tu usa, apontando para a tua maquina, e torcer para que o provedor de internet que você contratou naõ tenha bloqueado a porta 80, o que é muito comum.

 

Troca o 80 para 8080 e ver se funciona o acesso pela porta 8080

tpw, eu já troquei lá o valor 80 por 8080, porem não deu certo. Agora sobre o modem, como faço para configurar ele?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara eu fiz todo procedimento aqui em casa usando XAMP e no trabalho e funcionou, me explica extamente o que você fez e como você está testando, assim podemos ajudar. Se deu algum erro manda um print

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olha, não sei se vai dar certo, mas tente o seguinte:

Abra o config.inc.php, no caso do Wamp fica em C:\\wamp\apps\phpmyadmin\config.inc.php
Então adicione isso aqui antes de acabar o arquivo:

$cfg['ForceSSL'] = TRUE;

Isso vai forçar o uso do procolo http.....

 

Agora tenta abrir o phpmyadmin.conf, acho que fica em C:\\wamp\alias\phpmyadmin.conf e deixe parecido com isso:

 

<Directory "c:/wamp/apps/phpmyadmin3.2.0.1/">
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
Allow from 192.168.5.200
</Directory>
?
<Directory "/usr/share/phpmyadmin">
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
Allow from 192.168.5.200
</Directory>

 

Onde esse IP 192.168. 5.200 é o IP visível e o 127.0.0.1 é o loopback.... Não sei se já tentou, mas tente utilizar o programa NO-IP para deixar o IP "estático".

 

Lembro de ter visto este tutorial em algum lugar, na verdade isso estava salvo aqui no pc então não sei se vai funcionar com você, não testei aqui porque estou utilizando o linux, mas creio que deve ser o mesmo procedimento a única coisa que muda deve ser os locais dos arquivos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá á todos que responderam desculpem por não voltar aqui e dar noticias, tive problemas! Bem, consegui tornar o localhost online, alterando o arquivo httpd. mudei esta linha:

 

Listen 80

 

para

 

Listen 10080

 

Agora no endereço eu coloco:

 

http://MeuIP:10080/

 

A porta 80, estava sendo usada, ou bloqueada. Então tive que achar um livre. Á 10080 deu certo!

 

Mais uma vês eu agradeço e peço desculpas!

 

podem fechar o tópico.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estou com um problema parecido.

Já dei as permissões Allow from all no arquivo de configuração do apache e ainda não resolveu. Não consigo acessar o servidor de outras máquinas da rede. Meu servidor está configurado como ip fixo e a porta do apache está listada para a 8080.

Esta porta está na lista de exceções do firewall.

Minha internet é via rádio. Recebo o link de meu provedor para o kit cliente que passa para um roteador que atribui ip dinamico para todos os equipamentos de minha rede.

O ip do kit cliente está na faixa 192.168.1.1 e meu roteador na faixa 192.168.0.1 -> Uma breve descrição do cenário da rede.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.