Ir para conteúdo
11closed

php PDO não está inserindo dados no BD

Recommended Posts

Olá pessoal Bom Dia!

 

Estou com um problema aqui, não estou conseguindo inserir dados no BD. Eu instalei recentemente o WAMP aqui e estou usando esse script para inserir dados no BD, mas não sei porque não está inserindo

Config.php

ob_start();
// Tabelas
$tabela1 = "clientes"; 

$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 

	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();
	}

 

Cadastrando.php

error_reporting(E_ALL & ~ E_NOTICE);
	include("../config/config.php");

$run = $con->prepare("INSERT INTO $tabela1 (NOME) VALUES (:NOME)");
$dados = array(':NOME' => $name);
$cadastra = $run->execute($dados);

Meu BD também é novo, coloquei na tabela clientes ID como PRIMARY e A_I

 

Antes eu tinha um site dessa mesma programação que estava funcionando, ai depois de um tempo eu retornei, reinstalei o WAMP, porque estava com erros aqui, aí agora o mesmo site não está inserindo, alguem sabe porque não insere? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Uerlen, a pagina fica branca, não me retorna nenhum erro

 

 

será que tem que ativar algo nos ".ini" ? 

 

no WAMP em PHP, php.ini o meu está assim

extension=php_pdo_firebird.dll
extension=php_pdo_mysql.dll
;extension=php_pdo_oci.dll
;extension=php_pdo_odbc.dll
;extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
//Adiciona essas opção na construção do PDO
$opcoes = array(PDO::ATTR_ERRMODE => PDO::ERRMODE_EXCEPTION);
$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass, $opcoes);


//Coloca seu execute dentro do try/catch
try{
    $con->execute();
}catch(PDOException $e){
    echo $e->getMessage();
}

Tenta assim

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

olá. verifique suas variaveis, principalmente essa:

Em 10/08/2018 at 00:29, 11closed disse:

$name

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 10/08/2018 at 00:29, 11closed disse:

Olá pessoal Bom Dia!

 

Estou com um problema aqui, não estou conseguindo inserir dados no BD. Eu instalei recentemente o WAMP aqui e estou usando esse script para inserir dados no BD, mas não sei porque não está inserindo

Config.php


ob_start();
// Tabelas
$tabela1 = "clientes"; 

$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 

	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();
	}

 

Cadastrando.php


error_reporting(E_ALL & ~ E_NOTICE);
	include("../config/config.php");

$run = $con->prepare("INSERT INTO $tabela1 (NOME) VALUES (:NOME)");
$dados = array(':NOME' => $name);
$cadastra = $run->execute($dados);

Meu BD também é novo, coloquei na tabela clientes ID como PRIMARY e A_I

 

Antes eu tinha um site dessa mesma programação que estava funcionando, ai depois de um tempo eu retornei, reinstalei o WAMP, porque estava com erros aqui, aí agora o mesmo site não está inserindo, alguem sabe porque não insere? 

 

 

Caro amigo

 

Um exemplo para INSERT em PDO.

<!DOCTYPE html>
<html>
	<head>

     <?php 
       //Conexão com o Banco de Dados
       include"config.php"; 
     ?>

		<meta charset="utf-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<title>PDO Insert</title>
		<link rel="stylesheet" href="">
	</head>
	<body>
		
		<?php 
          
          if(isset($_POST['enviar'])){

              //Funcão strip_tags - elimina qual extensão (html, php e etc)
          	  //Função trim - elimina qualquer espaço em branco
	          $campo1 = strip_tags(trim($_POST['campo1']));
	          $teste =  strip_tags(trim($_POST['teste']));

              //Define a tabela
	          $sql_teste  = 'INSERT INTO teste (campo1,campo2)';
	          $sql_teste .= 'VALUES (:campo1,:campo2)';  //Função [ .= ] - concatenar      

	          try{
	          	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	                $query_teste = $conecta->prepare($sql_teste);

	                $query_teste->bindValue(':campo1',$campo1, PDO::PARAM_STR);
	                $query_teste->bindValue(':campo2',$teste, PDO::PARAM_STR);     

	                //Executa a ação      
	                $query_teste->execute();

	                echo 'Cadastro com sucesso';

	          } catch (PDOException $error_insert) {
	          	echo 'Erro ao cadastrar '.$error_insert->getMessage();
	          }
         
          }

		?>

		<form name="testando" action="" method="post" enctype="multipart/form-data">
          <input type="text" name="campo1" /><br/>
          <input type="text" name="teste" /><br/>
          <input type="submit" name="enviar" value="Enviar" /><br/>
	</body>  

</html>

 

Espero ter ajudado

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Remazela fiz do jeito que você falou, e agora está aparecendo a mensagem "Cadastro com sucesso", porém os dados não estão sendo inseridos no BD

 

ficou assim aqui

config.php

ob_start();

$tabela1 = "clientes"; 

//Banco de Dados
$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 
	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();

cadastro.php

<form action="cadastrando.php" method="post" id="form" name="form">
  
  Nome*:  <input id="nome" name="nome" class="text" />
  Email*:  <input id="email" name="email" class="text" />
  
<input type="submit" name="imageField"  class="botcadastro" value="Cadastrar" Onclick="return verifica()" />  
</form> 

cadastrando.php

include("../config/config.php"); 

	$nome = $_POST["nome"];
	$email = $_POST["email"];
	
	$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';
	$sql_teste .= 'VALUES (:NOME,:EMAIL)';  //Função [ .= ] - concatenar

	try{
	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	    $query_teste = $con->prepare($sql_teste);

	    $query_teste->bindValue(':NOME',$nome, PDO::PARAM_STR);
	    $query_teste->bindValue(':EMAIL',$email, PDO::PARAM_STR);     

	    //Executa a ação      
	    $query_teste->execute();

	    echo 'Cadastro com sucesso';

	} catch (PDOException $error_insert) {
	    echo 'Erro ao cadastrar '.$error_insert->getMessage();
	}

:sweat: não estou encontrando onde está o erro, será que tem haver algo com a versão do php ou do wamp?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite. Você simplesmente está tratando a variável "$tabela" como TEXTO ao utilizar ela com aspas simples e não dupla.

 

isso aqui:

$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';

  É apenas texto, $tabela1 é considerado como texto e não variável. Logo, o insert into está tentando inserir algo em uma tabela com o nome $tabela1 o que não existe. O erro deveria mostrar que não existe essa tabela também. O correto é com aspas duplas:

$sql_teste  = "INSERT INTO $tabela1 (NOME,EMAIL)";

de igual forma, faça na linha concatenada também. Sempre quando for utilizar sintaxe SQL coloque em aspas duplas para uma boa prática e evitar problemas do tipo.

 

Verifique se os campos em sua tabela estão com os nomes maiúsculos.

 

Abraço

Compartilhar este post


Link para o post
Compartilhar em outros sites
57 minutos atrás, Alaerte Gabriel disse:

Boa noite. Você simplesmente está tratando a variável "$tabela" como TEXTO ao utilizar ela com aspas simples e não dupla.

 

isso aqui:


$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';

  É apenas texto, $tabela1 é considerado como texto e não variável. Logo, o insert into está tentando inserir algo em uma tabela com o nome $tabela1 o que não existe. O erro deveria mostrar que não existe essa tabela também. O correto é com aspas duplas:


$sql_teste  = "INSERT INTO $tabela1 (NOME,EMAIL)";

de igual forma, faça na linha concatenada também. Sempre quando for utilizar sintaxe SQL coloque em aspas duplas para uma boa prática e evitar problemas do tipo.

 

Verifique se os campos em sua tabela estão com os nomes maiúsculos.

 

Abraço

 

Olá @Alaerte Gabriel, coloquei as duplas e deu a mesma coisa. E SIM os campos no BD são maiúsculos também

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro amigo

 

Tenta assim

 

config.php

<?php

    define('HOST','localhost');
    define('DB','nomeBancoDados');
    define('USER','root');
    define('PASS','');            

    $conexao = 'mysql:host='.HOST.'; dbname='.DB;

    try{
         $conecta = new PDO($conexao, USER, PASS);
         $conecta->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

       } catch(PDOexception $error_conecta) {
          echo htmlentities('Erro ao conectar'.$error_conecta->getMessage());
       }

?>

 

o insert

		<?php 
          
              //Funcão strip_tags - elimina qual extensão (html, php e etc)
          	  //Função trim - elimina qualquer espaço em branco
	          $campo1 = strip_tags(trim($_POST['campo1']));
	          $teste =  strip_tags(trim($_POST['teste']));

              //Define a tabela
	          $sql_teste  = 'INSERT INTO teste (campo1, campo2)';
	          $sql_teste .= 'VALUES (:campo1, :campo2)';  //Função [ .= ] - concatenar      

	          try{
	          	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	                $query_teste = $conecta->prepare($sql_teste);

	                $query_teste->bindValue(':campo1',$campo1, PDO::PARAM_STR);
	                $query_teste->bindValue(':campo2',$teste, PDO::PARAM_STR);     

	                //Executa a ação      
	                $query_teste->execute();

	                echo 'Cadastro com sucesso';

	          } catch (PDOException $error_insert) {
	          	echo 'Erro ao cadastrar '.$error_insert->getMessage();
	          }
        

		?>

 

 

Observa no seu código o seguinte:

//Você criou a variável com letras minúsculas
	$nome = $_POST["nome"];
	$email = $_POST["email"];
	

  //Aqui você passou com letras maiúsculas
	    $query_teste->bindValue(':NOME',$nome, PDO::PARAM_STR);
	    $query_teste->bindValue(':EMAIL',$email, PDO::PARAM_STR);

 

Para inserir, as variáveis tem que ter o nome idêntico do banco de dados.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Finalmente deu certo pessoal, muito obrigado pela ajuda.

 

Não sei bem qual era o problema, eu deletei toda a tabela no Banco de dados e fiz tudo novamente, aí deu certo 

 

vlw pessoal

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Conteúdo Similar

    • Por rd111072
      Olá, moçada!

      Tenho esse gráfico aqui: http://riocir.com.br/renan/chart_barg_g2.php 
      Mas ele exibe só os dias da semana do mês 1. Queria que ele exibisse todos os dias de todos os meses (como é o resultado do echo).

      Segue o código. Alguém pode me ajudar?
       
       
    • Por capaldi
      <?php
      if(isset($_GET['deletar']) && $_GET['deletar'] == 'sim'):
          $id_produto = (int)$_GET['produto'];
          $pegar_dados_produto = BD::conn()->prepare("SELECT img_padrao FROM loja_produtos WHERE id = ?");
          $pegar_dados_produto->execute(array($idProduto));
          $dadosProd = $pegar_dados_produto->fetchObject();
          
          $verificar_imagens = BD::conn()->prepare("SELECT * FROM loja_imgprod WHERE id_produto = ?");
          $verificar_imagens->execute(Array($idProduto));
          
          if($verificar_imagens->rowCount() == 0){
              if(unlink('../../produtos/'.$dadosProd->img_padrao)){
                  $deletar_produto =BD::conn()->prepare("DELETE FROM loja_produtos WHERE id = ?");
                  if($deletar_produto->execute(array($IdProduto))){
                      echo'<script>alert("Produto excluido com sucesso!");location.href"index.php?pagina=editarProdutos</script>';    
                  }
                  
              }
              
          }else{
              while($dadosImagenm = $verificar_imagens->fetchObject()){
                  unlink('../../produtos/'.$dadosImagem->img);
              }
              if(unlik('../../produtos/'.$dadosProd->img_padrao)){
                  $deletar_produto = BD::conn()->prepare("DELETE FROM loja_produtos WHERE id = ?");
                  if($deletar_produto->execute(array($idproduto))){
                      echo'<script>alert("Produto excluido com sucesso!");location.href"index.php?pagina=editarProdutos</script>';
                  }
              }
          }
      endif;
      ?>
       
      Ola, estou tabalhando com esse script, e não consigo resolver esse problema alguém pose me ajudar?
    • Por mateumt15
      Estou com o trecho de codigo abaixo, mas quando tento mostrai isto em uma tabela ele sempre pula a primeira linha do banco. 
      <?php $servername = "127.0.0.1";
              $username = "root";
              $password = "12345678";
              $dbname = "mydb";
              $conn = new mysqli($servername, $username, $password, $dbname);
              $sql = ("select id_link,link,data_inicio,data_fim,acao,dominio from link");
              $result = $conn->query($sql);
              $row = $result->fetch_assoc();
             
              while ($row = $result->fetch_assoc()):
                  echo "<tr>";
                  echo"<td>";echo $row['id_link'];echo "</td>";
                  echo"<td>";echo $row['link'];echo "</td>";
                  echo"<td>";echo $row['data_inicio'];echo "</td>";
                  echo"<td>";echo $row['data_fim'];echo "</td>";
                  if($row['acao']==='0')
                  {
                      echo"<td>";echo 'Bloqueado';echo "</td>";
                  }
                  if($row['acao']==='1')
                  {
                      echo"<td>";echo 'Permitido';echo "</td>";
                  }
                  if($row['dominio']==='0')
                  {
                      echo"<td>";echo 'URL';echo "</td>";
                  }
                  if($row['dominio']==='1')
                  {
                      echo"<td>";echo 'Dominio';echo "</td>";
                  }
              endwhile;
              $conn->close();
      ?>
    • Por patriciahelena
      Boa noite,
       
      Preciso de ajuda.
      No arquivo form.php tenho 3 inputs de entrada(valor1, valor2, valor3) e 3 inputs(disabled) que receberão os valores calculados do arquivo form_matematico5.php.
      Na tag form onsubmit="return calcula()"
       
          <h4 class="calcula"></h4>
       
      <script>
      function calcula($volmedio, $temp, $precogas) {
      $.get("form_matematico5.php", $('#calculorecovap').serialize(),
          function(data){
              $('.calcula').html(data);
          }
      );
      return false;
      }
      </script>
       
       
      No arquivo form_matecatico5.php é feito os calculos gerando 3 valores. 
      Tenho um echo:
      echo 'texto<br><div style=font-size:23px;color:red;>' . number_format($Resultado1,0,",","."). '</div> <br> texto<br><div style=font-size:23px;color:red;>'. number_format($Resultado2,0,",","."). '</div> <br>texto<br><div style=font-size:23px;color:red;>R$ '. number_format($Resultado3,2,",","."). '</div>';
       
      Ele retorna o echo certinho em     <h4 class="calcula"></h4>.
      Mas o que eu quero mesmo é que Resultado1 retorne dentro do primeiro input(disabled), o Resultado2 dento do segundo input(disabled) e assim com o terceiro. Ou seja,
      Cada input(disabled), recebera um valor diferente e não o total de .calcula.
       
      Espero ter explicado direitinho,
      Obrigada
       
       
       
       
       
       
       
    • Por luisfeliperm2
      Estou criando um sistema de login e cadastro de um jogo em php. Conectei ao postgresql e agora estou com um problema. Preciso saber qual criptografia é utilizada. Todas as hashs possuem 32 caracteres e por isso pensei que fosse MD5. Mas não é.
      password - > 62f9f2022536274b47f4daa0887361cf
      teste1 -> deaafc806aef00d0262e098ff089fff1
      Outras senhas criptografadas:
      59a93faaaf6d43ca4c3ef9ec183200ea
      47d163c4e9388dfd4b2dc7c327a33761
      8dffc56f2382d0f5552c04d9fa014d0e
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.