Jump to content
11closed

php PDO não está inserindo dados no BD

Recommended Posts

Olá pessoal Bom Dia!

 

Estou com um problema aqui, não estou conseguindo inserir dados no BD. Eu instalei recentemente o WAMP aqui e estou usando esse script para inserir dados no BD, mas não sei porque não está inserindo

Config.php

ob_start();
// Tabelas
$tabela1 = "clientes"; 

$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 

	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();
	}

 

Cadastrando.php

error_reporting(E_ALL & ~ E_NOTICE);
	include("../config/config.php");

$run = $con->prepare("INSERT INTO $tabela1 (NOME) VALUES (:NOME)");
$dados = array(':NOME' => $name);
$cadastra = $run->execute($dados);

Meu BD também é novo, coloquei na tabela clientes ID como PRIMARY e A_I

 

Antes eu tinha um site dessa mesma programação que estava funcionando, ai depois de um tempo eu retornei, reinstalei o WAMP, porque estava com erros aqui, aí agora o mesmo site não está inserindo, alguem sabe porque não insere? 

Share this post


Link to post
Share on other sites

Uerlen, a pagina fica branca, não me retorna nenhum erro

 

 

será que tem que ativar algo nos ".ini" ? 

 

no WAMP em PHP, php.ini o meu está assim

extension=php_pdo_firebird.dll
extension=php_pdo_mysql.dll
;extension=php_pdo_oci.dll
;extension=php_pdo_odbc.dll
;extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll

 

Share this post


Link to post
Share on other sites
//Adiciona essas opção na construção do PDO
$opcoes = array(PDO::ATTR_ERRMODE => PDO::ERRMODE_EXCEPTION);
$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass, $opcoes);


//Coloca seu execute dentro do try/catch
try{
    $con->execute();
}catch(PDOException $e){
    echo $e->getMessage();
}

Tenta assim

 

Share this post


Link to post
Share on other sites

olá. verifique suas variaveis, principalmente essa:

Em 10/08/2018 at 00:29, 11closed disse:

$name

 

Share this post


Link to post
Share on other sites
Em 10/08/2018 at 00:29, 11closed disse:

Olá pessoal Bom Dia!

 

Estou com um problema aqui, não estou conseguindo inserir dados no BD. Eu instalei recentemente o WAMP aqui e estou usando esse script para inserir dados no BD, mas não sei porque não está inserindo

Config.php


ob_start();
// Tabelas
$tabela1 = "clientes"; 

$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 

	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();
	}

 

Cadastrando.php


error_reporting(E_ALL & ~ E_NOTICE);
	include("../config/config.php");

$run = $con->prepare("INSERT INTO $tabela1 (NOME) VALUES (:NOME)");
$dados = array(':NOME' => $name);
$cadastra = $run->execute($dados);

Meu BD também é novo, coloquei na tabela clientes ID como PRIMARY e A_I

 

Antes eu tinha um site dessa mesma programação que estava funcionando, ai depois de um tempo eu retornei, reinstalei o WAMP, porque estava com erros aqui, aí agora o mesmo site não está inserindo, alguem sabe porque não insere? 

 

 

Caro amigo

 

Um exemplo para INSERT em PDO.

<!DOCTYPE html>
<html>
	<head>

     <?php 
       //Conexão com o Banco de Dados
       include"config.php"; 
     ?>

		<meta charset="utf-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<title>PDO Insert</title>
		<link rel="stylesheet" href="">
	</head>
	<body>
		
		<?php 
          
          if(isset($_POST['enviar'])){

              //Funcão strip_tags - elimina qual extensão (html, php e etc)
          	  //Função trim - elimina qualquer espaço em branco
	          $campo1 = strip_tags(trim($_POST['campo1']));
	          $teste =  strip_tags(trim($_POST['teste']));

              //Define a tabela
	          $sql_teste  = 'INSERT INTO teste (campo1,campo2)';
	          $sql_teste .= 'VALUES (:campo1,:campo2)';  //Função [ .= ] - concatenar      

	          try{
	          	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	                $query_teste = $conecta->prepare($sql_teste);

	                $query_teste->bindValue(':campo1',$campo1, PDO::PARAM_STR);
	                $query_teste->bindValue(':campo2',$teste, PDO::PARAM_STR);     

	                //Executa a ação      
	                $query_teste->execute();

	                echo 'Cadastro com sucesso';

	          } catch (PDOException $error_insert) {
	          	echo 'Erro ao cadastrar '.$error_insert->getMessage();
	          }
         
          }

		?>

		<form name="testando" action="" method="post" enctype="multipart/form-data">
          <input type="text" name="campo1" /><br/>
          <input type="text" name="teste" /><br/>
          <input type="submit" name="enviar" value="Enviar" /><br/>
	</body>  

</html>

 

Espero ter ajudado

 

 

 

Share this post


Link to post
Share on other sites

Olá @Remazela fiz do jeito que você falou, e agora está aparecendo a mensagem "Cadastro com sucesso", porém os dados não estão sendo inseridos no BD

 

ficou assim aqui

config.php

ob_start();

$tabela1 = "clientes"; 

//Banco de Dados
$bd = "banco"; 
$user = "root"; 
$pass = ""; 
$host = "localhost"; 
	
	try {
		$con = new PDO('mysql:host=localhost;dbname=banco', $user, $pass);
	  
	} catch(PDOException $e) {
		echo 'ERROR: ' . $e->getMessage();

cadastro.php

<form action="cadastrando.php" method="post" id="form" name="form">
  
  Nome*:  <input id="nome" name="nome" class="text" />
  Email*:  <input id="email" name="email" class="text" />
  
<input type="submit" name="imageField"  class="botcadastro" value="Cadastrar" Onclick="return verifica()" />  
</form> 

cadastrando.php

include("../config/config.php"); 

	$nome = $_POST["nome"];
	$email = $_POST["email"];
	
	$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';
	$sql_teste .= 'VALUES (:NOME,:EMAIL)';  //Função [ .= ] - concatenar

	try{
	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	    $query_teste = $con->prepare($sql_teste);

	    $query_teste->bindValue(':NOME',$nome, PDO::PARAM_STR);
	    $query_teste->bindValue(':EMAIL',$email, PDO::PARAM_STR);     

	    //Executa a ação      
	    $query_teste->execute();

	    echo 'Cadastro com sucesso';

	} catch (PDOException $error_insert) {
	    echo 'Erro ao cadastrar '.$error_insert->getMessage();
	}

:sweat: não estou encontrando onde está o erro, será que tem haver algo com a versão do php ou do wamp?

Share this post


Link to post
Share on other sites

Boa noite. Você simplesmente está tratando a variável "$tabela" como TEXTO ao utilizar ela com aspas simples e não dupla.

 

isso aqui:

$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';

  É apenas texto, $tabela1 é considerado como texto e não variável. Logo, o insert into está tentando inserir algo em uma tabela com o nome $tabela1 o que não existe. O erro deveria mostrar que não existe essa tabela também. O correto é com aspas duplas:

$sql_teste  = "INSERT INTO $tabela1 (NOME,EMAIL)";

de igual forma, faça na linha concatenada também. Sempre quando for utilizar sintaxe SQL coloque em aspas duplas para uma boa prática e evitar problemas do tipo.

 

Verifique se os campos em sua tabela estão com os nomes maiúsculos.

 

Abraço

Share this post


Link to post
Share on other sites
57 minutos atrás, Alaerte Gabriel disse:

Boa noite. Você simplesmente está tratando a variável "$tabela" como TEXTO ao utilizar ela com aspas simples e não dupla.

 

isso aqui:


$sql_teste  = 'INSERT INTO $tabela1 (NOME,EMAIL)';

  É apenas texto, $tabela1 é considerado como texto e não variável. Logo, o insert into está tentando inserir algo em uma tabela com o nome $tabela1 o que não existe. O erro deveria mostrar que não existe essa tabela também. O correto é com aspas duplas:


$sql_teste  = "INSERT INTO $tabela1 (NOME,EMAIL)";

de igual forma, faça na linha concatenada também. Sempre quando for utilizar sintaxe SQL coloque em aspas duplas para uma boa prática e evitar problemas do tipo.

 

Verifique se os campos em sua tabela estão com os nomes maiúsculos.

 

Abraço

 

Olá @Alaerte Gabriel, coloquei as duplas e deu a mesma coisa. E SIM os campos no BD são maiúsculos também

Share this post


Link to post
Share on other sites

Caro amigo

 

Tenta assim

 

config.php

<?php

    define('HOST','localhost');
    define('DB','nomeBancoDados');
    define('USER','root');
    define('PASS','');            

    $conexao = 'mysql:host='.HOST.'; dbname='.DB;

    try{
         $conecta = new PDO($conexao, USER, PASS);
         $conecta->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

       } catch(PDOexception $error_conecta) {
          echo htmlentities('Erro ao conectar'.$error_conecta->getMessage());
       }

?>

 

o insert

		<?php 
          
              //Funcão strip_tags - elimina qual extensão (html, php e etc)
          	  //Função trim - elimina qualquer espaço em branco
	          $campo1 = strip_tags(trim($_POST['campo1']));
	          $teste =  strip_tags(trim($_POST['teste']));

              //Define a tabela
	          $sql_teste  = 'INSERT INTO teste (campo1, campo2)';
	          $sql_teste .= 'VALUES (:campo1, :campo2)';  //Função [ .= ] - concatenar      

	          try{
	          	    //Antes de executar qualquer tarefa, verifica no Bco Dados Login e Senha
	                $query_teste = $conecta->prepare($sql_teste);

	                $query_teste->bindValue(':campo1',$campo1, PDO::PARAM_STR);
	                $query_teste->bindValue(':campo2',$teste, PDO::PARAM_STR);     

	                //Executa a ação      
	                $query_teste->execute();

	                echo 'Cadastro com sucesso';

	          } catch (PDOException $error_insert) {
	          	echo 'Erro ao cadastrar '.$error_insert->getMessage();
	          }
        

		?>

 

 

Observa no seu código o seguinte:

//Você criou a variável com letras minúsculas
	$nome = $_POST["nome"];
	$email = $_POST["email"];
	

  //Aqui você passou com letras maiúsculas
	    $query_teste->bindValue(':NOME',$nome, PDO::PARAM_STR);
	    $query_teste->bindValue(':EMAIL',$email, PDO::PARAM_STR);

 

Para inserir, as variáveis tem que ter o nome idêntico do banco de dados.

Share this post


Link to post
Share on other sites

Finalmente deu certo pessoal, muito obrigado pela ajuda.

 

Não sei bem qual era o problema, eu deletei toda a tabela no Banco de dados e fiz tudo novamente, aí deu certo 

 

vlw pessoal

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By perfectraider99
      Galera bom dia, recentemente me pediram pra fazer um sistema de postagem para um site de carros . 
      pesquisei formas de fazer e encontrei um projeto de upload de imagens 
      fiz tudo certinho no local host e funcionou perfeitamente mas quando fui colocar no servidor nada funcionou, nem enviava o formulario nem amostrava os produtos.
      por favor galerinha estou a muito tempo tentando resolver esse problema . 
      aqui tá o meu codigo 
       
      index : 
       
       
      <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <style> body{ font-family: arial; } section{ background-color: rgb(123,104,238,.4); width: 70%; margin: auto; } input, label, textarea{ display: block; width: 100%; height: 30px; } label{ line-height: 30px; margin-top: 10px; } textarea{ height: 150px; } form{ width: 60%; margin: auto; box-sizing: border-box; padding: 20px; } #botao{ margin-bottom: 10px; width: 50%; background-color: rgba(0,0,0,.8); color: white; height: 40px; cursor: pointer; border: none; font-size: 15pt; } h1{ text-align: center; } #foto{ margin-top: 20px; margin-bottom: 20px; } a{ background-color: rgb(0,255,127); display: block; width: 220px; height: 50px; color: black; text-decoration: none; float: right; text-align: center; line-height: 50px; margin: 20px; border: 1px solid rgba(0,0,0,.2); } </style> </head> <body> <section> <a href="produtos.php">Ver todos os produtos</a> <form method="POST" enctype="multipart/form-data"> <h1>ENVIO DE IMGS</h1> <label for="nome">Nome do Produto</label> <input type="text" name="nome" id="nome"> <label for="des">Descrição</label> <textarea name="desc" id="desc"></textarea><br> <input type="file" name="foto[]" multiple id="foto"> <input type="submit" id="botao"> </form> </section> </body> </html> produtos : <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <style type="text/css"> section{ width: 70%; margin: auto; font-family: arial; } div{ width: 15%; float: left; padding: 1%; background-color: rgb(123,104,238,.4); margin: 10px; } img{ width: 100%; height: 150px; } h2{ font-size: 12pt; color: white; text-align: center; background-color: rgba(0,0,0,.5); padding: 10px 0px; font-weight: normal; } p{ font-size: 10pt; } </style> </head> <body> <section> <?php require 'classes/Produto_class.php'; $p = new Produto_class('formulario_produtos','infinityfree.net','root', '99583460'); <- aqui ta a parte do banco de dados $dadosProduto = $p->buscarProdutos(); if (empty($dadosProduto)) { echo 'Ainda não há produtos aqui'; }else { foreach ($dadosProduto as $value) { ?> <a href="exibir_produto.php"> <div> <img src="imagens/<?php echo $value['foto_capa'] ?>"> <h2><?php echo $value['nome_produto'] ?></h2> </div> </a> <?php } } ?> </section> </body> </html> e aqui tá a parte do banco de dados : <?php class Produto_class{ private $pdo; public function __construct($dbname, $host, $user, $senha) { try { $this->pdo = new PDO("mysql:dbname=".$dbname.";host=".$host,$user, $senha); } catch (PDOException $e) { echo 'erro com banco de dados :'.$e->getMessage(); } catch (Exception $e) { echo 'erro Generico :'.$e->getMessage(); } } public function enviarProduto($nome, $descricao, $fotos = array()) { //INSERIR PRODUTO ( TABELA DO PRODUTO ) $cmd = $this->pdo->prepare('INSERT INTO produtos(nome_produto, descricao) values (:n, :d)'); $cmd->bindValue(':n', $nome); $cmd->bindValue(':d', $descricao); $cmd->execute(); $id_produto = $this->pdo->LastInsertId(); //INSERIR AS IMAGENS DO PRODUTO (TABELA DE IMAGENS) if(count($fotos) > 0 )// Se veio imagens { for ($i=0; $i < count($fotos); $i++) { $nome_foto = $fotos[$i]; $cmd = $this->pdo->prepare('INSERT INTO imagens (nome_imagem, fk_id_produto) values (:n, :fk)'); $cmd->bindValue(':n', $nome_foto ); $cmd->bindValue(':fk', $id_produto); $cmd->execute(); } } } public function buscarProdutos()//TODOS { $cmd = $this->pdo->query('SELECT *, (SELECT nome_imagem from imagens where fk_id_produto = produtos.id_produto LIMIT 1) as foto_capa FROM produtos'); if($cmd->rowCount() > 0) { $dados = $cmd->fetchAll(PDO::FETCH_ASSOC); }else { $dados = array(); } return $dados; } public function buscarPrdutoPorId($id) { } public function buscarImagensPorId($id) { } }
       
      Já troquei a variavel $p = new Produto_class no arquivo que eu mandei pro servidor ..
    • By Sapinn
      Tô fazendo esse forum pq não achei nada que me ajudasse. Tenho um site em que os professores dão temas para as usuarios produzirem textos, basicamente um site de historias. Preciso que o aluno saiba se ja fez um texto sobre aquele determinado tema. Sendo assim tenho duas tabelas no meu banco usuario que cadastra todos os usarios e historia que tem o tema. Quando o aluno vai enviar a historia automaticamente envia seu email. O que eu realmente quero é comparar se o email existe nas duas tabelas se sim ele retorna já foi feito se não ele retorna Nada feito ainda.
    • By Kellyfer
      Ola estou tentando publicar imagens multilas usando o comando FOR mas nao estou acertando, alguem poderia me ajudar??
      /*script*/
      <?php 
      date_default_timezone_set('America/Sao_Paulo');
      session_start();?> 
      <!DOCTYPE html>
      <html lang="pt-br">
      <head>
          <meta charset="utf-8">
          <title>Upload de Imagens</title>
      </head>
      <body>
      <!--FORMULÁRIOS-->
      <form action="upload.php" method="post" enctype="multipart/form-data">
          <input type="file" name="arquivos[]" multiple required>
          <input type="submit" value="Publicar">
      </form>
      <p>
      <?php 
      if(isset($_SESSION['erro'])):
          echo $_SESSION['erro'];
          session_unset();
      elseif(isset($_SESSION['sucesso'])):
          echo $_SESSION['sucesso'];
          session_unset();
      endif;
      ?>
      </p>
      <?php 
      /*MOSTRANDO AS IMAGENS NA TELA*/
      $utf8 = header("content-type:text/html;charset= utf-8");
      $conn = new mysqli('localhost','thesim','xthesimx1986','db_galeria');
      $conn->set_charset("utf8");
      $busca_image = "SELECT id, nome_arquivo FROM tb_upload  ORDER BY id DESC";
      $res = mysqli_query($conn, $busca_image);
       if(mysqli_num_rows($res) <= '0'){
           echo "Nenuma imagem encontrada!";
       }else{
           while($res_pos =mysqli_fetch_array($res)){
               $nome_arquivo    =$res_pos[0];
      for($c=0; $c>=10; $c++);
      print "<div class='foto'><img src='uploads/$nome_arquivo$c</div>";
      }
      }
      ?>
      </body>
      </html>
      Imagens anexadas



    • By tatysouzac
      Minha view:
      <div>                            
                                          <form method="post" action="http://localhost/integradorcode/index.php/welcome/validar">
                                          EMAIL: <input type="text" name="email"  /> <br><br>
                                          SENHA:  <input type="password" name="senha"/> <br><br><br><br>
                                          <input class="myButton" type="submit" value="Entrar"/> <br><br>
                                          </form>
                                          <a href="Cadastro.php" class="myButton">Cadastrar</a><br><br>
                                          <a href="#" class="myButton">Esqueceu sua senha?</a>
               </div>
       
       
       
      Controller:
       
          public function validar(){
              //var_dump($_POST);
              $this->load->model("Cadastro_model");
              $result = $this->Cadastro_model->validar($_POST["email"],md5($_POST["senha"]));
              var_dump($result);
          }
       
       
      Model:
       
          function validar($email, $senha){
              return $this->db->query("SELECT * FROM `cadastro_clientes` WHERE email_cliente = '{$email}'  AND senha_cliente = '{$senha}' AND status = 1 LIMIT 1")->result_array();
          }
       
       
      Não da nenhuma mensagem de erro mas coloco senha e login certos do meu bd e o return não retorna nada array 0 
    • By terra
      Olá,
       Tenho esse codigo
       
      e gostaria de chamar  bairro = dados.address.suburb; aqui nesse função 
       
       
      Agradeço qualquer ajuda
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.