Jump to content
Luiz Henrique Mendes Tisco

Formulário 1 interagindo com componente do formulario 2 - Delphi

Recommended Posts

Boa tarde! Eu estou iniciando em delphi, sou bem novato. Porém estava querendo fazer com que ao pressionar um botão no form1 ele abrisse o form2 com uma informação calculada no label. Porém estou com problema na questão de fazer esses formulario se interligarem. Desde Já Agradeço. Talvez até chamando uma procedure do form1 para responder no form2

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By carlos melo
      Boa noite, trabalho com Delphi e estou tendo dificuldade em fazer conexão com meu servidor que esta na argentina, uso o firedac para fazer a conexão com o banco, so que o comando que estou utilizando esta dando erro e não sei se estou configurando certo a minha query.
       
      Ja criei os linked server e tambem não resolveu......
       
       uso um select dentro do delphi dessa maneira : 
      DELPHI
      FDQuery e dentro uso esse select
      Select * from [192.168.XX.XXX].banco.dbo.tabela direcionando para o meu servidor que esta na argentina sendo 192.168.xx.xxx o ip do servidor de la e o nome do banco é servicos e a tabela ordens.
       
      Se alguem conhece ou ja fez esse tipo de conexão , estou precisando dessa grande ajuda...
       
      obrigado
    • By andreluis78
      Olá a todos.
      Criei um procedimento para verificar se um usuário está cadastrado no banco de dados.
      Utilizo Firebird como BD e componentes Zeos para acessar o banco.
      Resolvi criar uma query em tempo de execução para fazer a verificação. Não dá nenhum erro, porém, quando digito o nome do usuário no Edit e clico
      no botão que executa o procedimento, ele dá ''usuário inexistente'', mesmo se o nome do usuário estiver cadastrado no banco.
       
      Segue o código:
       
      procedure Tfrm_login.SpeedButton1Click(Sender: TObject); var Qry : TZQuery; begin   Qry:=TZQuery.Create(nil);   Qry.Connection := dm_dados.ZConnection1;  //componente de conexão   Qry.SQL.Add('select codigo, nome, acessar, user, pass from clientes');   Qry.Open;   if Qry.Locate('USER',Edit1.Text,[]) then   begin     ShowMessage('usuário cadastrado');   end   else   begin     ShowMessage('usuário inexistente');     Edit1.SetFocus;   end;   FreeAndNil(Qry); end;  
      Se alguém puder ajudar agradeço desde já.
      Obrigado
    • By gabrielmdn
      Boa noite meus amigos.
       
      Estou com um problema enorme aqui. Precisei formatar o PC, e entao fiz um backup de tudo que tenho..normal 
      Quando abri o meu projeto no delphi e pedi para compilar ele parou na linha 114 e começou a aumentar os erros. Deixei por duas horas para ver até onde ia...e continuou
      Não tenho ideia do que esta acontecendo. Se não tivesse forçado a parada forçada nao teria parado até agora. 
       
      Alguem ja passou por isso? Estou bem preocupado, pois isso nunca me aconteceu.

    • By liniker.o
      Boa tarde pessoal!
      Estou com um problema em meu código quando coloco uma referencia de fonte a mesma não carrega, quando faça o mesmo procedimento local colocando os caminhos de pasta funciona normalmente.
      Será que alguém poderia me ajudar?
      Segue o código.
      <html> <head> <title>Minha pagina</title> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <!-- Se não declarar charset por meta, envie um header de igual valor --> <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> </head> <?php //Carregar imagem tamanho da imagen = 515x76 $img = ImageCreateFromJPEG("base.jpg"); //Definir cor $cor1 = imagecolorallocate($img, 0, 0, 0); $cor2 = imagecolorallocate($img, 0, 0, 0); // carregar fonte... $fonte1 = 'https://ff.static.1001fonts.net/r/o/roboto-condensed.light.ttf'; $fonte2 = 'https://ff.static.1001fonts.net/r/o/roboto-condensed.light.ttf'; //Escrever nome $txtNome = $_POST['nome']; $txtFuncao = $_POST['func']; $txtEmail = $_POST['email']; $txtDDD = "+55 ".$_POST['telefone']; // IMAGEM, TAMANHO_FONTE, 0, POSICAO X, posicao Y, TEXTO_COR, ARQ_FONTE, TEXTO imagettftext($img, 32, 0, 250, 100, $cor1, $fonte1, $txtNome); imagettftext($img, 18, 0, 250, 125, $cor1, $fonte2, $txtFuncao); imagettftext($img, 18, 0, 250, 150, $cor1, $fonte2, $txtEmail); imagettftext($img, 18, 0, 250, 180, $cor1, $fonte2, $txtDDD); //Header e output header('Content-type: image/jpeg'); imagejpeg($img,"Assinatura - ".$txtNome.".jpg"); imagedestroy($img); header('Location: Assinatura - '.$txtNome.'.jpg'); ?>  
    • By jranesio
      Estou com problemas com script PHP e cURL para:
      1 - logar no site
      2 - acessar formulario de pesquisa e passar os dados
      3 - receber a página de resposta html
      Itens 1 e 2 estão OK, obtenho a resposta (item 3).
      Alguém pode orientar onde estou errando? Segue script.
      Obrigado
       
       
      <?php
       
      $cookie = dirname(__FILE__).'/cookie.txt';
      $url1='http://clima.feis.unesp.br/login.php'; //página de login
      $url2='http://clima.feis.unesp.br/dados_diarios.php'; //formulario de pesquisa
      $url3='http://clima.feis.unesp.br/recebe_formulario.php'; //Resultado esperado
      $username = 'usuario=siteteste';
      $password = 'senha=testesite';
      $dadosform= [ 'dataini' => '01/01/2020',
      'datafim' => '01/03/2020',
      'estacao' => '1'
      ];
      $useragent='Mozilla/5.0 (Windows NT 6.2) AppleWebKit/536.6 (KHTML, like Gecko) Chrome/20.0.1090.0 Safari/536.6';
      $ch = curl_init($url2);
      curl_setopt_array($ch, [
                              CURLOPT_COOKIESESSION => 1,
                              CURLOPT_COOKIEJAR => $cookie,
                              CURLOPT_COOKIEFILE => $cookie,
                              CURLOPT_USERAGENT => $useragent,
                              CURLOPT_AUTOREFERER => 1,
                              CURLOPT_URL => $url2,
                              CURLOPT_POST => 1,
                              CURLOPT_RETURNTRANSFER => 1,
                              CURLOPT_FOLLOWLOCATION => 0,
                              CURLOPT_USERPWD => $username.":".$password,
                              CURLOPT_VERBOSE => 1 ,
                              CURLINFO_HEADER_OUT => 1,
                              CURLOPT_POSTFIELDS => $dadosform,
      ]);
      $resultado = curl_exec($ch);
      $errno = curl_errno($ch);
      echo "<br>Login: ". curl_strerror($errno).'<hr>';
      echo '<hr>';
      if($errno == 0) {
          print_r($resultado);
      }

      curl_close($ch);
      echo '<br>[FIM]';
       
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.