Jump to content
C.SALLES

Dev c++ duvida em problema

Recommended Posts

Faça um programa leia dois números inteiros e utilize uma função SOMAR que receba esses dois números por parâmetro e retorne a soma dos números inteiros existentes entre eles.

Sou iniciante em programação e tentei fazer o programa da tal forma:

 

#include<stdlib.h>
#include<math.h>
#include<stdio.h>
int SOMAR((((int soma;i;n1;n2))))
{
    return; 
     for (i=n1+1; i<n2; i++) {  
    soma += i; 
    } 
}

int main() { 
int n1, n2; 
printf("Informe os números: "); 
scanf("%d %d", &n1, &n2);  
printf("\nSoma: %d\n", SOMAR(soma)); 
return 0; 
system ("pause");
}
 

Não roda por vários motivos e sinceramente sei nem como resolver

Share this post


Link to post
Share on other sites

Não entendi muito bem o que tentou fazer visto que estavas a usar um for para fazer o programa, eu recomeçei todo o programa que fez e alterei bibliotecas também adicionando algumas que faltavam, porém também devias saber que quando escrevemos "return //aqui um numero" serve para terminar um programa, como se fosse um End, tenta estudar mais os comandos, fizeste o programa como se não soubesses metades do comandos, claro eu entendo que sejas iniciante. :)

 

Eu fiz o programa da seguinte forma, também utilizado o for, se era isso que queria fazer, caso não queria elimine o for apenas.

 

 

#include <stdlib.h>
#include <iostream>
#include <stdio.h>

using namespace std;

void soma(int soma,int n1,int n2)

    int i;
    for (i = 0; i < 1; i++){
        soma = n1 + n2;
    }
    cout << soma;
}


int main() { 
    int n1, n2;
    cout << "Insira os numeros: ";
    cin >> n1;
    cin >> n2;
    cout << "\nTotal: ";
    soma(0,n1,n2);
}

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By christin cley
      Construir um algoritmo em C++ que preencha um matriz quadrada de tamanho 4 pelo usuário. Após o preenchimento pelo usuário, verifique na diagonal principal qual foi o maior valor digitado e exiba na tela o valor. Por fim,  exiba na tela toda matriz em forma de matriz na tela.
    • By Guss
      var carro = {
      cor = "azul",
      modelo = "fusca",
      marca = "Volwagen,
      kms = 10000,
      combustivel = "gasolina"
      }
       
    • By 4ly
      O exercício propunha fazer duas funções uma para multiplicação e outra para criar uma fatorial, porém devem ser feitas usando apenas operações de soma e subtração
      bom fiz uma função para multiplicar e esta funcionando porém estou tentando utiliza-la para fazer a fatorial e o resultado sempre da zero ;-; podem me ajudar 
       
       
      algoritmo "semnome" var a,b:inteiro funcao multi(a:inteiro;b:inteiro):real var aux:real inicio se a=0 entao retorne 0 senao aux <- 0 enquanto b>0 faca aux <- aux+a b <- b-1 fimenquanto retorne aux fimse fimfuncao funcao fatorial(a:inteiro):real var fat,res:real inicio enquanto fat > 0 faca fat<-a fat <- fat - 1 res <- multi(fat,a) fimenquanto retorne res fimfuncao inicio leia(a) escreval(fatorial(a)) fimalgoritmo  
    • By Nasus
      Preciso fazer um programa de controle de comandas de um restaurante , envolvendo struct e arquivos, porém ñ sei por onde começar, alguém pode me ajudar?
       
      Estou fazendo da seguinte forma:
          struct produto{ int codigo_produto; char descrição[50]; double valor; }prod[4];   struct mesa{ int cod_mesa; char setor[30]; int codigo_garçom; }mes[3];   struct garçom{ int codigo_garçom; char nome[70]; }gar[;   struct consumo{ int cod_produto,cod_consumo; char data [10];     }
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.