Jump to content
Webster Moitinho

Executando duas consultas

Recommended Posts

Estou tentando fazer o controle de acesso do meu site. Para tanto criei duas tabelas:

Stat (Armazena cada sessao dos usuários
Estrutura da tabela `stat`

CREATE TABLE `stat` (
  `id_stat` int(11) NOT NULL,
  `navegador` varchar(85) NOT NULL,
  `usuario` int(11) NOT NULL,
  `cep` varchar(7) NOT NULL,
  `ip_visitante` varchar(15) NOT NULL,
  `sessao` varchar(72) NOT NULL,
  `pais` varchar(30) NOT NULL,
  `estado` varchar(30) NOT NULL,
  `cidade` varchar(50) NOT NULL,
  `latitude` decimal(11,5) NOT NULL,
  `longitude` decimal(11,5) NOT NULL,
  `ip_meuservidor` varchar(72) NOT NULL,
  `hora_req` time NOT NULL,
  `origem` varchar(175) NOT NULL,
  `idioma` varchar(50) NOT NULL,
  `SERVER_ADMIN` varchar(90) NOT NULL,
  `servidor` varchar(90) NOT NULL,
  `visitada` longtext CHARACTER SET utf8 NOT NULL,
  `registro` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

-- Indexes for table `stat`

ALTER TABLE `stat`
  ADD PRIMARY KEY (`id_stat`);


-- AUTO_INCREMENT for table `stat`

ALTER TABLE `stat`
  MODIFY `id_stat` int(11) NOT NULL AUTO_INCREMENT;

sub_stat (Para armazenar as páginas visitadas e as interações com o cliente:

CREATE TABLE `sub_stat` (
  `id_substat` int(11) NOT NULL,
  `sessao` varchar(72) NOT NULL,
  `hora_req` time NOT NULL,
  `origem` varchar(85) NOT NULL,
  `visitada` varchar(85) NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

-- Indexes for table `sub_stat`

ALTER TABLE `sub_stat`
  ADD PRIMARY KEY (`id_substat`);

-- AUTO_INCREMENT for table `sub_stat`

ALTER TABLE `sub_stat`
  MODIFY `id_substat` int(11) NOT NULL AUTO_INCREMENT;

O desejado portanto, seria que quando o usuário entrasse na página, o script localizasse a sessão do usuário, buscaria a sessão na tabela stat, caso não existisse, iria inserir o registro tanto na tabela stat, quanto na tabela sub_stat. Se existisse a sessão na tabela stat, então somente haveria inserção dos registros na tabela sub_stat. Eu não estou conseguindo executar a segunda consulta, que vai popular a tabela sub_stat.

 

Meu código está assim:

 



		$sql = "SELECT sessao FROM stat
		WHERE sessao = '$sessao'";
		
		$prepara 		= $PDO->prepare( $sql );
		$prepara->execute();	
		$login_check   	= $prepara->rowCount();

		if($login_check < 1){



		$sql = "INSERT INTO `stat` 
		(`id_stat`, 
		`navegador`, 
		`usuario`, 
		`cep`, 
		`ip_visitante`, 
		`sessao`, 
		`pais`, 
		`estado`, 
		`cidade`, 
		`latitude`, 
		`longitude`, 
		`ip_meuservidor`, 
		`hora_req`, 
		`origem`, 
		`idioma`, 
		`servidor`, 
		`visitada`, 
		`registro`) 
		VALUES 
		(NULL, 
		'$navegador', 
		'$usuario', 
		'$cep', 
		'$meuip', 
		'$sessao', 
		'$pais', 
		'$estado', 
		'$cidade', 
		'$lat', 
		'$long', 
		'$ip', 
		'$hora_req', 
		'$origem', 
		'$idioma', 
		'$servidor', 
		'$visitada', 
		'$registro')";
	$compile	= $PDO->prepare($sql);
	$vai	= $compile->execute();

		

		$sql2 = "INSERT INTO `sub_stat` 
		(`id_substat`, 
		`sessao`, 
		`hora_req`, 
		`origem`, 
		`visitada`) 
		VALUES 
		(NULL, 
		'$sessao', 
		'$hora_req', 
		'$origem', 
		'$visitada'"; 
	$compile2	= $PDO->prepare($sql2);
	$vai	= $compile2->execute();

	} else {
	
	
		$sql = "INSERT INTO `sub_stat` 
		(`id_substat`, 
		`sessao`, 
		`hora_req`, 
		`origem`, 
		`visitada`) 
		VALUES 
		(NULL, 
		'$sessao', 
		'$hora_req', 
		'$origem', 
		'$visitada'"; 
	$compile	= $PDO->prepare($sql);
	$vai	= $compile->execute();

}

 

Share this post


Link to post
Share on other sites

Reparei que falta o fechamento de alguns
VALUES, porém, independente do mesmo,
tente usar o seguinte código:

 

CÓDIGO

<?php

$sql = "SELECT sessao FROM stat WHERE sessao = '$sessao'";
		
$prepara = $PDO->prepare ( $sql );
$prepara->execute ();	
$login_check = $prepara->rowCount ();

if ( $login_check < 1 ){
	$sql = "INSERT INTO `stat` (
	`id_stat`, 
	`navegador`, 
	`usuario`, 
	`cep`, 
	`ip_visitante`, 
	`sessao`, 
	`pais`, 
	`estado`, 
	`cidade`, 
	`latitude`, 
	`longitude`, 
	`ip_meuservidor`, 
	`hora_req`, 
	`origem`, 
	`idioma`, 
	`servidor`, 
	`visitada`, 
	`registro`
	)
	VALUES
	(
		NULL, 
		'$navegador', 
		'$usuario', 
		'$cep', 
		'$meuip', 
		'$sessao', 
		'$pais', 
		'$estado', 
		'$cidade', 
		'$lat', 
		'$long', 
		'$ip', 
		'$hora_req', 
		'$origem', 
		'$idioma', 
		'$servidor', 
		'$visitada', 
		'$registro'
	);
	INSERT INTO `sub_stat` 
	(
	`id_substat`, 
	`sessao`, 
	`hora_req`, 
	`origem`, 
	`visitada`
	)
	VALUES
	(
		NULL, 
		'$sessao', 
		'$hora_req', 
		'$origem', 
		'$visitada'
	)";

	$compile = $PDO->prepare ( $sql );
	$vai = $compile->execute ();
} else {
	$sql = "INSERT INTO `sub_stat` 
	(
	`id_substat`, 
	`sessao`, 
	`hora_req`, 
	`origem`, 
	`visitada`
	) 
	VALUES 
	(
		NULL, 
		'$sessao', 
		'$hora_req', 
		'$origem', 
		'$visitada'
	)";

	$compile	= $PDO->prepare ( $sql );
	$vai	= $compile->execute ();
}

 

Share this post


Link to post
Share on other sites
5 minutos atrás, Webster Moitinho disse:

Obrigado Shadow DLL... Eu não notei que faltava fechar o parêntesis. Valeu!!!

 

Disponível ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ILR master
      Fala pessoal, tudo bem?
       
      Eu tenho um dominio e vários subdomios dentro.
      Quero saber como recuperar um cookie nos subdominios, uma vez que ele foi criado em um subdominio específico.
       
      Estrutura:
      Tô criando o cookie em usuario.dominio.com.br com o seguinte código:
       
      $valor = md5(uniqid(rand(), true));
      setcookie("token", $valor, time() + (60 * 10), "/", "www.dominio.com.br");
       
      Porém, quero recuperar esse valor em todos os outros subdominios, mas esse codigo aí não tá funcionando.
       
      Alguém pode ajudar?
      Valeu
       
    • By landerbadi
      Boa tarde pessoal. Estou tentado fazer uma consulta no banco de dados porém estou tendo dificuldades. Tenho uma tabela chamada "itens" com os seguintes campos: id, item, ativo. Nela tem cadastrado vários itens. No campo ativo eu coloco a letra "S" para informar que este item está ativo no sistema. Por exemplo: 1, casa, S 2, mesa, S 3, cama, S 4, moto S 5, rádio O quinto registro "radio" não está ativo no sistema pois não tem um "S" no campo ativo. E outra tabela chamada "produtos" com os seguintes campos (id, item1, item2, item3) com os seguintes registros: 1, casa, mesa, moto 2, mesa, casa, cama 3, rádio, cama, mesa Eu preciso fazer uma busca na tabela produtos da seguinte maneira: Eu escolho um registro na tabela "itens", por exemplo "mesa". Preciso fazer com que o php me liste todos os registros da tabela "produtos" que contenham a palavra "mesa". Até aqui tudo bem eu consigo listar. Estou fazendo assim: <?php $item = "mesa" $sql = mysqli_query($conn, "SELECT * FROM produtos WHERE item1 LIKE '$item' OR item2 LIKE '$item' OR item3 LIKE '$item' LIMIT 10"); while($aux = mysqli_fetch_assoc($sql)) { $id = $aux["id"]; $item1 = $aux["item1"]; $item2 = $aux["item2"]; $item3 = $aux["item3"]; echo $id . " - " . $item1 . ", " . $item2 . ", " $item3 . "<br>"; } ?> O problema é que está listando todos os registros que contém o item mesa. Eu preciso que o php verifique os demais item e me liste somente os registro em que todos os registros estejam ativos no sistema. No exemplo acima ele não deveria listar o registro 3. pois nesse registro contém o item "radio" e este item não está ativo no sistema. Ou seja, o registro "radio" na tabela itens não possui um "S" na coluna "ativo". Alguém sabe como resolver isso?
    • By ILR master
      Fala galera.
      Espero que todos estejam bem.
      Seguinte: Tenho um arquivo xml onde alguns campos estão com : (dois pontos), como o exemplo abaixo:
       
      <item>
      <title>
      d sa dsad sad sadasdas
      </title>
      <link>
      dsadas dsa sad asd as dsada
      </link>
      <pubDate>sadasdasdsa as</pubDate>
      <dc:creator>
      d sad sad sa ad as das
      </dc:creator>
      </item>
       
      Meu código:
       
      $link = "noticias.xml"; 
      $xml = simplexml_load_file($link); 
      foreach($xml -> channel as $ite) {     
           $titulo = $ite -> item->title;
           $urltitulo = $ite -> item->link;
           print $urltitulo = $ite -> item->dc:creator;
      } //fim do foreach
      ?>
       
      Esse campo dc:creator eu não consigo ler. Como faço?
       
      Agradeço quem puder me ajudar.
       
      Abs
       
       
    • By First
      Olá a todos!
       
      Eu estou criando um sistema do zero mas estou encontnrando algumas dificuldades e não estou sabendo resolver, então vim recorrer ajuda de vocês.
      Aqui está todo o meu código: https://github.com/PauloJagata/aprendizado/
       
      Eu fiz um sistema de rotas mas só mostra o conteúdo da '/' não sei porque, quando eu tento acessar o register nada muda.
      E eu também quero que se não estiver liberado na rota mostra o erro de 404, mas quando eu tento acessar um link inválido, nada acontece.
      Alguém pode me ajudar com isso? E se tiver algumas sugestão para melhoria do código também estou aceitando.
       
       
      Desde já, obrigado.
    • By landerbadi
      Olá pessoal, boa tarde
       
      Tenho uma tabela chamada "produtos" com os seguintes campos (id, produto) e outra tabela chamada "itens" com os seguintes campos (id, prod_01, prod_02, prod_03, prod_04).
       
      Na tabela produtos eu tenho cadastrado os seguintes produtos: laranja, maçã, uva, goiaba, arroz, feijão, macarrão, etc.
       
      Na tabela itens eu tenho cadastrado os itens da seguinte maneira:
       
      1, laranja, uva, arroz, feijão;
      2, maçã, macarrão, goiaba, uva;
      3, arroz, feijão, maçã, azeite
       
      Meu problema é o seguinte: 
      Eu escolho um produto da tabela "produtos", por exemplo "uva".  Preciso fazer uma consulta na tabela "itens" para ser listado todos os registros que contenham o produto "uva" e que todos os demais produtos estejam cadastrados na tabela "produtos".
       
      No exemplo acima seria listado apenas dois registros, pois o terceiro registro não contém o produto "uva". 
       
      Alguém pode me ajudar? Pois estou quebrando a cabeça a vários dias e não consigo achar uma solução.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.