Jump to content

Archived

This topic is now archived and is closed to further replies.

nivaldo_js

Video na net

Recommended Posts

nivaldo_js, os formatos .avi e .mpeg não são apropriados, mesmo para quem acessa internet usando ADSL.

Você pode sim utilizá-los mas não é viável, se puder troque para .wmv (windows media)

 

pra rodar um video use o <object>

 

<object width="259" height="189" classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" standby="Carregando o VIDEO..." type="application/x-oleobject" VIEWASTEXT><param name="FileName" value="[B]video.avi[/B]"><param name="AutoStart" value="false"><param name="TransparentAtStart" value="false"><param name="ShowControls" value="1"><param name="ShowDisplay" value="0"><param name="ShowStatusBar" value="1"><param name="AutoSize" value="1"><param name="AnimationAtStart" value="1"><embed type="application/x-mplayer2" pluginspage="http://www.microsoft.com/windows/mediaplayer/download/default.asp" width=259 height=189 src="[B]video.avi[/B]" autostart="0" transparentatstart="0" showcontrols="1" showdisplay="0" showstatusbar="1" autosize="1" animationatstart="1"></embed></object>
width largura do player

height altura do player

FileName local relativo ou absoluto do arquivo (.mid, .wav, .mp3, .wma, .mov, .mpeg, .asx)

src local relativo ou absoluto do arquivo (.mid, .wav, .mp3, .wma, .mov, .mpeg, .asx)

standby texto exibido enquanto o buffer do arquivo de midia é carregado

type tipo de aplicação

TransparentAtStart se true a tela de exibição do video fica em modo transparente ao iniciar o aplicativo, se false a tela é exibida. Para a tag <embed> os valores são 0 ou 1.

autostart se true, o arquivo de midia será inicializado automatimente, se false ficará em modo parado

showstatusbar se 1 exibe o status do arquivo de midia, se 0 oculta as informações

showdisplay se 1 exibe informações sobre o arquivo de midia, se 0 oculta as informações

autosize se 1 os valores de width e height serão ignorados e o player retornará o tamanho real do video, se 0 o player retornará as dimensões especificadas, que se não forem especificadas o parâmetro

autosize receberá o valor 1

codebase local de onde o midia player será baixado para auto instalação, caso o usuário não o tenha instalado

pluginspage ídem ao codebase

Share this post


Link to post
Share on other sites

Mesmo com seu Codigo não funciona :

 

<HTML>

<HEAD>

<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">

</HEAD>

<BODY>

<object width="259" height="189" classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95"

codebase="

http://activex.microsoft.com/activex/contr...,1,52,701"

standby="Carregando o VIDEO..." type="application/x-oleobject" VIEWASTEXT>

<param name="FileName" value="../images/globe.avi">

<param name="AutoStart" value="false">

<param name="TransparentAtStart" value="false">

<param name="ShowControls" value="1">

<param name="ShowDisplay" value="0">

<param name="ShowStatusBar" value="1">

<param name="AutoSize" value="1">

<param name="AnimationAtStart" value="1">

<embed type="application/x-mplayer2"

pluginspage="http://www.microsoft.com/windows/mediaplayer/download/default.asp"

width=259 height=189 src="../images/globe.avi"

autostart="0"

transparentatstart="0"

showcontrols="1"

showdisplay="0"

showstatusbar="1"

autosize="1"

animationatstart="1">

</embed>

</object>

<P> </P>

 

</BODY>

</HTML>

 

DETALHE

COM AS TAG E DA ESSES ERROS ABAIXO:

 

http://192.168.1.223/ExemploASP_Local/Testes/globe.avi não encontrado. Verifique se o caminho e o nome do arquivo estão corretos. (Erro=80070002)

 

Não é possível abrir. Verifique se o caminho e o nome do arquivo estão corretos e tente novamente. (Erro=80070002)

 

 

SEM A TAG DA SOMENTE ESSE ERRO

 

Não é possível abrir. Verifique se o caminho e o nome do arquivo estão corretos e tente novamente. (Erro=800C0008)

 

 

 

Será q não funciona por motivo de eu estar usando .avi ???

 

Obrigado !!

Share this post


Link to post
Share on other sites

a própria mensagem de erro diz:

"arquivo não encontrado"

quanto as tags você deve usar as duas

<object> para o IE

<embed> para NE

 

tentei baixar o avi desse link que você passou:

http://192.168.1.223/ExemploASP_Local/Testes/globe.avi

 

o browser não encontrou..

 

esse script suporta qualquer tipo de midia que o windows media player do micro do usuário suporta

pode-se colocar até mesmo um avi do tipo divx, xvid, dede que o usuário tenha os codecs instalados

Share this post


Link to post
Share on other sites

×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.