Ir para conteúdo

The

Members
  • Total de itens

    6
  • Registro em

  • Última visita

Reputação

0 Comum

Sobre The

  • Classificação
    Th3_kill3r

Informações Pessoais

  • Sexo
    Masculino
  1. The

    404 Page Not Found - Codeigniter 3 Ubuntu

    Fala Pessoal, preciso de uma grande ajuda, sempre desenvolvi no ambiente windows e agora quero desenvolver no ambiente linux devido que é bem melhor que windows, instalei o ubuntu 14.04 LTS, após fazer a instalação fiz a instalação do apache2, php e mysql, nesta ordem: sudo apt-get update sudo apt-get install apache2 subiu o apache tudo certo, sem problemas instalei o mysql sudo apt-get install mysql-server php5-mysql depois sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt Até ai tudo certo, fiz o teste para saber o mysql, php e apache está ok.....e estava tudo certo salvei todos os meus arquivo de desenvolvimento e coloquei na pasta /var/www/html (a versão 14.04 colocou nesta pasta), configurei o banco de dados e o primeiro erro que deu foi que não era possível carregar a class session, fui em config e alterei para Session/session e o problema foi resolvido, a página index carrega normalmente, porém quando tento acessar qualquer página sem ser a index aparece o seguinte erro: 404 Page Not Found The page you requested was not found. com isso fui ver se o modo de escrita estava ativo, utilizo o .htaccess sudo a2enmod rewrite e o módulo estava ativo sudo gedit /etc/apache2/sites-available/000-default.conf acessei o arquivo e adicionei o seguinte código: ServerAdmin webmaster@localhost DocumentRoot /var/www/html <Directory "/var/www/html"> AllowOverride All </Directory> tbm fiz alterações no arquivo apache2.conf sudo gedit /etc/apache2/apache2.conf e deixei da seguinte forma: <Directory /var/www/html/> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory> mesmo assim continua dando erro, então mudei meu arquivo .htaccess: RewriteEngine on RewriteBase / RewriteCond $1 !^(index\.php|robots\.txt|interno|externo|application) RewriteRule ^(.*)$ /sociedade/index.php/$1 [L,QSA] mesmo assim continua com o mesmo problema, então fui na pasta application/config/config.php e fiz algumas alterações: $config['base_url'] = 'http://'.$_SERVER['SERVER_NAME'].'/sociedade'; $config['index_page'] = ''; $config['uri_protocol'] = 'AUTO'; e mesmo assim continua da mesma forma, quando acesso o meu desenvolvimento abre a primeira página que configurei no controller, mas quando tento navegar pelas página continua apresentando o erro 404 tbm dei permissão de escrita e leitura da pasta www sudo chmod -R 777 /var/www não sei o que fazer mais, alguém consegue me ajudar????? a primeira função ele executa, mas quando tentar abrir outra view dá o erro..... Fiquei em dúvida se postava aqui no PHP ou na área de linux, se tiver errado algum moderador pode mover para o lugar
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.