Ir para conteúdo

YumalaySc

Members
  • Total de itens

    15
  • Registro em

  • Última visita

  • Dias vencidos

    1

YumalaySc venceu o dia em Maio 2 2015

Teve o conteúdo mais curtido

Reputação

2 Comum

Sobre YumalaySc

Últimos Visitantes

123 visualizações
  1. YumalaySc

    Salvando texto em um TXT usando LOOP

    Vou formular melhor a pergunta! Quero um programa que faça isto em um loop: Pegar o texto (Que será informado em um textBox) Separa-los por um " ; " (Ponto e vírgula) Pegar um numero do loop atual Por fim salva-los em um documento txt no caso, neste formato (" texto;numero") EX: yumalay;000001 E sim, quero fazer isto para o mesmo texto sempre. apenas mudando os números que ficariam assim: yumalay;000001 yumalay;000002 yumalay;000003 yumalay;000..... yumalay;000999 yumalay;000.... yumalay;999999 Espero que tenhas entendido desta vez, e obrigado pela ajuda desde já!
  2. YumalaySc

    Salvando texto em um TXT usando LOOP

    Olá! Gostária a ajuda de vocês para salvar dados em um arquivo (TXT). Até o momento consegui fazer para salvar o arquivo, mas o que quero fazer é isto: Pegar um texto em uma textbox Fazer com que este texto seja "colado" em uma txt seguido de algo que o separe de um conjunto de numeros que seram dados de um loop, por exemplo Nome;001 Nome:002 Nome:... Nome:999 Sendo que deve ser delimitado o For tipo quero que sejam colocados 100 numeros, no caso de 0 a 99 Esperam que tenham entendido o que quiz dizer! Até o momento fiz um sistema para salvar e não consegui fazer o loop que salve os dados que quero, estou bem perdido e obviamente sou iniciante em VB! Vlw a atenção de todos! Imports System.IO Public Class Form1 Dim contador As Integer Dim arquivo As System.IO.File Dim escArquivo As System.IO.StreamWriter Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load End Sub Private Sub Button1_Click(sender As System.Object, e As System.EventArgs) Handles Button1.Click Dim separador As String = ";" Dim texto As String email = TextBox1.Text For contador As Integer = 0 To 999999 WriteLine(texto + separador + contador) Next Dim salvarArquivo As SaveFileDialog = New SaveFileDialog() Dim caminho As DialogResult Dim fluxoTexto As IO.StreamWriter Dim arquivo As String salvarArquivo.CheckFileExists = False salvarArquivo.Title = "Arquivo Texto |*.txt |" caminho = salvarArquivo.ShowDialog arquivo = salvarArquivo.FileName If arquivo = Nothing Then MessageBox.Show("Arquivo Inválido", "Salvar Como", MessageBoxButtons.OK) Else fluxoTexto = New IO.StreamWriter(arquivo) fluxoTexto.Write(txtLinhas.Text) fluxoTexto.Close() End If End Sub Private Function txtLinhas() As Object Throw New NotImplementedException End Function
  3. Amigo, estava elaborando um sistema para você entender melhor, porem estou sem tempo e o mesmo iria me reter por muito tempo. deixo abaixo um link lhe ensinando como calcular os numeros verificadores. http://www.geradorcpf.com/algoritmo_do_cpf.htm Espero que ajude.
  4. Ola Leandro, tudo certo? Fiz o algoritmo para lhe dar uma ideia, o mesmo nao trabalha com vetor, apenas soma dos dados (trabalhar com vetor e mais fácil, porem apenas quis lhe dar uma "luz". Se precisar de algo ou se meu código não condizer com oque deseja, só falar ) Obs Tem apenas cadastro de nome de usuário, para demais opções apenas adicione no codigo algoritmo "semnome" // Função : cadastrar novo user, imprimir os existentes // Autor : Eduardo Cipriani // Data : 04/06/2015 // Seção de Declarações var cont , validacao :inteiro uc , usuario : caracter inicio escreval("Programa Iniciado") escreval("Oque deseja fazer? informe o numero para realizar a operaçao") escreval("1° Cadastrar novo usuario?") escreval("2° Imprimir os existentes") escreval("3°Sair do programa") leia(validacao) // o usuario informe oque quer executar repita //comando repita (ele ira repetir ate o user digitar 3 olha no fim do comando) se(validacao = 1)entao // Se digitar 1 ele ira dar a opcao de cadastrar user escreval("Informe o nome do usuario") leia(usuario) // le o nome do usuario uc <- uc + " e " + usuario //"pega o usuario cadastrado e soma com os ja existentes e joga na variavel uc (usuarios cadastrados) cont <- cont + 1 // para validar se ja foram cadastrados usuario Ve na "validacao = 2" abaixo escreval("Deseja executar novamente? informe o numero correspondente") // leia(validacao) // valida se quer executar novamente fimse se(validacao = 2)entao // valida para que se o user digitar 2 imprima os usuarios cadastrados se(cont > 0)entao // valida para ver se tem algum user cadastrado escreval("Usuarios Cadastrados;") escreval(uc) //mostrar os usuarios cadastrados escreval("Deseja executar novamente? informe o numero correspondente") leia(validacao) // valida se quer executar novamente senao escreval("Nenhum usuario cadastrado") escreval("Deseja executar novamente? informe o numero correspondente") leia(validacao) // valida se quer executar novamente fimse fimse se(validacao = 3)entao // Se for digitado 3 exibe a mensagem abaixo escreval("Obrigado por utilizar o programa") fimse ate validacao = 3 // Se o usuario digitar 3 o programa e finalizado //espero que tenha lhe ajudado. qualquer duvida so pedir. escreval("Programa finalizado") fimalgoritmo Comentei o código inteiro, espero que ajude.
  5. YumalaySc

    Como desenvolver uma Vitrola Online ?

    Ola amigo, a forma mais simples e utilizando HTML + CSS (codificação) porem de certa forma oque você esta falando e possível fazer apenas com imagens. (1 imagem com vários produtos nela, feita em PS)
  6. YumalaySc

    Portugol Exercicios

    Insano, por exemplo Dada uma sequência de 4 números, elabore um algoritmo que calcule a média dos valores positivos (ou nulos), ou seja, ignorando os valores negativos. você apenas necessita verificar se o numero e positivo e depois ler os quatro números e dividi-los por 4; Exemplo: algoritmo "semnome" // Função : ajudar alguem que nao faz a tarefa // Autor : Eduardo Cipriani // Data : 03/06/2015 // Seção de Declarações // Estude garoto, estudo. var n: inteiro media : real inicio media <- 0 //Zera a variavel media para nao dar erro //--------------------------------------------------1 leia(n) //le um numero se(n < 0)entao escreval("Informe um numero positivo") senao media <- media + n fimse //--------------------------------------------------2 leia(n) //le um numero se(n < 0)entao escreval("Informe um numero positivo") senao media <- media + n fimse //--------------------------------------------------3 leia(n) //le um numero se(n < 0)entao escreval("Informe um numero positivo") senao media <- media + n fimse //--------------------------------------------------4 leia(n) //le um numero se(n < 0)entao escreval("Informe um numero positivo") senao media <- media + n fimse //----ate aqui leu 4 valores, sendo que sua media e calculada apartir disto media <- (media / 4) // media recebe media dividido por 4 (que e o numero de nota) escreval("A media e: ",media) //escreve a media fimalgoritmo Fiz o algoritmo da forma mais difícil que consegui, pois pelo que percebi voce esta começando, por isso fiz de forma longa mas daria de fazer assim: algoritmo "semnome" // Função : pegar 4 notas e dar a media // Autor : Eduardo Cipriani // Data : 03/06/2015 // Seção de Declarações var n , k: inteiro media : real inicio media <- 0 para k de 1 ate 4 faca leia(n) se(n < 0)entao escreval("Informe um numero positivo") senao media <- media + n fimse fimpara escreval("A media e: ",media / 4) fimalgoritmo Espero que lhe ajude, porem analise o primeiro algoritmo! o segundo você encontrara em pouco tempo! Bons estudos,
  7. YumalaySc

    Portugol Exercicios

    Todos estes exercícios já estão respondidos aqui no fórum! use a busca, porem grande maioria e pequeno e de fácil criação, tente, se você ler, escrever e atribuir valor já da de fazer a maioria! Bons estudos.
  8. YumalaySc

    exercício

    Amigo, Não consegui compreender seu código. você não iniciou o Repita, porem o finalizou, use a opção "codigo" no painel de postagem do fórum, ele ajuda a compreender melhor, Simbolo para essa opção e um "<>" em azul. refiz seu código pois não entendi o sentido dele acima. qualquer duvida só pedir algoritmo "semnome" // Função : ler varios numeros inteiros, mostrar qual o menor e dar a opçao de fim ao usuario // Autor : Eduardo Cipriani // Data : 27/05/2015 // Seção de Declarações var n , menor : inteiro pergunta : caracter inicio menor <- 100000 //joguei um numero alto para que todos os numeros digitados sejam menores, n sei outra maneira de validar isto escreval("Deseja executar o programa? Digite Sim") leia(pergunta) repita escreval("Informe um numero!") leia(n) se(n < menor)entao menor <- n fimse escreval("Deseja executar novamente?") leia(pergunta) ate pergunta = "Nao" escreval("O menor numero digitado e: ",menor) fimalgoritmo
  9. YumalaySc

    Esperava encontrar então (VisuAlg)

    Use o se sal=<700 entao assim: se(sal <= 700) entao Provavelmente é por sintaxe incorreta. Se não resolver fale.
  10. Fazendo isto apresentara todos os números não-pares como numeros primos, sendo que nem todo numero impar é primo. pelo que entendi kk. mas vlw a tentativa mesmo assim. :yes:
  11. Exercício semelhante ao postados pelo caaaike, porem pede para que mostre os números primos. Tentei fazer porem não consegui. Faça um programa que receba N números inteiros e mostre quais são números primos dentre os números que foram digitados. De preferência deve-se usar "enquanto...faz." Porem não sei se esta 100% certo, pois não sei como testar todos os números primos algoritmo "semnome" // Função : Verificar em exibir quais numeros digitados são primos. // Autor : Eduardo Cipriani // Data : 30/04/2015 // Seção de Declarações var n,numero , k : inteiro inicio leia(n) para k de 1 ate n faca numero <- numero +1 // Para fazer a contagem automatica, irei mudar depois para o usuario passar o numero que quer ver se é primo se(numero = 2) entao // Se o numero dois for informado ja o mostra escreval("O numero",numero," é primo") fimse se(numero mod 2 = 1) entao // este é meu problema, aqui verifico apenas se é impar, e não se é primo. se(numero = 1) entao // se numero for 1 (que não é primo) passe-o para 2 que é primo (isto apenas para contagem automatica) numero <- + 1 senao escreval("O numero",numero," é primo") fimse fimse fimpara fimalgoritmo
  12. YumalaySc

    Algoritmos (visualg)

    Bruno, No final desta playlist tem o vídeo que você precisa. (Prof. Gustavo Guanabara.) https://www.youtube.com/playlist?list=PLHz_AreHm4dmSj0MHol_aoNYCSGFqvfXV
  13. YumalaySc

    algoritimo no portugol

    algoritmo "hh/mm/ss" // Função : Calcular Hora minuto e segundo referente aos segundos do dia. // Autor : Eduardo Cipriani // Data : 26/04/2015 // Seção de Declarações var segundos ,k ,h , m , s : inteiro inicio leia(segundos) //lê os segundos que seram examinados k <- 1 // da um valor inicial para cada variavel h <- 0 m <- 0 s <- 0 se(segundos > 86400) entao // Se segundos foram maiores que os de um dia, exibira uma mensagem de erro. (o programa calcula no maximo 24h) escreval("Este algoritmo não calcula Dias, informe até 58764 Segundos.") fimse se(segundos < 86401) entao // Se os segundos informados estiverem dentro de 24h (86400 Segundos) entao executara o laço abaixo para k de 1 ate segundos faca // Fara o loop de 1 ate os segundos s <- s + 1 // A cada vez q passa aq S Recebe o seu valor +1 se(s = 60) entao //se S for igual a 60 (60 é os segundos, 60 segundos é um minuto, portanto... )/ m <- m + 1 // m (de minuto) vai ser o seu valor e +1 s <- 0 // o segundos são zerados (pois você reinicia sempre que chega a 60) fimse se(m = 60) entao // o mesmo processo dos segundos acima, porem agora com minutos h <- h + 1 // como nos minutos acima, porem agora passa a ser hora. m <- 0 fimse fimpara fimse escreval("A hora referente aos segundos informados é: ",h," /",m," /",s) // mostra a hora , Minuto , Segundo. // Obs: Espero que ajude. Se precisar de mais alguma coisa só falar. fimalgoritmo Comentei, fiz o mais explicado que consegui. porem se mesmo assim precisar de ajuda. Peça sobre o ponto exato que esta com dúvida.
  14. YumalaySc

    Programação e Algoritmos

    Poste oque você ja fez para podermos lhe ajudar. algoritmo "semnome" // Função :Ler N valores e mostrar a soma e a media dos que forem maiores que 20 // Autor : Eduardo Cipriani // Data : 26/04/2015 // Seção de Declarações var k ,n , numero, media, soma, cont : inteiro inicio leia(n) // le o quantos numeros seram pedidos, no seu caso 13 media <- 0 //Zera a variavel media soma <- 0 para k de 1 ate n faca // Faz a contagem de 1 até o numero pedido (no seu caso n = 13) leia(numero) // Lê os numeros que queres ver se são maiores que 20 se(numero > 19) entao // Se o numero for igual ou maior que vinte ele.. soma <- soma + numero media <- media + numero cont <- cont + 1 //cont serve para dividir a media no final fimse fimpara // Imprime os dados requeridos. escreval("A soma dos ",cont," numeros maiores que 20 digitado é: ",soma) escreval("A media dos ",cont," numero maiores que 20 digitados é: ",media / cont) fimalgoritmo O codigo está ai. Porem amigo, Analise-o, não copie apenas.
  15. YumalaySc

    algoritimo no portugol

    algoritmo "hh/mm/ss" // Função : Calcular Hora minuto e segundo referente aos segundos do dia. // Autor : Eduardo Cipriani // Data : 26/04/2015 // Seção de Declarações var segundos ,k ,h , m , s : inteiro inicio leia(segundos) k <- 1 h <- 0 m <- 0 s <- 0 se(segundos > 86400) entao escreval("Este algoritmo não calcula Dias, informe até 86400 Segundos.") fimse se(segundos < 86401) entao para k de 1 ate segundos faca s <- s + 1 se(s = 60) entao m <- m + 1 s <- 0 fimse se(m = 60) entao h <- h + 1 m <- 0 fimse fimpara fimse escreval("A hora referente aos segundos informados é: ",h," /",m," /",s) fimalgoritmo Tente este, Não comentei, porem se precisar só pedir, também não utilizei os segundos que você passou, e sim os de um dia. Qualquer dúvida só falar.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.