Jump to content

YumalaySc

Members
  • Content count

    15
  • Joined

  • Last visited

  • Days Won

    1

YumalaySc last won the day on May 2 2015

YumalaySc had the most liked content!

Community Reputation

2 Comum

About YumalaySc

Recent Profile Visitors

507 profile views
  1. YumalaySc

    Salvando texto em um TXT usando LOOP

    Vou formular melhor a pergunta! Quero um programa que faça isto em um loop: Pegar o texto (Que será informado em um textBox) Separa-los por um " ; " (Ponto e vírgula) Pegar um numero do loop atual Por fim salva-los em um documento txt no caso, neste formato (" texto;numero") EX: yumalay;000001 E sim, quero fazer isto para o mesmo texto sempre. apenas mudando os números que ficariam assim: yumalay;000001 yumalay;000002 yumalay;000003 yumalay;000..... yumalay;000999 yumalay;000.... yumalay;999999 Espero que tenhas entendido desta vez, e obrigado pela ajuda desde já!
  2. Olá! Gostária a ajuda de vocês para salvar dados em um arquivo (TXT). Até o momento consegui fazer para salvar o arquivo, mas o que quero fazer é isto: Pegar um texto em uma textbox Fazer com que este texto seja "colado" em uma txt seguido de algo que o separe de um conjunto de numeros que seram dados de um loop, por exemplo Nome;001 Nome:002 Nome:... Nome:999 Sendo que deve ser delimitado o For tipo quero que sejam colocados 100 numeros, no caso de 0 a 99 Esperam que tenham entendido o que quiz dizer! Até o momento fiz um sistema para salvar e não consegui fazer o loop que salve os dados que quero, estou bem perdido e obviamente sou iniciante em VB! Vlw a atenção de todos! Imports System.IO Public Class Form1 Dim contador As Integer Dim arquivo As System.IO.File Dim escArquivo As System.IO.StreamWriter Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load End Sub Private Sub Button1_Click(sender As System.Object, e As System.EventArgs) Handles Button1.Click Dim separador As String = ";" Dim texto As String email = TextBox1.Text For contador As Integer = 0 To 999999 WriteLine(texto + separador + contador) Next Dim salvarArquivo As SaveFileDialog = New SaveFileDialog() Dim caminho As DialogResult Dim fluxoTexto As IO.StreamWriter Dim arquivo As String salvarArquivo.CheckFileExists = False salvarArquivo.Title = "Arquivo Texto |*.txt |" caminho = salvarArquivo.ShowDialog arquivo = salvarArquivo.FileName If arquivo = Nothing Then MessageBox.Show("Arquivo Inválido", "Salvar Como", MessageBoxButtons.OK) Else fluxoTexto = New IO.StreamWriter(arquivo) fluxoTexto.Write(txtLinhas.Text) fluxoTexto.Close() End If End Sub Private Function txtLinhas() As Object Throw New NotImplementedException End Function
  3. YumalaySc

    Programação e Algoritmos

    Poste oque você ja fez para podermos lhe ajudar. algoritmo "semnome" // Função :Ler N valores e mostrar a soma e a media dos que forem maiores que 20 // Autor : Eduardo Cipriani // Data : 26/04/2015 // Seção de Declarações var k ,n , numero, media, soma, cont : inteiro inicio leia(n) // le o quantos numeros seram pedidos, no seu caso 13 media <- 0 //Zera a variavel media soma <- 0 para k de 1 ate n faca // Faz a contagem de 1 até o numero pedido (no seu caso n = 13) leia(numero) // Lê os numeros que queres ver se são maiores que 20 se(numero > 19) entao // Se o numero for igual ou maior que vinte ele.. soma <- soma + numero media <- media + numero cont <- cont + 1 //cont serve para dividir a media no final fimse fimpara // Imprime os dados requeridos. escreval("A soma dos ",cont," numeros maiores que 20 digitado é: ",soma) escreval("A media dos ",cont," numero maiores que 20 digitados é: ",media / cont) fimalgoritmo O codigo está ai. Porem amigo, Analise-o, não copie apenas.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.