Jump to content

capoia

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Comum

About capoia

  1. Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo . Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1) Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar: valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores... Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável... espero que possam me ajudar. meu código ficou assim : Algoritmo "Valores e Média" // Linguagem e Lógica de Programação // // Descrição : Recebe x valores e calcula a média // Autor(a) : Wellington Capoia // Data atual : 20/4/2016 Var // Seção de Declarações das variáveis media, valores, cont, resultado, valoressomados: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... cont <- 0 valores <- 0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") enquanto valores <> -1 faca escreval ("Digite os valores:") leia (valores) valores <- valores+valores cont <- cont+1 fimenquanto escreval ("valores somados", valoressomados) cont <- cont-1 escreval ("Valores digitados:", cont) resultado <- valoressomados/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.