Jump to content

capoia

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Comum

About capoia

  1. capoia

    [DUVIDA]ELIF

    Boa noite, sou estudando e agora estou aprendendo phyton na faculdade, o professor deu o seguinte enunciado : 1. Elabore um código (função) que peça o nome do usuário e o armazene em uma variável. 2. Obtenha o tamanho do nome inserido e armazene-o em outra variável. 3. Utilize a biblioteca RANDOM para gerar um número aleatório. 4. Faça um laço de repetição onde a quantidades de chances que o usuário terá de acertar o número será igual a quantidade de letras do nome inserido. 5. Se o usuário acertar o número, retorne algum indicativo de acerto. Se não, retorne algum indicativo de que ele errou. 6. Na função principal, faça um laço de repetição para verificar se o usuário acertou a última rodada ou não. Dependendo do retorno, elabore um placar, onde será contabilizado a cada rodada, quantas vitórias e quantas derrotas o usuário teve. 7. Verifique se o usuário deseja continuar jogando para permanecer dentro do laço. Caso contrário, termine o programa. então eu fiz o seguinte código: import random def nome(): nome = input ('Informe seu nome: ') print('O tamanho do seu nome é: ' + str(len(nome))) qtdnome = str(len(nome)) return int(qtdnome) def tente(qtdnome): naleatorio = random.randint(1,15) while qtdnome > 0: print ('Digite um numero maior que 0: ' + int(input(palpite))) qtdnome = qtdnome -1 if int(palpite) == naleatorio: print ('Parabens! Voce ganhou , o numero aleatorio era: ' + naleatorio) return 1 elif palpite <= 0: print ('Voce digitou um numero invalido') qtdnome = qtdnome++ else: print ('Voce errou, tente novamente!') if qtdnome == 0: print ('Voce perdeu!') return 0 ## Começo do algoritmo! ## qtdnome = nome() print ('Suas chances sao: '+ qtdnome) print ('Deseja jogar? Digite 1 para jogar: ') jogarnovamente = input while jogarnovamente == 1: resultado = tente() if resultado == 1: print ('Voce acertou da ultima vez!') acertos = acertos++ else: print ('Voce errou da ultima vez!') erros = erros++ print ('Total de vezes que voce acertou: ' + acertos) print ('Total de vezes que voce errou: ' + erros) Porem na hora de compilar ele fala que tem erro ali na linha do ELIF , mais precisamente deixa selecionado em vermelho o elif ! Sou iniciante ainda e ele não especifica o erro, fica difícil de eu achar, alguém poderia me explicar?
  2. Ual , muito obrigado , mais claro que isso impossível , obrigado mesmo pela ajuda, me deu uma aula agora :)
  3. Tive que ler algumas vezes kk mas acho que entendi .... então ali no caso o CN vai contar quantas vezes foi divisível né? ( quantas vezes o mod deu zero ) e se for 2 ele exibe esse numero , correto?
  4. Boa tarde, estou aqui novamente pedindo uma ajuda, não quero que vocês pensem que quero que faça minhas tarefas ou algo do tipo é só porque não consegui encontrar mesmo , meu professor de algoritmo passou pra acharmos os números primos de 1 a 500 .. eu sei que para achar o numero primo ele tem que ser divisível por 1 e por ele mesmo ... e somente por essas duas opções. eu achei o seguinte algoritmo pesquisando pela net : Var // Seção de Declarações das variáveis n, cn, i, dv: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para i de 1 ate 500 faca cn <- 0 para dv de 1 ate i faca se (i % dv = 0) entao cn <- cn + 1 fimse fimpara se cn = 2 entao escreval ("Primo: ", i, " ") fimse fimpara Fimalgoritmo e ele realmente funciona .. só que eu não consigo entender o código , porque ai ele verifica o mod para ver se é 0 e ai conclui que é divisível pelo próprio numero e por 1 , entendi , porem como garante que não é divisível por outros números? alguém pode por favor me explicar? desde já agradeço.
  5. Boa tarde, sou novo por aqui , comecei a fazer sistema da informação a pouco tempo . Na aula de ontem o professor pediu pra fazermos um exercício em portugol que recebe x números , e depois faz a media dos mesmos ( e quando quiser parar e receber a media a pessoa digita -1) Eu fiz praticamente todo , ta tudo correto , só não consigo fazer com q os valores que a pessoa coloca vão se somando... eu tentei colocar: valores <- valores+valores para ele pegar o valor q a pessoa colocou e somar com o valor novo ... mas não sei porque quando coloco isso ele entra em looping e quando digito -1 ele n para , continua pedindo pra digitar os valores... Não sei se entenderam oque quis dizer , mas preciso q o algoritmo receba um valor , guarde esse valor na variável "valores" depois quando for repetir o laço pela segunda vez ele pegue esse valor armazenado e some com o valor novo e assim sucessivamente , o problema e q eu não sei quantos valores a pessoa vai por é infinito ... por isso não posso por simplesmente n1+n2 , é um variável com outra variável... espero que possam me ajudar. meu código ficou assim : Algoritmo "Valores e Média" // Linguagem e Lógica de Programação // // Descrição : Recebe x valores e calcula a média // Autor(a) : Wellington Capoia // Data atual : 20/4/2016 Var // Seção de Declarações das variáveis media, valores, cont, resultado, valoressomados: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... cont <- 0 valores <- 0 escreval ("Algoritmo para receber um numero x de valores e calcular média") escreval ("Para para calcular a média digite -1 a qualquer momento") enquanto valores <> -1 faca escreval ("Digite os valores:") leia (valores) valores <- valores+valores cont <- cont+1 fimenquanto escreval ("valores somados", valoressomados) cont <- cont-1 escreval ("Valores digitados:", cont) resultado <- valoressomados/cont escreval ("A média dos valores é:", resultado) Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.