Ir para conteúdo

ph1

Members
  • Total de itens

    8
  • Registro em

  • Última visita

Reputação

0 Comum

Sobre ph1

  • Data de Nascimento 12/11/1968

Informações Pessoais

  • Sexo
    Masculino
  • Localização
    Rio de Janeiro
  • Interesses
    Carros, técnologia, ficção científica, cinema, livros.
  1. //#include <iostream> #include <cstdlib> #include <stdio.h> using namespace std; int main() { setlocale(LC_ALL, "Portuguese"); int a,b,c,d,i,e,f,g,h; cout << "Entre com os valores da primeira fracao: "; cin >> a; cin >> b; cout << "Entre com os valores da segunda fracao: "; cin >> c; cin >> d; e = ((a*d)+(b*c)); f = b * d; congela aqui: cout << "A soma das fracoes é: " << e << "/" << f << "\n"; //i = 0; //if (e % i == 0) || (f % i == 0) //dessa forma não pode, parenteses isolados. if (e % i == 0 || f % i == 0)//correto //if ((e % i == 0) || (f % i == 0))//correto cout << "A simplificação nao é possivel\n"; /* for (i=2;i<=10;i++) { if((e % i != 0) || (f % i != 0)) { g = e / i; h = f / i; cout << "\nO resultado da simplificação da fracao é:\n " << g << "/" << h; } */ system("pause"); return 0; } } Tentei de vários maneiras, e descobri que quando chega para mostrar o resultado da fração, o programa congela, não sei qual o motivo, para mim está montado certo. Será que é o tipo de variável? Obrigado.
  2. ph1

    Sequência de números 36X37/1...

    Obrigado, vou alterar o código e ver se funciona.
  3. ph1

    Série de sequência numérica

    Fiz o exercício, mas não sei porque não está funcionando. { Escreva um algoritmo que calcule e escreva a soma dos dez primeiros termos da seguinte serie: 2/500 - 5/450 + 2/400 - 5/350 + ... } #include <iostream> #include <cstdlib> #include <stdio.h> using namespace std; int main() { setlocale(LC_ALL, "Portuguese"); int i, denominador; float s; denominador = 500; s = 0; for (i=1;i<=10;i++) { if ((i % 2) != 0) { s = s + (2/denominador); } else { s = s - (5/denominador); } denominador = denominador - 50; cout << s << "/" << denominador; } return 0; } Dá sempre 0250. Não descubro o erro.
  4. ph1

    Sequência de números 36X37/1...

    Eu estou no início do treinamento. Fiz um pequeno algoritmo no qual há uma sequência de números e começa de 36 X 37 / 2 + 35 X 36 /3 + ... 1 X 2 / 37. int deno,a,b; a = 37; b = 38; for (deno=1;deno<=38;deno++){ a = a - 1; b = b - 1; cout << a << " X " << b << "/" << deno << "\n"; O problema está no final da impressão, quando chega ao final é impresso -1 X 0 / 38. Quero que termine com 0 X 0 / 38.
  5. ph1

    Média dentro de repetição dando negativo.

    #include <iostream> #include <cstdlib> #include <locale.h> using namespace std; int main(void) { setlocale(LC_ALL, "Portuguese"); float porcentagem,contador,acumulador,altura,menor,maior,media,altura_t; int resposta,resp,i,homem,pessoas,contm; porcentagem, contador, acumulador, altura,menor,maior,media,altura_t=0; contm = 0; resp = 0; resposta = 0; homem = 0; cout << "Entre com a altura, digite -1 para sair: "; cin >> altura_t; maior = altura_t; menor = altura_t; while (altura_t != -1) { if (altura_t == 0) { maior = altura_t; menor = altura_t; altura_t++; } if (altura_t > maior) maior = altura_t; else if (altura_t < menor) menor = altura_t; cout << "Entre com a altura, digite -1 para sair: "; altura_t++; cin >> altura_t; } while (resposta != -1) { if (resposta != -1) if (resposta == 1) { acumulador = acumulador + altura; //altura++; cout << "Entre com a altura da mulher, digite -1 para sair: "; contm++; cin >> altura; } else if (resposta == 2) { homem++; } cout << "Para sair digite -1, dê enter para continuar. \n"; cout << "Escolha, 1 para mulher, 2 para homens: \n"; cin >> resposta; } porcentagem = altura_t * 100 / contm; //está dando negativo no resultado. //porcentagem = (acumulador * contm ) / 100; //z = (x / y) * 100; media = acumulador / contm; cout << "A maior altura é: " << maior << " e a menor altura é: " << menor << "\n"; cout << "O número de homens é de:" << homem << "\n"; cout << "A porcentagem de mulheres em relação ao total de pessoas é de: " << porcentagem << "\n"; cout << "A média de altura das mulheres é de: " << media << endl; } Desculpe se coloque este tópico, mas acho que não coloquei anteriormente. Minha dúvida é porque a porcentagem de mulheres dentro do total de pessoas está dando negativo. Obrigado.
  6. ph1

    Dificuldade em exercício

    Perfeito, entendi a lógica do programa. Tudo é feito encima de i e não de n, n é só para colocar um limite no número de iterações. Muito obrigado pela ajuda. Fiz um rascunho e um tipo de teste de mesa. Obrigado.
  7. ph1

    Dificuldade em exercício

    Calcular e imprimir a média aritmética dos números inteiros positivos ímpares inferiores ou iguais a um número N lido inicialmente. #include <cmath> // ou <math.h> #include <iostream> #include <cstdlib> #include <locale.h> #include <iomanip> using namespace std; int main() { setlocale(LC_ALL, "Portuguese"); float m,acm; int cont,n; acm = 0; cout << "Entre com um número qualquer.:\t"; cin >> n; for (cont = 0;cont <= n;n++) { if ((n % 2)==1) { acm = acm + 1; m = acm / n; } else if ((n % 2) == 0) { cout << "O número não é ímpar."; } } cout << "A média dos" << n << " números ímpares é de:\t" << m; } Estou com com dificuldade nesse exercício. Porque está dando loop infinito? Não descubro o erro.
  8. Prazer para todos. Fiz este exercício para calcular as calorias gastas em uma refeição. Entra com prato, bebida e sobremesa. O problema está em comparar as strings. O VisualG não aceita a comparação. Por exemplo, entro com a string carne, o programa diz: esperava encontrar então na linha se (prato = carne) então. Não há explicação possível para esse problema. Não sei onde está o erro, para mim, a lógica está correta. Obrigado. Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 02/10/2017 Var // Seção de Declarações das variáveis cal1,cal2,cal3,p1,p2,p3,caltotal:inteiro prato,bebida,sobremesa:caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Entre com o prato") leia (prato) escreval(prato) se (prato = carne) então cal1 <- 350 senão se (prato = peixe) então cal1 <- 230 senão se (prato = frango) então cal1 <- 250 senão cal <- 180 fimse fimse fimse escreval("Entre com a bebida") leia (bebida) se (bebida = cha) então cal2 <- 20 senão se (bebida = suco de laranja) então cal2 <- 100 senão se (bebida = suco de melao) então cal2 <- 100 senão se (bebida = refrigerante diet) então cal <- 65 fimse fimse fimse fimse escreval("Entre com a sobremesa") leia (sobremesa) se (sobremesa = abacaxi) então cal3<- 75 senão se (sobremesa = sorvete diet) então cal <- 110 senão se (sobremesa = mouse diet) então cal3 <- 170 senão se (sobremesa = mouse chocolate) então cal <- 200 fimse fimse fimse fimse senão escreval ("Opção inválida.") caltotal <- cal1 + cal2 + cal3 escreval("O prato escolhido foi: ",prato) escreval("A bebida escolhida foi: ",bebida) escreval("A sobremesa escolhida foi: ",sobremesa) escreval("O total de calorias é de: ",caltotal) Fimalgoritmo
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.