Jump to content

GabrielMoura

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Comum

About GabrielMoura

Contato

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. GabrielMoura

    Matriz em Python

    Boa noite pessoal, Estou construindo uma matriz em Python, mas estou com dificuldade na hora do print. Segue o meu código: linhas = 4 entrada = input() valor = entrada.split() matriz = [] while (entrada != ''): for i in range(linhas): linha = [] for j in range(len(valor)): valor[j] = int(valor[j]) linha.append(valor[j]) matriz.append(linha) entrada = input() print(*matriz, sep='\n') Quando digito: 1 2 3 4 5 6 7 8 A impressão é: [1, 2, 3, 4] [1, 2, 3, 4] Alguém pode me ajudar? Obrigado
  2. Boa noite pessoal, Sou novo aqui no fórum, então um Oi para todos. Sou novo na programação e estou com um exercício que está difícil de resolver. Uso VisualG para testar. Preciso inserir uma palavra e apresentar como saída a inversão de duas em duas letras. Exemplo: digitar a palavra EXEMPLO e ter como saída: XEMELPO, inclusive quando a palavra tiver um número ímpar de letras a última não modifica. Já tentei alguma coisa, mas não sei se uso vetor mesmo, em todos os exemplos de inversão de palavras o vetor é usado. Alguém pode me dar uma luz? Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 26/10/2018 // Seção de Declarações var palavra: caracter vet: vetor [1..30] de caracter tamanho: inteiro i: inteiro inicio escreva ("Digite uma palavra: ") leia (palavra) tamanho <- compr (palavra) escreva ("A palavra tem ", tamanho, " letras.") para i de 1 ate tamanho faca se ((i mod 2) = 0) entao vet <- vet [i+1] fimse palavra <- vet fimpara escreva ("A palavra agora é ", palavra) fimalgoritmo Obrigado desde já.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.