Jump to content

TheLord23

Members
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Comum

About TheLord23

  1. ESTOU COMEÇANDO AGORA NA PROGRAMAÇÃO COM VISUALG E TERIA QUE COLOCAR ESTE CODIGO EM UM LAÇO DE REPETIÇÃO. POREM NÃO ESTOU CONSEGUINDO PODERIAM ME AJUDAR ? SÓ PENSANDO QUE O USUÁRIO IRA DIGITAR O TAMANHO DO VETOR, APOS ISSO CADA OPÇÃO QUE ELE ESCOLHER E ELA SER EXECUTADA DE FORMA CORRETA ELE VOLTARA PARA O MEUNU PRINCIPAL DAS OPÇÕES ATE QUE ELE SELECIONE A OPÇÃO "F" POREM TENTEI ESCREVELO USANDO ENQUANTO MAS ACABOU QUE EU NÃO CONSIGO PREVINIR OS ERROS DO USUÁRIO QUANDO ELE COLOCA AS INFORMAÇÕES TIPO: -ARMAZENAR UM NÚMERO NO VETOR E ESSE NÚMERO NÃO SER SOBRESCREVIDO ATE QUE O PROGRAMA SEJA ENCERRADO -SE ELE DIGITAR PRA BUSCAR OU INSERIR O NÚMERO ZERO O PROGRAMA INFORMAR QUE O VALOR É INVÁLIDO TENTEI USAR PROCEDIMENTOS E FUNÇÕES MAS OS ERROS CONTINUARAM. Algoritmo "DESAFIO" Var AUX,CONTADOR,BUSCAR:INTEIRO POSICAO,AUX_TEMP:INTEIRO OPCAO:CARACTERE RESULT_BUSCA: LOGICO SOMA_VET:REAL NUMERO:VETOR[1..500]DE INTEIRO Inicio ESCREVAL("*********************************") ESCREVAL("* CADASTRO DE VETORES - DESAFIO *") ESCREVAL("*********************************") ESCREVA("DIGITE O TAMANHO DO VETOR A SER CADASTRADO: ") LEIA(AUX) NUMERO[AUX] <- AUX ESCREVAL("A - Cadastrar um novo número;") ESCREVAL("B - Buscar um número") ESCREVAL("C - Excluir um número;") ESCREVAL("D - Listar os números cadastrados;") ESCREVAL("E - Exibir a soma dos números do vetor;") ESCREVAL("F - Sair do sistema.") LEIA(OPCAO) OPCAO <- MAIUSC(OPCAO) ESCOLHA OPCAO CASO "A" PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA ESCREVA("DIGITE O VALOR QUE SERÁ ARMAZENADO NA",CONTADOR,"ª POSIÇÃO DO VETOR: ") LEIA(NUMERO[CONTADOR]) FIMPARA CASO "B" ESCREVA("QUAL NÚMERO DESEJA ENCONTRAR: ") LEIA(BUSCAR) PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA SE NUMERO[CONTADOR] = BUSCAR ENTAO RESULT_BUSCA <- VERDADEIRO POSICAO <- CONTADOR FIMSE FIMPARA PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA ESCREVAL(NUMERO[CONTADOR]) FIMPARA ESCREVAL("") ESCREVAL("---------") SE RESULT_BUSCA = VERDADEIRO ENTAO ESCREVAL("O NÚMERO",BUSCAR,"FOI ENCONTRADO E ESTA NA POSIÇÃO",POSICAO) SENAO ESCREVAL("O NÚMERO NÃO FOI ENCONTRADO !") FIMSE CASO "C" escreval("QUAL NÚMERO DESEJA EXCLUIR DO VETOR: ") leia(BUSCAR) SE NUMERO[CONTADOR] = BUSCAR ENTAO NUMERO[CONTADOR] <- 0 ESCREVAL("O NÚMERO",BUSCAR,"NA POSIÇÃO",POSICAO,"DO VETOR FOI EXCLUIDO !") FIMSE PARA CONTADOR DE 1 ATE NUMERO[AUX] PARA AUX DE CONTADOR + 1 ATE AUX FACA SE NUMERO[AUX] > NUMERO[CONTADOR] AUX_TEMP <- NUMERO[AUX] NUMERO[AUX] <- NUMERO[CONTADOR] NUMERO[CONTADOR] <- AUX_TEMP FIMPARA FIMPARA ESCREVA("VALROES DO VETOR: ") PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA ESCREVAL(NUMERO[CONTADOR]) FIMPARA CASO "D" ESCREVA("VALORES DO VETOR: ") PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA ESCREVAL(NUMERO[CONTADOR]) FIMPARA CASO "E" PARA CONTADOR DE 1 ATE NUMERO[AUX] FACA SOMA_VET <- SOMA_VET + NUMERO[CONTADOR]] FIMPARA ESCREVAL("") ESCREVA("A SOMA DO VETOR É:",SOMA_VET) CASO "F" ESCREVAL("ENCERRANDO SISTEMA...") OUTROCASO ESCREVAL("OPÇÃO INVÁLIDA !") FIMESCOLHA Fimalgoritmo
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.