Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''funções''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 30 registros

  1. Me foi passado um trabalho de faculdade que consiste em: imagine um vetor inicialmente vazio com capacidade CAP. cria um programa que através de um menu permita o usuário inserir um novo numero remover um valor remover o elemento de uma determinada posição alteração de um valor por outro buscar determinado valor e dizer sua posição (caso exista) exibição de todos os elementos do vetor quero algumas ideias de como começar, quais funções, variáveis usar. sou bastante leigo nesse assunto.
  2. Bom dia, estou com uma dificuldade em um algoritmo para um jogo da forca em VisuALG, o algoritmo foi solicitado para um trabalho e um dos requisitos é que ele tenha uma função, como vocês podem ver foi colocado uma função, porém a professora disse que aquela função não retorna nenhum valor, e por isso ela se encaixa como procedimento, pesquisei, tentei e não conseguir encaixar uma função nesse algorítimo, queria acrescentar também a cada final de rodada a opção de jogar ou não novamente. desde já agradeço a ajuda. abaixo segue o Algorítimo - obs o visuALG utilizado foi o 2.0 algoritmo "Jogo da forca" var op,frutas,ne,na:inteiro //op: opçao, ne: numero erro, na:numero de acertos l1,l2,l3,l4,l5,l6,l7,ld1,ld2,ld3,ld4,ld5,ld6,ld7,dig,verifica:caracter //linhas(l1,l2,l3...) serão usadas para o aleatorio, já as ld (ld1, ld2, ld3) serão usadas para verificar o acerto V,D:Caracter funcao Derrota () :caracter inicio Escreval("============================================================") escreval("============================================================") escreval escreval(" --------- FIM DE JOGO! ------- ") ESCREVAL ESCREVAL(" --------- GAME OVER =( ------- ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao funcao vitoria () : caracter inicio limpatela Escreval("============================================================") escreval("============================================================") escreval escreval(" PARABÊNS VOCE VENCEU! ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao inicio aleatorio on // ativa o modo aleatorio fonte, palavra on é opcional aleatorio 1,7 // seleciona o ranger do aleatorio, é preciso definir para o comando ter as opção para escolha leia (frutas) // todo leia vai ser lançado um numero aleatorio nesse caso de 1 a 3 aleatorio off // desativa o modo aleatorio, assim ele escolher uma das opções das palavras. limpatela // limpa tela repita // (repita 1) repitir o comando ate achar o comando interrompa escreval("---SEJA BEM VINDO---") escreval escreval(" ---JOGO DA FORCA--- ") escreval("Autores: Charles Ramos, Pedro Duca, Richard Vepo") escreval escreval escreval("Digite 1 para jogar e 0 para sair") leia(op) escolha op // verificar qual opção foi selecionada caso 0 //sair escreva("você escolheu a opção 0 para sair") escreval escreval fimalgoritmo // encerrar o algoritmo caso 1 interrompa // para o loop de escolher opção outrocaso // caso digite algo diferente de 0 ou 1 ele vai limpar a tela limpatela // limpa a tela, e vai voltar para o loop de opção. fimescolha fimrepita// fim repita 1 escolha frutas // palava que vai ser escolhida automaticamente pelo aleatorio no inicio do código em aleatorio on caso 1 l1 <- "d" l2 <- "a" l3 <- "m" l4 <- "a" l5 <- "s" l6 <- "c" l7 <- "o" caso 2 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "x" l7 <- "i" caso 3 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "t" l7 <- "e" caso 4 l1 <- "a" l2 <- "c" l3 <- "e" l4 <- "r" l5 <- "o" l6 <- "l" l7 <- "a" caso 5 l1 <- "l" l2 <- "a" l3 <- "r" l4 <- "a" l5 <- "n" l6 <- "j" l7 <- "a" caso 6 l1 <- "p" l2 <- "e" l3 <- "s" l4 <- "s" l5 <- "e" l6 <- "g" l7 <- "o" caso 7 l1 <- "g" l2 <- "u" l3 <- "a" l4 <- "r" l5 <- "a" l6 <- "n" l7 <- "a" fimescolha ld1 <- "_" // LINHAS USADAS PARA ESCREVER ld2 <- "_" ld3 <- "_" ld4 <- "_" ld5 <- "_" ld6 <- "_" ld7 <- "_" // inicio do jogo repita //repita2 se (ne > 7) entao // Se número de erros for maior que 6 que é o tamanho das palavras logo, jogador perde, ou seja, jogador possui 6 chances apenas. D<- Derrota FIMALGORITMO fimse se (ld1 <> "_") e (ld2 <> "_") e (ld3 <> "_") e (ld4 <> "_") e (ld5 <> "_") e (ld6 <> "_") e (ld7 <> "_") entao // Se as linhas forem diferentes de _ significa que existe letra no local, V<- Vitoria FIMALGORITMO fimse limpatela Escreval("============================================================") escreval("============================================================") escreval("") escreval(" /-----|") escreval(" / |") se (ne > 0 ) entao escreval(" / (x.x)") senao escreval(" /") fimse se (ne > 1 ) entao escreval(" | __||__ ") senao escreval(" | ") fimse se (ne > 2 ) entao escreval(" | /| |\\") senao escreval(" | ") fimse se (ne > 3) entao escreval(" | / |_____| \\") senao escreval(" | ") fimse se (ne > 4) entao escreval(" | || ||") senao escreval(" | ") fimse se (ne > 5) entao escreval(" | _|| _||") senao escreval(" | ") fimse se (ne > 6) entao escreval(" | |__||__|") escreval("===== ULTIMA CHANCE! ") senao escreval(" | ") escreval("===== ") fimse escreval("") escreval("Acertos: ",na) escreval("Erros: ",ne) escreval("") escreva("Palavra com 7 letras: ",ld1," ",ld2," ",ld3," ",ld4," ",ld5," ",ld6," ",ld7) Escreval("") escreval("Dica da palavra: FRUTA ") escreval escreva("digite uma letra: ") leia(dig) verifica <- "0" se (l1 = dig) e (ld1 = "_") entao ld1 <- dig na <- na + 1 verifica <- "1" fimse se (l2 = dig) e (ld2 = "_") entao ld2 <- dig na <- na + 1 verifica <- "1" fimse se (l3 = dig) e (ld3 = "_") entao ld3 <- dig na <- na + 1 verifica <- "1" fimse se (l4 = dig) e (ld4 = "_") entao ld4 <- dig na <- na + 1 verifica <- "1" fimse se (l5 = dig) e (ld5 = "_") entao ld5 <- dig na <- na + 1 verifica <- "1" fimse se (l6 = dig) e (ld6 = "_") entao ld6 <- dig na <- na + 1 verifica <- "1" fimse se (l7 = dig) e (ld7 = "_") entao ld7 <- dig na <- na + 1 verifica <- "1" fimse se (verifica = "0") entao ne <- ne + 1 fimse escreval("==============================================================") escreval("==============================================================") fimrepita fimalgoritmo
  3. Estou trabalhando com PHP e utilizo URL amigável. Ao clicar no link <a class="nav-link" href="<?php echo URL::getBase(); ?>blog" tabindex="12">blog</a>, minha URL fica: Abrindo a página blog.php esta contém a função function getBlog() que lista todos os artigos, com uma paginação de 10 por página. Ao clicar em um destes artigos, minha URL fica: Abrindo a página artigo.php esta contém a função: function getViewBlog() { // Ler URL (array) $url = $_SERVER['REQUEST_URI']; $valor = explode("/", $url); // Recebe o id do rgf_content via GET $id_blog = $valor[3]; ... } Onde pega o id_blog da URL e mostra todo o conteúdo deste artigo nesta página. O que estou buscando realizar é fazer com que estas duas funções abram na mesma página que aqui neste caso seria a blog.php. O motivo que leva-me a essa lógica é que da maneira que se encontra e quando estou na página artigo.php e ao clicar no link do breadcrumbs em artigo surge o erro: Pois na URL não aparece o conteúdo da variável $id_blog.
  4. Boa tarde, Necessito concluir minha função Se, de forma a qual me retorne em valor-se-falso o valor encontrado por ela no valor-se-verdadeiro, Assim consigo tornar automatizado minha planilha, carregando a quantidade de clientes que cada pessoa tem até o final do mês de forma a ser acumulativo, E também a quantidade estimada e fornecida acumulativa a cada mês. O problema é que quando vira a data programada ex.31/05/18 (43251) a formula me retorna um erro, "" ou Nda... preciso que ela retorne o valor que estava antes ou até a data mas que não mude dali em diante pois sera a função de uma próxima célula. Pensando no conceito de que esta planilha sera alimentada diariamente,. preciso que no fechamento de cada mês ela grave tais informações. Se houver outras funções ou modificações na planilha, Agradeço Ideias. Segue planilha... https://drive.google.com/open?id=110HwTjlQdyuROEB4hQGRvZU2PBTu3IaU
  5. Caio Marcio de Campo

    Chamada de funções em ASP

    Criei um arquivo funcoes.js (listado abaixo) que contém uma função que identifica qual o site acessado (produção ou desenvolvimento), arquivo que conterá outras funções. Como sou iniciante, preciso montar uma página que deve identificar qual o site acessado. Como faço para executar a função na página? Tem algum erro na codificação? //*** Identifica os servidores function IDServidor() { //*** Pega string da URL var url = document.location.toString() //*** Verifica se URL é da Internet ou local if (url.match("www") != null) { varServer = "https://www.site.com.br/centro/" } else { varServer = "http://78.145.28.106/centro/" } return varServer; }
  6. 1. Crie uma função para calcular a potência apenas com números inteiros. A função deve receber dois números inteiros, um para base e um para o expoente, e deve retornar o resultado da computação. Nome da função: potencia . 2. Crie uma função que receba 2 números (double) e retorne qual o valor do maior. Nome da função: maior . 3. Crie uma função que receba 2 números (double) e retorne qual o valor do menor. Nome da função: menor . 4. Crie uma função que receba dois números (double) e um caractere informando o tipo de operação desejada entre (+ , - , / ou *). Sua função deve efetuar o cálculo e retornar o resultado. Nome da função: operacao . 5. Crie uma função que receba dois números inteiros positivos X e Y e retorna um vetor com todos os números divisíveis por Y entre 0 e X inclusive. Nome da função: divisiveis . 6. Crie uma função que receba um número positivo inteiro X maior que zero e retorna um vetor contendo os X primeiros números da sequência fibonacci. Ex.: 0 1 1 2 3 5 são os 6 primeiros números da sequência fibonacci. Começa em 0 e 1, a soma dos dois últimos números dá origem ao próximo. Nome da função: fibonacci . 7. Crie uma função que receba um vetor de números reais e retorna o maior elemento do vetor. (não use funções prontas para tratar o vetor) Nome da função: maxVec . 8. Crie uma função que receba um vetor de números inteiros e retorna o menor elemento do vetor. (não use funções prontas para tratar o vetor) Nome da função: minVec . 9. Crie uma função que receba 2 vetores de inteiros a e b e retorna um vetor i com a intersecção entre a e b . Ex.: se a possui os elementos {1,2,4,4,0} e b possui os elementos {8,4,2,8}, então interseção a e b será igual a {2,4}. Nome da função: interseccao . 10. Analise o código abaixo e entenda o que ele faz: static void Main ( string [] args) { string source = "reviver" ; for ( int i = 0 ; i < source . Length ; i ++) { Console . Write ( source [ i ] + "\n" ); } Console . ReadKey (); } Com base no código acima, crie uma função para detecção de palíndromos de uma palavra . A função recebe a palavra e retorna um valor booleano, true para palíndromos ou false caso contrário. Nome da função: palindromo. Obs.: palíndromos são palavras, frases, versos ou expressões que podem ser lidas da esquerda para a direita ou da direita para a esquerda tendo a grafia e sentidos mantidos. Em um palíndromo, desconsideram-se os acentos, pontuação e espaços, ou seja, são consideradas apenas as letras e palavras. Ex.: reviver, radar, ovo,...
  7. Leonardo Fernandes_51639

    Parâmetro opcional no meio da lista de parâmetros de uma função ou método

    Considere a seguinte função em PHP: function myf($ent1=0,$ent2=0,$ent3=0){ return $ent1 + $ent2 + $ent3; } Se eu quiser omitir o último parâmetro, chamo por myf(3,4) e automaticamente o valor de $ent3=0. E se eu quiser omitir o segundo parâmetro ? O php não aceita que eu a chame por myf(3,,4). Então como chamar ?
  8. Ola pessoal, Vejo diversas pessoas utilizando funções para evitar "problemas" de usuários mau intencionados, bem como aqueles sem nenhum intenção. Estas funções são claras para mim, entendo muitas delas, mas o que eu queria saber é quais o pessoal mais utiliza e as melhores "ideias" para as seguintes situações: Obs. Algo que seja simples porém seguro nos formulários do dia dia também é importante. CADASTRO EM FORMULÁRIOS (POST) NO GERAL ACESSO AO PAINEL DE CONTROLE POR LOGIN E SENHA ENVIO DE INFORMAÇÕES PARA O BANCO DE DADOS PARA CONSULTA Algumas funções que já vi, por favor me informem se tem mais e como podemos utilizar: htmlspecialchars(), evitar injetar tags HTML ou Java Scrpit em sua página int(), input que os valores precisam ser números, essa é um saída. trim(), evita inserção de dados no query do mysql... retorna uma string com os espaçoes retirados do ínicio e do final de str. preg_replace(), evitar adicionar informações como "SELECT", "INSERT" e demais no formulário que possa evitar tal "invasão em sem mysql" String ou um array com strings para pesquisar e substituir ============================ strip_tags(), esta função tenta retornar uma string retirando todas as tags HTML e PHP de str. fgetss(), tenta retirar qualquer tag HTML ou PHP do texto que ele lê. Obs. Para mim são iguais =========================== get_magic_quotes_gpc(), utilizada para verificar se houve mudança nas informações recebidas da original. addslashes(), retorna uma string com barras invertidas antes de caracteres que precisam ser escapados para serem escapados em query a banco de dados, etc. Estes caracteres são aspas simples ('), aspas duplas ("), barra invertida (\) e NUL (o byte NULL). Agora vamos ao exemplo: /** FUNÇÃO PARA EVITAR ENVIO DE INFORMAÇÕES MAL INTENCIONADAS **/ function anti_injection($obj){ $obj = preg_replace("/(from|alter table|select|insert|delete|update|where|drop table|show tables|#|*|--|\\)/i", "", $obj); $obj = trim($obj); $obj = strip_tags($obj); if(!get_magic_quotes_gpc()) { $obj = addslashes($obj); return $obj; } }
  9. halfar

    executar funcao js no php apos chamada ajax

    é o seguinte. O que preciso é executar uma função js dentro do php. Na realidade eu já consegui, fiz assim: eu tenho um arquivo chamado teste.php, e dentro deste arquivo consta o codigo que segue abaixo. Este script funciona se voce executar ele diretamente no navegador, assim: http://www.dominio.com.br/teste.php Dessa forma funciona. No entanto, se este arquivo for uma chamada do ajax, então não funciona. Explicando melhor, supondo que numa pagina inicial.php tenha um botão que ao ser clicado, irá executar uma funcao js utilizando o ajax. Então, nesta função, quando o ajax executar a resposta (req.open("GET", "teste.php?retorno="+result, true);), a página irá ser executada normalmente, sem nenhum erro aparente, todavia a funcao mensagem_completa() não funciona. Será que tem uma forma de fazer esta função funcionar?
  10. Eis o programa para contagem de vogais e consoantes pronto. A questão é como contar os caracteres especiais sem especificá-los. Adicionei um }else{ especiais += 0; } ...porém assim obtenho números #include <stdio.h> #include <string.h> void quantidade(char *texto, int contador); int main(){ char texto[255]; int contador; gets(texto); contador = strlen(texto); quantidade(texto, contador); return 0; } void quantidade(char *texto, int contador){ char alf[27]={'a','e','i','o','u','b','c','d','f','g','h','j','k','l','m','n','p','q','r','s','t','v','w','x','y','z','\0'}; int i, j, vogais=0, consoantes=0; for(i=0;i<contador;i++){ for(j=0;j<27;j++){ if(texto[i] == alf[j] && j < 5){ vogais += 1; }else if(texto[i] == alf[j] && j >= 5){ consoantes += 1; } } } printf("Vogais:%d\n",vogais); printf("Consoantes:%d\n",consoantes); } arbitrariamente grandes(sim,declarei int especiais=0 antes).
  11. gustavohmc

    Funções

    [Resolvido]Vou colar o problema aqui para melhor elucidar a quem puder me ajudar: "Crie uma função que receba três valores, 'a', 'b' e 'c', que são os coeficientes de uma equação do segundo grau e retorne o valor do delta, que é dado por 'b² - 4ac' Usando as 3 funções acima, crie um aplicativo que calcula as raízes de uma equação do 2o grau: ax² + bx + c=0 Para ela existir, o coeficiente 'a' deve ser diferente de zero. Caso o delta seja maior ou igual a zero, as raízes serão reais. Caso o delta seja negativo, as reais serão complexas e da forma: x + iy" Minha dúvida é: é possível criar uma função que receba os 3 valores e dentro dessa função criar outras duas funções, uma para o delta e outra para as raízes e, na hora de passar os valores, as funções delta e raízes os recebam também, impedindo assim que seja possível passar valores diferentes para as funções internas? tipo <?+ $b +$c function val ($a, $b, $c){ return $a, $b, $c; function delta(){ return $b*$b -4*$a*$c; } function raizes(){ return $a*$a + $b +$c; } ?>
  12. leonardo-benitez

    Função em HTML

    Boa tarde. Existe um trecho do meu código em HTML que se repete em todas as páginas (barra de navegação). Estou começando agora, então nem sei se isso é possível, mas quero criar uma função que faça as marcações da barra de navegação, então eu simplesmente incluo o arquivo e chamo essa função em todas as páginas, ao invés de ficar repetindo o mesmo código. Alguém pode me ajudar? Obrigado
  13. Alexsander Fernandes

    Ajuda com sistema em C++

    Bom dia a todos, Recentemente fiz o seguinte código para um exercício da faculdade: #include <stdio.h> #include<string.h> int main () { int assentos[300]; char nomes[300][15]; int ocupados[50][6] = { 0 }; int contassentos = 0; char escolha; do { printf("\n Digite o nome do passageiro: "); scanf("%s", nomes[contassentos]); printf("\n Digite o numero do assento requerido: "); scanf("%d", &assentos[contassentos]); printf("\n Nome do passageiro: %s", nomes[contassentos]); printf("\n Assento escolhido: %d", assentos[contassentos]); int fileira = (assentos[contassentos] - 1) / 6; int assento = assentos[contassentos] - 1 - fileira * 6; if (ocupados[fileira][assento]) { printf("\n O assento já está ocupado, escolha outro!"); } ocupados[fileira][assento] = 1; if (contassentos++ == 300) { break; } printf("\n Deseja continuar? <S/N>"); scanf(" %c", &escolha); } while (escolha == 'S' || escolha == 's'); printf("\n"); for (int i = 0; i < 50; i++) { for (int j = 0; j < 6; j++) { printf("F%02dA%d=%s | ", i + 1, j + 1, ocupados[j] ? "ocupado" : "livre "); } printf("\n"); } } Agora me foi solicitado o seguinte: Na aplicação prática 1 foi construído um programa em C com estruturas de dados homogêneas para representar os passageiros e os assentos de um voo. Nas unidade de aprendizagem 5 a 8, foram apresentadas formas de manipulação de dados que já estão armazenados. Complementar o programa desenvolvido na aplicação prática 1, criando: Um registro para manipulação dos dados em tempo real com nome e número do assento; Um arquivo para persistência dos dados com nome e número do assento; Uma função para cadastrar uma reserva; Uma função para consultar reservas. Lembrando, que para cadastrar a reserva é necessário consultar se o assento está ou não livre Alguém poderia me ajudar com esse código? Estou com prazo apertado para entrega e ainda não terminei o conteúdo referente ao STRUCT e a FUNÇÕES. Abrigado a todos.
  14. keven1406

    Não consigo entender esse código

    Pessoal, estou estudando JavaScript pelo livro JavaScript Eloquent. Estou confuso com o funcionamento desse codigo: Link do capitulo do livro: https://github.com/braziljs/eloquente-javascript/blob/master/chapters/05-funcoes-de-ordem-superior.md A parte é sobre funções de ordem superior. E você pode ter funções que alteram outras funções. function noisy(f) { return function(arg) { console.log("calling with", arg); var val = f(arg); console.log("called with", arg, "- got", val); return val; }; } noisy(Boolean)(0); // → calling with 0 // → called with 0 - got false Eu entendo até bem o que está acontecendo, mas o que não entendo é como esse parâmetro "0" chega até a função noisy. Pelo que estou vendo ele é apenas um numero entre parênteses. Não sabia que valores isolados como esses poderiam ser passados como função. Sempre pensei que o certo seria: noisy(Boolean, 0); E que função f(arg) seria essa que nem declarada esta? Vou continuar analisando ela para ver se consigo entender. Desde já obrigado pessoal.
  15. onde está o erro nos links abaixo, tentei das formas abaixo, mas nenhuma forma funciona, clico no link e não acontece nada. echo "<a href='javascript:void(0)' onclick= 'mostra_texto($xid, $tabela);'>" . $titulo[$linha] . "</a>"; echo "<a href='#'onClick='mostra_texto($xid, $tabela);'>" . $titulo[$linha] . "</a>"; echo "<a href='javascript:mostra_texto($xid, $tabela);'>" . $titulo[$linha] . "</a>"; coloquei umas mensagens de alert() logo no inicio da função, não aparece nada, pelo jeito nem está lendo a função.
  16. 0x000000

    O que acontece nesse caso com a funções?

    Por exemplo, a função pré-definida math.random() ela esta chamando a função math que esta dentro da função random ou o parametro math que faz parte da função random?
  17. josenilson

    Mostrando o resultado de um SELECT

    olá pessoal, achei esse exemplo de mostrar o que estou selecionado em um select, ou seja quando selecionado uma opção da lista ela e mostrada no input, porem preciso que ao selecionar uma determinada opção da lista ele me mostre o resultado de uma determinada coluna no banco de dados segue o exemplo. <html> <head> <script type="text/javascript"> function alimentarCampo() { var minhaLista = document.getElementById("minhaLista"); document.getElementById("campoReceber").value = minhaLista.options[minhaLista.selectedIndex].value; } </script> </head> <body> <form name="Formulario"> Selecione seu Browser: <select id="minhaLista" name="campo_selecione" onchange="alimentarCampo();"> <option value="CARRO">CARRO</option> <option value="MOTO">MOTO</option> </select> <p>Descrição do Browser: <input type="text" id="campoReceber" name="campo" size="50"></p> </form> </body> </html> ou seja ao selecionar o carro quero mostrar no input não o nome carro e sim sua placa, porem esta informação esta no tabela do banco de dados, como faço uma função pra isso ? diante mão agradeço a todos .
  18. Eduardo_555

    Ajuda com manipulação de arquivos txt em c/c++

    Olá bom dia!! Estrou desenvolvendo um algorítimo que deve ler dados de uma pessoa armazenar em uma tabela hash o programa deve ter um menu e la tem de ter uma opção salvar, quando selecionada deve gravar os dados em um arquivo em vários aquivos txt, exemplo, ele deve calcular por índice do hash e dividir cada índice fica em um txt separado índice 1 - txt_1 índice 2 - txt_2 o problema esta na hora de criar o arquivo pois gostaria de criá-lo usando um for, para que a criação seja automática e eu não precise repetir código. Criei uma função que converte um inteiro em string e tentei usar como nome do arquivo mais não funcionou não!! Como faço isso.? já fis estes códigos para isso. //funcao que converte os inteiros em strings e os retorna string func_arquivo::converte_string(int valor){ string convertido; stringstream converter; converter << valor; convertido = converter.str(); return convertido; } //funcao que cria o arquivo void func_arquivo::cria_arquivo(){ ofstream arquivo; for(int i=0;i<TAM;i++){ string nome = converte_string(i); arquivo.open(nome + "txt", ios::trunc); arquivo.close(); } } Se precisar ver o código por completo podem verificar no git hub. https://github.com/Noplagio/TrabalhoHashing Aguardo uma ajuda!
  19. Wesley Ruchel

    Conteúdo sobre Funções SQL SERVER

    Olá pessoal! Poderiam me indicar um bom material de leitura sobre funções SQL Server? GRATO!
  20. josenilson

    function no xampp e wamp

    Bom dia a todos ! Estava utilizando essa função para gerar uma lista em um combo Box no meu form, porem o server em que estava sendo utilizado tal função era o XAMMP, funcionava normalmente, mudei para o WAMP SERVER, a função parou de funcionar, ha diferença entre código xammp ou wamp ? Digo não deveria funcionar nos dois server ? as versões do php dos dois são as mesmas isso tem alguma coisa a ver ? Logo abaixo esta a função. <!-------------NESTE PONTO ABAIXO ESTA MONTADO A FUNÇÃO QUE GERA A OPÇÃO DE NÍVEL DE USUÁRIO--------------> <tr> <td> <?php function combonivel($lista = false){ $montarArray = array("NIVEL","ADMINISTRADOR", "VISUALIZADOR"); if ($lista == ""){ foreach ($montarArray as $i){ $resultArray .= "<option value=\"{$i}\">{$i}</option>"; } return $resultArray; } else { foreach ($montarArray as $i){ if ($lista == $i){ $resultArray .= "<option value=\"{$i}\" selected=\"selected\">{$i}</option>"; } else { $resultArray .= "<option value=\"{$i}\">{$i}</option>"; } } return $resultArray; } } ?> <select name="nivel" id="nivel" class="form-control"placeholder="nivel"> <?php echo combonivel(); ?> </select> </td> </tr> <!------NESTE PONTO ACIMA ESTA MONTADO A FUNÇÃO QUE GERA A OPÇÃO DE NÍVEL DE USUÁRIO-------->
  21. lwtec

    juntar duas funções em uma só

    como faço para por essa função que coloquei abaixo de validar cpf junto com a minha função de validar os outros campos? ou seja, como faço para juntar as duas em uma só? já tentei varias formas e não deu certo. função de validar cpf function validaCPF() { strCPF = $("#cpf").val(); strCPF = strCPF.replace(/[^\d]+/g,''); var Soma; var Resto; var cboll = true; Soma = 0; if (strCPF.length != 11 || strCPF == "00000000000" || strCPF == "11111111111" || strCPF == "22222222222" || strCPF == "33333333333" || strCPF == "44444444444" || strCPF == "55555555555" || strCPF == "66666666666" || strCPF == "77777777777" || strCPF == "88888888888" || strCPF == "99999999999") cboll = false; for (i=1; i<=9; i++) Soma = Soma + parseInt(strCPF.substring(i-1, i)) * (11 - i); Resto = (Soma * 10) % 11; if ((Resto == 10) || (Resto == 11)) Resto = 0; if (Resto != parseInt(strCPF.substring(9, 10)) ) cboll = false; Soma = 0; for (i = 1; i <= 10; i++) Soma = Soma + parseInt(strCPF.substring(i-1, i)) * (12 - i); Resto = (Soma * 10) % 11; if ((Resto == 10) || (Resto == 11)) Resto = 0; if (Resto != parseInt(strCPF.substring(10, 11) ) ) cboll = false; if(!cboll){ $('#cpf').css('background-color','#FF7171'); $('#cpf').focus(); }else{ $('#cpf').css('background-color','#FFF'); return cboll; } } Minha função principal function validar() { var nome = form1.nome.value; var email = form1.email.value; var cemail = form1.cemail.value; var senha = form1.senha.value; var csenha = form1.csenha.value; var telefone = form1.telefone.value; var cpf = form1.cpf.value; var rg = form1.rg.value; var datanasc = form1.datanasc.value; var sexo = form1.sexo.value; var pastor = form1.pastor.value; var liderj = form1.liderj.value; var igreja = form1.igreja.value; var aceitatermo = form1.aceitatermo.value; if (nome == "") { divMensagem1.innerHTML = 'Preencha o campo com seu nome'; form1.nome.focus(); return false; } if (nome.length < 6) { divMensagem16.innerHTML = 'Preencha o seu nome COMPLETO'; form1.nome.focus(); return false; } if (email == "") { divMensagem2.innerHTML = 'Preencha o campo com seu e-mail'; form1.email.focus(); return false; } if (cemail == "") { divMensagem3.innerHTML = 'Repita seu e-mail'; form1.cemail.focus(); return false; } if (email != cemail) { divMensagem17.innerHTML = 'Os e-mails est�o diferentes'; form1.email.focus(); return false; } if (senha == "") { divMensagem4.innerHTML = 'Preencha o campo com sua senha'; form1.senha.focus(); return false; } if (csenha == "") { divMensagem5.innerHTML = 'Repita sua senha'; form1.csenha.focus(); return false; } if (senha != csenha) { divMensagem18.innerHTML = 'Senhas est�o diferentes'; form1.csenha.focus(); return false; } if (telefone == "") { divMensagem6.innerHTML = 'Preencha o campo com seu telefone'; form1.telefone.focus(); return false; } if (rg == "") { divMensagem8.innerHTML = 'Preencha o campo com seu RG'; form1.rg.focus(); return false; } if (rg.length < 7) { divMensagem20.innerHTML = 'Preencha o campo com um RG v�lido'; form1.cpf.focus(); return false; } if (datanasc == "") { divMensagem9.innerHTML = 'Preencha o campo com a sua data de nascimento'; form1.datanasc.focus(); return false; } if (sexo == "") { divMensagem10.innerHTML = 'Escolha seu sexo'; form1.sexo.focus(); return false; } if (pastor == "") { divMensagem11.innerHTML = 'Preencha o campo com o nome do seu pastor'; form1.pastor.focus(); return false; } if (liderj == "") { divMensagem12.innerHTML = 'Preencha o campo com o nome do seu lider'; form1.liderj.focus(); return false; } if (igreja == "") { divMensagem13.innerHTML = 'Escolha a igreja que voc� pertence'; form1.igreja.focus(); return false; } if (aceitatermo == "") { divMensagem14.innerHTML = 'Precisamos saber se est� de acordo com os nossos termos e condi��es, marque sim ou n�o'; form1.aceitatermo.focus(); return false; } if (aceitatermo == 0) { divMensagem15.innerHTML = 'Cadastros no sistema conectados bg s� s�o permitidos para quem est� de acordo com os nossos termos e condi��es'; form1.aceitatermo.focus(); return false; } }
  22. Anonimo Nao

    Concatenação de Funções

    Boa tarde, me desculpe se não é esse o nome que se da para essa pratica. No entanto, vejo muito ela em diversas biblioteca, como o próprio jQuery. Exemplo: funcao_a().funcao_b() Gostaria de saber um exemplo básico de como criar um código que possa fazer isso. Se puderem me indicar links, ou mesmo o nome dessa pratica para que eu possa pesquisar e estudar mais afundo. Sou iniciante em javascript.
  23. Dougg_Ghost

    Ajuda em Ponteiros e funções

    Basicamente, tenho esse exercício (que foi passado em duas provas de C na faculdade), e nas duas acabei deixando em branco por não ter ideia de como fazer (nem como começar), não queria pedir resolução, mas sim explicação e se possível uma ajuda com código. Realmente não tenho ideia do que fazer por isso não coloquei meu código. Segue enunciado: Escreva uma função remove_dup(floatv[],int n) que receba o vetor e verifique a existência de elementos duplicados. Caso não existam elementos duplicados retorne 0. Caso existam, remova estes elementos (deixando apenas um) e retorne o número de elementos removidos.
  24. Gabriel_Duarte

    Funcionamento de Email no PHP

    Olá, Estou procurando livros e Informações mais confiáveis e simples de como funciona o Sistema de Email do php. desde como colocar a função mail() no php, ate como configurar dentro do php.in para qualquer email possível (ja pesquisei para o gmail, porem quero para qualquer tipo de email ate emails de servidores exemplo: contato@contato.com). Fiz uma pesquisa mas achei muita coisa vaga, com variância, então peça ajuda pra quem entende bem sobre esse assunto, ou que sabe aonde posso achar essas informações.
  25. Robson Barros da Rocha

    Validação de formulário com palavras específicas

    Bom dia pessoal. Eu queria pedir um favor. Eu não imagino como posso fazer tal coisa, então, gostaria de perguntar se existe alguma maneira em PHP, de, definir para um campo no formulário, que só seja aceite se por ventura o que ele escrever no campo, contenha uma palavra que eu definir. Por exemplo, um input text que ele, além do conteúdo personalizado dele, ele é obrigado a escrever o nome do meu site. Um campo de URL, por exemplo, aonde, o subdomínio é personalizado, mas, o subdomínio é definido como padrão. selva.hevemedia.com Ele pode alterar todo o texto, mas, para que o formulário seja enviado, é preciso que ele escreva a palavra hevamedia no meio das palavras dele. Tem como fazer algo assim:
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.