Jump to content

Search the Community

Showing results for tags 'locaweb'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Web Development
    • HTML e CSS
    • Javascript
    • PHP
    • Ruby
    • Python
    • Java
    • .NET
    • Docker, Kubernets and other environments
    • WordPress
    • Mobile
    • Agile
    • Desenvolvimento de Games
    • Banco de Dados
    • Design and UX
    • Algoritmos & Outras Tecnologias
  • Entretenimento e uso pessoal
    • Segurança & Malwares
    • Geral
    • iMasters's pub

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 6 results

  1. clayton.lima2020

    Erro no envio de email SMTP

    Bom dia! Pessoal estou com um problema estou tentando enviar um e-mail através de um formulário que criei no site da empresa que eu trabalho, porém na hora de enviar está dando erro. Obs: a hospedagem do site está na Locaweb Segue abaixo o erro: Fatal error: Uncaught Error: Call to undefined function eregi() in /home/storage/2/a8/c3/odontosmilesfran1/public_html/class.phpmailer.php:593 Stack trace: #0 /home/storage/2/a8/c3/odontosmilesfran1/public_html/class.phpmailer.php(518): PHPMailer->SmtpConnect() #1 /home/storage/2/a8/c3/odontosmilesfran1/public_html/class.phpmailer.php(410): PHPMailer->SmtpSend('Date: Sat, 5 Ju...', '--b1_b48d510d23...') #2 /home/storage/2/a8/c3/odontosmilesfran1/public_html/envio-franqueador.php(55): PHPMailer->Send() #3 {main} thrown in /home/storage/2/a8/c3/odontosmilesfran1/public_html/class.phpmailer.php on line 593 Segue o código do script de envio: <? require_once("class.phpmailer.php"); //Nova instância do PHPMailer $mail = new PHPMailer; //Informa que será utilizado o SMTP para envio do e-mail $mail->IsSMTP(); //Informa que a conexão com o SMTP será autênticado $mail->SMTPAuth = true; //Configura a segurança para SSL $mail->SMTPSecure = "ssl"; $mail->Port = 465; $mail->Host = "email-ssl.com.br"; //Usuário para autênticação do SMTP $mail->Username = "sejaumfranqueado@odontosmilesfranchising.com.br"; //Senha para autênticação do SMTP $mail->Password = "12345678"; // senha ficticia //Titulo do e-mail que será enviado $mail->Subject = "PEDIDO PARA SER UM FRANQUEADOR"; //Preenchimento do campo FROM do e-mail $mail->From = $mail->Username; $mail->FromName = $_POST['nome']; // Nome do remetente //E-mail para a qual o e-mail será enviado $mail->AddAddress("sejaumfranqueado@odontosmilesfranchising.com.br"); //Conteúdo do e-mail //$mail->Body = "Novo contato feito através do site Araújo Imóveis."; $mail->From = $_POST['email']; // E-mail do remetente $mail->Body .= "Modelo de Franquia: ".$_POST['modelo']."<br>"; $mail->Body .= "Nome: ".$_POST['nome']."<br>"; $mail->Body .= "Email: ".$_POST['email']."<br>"; $mail->Body .= "Fone Móvel: ".$_POST['fone']."<br>"; $mail->Body .= "Fone Fixo: ".$_POST['movel']."<br>"; $mail->Body .= "Estado: ".$_POST['estado']."<br>"; $mail->Body .= "Cidade: ".$_POST['cidade']."<br>"; $mail->Body .= "Mensagem: ".nl2br($_POST['mensagem']).""; $mail->AltBody = $mail->Body; //Dispara o e-mail $enviado = $mail->Send(); //Imprime sucesso. if($enviado) echo "<script>alert('Sua mensagem foi enviada com sucesso!')</script>"; echo "<meta http-equiv='refresh' content='2;URL=index.php'>"; ?> Segue o trecho do código do arquivo class.phpmailer.php onde está dando o erro /* Choose the mailer */ switch($this->Mailer) { case 'sendmail': $result = $this->SendmailSend($header, $body); break; case 'smtp': [b][color=red] $result = $this->SmtpSend($header, $body); // nessa linha 410 está dando erro [/color][/b] break; case 'mail': $result = $this->MailSend($header, $body); break; default: $result = $this->MailSend($header, $body); break; //$this->SetError($this->Mailer . $this->Lang('mailer_not_supported')); //$result = false; //break; } return $result; } /** Aqui está outro trecho do código: /* Retry while there is no connection */ while($index < count($hosts) && $connection == false) { $hostinfo = array(); [b][color=red] if(eregi('^(.+):([0-9]+)$', $hosts[$index], $hostinfo)) { // aqui está dando erro linha 593[/color][/b] $host = $hostinfo[1]; $port = $hostinfo[2]; } else { $host = $hosts[$index]; $port = $this->Port; } $tls = ($this->SMTPSecure == 'tls'); $ssl = ($this->SMTPSecure == 'ssl'); if($this->smtp->Connect(($ssl ? 'ssl://':'').$host, $port, $this->Timeout)) { $hello = ($this->Helo != '' ? $this->Hello : $this->ServerHostname()); $this->smtp->Hello($hello); if($tls) { if(!$this->smtp->StartTLS()) { $this->SetError($this->Lang("tls")); $this->smtp->Reset(); $connection = false; } //We must resend HELLO after tls negociation $this->smtp->Hello($hello); } $connection = true; if($this->SMTPAuth) { if(!$this->smtp->Authenticate($this->Username, $this->Password)) { $this->SetError($this->Lang('authenticate')); $this->smtp->Reset(); $connection = false; } } } $index++; } if(!$connection) { $this->SetError($this->Lang('connect_host')); } return $connection; } Obrigado a todos que puderem ajudar
  2. gilmario.junior

    [Resolvido] Erro ao publicar site

    Hoje publiquei um site que estou criando com o Visual Studio Utilizando no IIS local o mesmo funciona corretamente. Porem no momento de testar no servidor Locaweb está dando o erro abaixo. Server Error in '/social' Application. The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly. Requested URL: /social/default.aspx Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2623.0
  3. Estou tentando usar a função mail do php para enviar as informações de um formulário pro meu e-mail via Locaweb. Ja procurei em vários fóruns, mas não consigo fazer funcionar. Gostaria de saber porque mesmo colocando meta charset e a lingua o email sai desconfigurado, não reconhecendo acentos? Ao receber o e-mail a mensagem sai como senão tivesse o meta charset UTF-8, ou se a lingua não estivesse em português do Brasil. O site esta hospedado, envia o email com o cabeçalho sem ter este erro de desconfiguração. <!DOCTYPE HTML> <html lang="pt-BR"> <head> <meta charset="UTF-8"> <title>Formulário FormMail</title> <meta property="og:title" content="Teste de Envio via FormMail" /> <meta property="og:locale" content="pt_br" /> </head> <body> <!-- PARA HOSPEDAGEM COMPARTILHADA, DESCOMENTE A LINHA ABAIXO: --> <!-- <form method="post" action="http://www18.locaweb.com.br/scripts/FormMail.pl"/> --> <!-- Abaixo, informe uma conta de email do domínio da hospedagem (email@domínio.com.br) --> <input type="hidden" name="email" value="email@dominio.com.br"/> <!-- Informe a conta de emails que receberá os dados do formulário nele preenchido. --> <!-- Dica: Para adicionar outro recipiente do formulário, separe as contas de email por virgula Ex.: value="email@dominio.com.br, podeseroutroemail@outrodomínio.com.br" --> <input type="hidden" name="recipient" value="email@dominio.com.br"/> <!-- Abaixo, informe o qual o assunto padrão da mensagem --> <input type="hidden" name="subject" value="FormMail Teste Locaweb"/> <!-- Nesta tag, informe o redirecionamento desejado, página principal do site, mensagem de agradecimento, etc --> <input type="hidden" name="redirect" value="http://seudominio.com/obrigado.html"/> <table width="28%" border="1"> <tr> <td height="19" width="25%">Nome: </td> <td height="19" width="75%"><input type="text" name="nome" size="40" value=""></td> </tr> <tr> <td height="19" width="25%">E-mail: </td> <td height="19" width="75%"><input type="text" name="replyto" size="40" value=""></td> <!-- Este parametro ( name="replyto" ) recebe o email que você responderá posteriormente "Responder Para" --> </tr> <tr> <td height="19" width="25%">Mensagem: </td> <td height="19" width="75%"><textarea name="mensagem"></textarea></td> </tr> <tr> <td height="19" width="25%">&nbsp; </td> <td height="19" width="75%"> <input type="submit" name="Submit" value="Enviar Dados"> </td> </tr> </table> </form> </body> </html>
  4. Bom dia pessoal, Sou novo por aqui e gostaria de saber se já viram isso acontecer. Estou dando manutenção em um site de um amigo hospedado na Locaweb e a empresa que fez o site, utilizou as funções do OpenSSL para realizar as criptografias para envio de email, mas não está funcionando as funções do modulo, retornando a seguinte mensagem: Fatal error: Call to undefined function openssl_encrypt() in /home/storage/f/cc/7c/*****/public_html/inc/contato/mail.send.php on line 5 Procurei em vários foruns mas apenas encontrei para ativar a função no servidor, verifiquei e está ativa. A função openssl_encrypt é a primeira a dar o problema, como no código abaixo: <?php //ini_set("max_execution_time", 60000); $verify = array('Hash' => openssl_encrypt("d640a8a4f9927b7ffa03126ced5f87155027870e", 'DES-EDE3-CBC', 'c17055ac4e99f9d95f4fc5a9edce2b45c6253d35', 1, '07bcc012')); Sabem o que eu posso fazer para resolver esse problema e continuar usando a criptografia?
  5. Estou tentando instalar o prestashop no cpanel da locaweb. Só que no passo 3 da instalação ele da os seguintes erros: Cannot open external URLs (requires allow_url_fopen as On) Set short_open_tag to off in php.ini* Eu criei um arquivo php.ini no gerenciador de arquivos com os seguintes dados (fornecidos pela propria locaweb): upload_max_filesize = 200M post_max_size = 200M memory_limit = 256M date.timezone = "America/Sao_Paulo" extension=pdo.so extension=pdo_mysql.so extension=pdo_sqlite.so max_execution_time = 90 allow_url_fopen = on short_open_tag = off Mas o erro na instalação do prestashop continua....
  6. Gurandao

    Cálculo de Correção Monetária

    Olá galera, preciso criar um cálculo de correção monetária, já criei a tabela com todos os índices e fatores baseados no site https://api.tjsp.jus.br (Abril/2017). Vamos ao que interessa: Puxei os valores da tabela, a fórmula do cálculo é: Valor (dividido) pelo fator do mes que venceu (multiplicado) pelo ultimo indice cadastrado (mes anterior). Então temos os valores: Valor (270.72), fator do mês que venceu (48.485963) e fator do mês anterior atual (66.839575). Eu criei o seguinte cálculo: $correcao =$valor / $fator_vcto * $fator_atual; ou seja: $correcao = 270.72 / 48.485963 * 66.839575; O resultado que ele me apresenta é 276.699454107990 sendo que na calculadora e no excel o valor correto calculado é 373.1968723 Desde já agradeço à todos que puderem me ajudar!
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.