Jump to content

Search the Community

Showing results for tags 'slim'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Found 7 results

  1. Sou novo no Rails e mais ainda no Slim. Preciso colocar um Icon (estou usando um do Fontawesome) dentro de um f.text_field, mas não sei como fazer. No meu código tenho: i.fa.fa-user.fa-2x =f.text_field :name , placeholder: "Nome",class: "form-control" que resulta na imagem seguinte: O objetivo é fazer igual o da imagem seguinte: Alguém sabe como fazer, pois estou bem perdido? Obrigado
  2. greg_kaippert

    Configurar rotas Slim .htaccess

    Boa noite masters. Estou desenvolvendo um sistema com várias rotas SLIM, porém estou separando as rotas em arquivos. Por exemplo, as rotas de empresa, vão ficar no index.php, as rotas de departamentos vão ficar no arquivo departamento.php, e assim por diante. Consigo fazer uma ou outra funcionar pelo arquivo .HTACCESS, mas as duas funcionando juntas não consigo. CÓDIGO .HTACCESS ABAIXO: TENTATIVA1: RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^ index.php TENTATIVA 2: RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^ index.php RewriteRule ^ departamento.php Desde já agradeço. No aguardo, att Gregory.
  3. Cesar Augusto Graeff

    API REST com PHP

    Boa Tarde, Estou fazendo um painel de controle utilizando AngularJS para isto estou fazendo uma API REST com PHP e banco de dados MySQL Escolhi utilizar o framework Slim para desenvolver a API, porém estou com dificuldade em fazer um sistema de busca por parâmetros via query como mostrado abaixo: exemplo.com.br/api/v1/clientes?id=1&nome=teste A maior dificuldade seria fazer a passagem de parametros para condições com > , < , <= , >=, IN(), LIKE %% e etc. Alguém já fez um sistema de busca por query parecido com este ou conhece algum framework que faça isto?
  4. dwalisson

    Slim vs. Silex?

    Qual a opinão de vocês sobre estes dois microframeworks? Vantagens e desvantagens?
  5. noebezerra

    Problema com AJAX - PHP - Slim Framework

    Olá este é meu primeito tópico, então me desculpe se estiver no lugar incorreto. O projeto se trata de um sistema de enquete, com votação em 'estrelinhas' Tenho um problema no meu Ajax. Estou usando o Slim framework com Eloquent (sou iniciante) Projeto no github: https://github.com/noebezerra/survey-slim Eu tenho uma ajax $('.stars-default').click(function(e) { e.preventDefault(); $.ajax({ url: '../app/Controllers/Poll.php', type: 'GET', dataType: 'html', data: {valor: pointStar, qtdperguntas: qtdperguntas}, }) .done(function(data) { console.log(data); }) .fail(function() { console.log("error"); }) }); Ele me retorna um Array (pointStar) que é a quantidade de estrelas selecionadas para cada pergunta e a quantidade de perguntas que possui na enquete. Poll.php <?php namespace App\Controllers; use App\Models\PollAnswers; session_start(); /** * */ class Poll extends Controller { public function poll() { $qtdperguntas = $_GET['qtdperguntas']; $result = '['; for ($i=0; $i < $qtdperguntas; $i++) { if ($i < $qtdperguntas - 1) { $result .= '"'.$_GET['valor'][$i].'",'; } else { $result .= '"'.$_GET['valor'][$i].'"'; } } $result .= ']'; $userpoll = PollAnswers::where('id_user', '=', $_SESSION['user']); if (!$userpoll) { PollAnswers::create([ 'id_user' => $_SESSION['user'], 'answers' => $result ]); echo "insert"; } else { $userpoll->answers = $result; echo "update"; } } } ?> Controller.php <?php namespace App\Controllers; /** * */ class Controller { protected $container; public function __construct($container) { $this->container = $container; } public function __get($property) { if ($this->container->{$property}) { return $this->container->{$property}; } } } ?> PollAnswers.php <?php namespace App\Models; use Illuminate\Database\Eloquent\Model; /** * */ class PollAnswers extends Model { protected $table = 'poll_answers'; protected $fillable = array('id_user', 'id_poll_question', 'answers'); } ?> Quando o ajax chega lá na pagina dá o seguinte erro: Fatal error: Class 'Controller' not found in /var/www/html/survey-slim/app/Controllers/Poll.php on line 14, referer: http://localhost/survey-slim/public/ Parece que ele não reconhece minha classe. Alguém possui uma sugestão? Como o projeto está no github sinta-se avontade para contribuir =)
  6. LandersonAlmeida

    Slim 404 Page Not Found

    Hoje estava aprendendo a usar o Slim até que me apareceu um problema, tenho a seguinte estrutura de pastas (estou usando xampp): -- project/ -- app/ -- public/ -- .htaccess (#2) -- index.php -- lib/ -- bootstrap.php -- share/ -- vendor/ -- .htaccess (#1) No .htaccess #1 eu deixei assim: RewriteEngine On RewriteRule ^$ app/public [L] RewriteRule (.*) app/public/$1 [L] No .htaccess #2 está assim: RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{SCRIPT_FILENAME} !-d RewriteRule ^ index.php [QSA,L] Só que quando eu acesso: localhost/project redireciona para localhost/NewPainel/app/public/ E quando tento acessar localhost/project/hello retorna 404 ! só consigo acessar se for: localhost/NewPainel/app/public/hello. Meu bootstrap.php: $app = new Slim\App($configs); $app->get('/', function(){ echo "Home"; }); $app->get('/hello', function(){ echo "Hello !"; }); $app->run(); Obrigado desde já :) !
  7. eneias.carvalho

    Slim Framework POST vázioLi

    Olá galera. Estou precisando muito de uma ajuda, estou criando uma rest api e resolvi utilizar o Slim, o GET funciona perfeitamente, porem o POST está indo vazio, já segui uns 10 tutorias e sempre gravava apenas o ID na tabela do MySQL, isso por que o mesmo é auto increment, então resolvi verificar o retorno após o inserir, e pude observar que o POST sempre vai vázio, já tentei descobrir o por que e ainda não consegui, já instalei WAMP, XAMP, EasyPHP, Bitnami (pois desconfiava que poderia ser o Apache) porem em nenhum deu certo. Código: <?php /* Require Slim and plugins */ require 'Slim/Slim/Slim.php'; /* Register autoloader and instantiate Slim */ \Slim\Slim::registerAutoloader(); $app = new \Slim\Slim(); $app->response()->header('Content-Type', 'application/json;charset=utf-8'); $app->get('/', function () { echo "Helena Starter > Acompanha Fácil API"; }); $app->post('/users','addUser'); $app->get('/users','getUsers'); $app->run(); function getConn(){ return new PDO( 'mysql:host=localhost;dbname=hs.outjob.acompanhafacil.v100', 'root', '', array(PDO::MYSQL_ATTR_INIT_COMMAND => "SET NAMES utf8") ); } function addUser(){ $request = \Slim\Slim::getInstance()->request(); $user = json_decode($request->getBody()); $sql = "Insert Into tb_users(nome, usuario, senha) Values(:nome,:usuario,:senha)"; $conn = getConn(); $stmt = $conn->prepare($sql); $stmt->bindParam("nome",$user->nome); $stmt->bindParam("usuario",$user->usuario); $stmt->bindParam("senha",$user->senha); $stmt->execute(); $user->id = $conn->lastInsertId(); echo json_encode(array($user->id)); } function getUsers(){ $stmt = getConn()->query("Select * From tb_users"); $users = $stmt->fetchAll(PDO::FETCH_OBJ); echo "{users:".json_encode($users)."}"; } ?> Script da tabela: DROP TABLE IF EXISTS `tb_users`; CREATE TABLE `tb_users` ( `id` bigint(20) NOT NULL AUTO_INCREMENT, `nome` varchar(60) DEFAULT NULL, `usuario` varchar(30) DEFAULT NULL, `senha` varchar(255) DEFAULT NULL, `tipo` int(255) DEFAULT NULL, `fone` varchar(20) DEFAULT NULL, `email` varchar(255) DEFAULT NULL, `endereco` varchar(70) DEFAULT NULL, `complemento` varchar(20) DEFAULT NULL, `numero` varchar(10) DEFAULT NULL, `id_cidade` int(11) DEFAULT NULL, PRIMARY KEY (`id`) ) ENGINE=InnoDB AUTO_INCREMENT=21 DEFAULT CHARSET=latin1; Agradeceria muito se alguém pude-se indicar onde está o erro, já verifiquei o .htaccess e aparentemente está normal, não sei mais o que pode ser.
×

Important Information

Ao usar o fórum, você concorda com nossos Terms of Use.