Ir para conteúdo

Pesquisar na Comunidade

Mostrando resultados para as tags ''webbrowser''.

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Todas as áreas do Fórum

  • Q&A Desenvolvimento
    • Perguntas e respostas rápidas
  • Desenvolvimento e Banco de Dados
    • HTML e CSS
    • Java
    • Javascript
    • .NET
    • PHP
    • Python
    • Ruby
    • Mobile
    • Ambientes de Desenvolvimento
    • Arquitetura e Métodos Ágeis
    • Banco de Dados
    • DevOps
    • Desenvolvimento de Games
    • E-Commerce e Pagamentos Online
    • SEO e Otimizações
    • WordPress
    • Algoritmos & Outras Tecnologias
  • Design e Produto
    • Fotografia
    • Photoshop
    • Design de interfaces e UX
    • Edição/Produção de Vídeos
    • Marketing Online
    • Desenho, Ilustração e 3D
  • Entretenimento e uso pessoal
    • Geral
    • Segurança & Malwares
    • Gadgets e wearable
    • Softwares e Apps
    • Entretenimento

Encontrar resultados em...

Encontrar resultados que...


Data de Criação

  • Início

    FIM


Data de Atualização

  • Início

    FIM


Filtrar pelo número de...

Data de Registro

  • Início

    FIM


Grupo


Google+


Hangouts


Skype


Twitter


deviantART


Github


Flickr


LinkedIn


Pinterest


Facebook


Site Pessoal


Localização


Interesses

Encontrado 8 registros

  1. Eu fiz utilizando o método de captar do webbrowser e passa para a listbox os dados que eu quero. Funcionou certo em algum sites de imobiliárias, onde realmente tava trazendo apenas aqueles dados. Porem quando tento usar para pegar do OLX os imoveis ele vem com muitos dados. Aqui segue o codigo html que estou tentando pegar: <div class="OLXad-details mb30px"> <div class="atributes"> <h4 class="title">Detalhes do imóvel</h4> <ul class="list square-gray"> <li class="item"> <p class="text"> <span class="term">Tipo:</span> <strong class="description">Aluguel - apartamento kitchenette</strong> </p> </li> <li class="item"> <p class="text"> <span class="term">Área útil:</span> <strong class="description">50 m²</strong> </p> </li> <li class="item"> <p class="text"> <span class="term">Quartos:</span> <strong class="description">1</strong> </p> </li> <li class="item"> <p class="text"> <span class="term">Vagas na garagem:</span> <strong class="description">1</strong> </p> </li> </ul> <div class="OLXad-features mt20px"> <p class="text"> <span>Características:</span> <ul class="OLXad-features-list"> <li>Armários embutidos</li> <li>Varanda</li> <li>Área de serviço</li> </ul> </p> </div> </div> </div> <script type="text/javascript"> self.adParams = { 'real_estate_type': 'Aluguel - apartamento kitchenette', 'condominio': '', 'iptu': '', 'size': '50', 'rooms': '1', 'beds': '', 'garage_spaces': '1', 'features': '' } </script> <div class="OLXad-location mb20px"> <div class="atributes"> <h4 class="title">Localização</h4> <ul class="list square-gray"> <li class="item"> <p class="text"> <span class="term">Município:</span> <strong class="description"> Vila Velha </strong> </p> </li> <li class="item"> <p class="text"> <span class="term">CEP do imóvel:</span> <strong class="description"> 29118-060 </strong> </p> </li> <li class="item"> <p class="text"> <span class="term">Bairro:</span> <strong class="description"> Alecrim </strong> </p> </li> </ul> </div> </div> <div class="OLXad-id"> <p class="text"> <span class="term">Código do anúncio:</span> <strong class="description">417138772</strong> </p> </div> o Codigo que estou usando: Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click Try ListBox1.Items.Clear() Dim Tags(1) As String Tags(0) = "span" Tags(1) = "div" If Not IsNothing(WebBrowser1.Document) Then For Each _Tag As String In Tags Dim elementos As IList(Of HtmlElement) = WebBrowser1.Document.GetElementsByTagName(_Tag).OfType(Of HtmlElement).ToList() If Not IsNothing(elementos) Then Dim elementosPesquisa As IList(Of HtmlElement) = _ elementos.Where(Function(w) w.OuterHtml.Contains("description")).ToList() If Not IsNothing(elementosPesquisa) AndAlso elementosPesquisa.Count > 0 Then For Each el As HtmlElement In elementosPesquisa ListBox1.Items.Add(el.OuterText) Next End If End If Next End If Catch ex As Exception MessageBox.Show(ex.Message, "Error", MessageBoxButtons.OK, MessageBoxIcon.Information) End Try End Sub Alguém pode me ajudar? Agradeço desde ja.
  2. Boa tarde, tive qeu reabrir o topico pois embora eu tenha conseguido colocar o texto do webbrowser na label infelizmente não estou conseguindo atualizar ela a cada suponha 6 segundos, segue abaixo o código que estou usando no VB, agradeço a ajuda Public Class Form1 Private Sub Timer1_Tick(sender As Object, e As EventArgs) Handles Timer1.Tick WebBrowser1.Refresh() End Sub Private Sub WebBrowser1_DocumentCompleted(sender As Object, e As WebBrowserDocumentCompletedEventArgs) Handles WebBrowser1.DocumentCompleted Me.WebBrowser1.Navigate("url do conteudo a ser pego") Try If Not IsNothing(WebBrowser1.Document) Then Dim elementos = WebBrowser1.Document.GetElementsByTagName("span") If (Not IsNothing(elementos) And elementos.Count > 0) Then Dim i As Integer = 0 While (i < elementos.Count AndAlso Not elementos.Item(i).OuterHtml().Contains("texto_musica")) i += 1 End While If (i < elementos.Count) Then resultado = elementos.Item(i).InnerText Label1.Text = resultado End If End If End If Catch ex As Exception End Try Timer1.Enabled = True Timer1.Interval = 3000 Timer1.Start() End Sub Private Sub Label1_Click(sender As Object, e As EventArgs) Handles Label1.Click End Sub Dim resultado As String Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load End Sub End Class
  3. vamberto.farias

    Navegador para windows Ce com C#

    Boa tarde, amigos estou precisando criar um navegador em c# para rodar uma aplicação web em um dispositivo com windows Ce para q depois de aberto não se possa fechar a aplicação, coloquei o webbrowser e deixei travada e maximizado, o que ocorre é que quando a pagina é carregada nele todo os elementos ficam alinhados a esquerda, no internet explorer o site abre normalmente, alguma poderia me dar uma luz de como fazer os itens aparecerem centralizados.
  4. Humberto - S.O.S.

    webbrowser download android

    Olá. Estou desenvolvendo um aplicativo pelo Delphi XE7, e no meio do percurso usei um Form que nele tem um WebBrowser que abre uma página com links de downloads, ao clicar no link não ocorre nada. alguém saberia me ajudar? obg.
  5. prestoexpress@live.com

    WebBrowser nativo do delphi dando erro no RECAPTCHA

    Bom dia povo. Tenho uma janela em meu sistema que abre um webbrowser e dentro carrega um formulario de cadastro porem quando carrega o documento dentro do webbrowser o RECAPTCHA nao funciona exibindo Agradeço a quem puder ajudar. Obrigado
  6. prestoexpress@live.com

    WebBrowser nativo do delphi dando erro no RECAPTCHA

    Bom dia povo. Tenho uma janela em meu sistema que abre um webbrowser e dentro carrega um formulario de cadastro porem quando carrega o documento dentro do webbrowser o RECAPTCHA nao funciona
  7. Renan F. da Silva

    Editar pagina WebBrosew

    Boa noite, Alguém saberia me dizer um modo para eu editar a pagina do webbrowser Eu quero retirar umas divs (retirar ou ocultar) WebBrowser1.Navigate('http://192.168.9.199/acesso/'); Ocultar ou remover as div -class menu -class info -id nome Vale lembre que tem que ser pelo Delphi pois o codigo HTML no servidor NÃO POSSO ALTERAR pois não tenho acesso Obrigado
  8. Cebola

    ERRO COM OBJETO IDISPATCH WebBrowser

    Bom dia, Galera estou com um problema muito louco e que já procurei para todo canto uma solução e nada... É o seguinte: Fiz uma aplicação em Delphi que abre um site e gera uma guia a partir dele. Usei o componente WebBrowser e para pegar os dados das minhas tabelas usei uma TAdsQuery. Até ai tudo bem a primeira vez faz tudo certo, só que quando vou fazer a segunda e tento abrir a query com minha consulta sql da o seguinte erro: " Error 5018: The handle given was not recognized by Advantage. Verify specified handle is open/active. The given handle is not recognized as a valid Advantage Client Engine handle " Notei que isso só acontece se eu usar o objeto IDispatch que é criado dentro de um evento do WebBrowser.NewWindow2 que verifica se é criado alguma nova janela e a joga em um outro formulário.Segue o Código. #Código 1 2 3 4 5 procedure TfrmEmissaoGNRE.WebBrowser1NewWindow2(ASender: TObject; var ppDisp: IDispatch; var Cancel: WordBool); begin ppDisp:= new_form.wb_webMain.DefaultDispatch; end; Depois disso dou um showModal no meu novo formulário e a guia aparece, normalmente! Só que como expliquei, na próxima vez que vou usar uma consulta SQL pelo TAdsQuery o problema continua. E se eu der um disconect no meu TADSConection o mesmo erro é exibido. Alguém pode me ajudar ? Será que tem algum conflito de componentes? Já pesquisei de mais e não achei nada a respeito... Fico no aguardo.
×

Informação importante

Ao usar o fórum, você concorda com nossos Termos e condições.